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Chapter 1: Introduction
Moneydance is an easy to use and full-featured personal finance application that 
does not compromise your privacy. With Moneydance, your data is private, 
encrypted, and never shared. 

Moneydance makes any financial task easy with online banking and bill payment, 
account management, budgeting, investment tracking, multi-currency, as well as 
detailed graphs and reports, yet does not inhibit you from adopting more advanced 
approaches if you need to.

Moneydance has been designed based on the principles of Double Entry 
Accounting. While Moneydance is not Accounting Software, the fundamental 
principles can be readily applied to personal financial data, it does mean that every 
transaction will either have to have a category for Income and Expense type 
transactions or an account if it is a transfer.

Many personal finance products do not have this sort of requirement, simply 
because they are not based on accounting principles, all transaction data are free 
form entry and any “rules” are enforced through things like data entry screens. The 
basic rule of double entry is that for every credit there must be a corresponding and 
equal debit. What this means, in real terms, is that every entry is a transfer of money 
from one account to another, hence the term double entry.

From this you can see that In an accounting system you may have a large list of 
accounts, this is referred to as the Chart of Accounts. In adapting Accounting to 
Personal Finance, and specifically Moneydance, the Chart of Accounts has been 
split into two sections. We have what we see in Moneydance as the Accounts 
section i.e, Bank, Credit Card, Loans, Asset and Liability accounts. In accounting 
these would be items that appear in the Balance Sheet, they are the Assets and 
Liabilities you have. The other section is the Categories, this is where we have the 
Income and Expense items, in accounting these are in the Profit and Loss statement.
Hence in Moneydance if you combine Accounts and Categories you have your Chart
of Accounts.

To explain how it works let us say that you are paying your utility bill. You get the bill 
in the mail, and you write a check. By writing the check you effectively reduced the 
amount left in your bank account by the amount of the utility bill. In this case a debit 
(Withdrawal) is entered in the checking account. Now on the other side of the 
transaction you want to record the fact that you have paid the utility bill, so a credit 
(Deposit) would be entered for the same amount of the bill on the same date in an 
account (category) called utility bill. 

So just like in Accounting where every entry is a “transfer” between accounts, In 
Moneydance every entry is a “transfer” between an Account/Category and another 
Account/Category. Categories are just a particular type of account in Moneydance.

In some respects personal finance can be seen as a subset of Accounting, there is 
no payroll, inventory etc type of data, yet some of the data that is desirable to have 
and maintain, especially in the area of investments, is a super set of your everyday 
accounting type data. Moneydance has some ability to maintain the super set of 
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data, it does not have the capability to maintain everything however, very few 
products come close, and many do not do as much as Moneydance can.

In traditional accounting, where additional data needs to be maintain, it is done 
outside the main accounts, sometimes in Journals but often data is maintained in 
Worksheets. The computing equivalent to traditional accounting worksheets are 
Spreadsheets.

We routinely see the need to maintain additional data for Investment Accounts. 
Typically in accounting you only have the total value of the transactions in the 
accounts, you do not maintain lot information for example, but Moneydance can do 
this. Stock Splits are also not relevant in the total investment values but are 
important on a per share basis, Moneydance can also do this. However if you also 
have some capital returns, while in accounting and in Moneydance you can record 
the total amounts there is not the ability to assign this on a per share basis. This is 
where it may be necessary to maintain a worksheet with the details on a per share or
per lot basis.

Data Sets

You will often see references to the term Data Sets being used. Your Moneydance 
data is not stored in a single file, it is stored within a folder structure, attachments are
all stored individually and data will often be in small transactions files prior to being 
rolled into a master file, all of these files combined make up your data hence why this
term is used. The name of the folder is the name you have given to your data. It may
also be referred to as an Account Set. The terms Data Set and Account Set are 
interchangeable. Do not however confuse Account Set with Account. An Account is 
simply a single entity like a Bank or Credit Card, where as the Account Set can and 
will often contain multiple accounts.

Base “Account”

Underneath the menu bar at the top left you will see a name with a drop down 
Window selection that contains you accounts, By default the summary page is 
displayed and in the drop down next to the name is the word “Base”. 

The Base, while it is often referred to as one, is not an account, it is the name of the 
container that houses all of your data. In other words it is the base folder and all of 
your data for the set of accounts it contains is in the sub-folders and files that exist 
under this – Moneydance data does not live in a single file. Moneydance also uses 
this name as the name of your data set.

From this we have:

Base = Data Set Name = Name of container/folder/directory that contains your data

It is possible to change this name if so desired. See the chapter on Data Sets.

Document Conventions

Information in this document comes from many contributors, that use a variety of 
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Operating Systems, as such keyboard shortcuts in this guide are given in various 
formats. On a non-Mac computer (Windows, Linux, etc) the Control (Ctrl) key is 
equivalent to the Command key (⌘) on a Mac, the Alt key on Windows/Linux is 
usually the Option key on a Mac. 

Where we are referring to specific function keys on a keyboard we have enclosed 
the descriptive key text in <> brackets. 

Screen images come from a variety of systems so you will see some differences in 
look and feel.

Registering Moneydance

Before registering Moneydance you need to have opened a data set.  Next, select 
the Help → Register Moneydance menu item and enter your license key. 

If you purchased Moneydance from the Mac App Store Moneydance is pre-
registered and this step is not necessary. 

The Infinite Kind provide Microsoft with fully registered version so it should not be 
necessary to register a version obtained from the Microsoft Store.

If you have purchased Moneydance from Amazon you should receive an email with 
your license key in it, you can also log on to the Amazon website and retrieve your 
license from there.

With the Apple and Microsoft versions you should always obtain any updates from 
these sources. The direct version will not work with the licensing schemes these 
companies use.

Keyboard Short Cuts

Using keyboard shortcuts can streamline your Moneydance experience.  
Moneydance contains a number of time-saving features designed to make entering 
information (especially transactions) as quick and efficient as possible when using 
the keyboard. Listed below are the shortcuts and the context in which they apply for 
all supported Operating Systems.

For completeness we have included a small number of combined mouse/keyboard 
shortcuts where they are in context.

General

Function Mac Windows/Linux

Save  ⌘ S <Ctrl> S

Return to Summary ⌘ <Shift> H <Ctrl> <Shift> H

Find ⌘ F <Ctrl> F

Advanced Find ⌘ <Shift> F <Ctrl> <Shift> F

Hide/Restore Side Bar ⌘ <Shift> S <Ctrl> <Shift> S
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Close any 'open in a new window' 
windows

⌘ W <Ctrl> W

Open Summary Page ⌘ Comma <Ctrl> Comma

Quit ⌘ Q <Ctrl> Q

Menu

Function Mac Windows/Linux

Open File Menu <Option> F <Alt> F

Open Edit Menu <Option> E <Alt> E

Open Account Menu <Option> A <Alt> A

Open Tools Menu <Option> T <Alt> T

Open Extensions Menu <Option> X <Alt> X

Open Help Menu <Option> H <Alt> H

Move down list <Down Arrow> <Down Arrow>

Move up list <Up Arrow> <Up Arrow>

Select item <Enter> <Enter>

Edit

Function Mac Windows/Linux

Undo ⌘ Z <Ctrl> Z

Redo ⌘ <Shift> Z <Ctrl> <Shift> Z

Cut selected text ⌘ X <Ctrl> X

Copy selected text ⌘ C <Ctrl> C

Paste selected text ⌘ V <Ctrl> V

Select All  ⌘ A <Ctrl> A

Online

Function Mac Windows/Linux

Download all Accounts ⌘ <Shift> D <Ctrl> <Shift> D

Open Account Website ⌘ <Shift> O <Ctrl> <Shift> O

Download highlighted Account ⌘ D <Ctrl> D

Confirm selected transaction ⌘ Enter <Ctrl> Enter
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Tools

Function Mac Windows/Linux

Open Account Window  ⌘ <Shift> A <Ctrl> <Shift> A

Open Category Window ⌘ <Shift> C <Ctrl> <Shift> C

Open Reminder Window  ⌘ <Shift> R <Ctrl> <Shift> R

Open Budget Manager  ⌘ <Shift> B <Ctrl> <Shift> B

Open Graphs and Reports  ⌘ <Shift> G <Ctrl> <Shift> G

Translate Currencies  U⌘ <Ctrl> U

Calculator ⌘ <Shift> L <Ctrl> <Shift> L

Window

Function Mac Windows/Linux

Minimize ⌘ M <Ctrl> M

Welcome to Moneydance Screen ⌘ <Shift> 1 <Ctrl> <Shift> 1

Show MoneyBot Console ⌘ <Shift> 2 <Ctrl> <Shift> 2

Transaction Register

Function Mac Windows/Linux

Begin entry of a new transaction ⌘ N <Ctrl> N

Next field <Tab> <Tab>

Previous Field <Shift> <Tab> <Shift> <Tab>

Finish entering a record <Enter> <Enter>

Terminate the entry of the current 
transaction without saving it

<Esc> <Esc>

Delete the currently selected 
transaction

<Del> <Del>

While editing a transaction will bring 
up the split editor

⌘ L <Ctrl> L

To exit the split editor ⌘ W <Ctrl> W

Select all transactions in the register ⌘ A <Ctrl> A

Select transactions between two 
transactions

Select first 
transaction
Hold down 
<Shift> and click 
on last 
transaction

Select first 
transaction
Hold down <Shift> 
and click on last 
transaction
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Select discrete transactions Select first 
transaction, use 

 ⌘ Click for 
subsequent 
transactions

Select first 
transaction, use 
<Ctrl> Click for 
subsequent 
transactions

Displays a pop-up menu of available 
actions

Right-click or
<Ctrl>-click

Right-click

Add a new line for a Split transaction. ⌘ N <Ctrl> N

Show splits in a transaction, Hover on 
or select a transaction and then press

<Option> <Alt>

Go to the top of the register <Fn> 
<Left arrow>

<Home.>

Go to the bottom of the register <Fn> 
<Right arrow>

<End>

Cut the selected field  ⌘ X <Ctrl> X

Copy the selected field  ⌘ C <Ctrl> C

Paste the selected field  ⌘ V <Ctrl> V

Using Download button to start 
External Browser

 C⌘ lick <Ctrl> Click

Print transactions  ⌘ P <Ctrl> P

Single Line mode ⌘ <Option> 1 <Ctrl> <Alt> 1

Two Line mode ⌘ <Option> 2 <Ctrl> <Alt> 2

Show other side  ⌘ [ <Ctrl> [

Opens the Reconcile window for the 
current account

⌘ B <Ctrl> B

Mark as Uncleared ⌘ <Option> U <Ctrl> <Alt> U

Mark as Reconciled ⌘ <Option> R <Ctrl> <Alt> R

Mark as Cleared ⌘ <Option> C <Ctrl> <Alt> C

Moneydance has an auto completion feature for transactions. Transactions can be 
auto completed simply by typing in the payee field. With each keystroke, past 
transactions are searched for payees with names that begin with the text already 
entered. If a matching transaction is found, the rest of the current payee field is filled 
in with the matched payee value. At this point you can either continue to type, or use 
the TAB key to continue to the next field.
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Date Fields

Function All Systems

Advance or “spin” the date forward + or =

Wind or “spin” the date backward - or _ 

Select the current date t

Select the first day in the month m

Select the last day in the month n

Select the first day in the year y

Select the last day in the year r

Check Number Fields

Function All Systems

Advance or “spin” the check number up + or =

Wind or “spin” the check number down - or _ 

Pressing the +/= key in an empty check number field automatically calculates 
the next check number based on past transactions in that account.

Amount and Rate Fields

You can enter arithmetic expressions ( "(200 + 86) * 0.25" for example) in any 
numeric field and Moneydance will calculate the answer.  Entering a value followed 
by a three digit currency ID (USD, GBP, EUR, etc) will automatically convert the 
entered amount from the given currency to the native currency of the field.
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Chapter 2: Moneydance Menus
This chapter summarizes the Moneydance menu structure.

The File Menu

New: Create a blank data file.

New Transaction: Allows you to enter a new transaction into your register. (Only 
available when an account register is open).

Open: Open a different Moneydance data file. 

Import:  Imports QFX, OFX, OFC, QFC, QIF or CSV  files.

Export:  Export data in QIF, Raw JSON, and tab delimited formats.

Encryption:  Set a user defined Password to encrypt your Moneydance file.

Syncing: Set up syncing between Moneydance and other desktop or mobile 
devices.

Export Backup: Manually saves a compressed backup of your file to a specified 
location.

Print Checks: From within individual accounts only – prints checks from the current 
account.

Print Transactions: From within individual accounts only – prints transactions from 
the current account as they are shown in the register.

Preferences:  For Windows and Linux users, find Preferences under the File Menu. 
On a Mac, look under the Moneydance Menu.

The Edit Menu

From this menu you can Undo, Redo, Cut, Copy, Paste, Select All, Find and 
Advanced Search..

Find: Sends cursor to the Search/Find box.

Advanced Search: Brings up a dialog box with advanced search options.

The View Menu

Show Budget Status: Shows the Budget Status graph in the status bar.

Show Net Worth: Graph Shows the New Worth graph in the status bar.

Hide Status Graph:  Show no graph in the status bar. 

Hide/Show Side Bar: Hides or Shows the Side Bar.

Summary: Shortcut to the Summary.
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The Account Menu

Items under the Account menu operate on the account that is currently open in the 
main window.

New: Account Create a new account.

Edit Account: Edit the settings for the currently displayed account.  

Delete Account: Deletes the account and all transactions it contains.

Reconcile: Opens the reconcile interface.

The Online Menu

Download all Accounts:  Downloads transactions from your Bank for all accounts 
enabled for Direct Connect or Moneydance+.

Open Account Website:  Automatically opens your browser to a page you have 
pre-set. Designate the page you would like this function to open (your Bank's 
homepage, a link to your transfer file, etc.) by typing in the URL once as prompted. 
To edit the account website, go to Account → Edit Account and enter the new URL 
in the Website field. 

Set up Online Banking: Set up online banking for the currently shown account. 

Set up Online Bill Pay: Set up online bill payment for the currently shown account. 

Online Bill Payment: Open the online bill payment window.

Send Online Payment: Send online payment.

Download Transactions: Downloads transactions from current account only.

Confirm Selected New Transactions: Confirms the selected recently downloaded 
or imported transaction for the current account.

Forget Online Passwords: Forgets passwords (in encrypted data files) for direct 
connect enabled accounts.  To remember your account passwords, your file have a 
user defined password for encryption.

The Tools Menu

Accounts:  Add, edit, or delete accounts, and print the account list.

Categories: Add, edit, or delete categories, and print the category list.

Currencies:  Display currencies associated with the current file; add, modify, or 
delete currencies; set base currency for data file.

Securities:  Add, edit, or delete securities.

Reminders: Displays the calendar and reminder list tool.

Budget Manager:  Displays the budget management tool.
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Address Book:  Add, edit, and delete address book entries.

Graphs and Reports:  Brings up a graphs and reports dialog box.

Translate Currencies:  Brings up the currency converter tool.

Calculator:  Displays a simple calculator.

Loan Calculator:  Brings up the loan/mortgage calculator.

In order to use the VAT/GST functionality you must first enable it in your 
Preferences. 

VAT/GST Settings: Specify which categories are to be used with VAT/GST, the rate
for each category, and to which expense category you would like the VAT/GST 
assigned.

VAT/GST Transactions:  Displays a list of all the transactions for a specified 
account that have VAT/GST applied to them. You can also use this window to 
override the default rate applied to each transaction.

Quotes and Exchange Rates: Downloads currency and security prices.  This option
is only available under this menu if you have purchased Moneydance through the 
Mac App Store, otherwise please download the “Quotes and Exchanges Rates” 
extension.

The Extensions Menu

Add new features to Moneydance by downloading extensions from our website or by
loading them directly from a file.  If you purchased Moneydance from the Mac App 
Store, you will not see an Extensions menu unless/until you install one or more 
extensions.  See Chapter 18 Extensions and Python Scripts for more information.

The Window Menu

Shows a list of the currently open windows and an option to minimize the current 
window.

The Help Menu

Online Support: Brings you to our online support forum and user guide.  Check out 
our documentation, be part of our community, or ask our support agents a private 
question.

Register Moneydance: Tells you whether your copy of Moneydance is registered 
and allows you to enter your license key. (Not visible if purchased from the Mac App 
Store.)

Console window: Displays detailed error and debugging information.

About Moneydance: Provides information about what version of Moneydance/Java 
you are running, your license key, and translation credits. On a Mac this item is 
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located under the Moneydance menu.

Show Archive Folder: Opens the folder where Moneydance stores archived files by
default.

Show Documents Folder: Opens the folder where Moneydance stores data files by
default. 
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Chapter 3: Working with Data Sets

Opening an Existing Moneydance File

If you have been using Moneydance 2012 or later: Your account set(s) should be 
visible in the list on the right.  Click to open, or click “Open Other” to navigate to your 
data file in a different location. Please note, commencing with Moneydance 2015 
account sets use a new data storage format and cannot be opened using earlier 
versions of Moneydance.

If you are using Moneydance 2011 or earlier: Click “Import New Account Set” to 
navigate to and convert your data file into the new Moneydance format.

Creating a New Moneydance File

When creating a new account set you have two major options:

Create a New Account Set: Choose this option if you don’t need to import data from
another program.

Import New Account Set: Choose this option if you are opening a data file from 
Moneydance 2011 or earlier, or are importing data which you exported from another 
personal finance program.  For more details see the Moneydance Migration Guide.

Once you click on your desired option you will name your new Account Set, and will 
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choose a Primary Currency which will be the default currency for all new accounts.  
You will also select a File Type:

• Minimal is designed for those who are importing data from another program.

• Standard is for those who are not importing data.

Location of Moneydance Data Sets

The default location of Moneydance files are provided later in this document, 
however at this point we need to stress that Moneydance data sets should be 
housed on a local drive. They should not be placed on any form of network drive, nor
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should they be placed in a local folder that is under control of syncing software, an 
example of this is the Dropbox local folder that installing the Dropbox client software 
installation creates.

The reason for this is the way Moneydance reads and writes its data files along with 
the way software like the Dropbox client reads and writes files, how software like 
iCloud moves files between local and remote storage and also the way network 
devices work. The methods are just not compatible with the result that it is possible 
to corrupt your data.

Moneydance reads and writes file in a way that is appropriate for the data it handles 
and with an eye on how its syncing works.

Many of the devices discussed here can however be used for backups or the shared 
syncing location, this is because the files used in these processes are handled in a 
different way that is suitable for those particular functions but this method is also 
compatible with how these devices operate.
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Chapter 4: Accounts & Categories

Account and Category Basics

Moneydance supports a variety of account types as well as income and expense 
categories.  You can add, edit, and delete accounts and categories.  Deleting an 
account or category will also delete all transactions in that account or category.  All 
accounts, aside from Investment Accounts, can be specified as a “Child of” (sub-
account of) another account or category of the same type.

As discussed earlier what in accounting is referred to as the “Chart of Accounts” in 
Moneydance has been made more granular the ‘chart’ have been split into two major
sections i.e. Account and Categories and further split in these into sub types like 
Bank, Income etc.

Accounts

Firstly in this section we will examine Accounts.

Types of Accounts

Moneydance supports the following account types:

Bank Accounts represent accounts like checking and savings.

Credit Card Accounts keep track of your current balance on credit cards, this 
account type can also be used for other types of revolving lines of credit type 
accounts. The balance of the credit card account represents your current debt on 
that card.  

Investment Accounts hold securities (stocks, bonds, mutual funds, etc.) as well as 
cash. Investment accounts support entry of standard bank transactions. For more 
information see the chapter on Investment Accounts.

Loan Accounts track a loan with regularly scheduled payments, a known interest 
rate, and a fixed starting debt. When you open a loan account in Moneydance you 
can choose to add the principal of your new loan to the balance of another account.

Asset Accounts are a “catchall” account.  They can be used to track the value of a 
home, to keep a household inventory for insurance purposes, To track a loan you 
make to someone, or to track any other items you would like included in your net 
worth.

Liability Accounts are another “catchall”.  This could be used to track other 
liabilities you would like included in your net worth.

More detail on the account type are provided later in this guide.

Create Accounts Through the Accounts Menu

To create an account go to Accounts → New Account.   You will then be prompted to
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select which type of account you would like to create: Bank, Credit Card, Investment,
Asset, Liability, or Loan.

After selecting the account type an account creation window will appear, where you 
can enter the data relating to the account.

For all account types the Account Name, Start Date, Initial Balance, and Currency 
Type fields are required, all other fields are optional.

If you do not select a “Default Category” for the account, the first existing category in 
your data set (in alphabetical order) will be selected.

Create, Edit, or Delete Accounts Through the Tools Menu

You can easily edit or delete accounts through the Tools → Accounts menu item. To 
edit an existing account highlight the account’s name and click “Edit”. To delete an 
account highlight the account’s name and click “Delete”. Deleting an account will 
also delete all transactions in that account or category. If you would like to create a 
new account, click on the New button at the bottom of the screen.
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Closing Accounts

If you have closed a bank account, or have categories you no longer have need of, 
you can mark these accounts as “Inactive” to prevent them from being shown in drop
down lists in account registers or being sync’d with your mobile devices.   To mark 
an account/category as inactive, check the “Inactive” box.  This item is distinct from 
the “Hide on Summary Page if balance is zero” option.  Inactive accounts are still 
accessible from reports, and can be changed from their Inactive state by deselecting 
the checkbox (i.e., returned to active use) at any time. Any account marked as 
inactive, even if they contain a balance, is not counted in your Net Worth.

Categories

We will now examine categories.

Every transaction requires either a category or a transfer account. Moneydance is 
based on the rules of Double-entry accounting. The rules for Double entry is that 
every transaction must be associated with two “accounts”. In practice this means the 
account or category that funds are being sourced from and the second associated 
account or category which represents the destination of the funds, thus you must 
show both the “source” (from) and the “destination” (to) of the funds. Failure to do 
this represents a serious violation of double entry rules and Moneydance does not 
allow it.

One of the methods Moneydance used to enforce the rule is to enforce a “default 
category” for each account. Any transaction that does not have a category selected 
will use the default category – the standard category is the first in the category list. It 
can be a good idea to create a category like “uncategorized”, and set this as the 
default category.
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Types of Categories 

There are two types of categories:

1. Income Categories track where your money is coming from.

2. Expense Categories track where your money is going to.

You cannot mix categories, in other words if you were to say create an Income 
Category you cannot create an Expense category under it. Income Categories are in 
one section Expense categories in another.

Create, Edit, or Delete Categories Through the Tools Menu

You can create, edit or delete categories through the Tools → Categories menu 
item. To create a new category click “New”, to edit an existing category highlight the 
category’s name and click “Edit”, to delete a category highlight the account’s name 
and click “Delete”. Deleting a category will also delete all transactions in that account
or category.

Creating Categories When Entering Transactions in the Register

You can also create categories when entering a transaction. Type the name of the 
new category into the Category field and you’ll be offered the ability to create that 
category.  Clicking on the “Create Category...” item will ask you to choose if the new 
category will be an income or expense category.

You’ll then be taken to the standard category creation window, where you can set a 
parent category (if desired), the currency of the category, and other standard 
options.  When entering a split transaction, you can create multiple new categories 
from within the split entry window.
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VAT/GST Expense Categories

If you have enabled VAT/GST tracking in your Preferences, you can set the VAT tax 
rate when creating new categories.  For more information on setting up and tracking 
VAT/GST spending, see Chapter 15 Setting up VAT/GST

Tax Related Income and Expense Categories

You can designate an income or expense category as “Tax Related”.  This will make 
reporting easier at tax time, and is available as an option in the Income and Expense
and Detailed Income and Expense reports.  For more information on using Reports, 
see Chapter 13 Graphing and Reporting

Closing Categories

If you have categories you no longer have need of, you can mark it as “Inactive” to 
prevent them from being shown in drop down lists in account registers.  Inactive 
categories are still accessible from reports, and can be unmarked from Inactive (i.e., 
returned to active use) at any time.  To mark a category as inactive, check the 
“Inactive” box.

Structuring Categories

When creating categories you should consider how you wish to use them. The main 
thing to consider is reporting.

Take for example Health spending where you may be eligible for say a partial rebate.

If you have separate Income and Expense categories, i.e., a category for the 
expense and a category for the rebate they will be in different parts of the report, so 
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If you need a net figure you need to calculate it manually.

Now if you enter both into the one category (an Expense category) you will have 
positive and negative items in it and you will end up with a net figure.

Another way to do it it to have an Expense category with two sub-categories one that
you enter the rebate and one for the expenses, even though both categories are of 
the same type, one will have positive amounts and the other negative. With this 
arrangement you get a positive total, a negative total and a net total in your reports.

Chart of Accounts

It was explained earlier how what in accounting is a single Chart of Accounts has a 
more granular presence in Moneydance and is split into sections. 

What many people would still like is to be able to get the equivalent to a Chart of 
Account from Moneydance, in other words some sort of report that shows the 
structure of your setup.

In Moneydance you can get what is effectively a chart of accounts abet in two parts 
and with some additional information.

The first part is obtained through the menu command Tools → Accounts. What you 
see is a part of a Chart of Accounts – concentrating on what in Moneydance is 
referred as accounts but with additional data on Total Balance. Using the print option
you can get a printed/saved report of these. It will show the accounts/sub accounts 
structure and also show the type of account.

The second part is obtained through the menu command Tools → Categories. What 
you see is a part of a Chart of Accounts – concentrating on what in Moneydance is 
referred as categories but again with additional data on Total Balance. Using the 
print option you can get a printed/saved report of these. It will show the 
categories/sub categories structure and also show the type of category.

These two reports together effectively give you what is traditionally referred to as a 
Chart of Accounts.
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Chapter 5: Standard Accounts
The following sections outlines the standard account types that Moneydance 
supports. All of these account types share the same heritage and also share many 
similarities.

Bank Accounts

The primary use for this type of account is bank type accounts i.e. Transaction and 
Savings accounts. However this type can also be used for Cash accounts, Fixed 
Term Deposits with banking institutions etc.

You can setup a bank account by navigating to Account → New Account.

Much of the information on this screen is static

The Account Name, Start Date, Initial Balance, and Currency Type fields are 
required, all other fields are optional.

If you do not select a “Default Category” for the account, the first existing category in 
your data set (in alphabetical order) will be selected.

By default the Currency is set as the Base Currency of your data file. The currency 
cannot be changed once the account contains transactions.

The default settings for the Check Number field are to use either the system default 
or account specific settings, if set.
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Credit Card Accounts

The credit card account type can be considered for any revolving line of credit type 
account.

You can setup a credit card account as you would any other account, by navigating 
to Account → New Account.

Credit Card accounts usually have negative balances. These account type generally 
represent money that you owe and have a negative effect on your net worth.  A 
credit card account is used to keep track of your current balance on a single credit 
card. The balance on a credit card represents your current debt on the credit card.

A credit card account can store information such as card number, expiration date, 
interest rate (labeled APR – Annual Percentage Rate), and bank name for your 
convenience.  You do not need to enter any of this information if you do not desire.  
None of these values, including the interest rate, affects the operation of the account.
You can specify that the credit card is a child (or sub-account) of another account.

Rather than the "Initial Balance" field, you will see "Initial Debt".

The default settings for the Check Number field are to use either the system default 
or account specific settings.

Purchase transactions are entered into a credit card account just as they are in a 
bank account – a description, category of spending, amount, etc.  Credit card 
payments are recorded as a transfer of funds from the bank (often a checking) 
account to the credit card account.  This reduces the balance of the checking 
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account and reduces the debt on the credit card.  See the sample transaction below.

Asset Accounts

Asset Accounts are a general account. They can be used to track the value of any 
assets you may hold.

For example you could use such an account to track the value of your home, 
perhaps one to track the value of an investment property. Another use is to keep a 
household inventory for insurance purposes. Such accounts have been used to track
peer to peer lending. Any asset you own can be pretty well tracked in an Asset 
account.

While this account type would be user to track the capital value, Income and 
expenses relating to such an asset would be likely to be recorded in a bank account.

The value of any asset accounts are included in your net worth.

You can setup an asset account as you would any other account, by navigating to 
Account → New Account.

The set up screen shows:

The default settings for the Check Number field are to use either the system default 
or account specific settings.

The register works identically to a bank register.
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Liability Accounts

Liability Accounts can be used for anything that you owe. This could be used to track
any other liabilities you may have. For example while Moneydance has the ability to 
track standard bank type loans, some loan types may be better handled in a Liability 
account, for example a peer to peer loan.

The value of any liability accounts are included in your net worth calculation.

You can setup a liability account as you would any other account, by navigating to 
Account → New Account.

The set up screen looks like:

The default settings for the Check Number field are to use either the system default 
or account specific settings.

The register works identically to a bank register.

Standard Registers & Transactions

What is a Transaction?

A "transaction" is any entry the results in a change in the balance of your accounts, 
plus all the information about how much was spent or received and where the money
went or came from.  Moneydance uses the double entry method of accounting, 
which means that every transaction has two sides, just like a coin. The value of one 
account or category will increase and another will decrease when a transaction is 
made. Transactions can be between a financial account and an expense or income 
category, or between two financial accounts (such as a transfer from a checking to a 
savings account).  Double entry accounting has been in use for centuries and has 
been shown to help reduce errors and also help find any that are made.
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Viewing, Filtering, and Sorting the Register

The account register displays all transactions in the account and is used to enter, 
edit, and delete transactions. It is visually similar to a paper check book register. To 
open an account register click on an account name in the Side Bar or Summary, or 
select the account name from the drop-down box in top left of the Moneydance 
program window.

The filter buttons running along the top of the register allow you to to restrict the 
transactions displayed in your register.  Click “All” to see every transaction in the 
register, or one of the time frames to see a sub-set of transactions. Click the 
“Unconfirmed” button to show downloaded transactions which have not yet been 
confirmed or the “Uncleared” button to only display transactions which you have not 
yet marked as cleared.

The Split Register button at the top right of the window toggles between showing 
Confirmed and Unconfirmed transactions in a single pane, or showing Confirmed 
transactions in the top panel and Unconfirmed in the bottom.

You can change the order of transactions in the register by clicking on any column 
heading.  Click twice to reverse the sort order. To sort the register by more than one 
variable, such as by date and then by Check #, ctrl+clicking (or right click) in the 
transaction register and select Sort By →. To the right of the Balance header is a 
small double arrow indicator, clicking on this acts like a right click and brings up that 
context menu.

You can change the width of any field by clicking on the divided line in the header, 
the cursor should change to a double headed one, and dragging the divider to the 
position you wish.

Transaction Fields

You can create a transaction in any register except in a Loan Account (learn more 
about Loan Accounts in Chapter 7 Loan Accounts). Investment Accounts have a 
slightly different set of fields, which are explained in detail starting in Chapter 6
Investment Accounts. With the exception of Investment accounts all account 
registers have the same format, and contain the following fields:

Date: The date on which the transaction occurs.

Tax Date: The date of the transaction for tax purposes, if different from the normal 
transaction date. This is only displayed if you checked the “Use Tax Date” box in 
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Moneydance → Preferences → General (or File → Preferences → General on 
Windows and Linux).

Check#: Selecting the {Print} option will include that transaction when printing 
checks.  Selecting the <Next Check#> option will insert the next check number for 
that account. The algorithm for determining the next check number is:

1. Find all transactions with check numbers in the last 180 days

2. If there are none find the most recent transaction with a check number and 
add 1 to it.

3. If there are transactions with check numbers in the last 180 days find the last 
ten. Add 1 to the highest of the last 10.

What this means is that you can enter checks out of sequence and if you start using 
a new series of checks after you enter ten checks the next check number facility will 
start to use the new sequence.

To add, delete or modify the options for this field, you do so from within the Selection
list available for the field.

Description: The person or entity who receives or gives the funds.  To enter an 
address book entry in this field use the down arrow key.  Downloaded/imported 
transactions which are unconfirmed are marked with a small blue dot, confirmed 
transactions are marked with a small blue circle, split transactions are marked with a 
small “s”, and transactions with an attachment are marked with a small paperclip.  
Address book entries are prefaced by a green @ symbol.

Memo: Any additional information. The exact dividing line between what is in the 
Description and Memo fields is mainly one of personal taste or financial institution 
download format.

Category: The "other side" of this transaction.  To make a transfer between 
accounts (from a savings to a checking account, for example) the account that the 
transfer is with should be selected in the Category field.

Tags: Any tags you wish to assign to this transaction.

C: A blank space here indicates the transaction is uncleared; an orange diamond 
indicates it is reconciling; a green circle means the transaction is cleared/reconciled.

Payment:  Amount removed from this account and added to the account specified in
the Category field described above.

Deposit: Amount added to this account and removed from the account specified in 
the Category field.

Rate: Specifies the exchange rate for inter-currency transactions.  Automatically 
entered if you have installed the Quotes and Exchange Rates Updater extension.  
For information on manually entering an exchange rate, see Multi-Currency Support.

Foreign Amount: Permits entry of the exact amount of the other currency in a multi-
currency transaction. See on Multi-Currency Support for more details.

Balance: The current balance of the account; this field is not editable, it is calculated
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by the software.

Field Values in Square Brackets

Where you see a value in a field surrounded by square brackets [] it generally means
that this value has been set on the other side of the transaction and is being shown 
here for informational purposes only.

This means that if you were to say create a report and this value is a search or filter 
value then this side of the transaction would not appear in the report.

Check Number List

There are multiple Check Number lists within Moneydance. There is a global list and 
there is an account specific list for each account (excluding loan accounts).

You can set an account to either use the Global (Default) List or the account specific 
list, this is set at the Account level through the Account Info screen.

Through the account Info screen, accessed via the Account Edit menu command 
both of these list can be individually edited, by selecting the appropriate list and then 
choosing the Edit button.

The account specific check number list can also be maintained through the Check 
Number field in the register.

To access this list from within an account register click on the double headed arrows 
in the check number field and you will be presented with the account specific list of 
items.

The list comprises a number of predetermined items plus the most recent entries 
entered that are not check numbers or duplicates, the default is the last 20 items.

Modifying the Check Number List

At the bottom of the list is the ‘Edit List …’ command. This allows you to configure 
what is displayed in that specific account.

Both the Global and Account Specific list uses the same screen, it displays as 
follows:
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The information given below applies to both the Global and Account Specific lists. 
What is shown here is the edit screen showing the default settings. How it works is 
that you can edit what appears in the pop-up list for the check number field, as well 
as the entries that are available for auto-completion in that field.

The manually editable list is for items that you always want to appear in the pop-up 
list.

This screen is showing the default settings, there are 4 predefined items; CkCrd, 
Dep, Trn and CashPt. The + and – signs at the bottom of the internal window allows 
you to add or delete items from this list. If you click on + to add an item you will need 
to scroll down the list to see and edit the new item.

Moneydance will also by default add recently used text found in the check# field from
either all accounts, or the currently selected account, up to the "Max Entries" number
that you select. The Max Entries number applies only to the automatically calculated 
recent entries.

The Recent Entries option provides options to show in the list free form items that 
have been used in the register(s), the available options are:

• Include from the same account.
• Include from all accounts.
• Don’t include.

Don’t include, as is implied, will only display the predefined items and creates a 
similar behavior to earlier versions of Moneydance.

It must be noted that when you include Recent Entries it is taking these from account
entries, it is not possible to edit them within this facility or include only some or to 
exclude some. The option to include is either on or off. If you want to change one of 
the values you must edit the transaction that it comes from and change the value 
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there.

It may not be obvious where the transaction is located that a value is being obtained 
from. In such cases you can use tools like the Advanced Search or the Find and 
Replace Extension to find any transactions involved.

The Max Entries options sets the number of free form items to be displayed.

If the Show Next-Check-Number option and/or the Show Print-Check Option 
check boxes are selected then the popup will also show entries for those items at the
bottom of the pop-up list.

The Balance Box

When in the account register, your balance is listed in the lower right hand corner.  
Clicking on this box will allow you to see the various balance calculations. Some 
values are available only for account(s) which download information and transactions
directly from your bank.

Balance: The total of all your transactions in an account register, regardless of date 
or cleared/uncleared status.

Current Balance: The total of all your transactions up to and including today's date.

Cleared Balance: The total of all transactions you have marked "cleared.”

Confirmed Balance: The total of all transactions you have confirmed.

Unconfirmed Total: The total of all transaction that are marked as unconfirmed.

Ledger Balance: The balance provided by the bank. This includes all “outstanding” 
transactions such as deposits that are still pending clearance.

Available Balance: The current available balance provided by the bank when you 
last imported/download transactions.

Entering Transactions

To create a new transaction click the New Transaction button at the top right of the 
Account Register screen.  The New Transaction dialogue box is located at the very 
bottom of your screen. You can also create a new transaction by typing N. Double-⌘
click on an existing transaction to edit it.
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Creating a Split Transaction

To split a transaction into several categories, open the Category drop-down menu 
from the New Transaction Box and select “Split” (or use the keyboard shortcut L).⌘

To record a split, click the New Split button for each Category ( N). Click the Done ⌘
button when finished ( W). You can only add splits from the “Parent” side of the ⌘
split – the account where the split was created, not one of splits (in this example, 
Groceries and Cash on Hand).

To ensure that the total of the transaction is correct, create the transaction in the reg-
ister, but make sure to enter in a total amount before clicking on the Split button. The
first line of the split will have the total amount of the transaction. Enter in the informa-
tion for this split line, and correct the amount. When you click on the button to add a 
new split line, the program will autofill in the total transaction amount minus the value
of the above split. You can continue this process for each additional split. This 
should allow you to make sure you have allocated the exact amount of the total 
transaction, no more no less.

Each non-parent portion of a split transaction will are noted with a small “s” in the 
description field.

Split transactions can be used for both deposit and payment transactions. The most 
common use is to split amounts between multiple categories. This can be on a 
payment transactions where you may buy multiple items at one business that relate 
to different categories but there is only a single payment made. On the deposit side 
the most common use is with a paycheck where you start with the gross amount 
then have taxation deductions, health insurance payments made before the 
remaining funds are deposited into a bank account, the next section gives an 
example of this setup.
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You can view the details of a split transaction that is in the register by hovering over 
the transaction and then holding down the ALT key. Note that the focus must be on 
the register, not that it merely be opened, you can achieve this focus by selecting a 
transaction in the register if it has just been opened.

Using a Split Transaction for a Paycheck

Split transactions are the perfect way to enter a paycheck, and provide a good 
example of their use.

Many people want to keep more detailed records of their paychecks, including the 
amount which is withheld for taxes, insurance premiums, Health Saving Account 
contributions, or other items. In this example the United States Tax and withholding 
system is used, but the same strategy can be used regardless of your country.

First, we will create a split transaction. The first line of the split is the “Salary” 
amount, which will be the gross income amount. The remaining lines of the split will 
reflect any amount withheld from the check – federal, state, and local taxes, 
insurance premiums, Social Security and Medicare contributions, and any other 
items. The total “Deposit” amount will now reflect the amount of your take-home pay.
See the example screenshot below:

In order to simplify the process of entering your paycheck each time, it is often 
easiest to create a reminder transaction. To do so, first select the existing paycheck 
selection. Then right click (or Ctrl+clicking or two finger touch on a Mac) the 
transaction and select “Memorize” from the menu which appears:
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This will bring up the Transaction Reminder dialogue box. If you are paid every two 
weeks, then it is often best to set the transaction to repeat every 14 days. If you are 
paid via direct deposit and your paycheck is identical each week, you may want to 
have this transaction automatically entered in the register. To do so, check the “Auto-
commit” box. To the right of the Balance header is a small double arrow indicator, 
clicking on this also acts like a right click and brings up the context menu.
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If you deposit your check manually, or your paycheck varies from week to week, it is 
best to commit the reminder manually. A reminder of your upcoming transactions will
show on your home page.

Click on the paycheck reminder to show the Reminder Notification window.
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In this window, click on the “Category” field to display the split editor inbox. Then edit
the amounts of the individual lines of the split as necessary.

Quick Transaction Entry from the Search Box

The quick transaction entry interface is an easy way to enter transactions from within
the search box.  Typing within the search box will bring up a quick entry interface.
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Moneydance will “guess” the account and category of the transaction based on how 
you’ve categorized similar transactions in the past.  Click the “Edit” button to change 
the transaction and the “Record” button to enter it into the register. The Quick Entry 
interface is not available though the Reminders view, Loan registers, the Budget 
Manager, and graphs or reports.

Auto-Complete

Moneydance has an auto completion feature for transactions. Transactions can be 
auto completed by typing in the payee field. With each keystroke, past transactions 
are searched for payees with names that begin with the text already entered. If a 
matching transaction is found, the rest of the current payee field is filled in with the 
matched payee value. At this point you can either continue to type, or use the TAB 
key to continue to the next field. Using the down arrow while auto-completion is 
active will display all address book entries and recent payees that begin with the 
letters that have already been entered and allow you to select one of them.  You can 
opt to have auto-complete be case sensitive or non-case sensitive. You can edit this 
preference in the File → Preferences → General menu item.

Auto-complete is always enabled there is no option to disable the feature. Auto-
Complete can be overridden to a degree by the order of entering the information, for 
example if an amount for an existing payee has changed but all other details are the 
same enter the amount, then the name of the payee. If all details except the payee’s 
name have change then enter the amount, category and memo first and enter the 
payee name last.

For downloaded transactions only those that have been confirmed are included in 
the search.

Getting a List of Field Entries to Select From

The auto-complete feature can also be used to give you a list of items to select from,
in order to complete the field. For example in the Description field say you have a 
variety of transfer transactions and they all start “Transfer”. Type two or three letters 
of the word then press the down arrow – or click on the double headed arrow at the 
end of the field – you will be presented with a dialog box with entries that match what
you have typed and you can select from these.

Attachments

To more easily track and reference receipts you can attach files (for example PDF 
documents, JPG and other image files) to transactions. You can attach multiple files 
to a transaction. You can attach a file to a transaction by dragging the file onto a 
transaction in the Moneydance program window, or by right clicking on the 
transaction (or ctrl+clicking on a Mac) or by clicking on the small double arrow 
indicator to the right of the Balance header and selecting “Add attachment” from the 
menu which appears.  Once you’ve attached a file to a Moneydance transaction a 
copy of the file will be stored in your Moneydance data set, and the original file can 
be deleted (if desired).  Transactions which have attachments will have a paperclip 
icon in the description field.
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To see an attachment click once on the transaction.  In the window which appears 
click “Details” to see a thumbnail of the attached file; click once on the file to view, or 
click the X to delete the attachment. The thumbnail viewer only supports image type 
documents, to see other documents you will have to click on it to view it within the 
applications associated with the file type.

Tags

Transaction tags provide another level of expense or income tracking.  For example 
with a vacation while you are likely to have your vacation spending spread across 
multiple categories, such as Lodging, Food, Gas, etc, a tag will permit you to easily 
track and run reports to determine the total cost of the trip by ensuring that the same 
tag is assigned to all expenses associated with the vacation.  To enter a tag, begin 
typing in the Tags field.  To assign multiple tags to a transaction enter a comma after
each tag. For example, typing:  tag1, tag2.

When you are generating your reports you could elect to use all categories but then 
use the Tag as a filter with the result that only vacation related expenses are 
included in the report. The chapter on reports contains details on what reports permit
filtering by Tags.

You can see a list of all your tags by going to the Tag Summary report. This report is 
available within Tools --> Graphs and Reports, or by scrolling down to the reports in 

50



the left sidebar.

Removing a tag from all transactions will delete this tag. Once deleted from all 
transactions, the tag will no longer be available for selection.

Using the Address Book with Transactions

Moneydance's address book allows you to include information such as street 
addresses, phone numbers and email contacts for people and businesses.  To add, 
delete, or edit addresses go to the Tools → Address Book menu option.

You can select any entry from your Address Book from the Description drop-down 
menu in an account register. Description choices which point to address book 
information are marked with green @ symbols.  Address book entries must be used 
to print addresses on checks.

Totaling Transactions in the Register

If you wish to get an ad-hoc total of a number of transactions in the register select 
the transaction you wish the total and the total will appear in the status bar at the 
bottom of the register.

Right-Click Menu

Right-clicking a transaction brings up the Transaction Editing Menu. If you are using 
a single-button mouse, holding Control while clicking will also bring up this menu as 
will clicking on the small double arrow indicator to the right of the Balance header.

From the right-click menu you can:

Add Attachment:  To attach image files to a transaction.

Create Reminder from Transaction:  Creates a transaction reminder.

Duplicate Transaction:  Opens the New Transaction dialog box and fills in the 
current information which can be edited.

Show Other Side:  Opens the register of the other account/category involved in this 
transaction.

Mark as Uncleared:  Removes green check mark.

Mark as Reconciling:  Inserts orange diamond mark.

Mark as Cleared:  Inserts green check mark.

Batch Change:  Allows you to make changes either to a single transaction, or to 
multiple selected transactions at one time. (See below for more details.)
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Delete:  Deletes transaction.

Single Line Mode:  Sets the register to display only the Description line entries.

Two Line Mode:  Sets the register to display both Description and Memo line 
entries.

Sort by:  Sorts the register by a specified set of variables. See “Sorting the Register”
for more details.

Ascending:  Sorts the register from earliest to most recent date.

Show Transaction Details:  Displays all information associated with the transaction 
in the format it will be saved to the data file.  Generally only used for technical 
support issues.

Using Batch Change

Right-clicking (CTRL-click for Macs) one or more selected transactions will bring up 
a context menu providing functions that can be applied to the selected transaction(s) 
as does clicking on the small double arrow indicator to the right of the Balance 
header.

Just to review, the method you use to select multiple transactions makes use of the 
following keyboard short cuts:
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Function Mac Windows/Linux

Select all transactions in the register  A⌘ <Ctrl>A

Select transactions between two 
transactions

Select first 
transaction
Hold down 
<Shift> and click 
on last 
transaction

Select first 
transaction
Hold down <Shift> 
and click on last 
transaction

Select discrete transactions Select first 
transaction, use 

 Click for ⌘
subsequent 
transactions

Select first 
transaction, use 
<Ctrl> Click for 
subsequent 
transactions

One of the functions of the Transaction Editing Menu is Batch Change, which makes 
changes to the currently selected transaction(s). Batch Change allows you to make 
changes to the Description, Check#, Memo, Tags, Category, and Account fields in 
the register.

Changing the Category of a transaction changes the information which is currently in
the Category field of the transaction.  Changing the Account of the transactions will 
move them out of the current Account (or Category) register into a different Account 
(or Category) register.

Under Batch Change you can change the following values:

Item Description

Description The Description (payee) for the transaction(s)

Check # The text in the Check # field

Memo The Memo for the transaction(s)
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Tags The Tags that have been assigned to the transaction(s)

Category The Category that has been assigned to the transaction(s)

Account The Account the transaction(s) is/are in

In many cases this tool is used to change the value in multiple transactions, perhaps 
to correct a recurring mistake. In other cases, for example, it may be to add tags to a
range of transactions.

Account is a little different in that this changes the Account that the transaction is in 
so it is effectively a move command, you should note that if an account has been 
marked as inactive it will not be an option as the destination for the selected 
transactions. If you need to move transactions to an inactive account you will need to
first mark the account as being Active.

You can use Batch Change to move transactions from a Bank Account to a bank 
register in an Investment Account and vice versa, however you cannot use Batch 
Change with transactions that are in an Investment Register.

Batch change is a powerful command you should be very aware of what sort of 
register you are in, for example if you are in a category register and select to change 
the Category you can get into a lot of trouble quickly.

It is strongly recommended to take a backup before you start using Batch Change.

Sorting the Register

Right-clicking (CTRL-click for Macs) in the transaction register or clicking on the 
small double arrow indicator to the right of the Balance header will bring up a context
menu, selecting Sort By in this menu brings up the following display.

Select how you wish the register to be sorted. The items have the following meaning:
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Date:  Chronological by Date column.

Date Entered:  When you entered the transaction into the register.

Description:  Alphabetical by description field.

Amount:  Sorts by Payment and Deposits fields.

Cleared Status:  Sorts transactions by status under the “C” field.

Account:  Sorts transactions by account/category under the Category field.

Date/Status:  Sorts transactions by date, then by status within each day.

Date/Amount:  Sorts transactions by date, then by amount within each day.

Date/Check#:  Sorts transactions by date, then by check # within each day.

Check#:  Sorts transactions by check number.

Status/Check#:  Sorts transactions by status and check number.

Moving a Transaction Between Accounts

It is not immediate obvious how to move a transaction between accounts. In many 
application Cut and Paste is used for this purpose, in Moneydance cut and paste 
works at the field level, not at the transaction level, transactions comprise multiple 
fields.  To move a transaction you can use the following process.

1. Select the transaction.

2. Right click on the transaction and select Batch Change.

3. Select Account from the drop down list.

4. Select the account you want to move the transaction to then select OK.
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The transaction should now be in the correct account.

Duplicating a Transaction

To duplicate a transaction right click on the transaction and choose the menu item 
Duplicate transaction, you can then change and details like the date and save the 
transaction.

Copying a Transaction Between Accounts

It is not immediate obvious how to copy a transaction between accounts. It is a two 
step process.

1. Duplicate the transaction.

2. Use Batch change to move the transaction the newly duplicated transaction to
the other account.

Transfers and Categories

When you transfer funds from one account to another it is seen as a simple transfer 
in Moneydance. There is no provision to also assign a category. As Moneydance is 
based on account principles that is not unusual, a reduction of the value of one 
account is exactly matched by an increase in the value of another. To also have it 
increase the value of a category would be counting the increase in two places.

In many instances the way this works is entirely appropriate, for example the transfer
that you enter in Moneydance to pay off a credit card, each individual expense in the 
credit card has already been assigned to a category so a transfer just removes the 
debt.

In some cases however it may be appropriate to record the transfer and assign a 
category. It is accounting principles that are preventing us doing that so the 
appropriate approach is to use an accounting methodology to facilitate it. The basic 
problem we have is that we want a transaction to have 3 legs, the transfer out of an 
account, the transfer into an account and a category. In simple terms we need 4 
legs. Moneydance is using Double Entry accounting so everything is done in 
multiples of 2.

Our original transfer has 2 legs – or two sides to use accounting parlance, we need 
to create what is effectively a four sided transaction, which in fact we do by creating 
2 x 2 sided transactions.

In the example given above we have said there are two account plus one category 
that we want to use. What we can do is create another category to use with our 
transactions and thus give us the 4 legs needed. If this is a regular occurrence the 
category may be named as something as simple as “Money to XYZ acct”.

The first transaction would be drawing the funds from the source account and using 
the above created account. The second transaction would be the deposit to the new 
account with the category you require.

56



Voiding a Transaction

Moneydance does not have a facility to void a transaction.

In double entry accounting you never void a transaction, rather it you post a 
transaction and for some reason it never completes you post a reversal entry to the 
account. This technique can be used in Moneydance, if you want to follow what 
happens in the accounting world.

We can however adopt an approach that mimics the action of voiding a transaction 
but maintains the details of what the transaction would have been if it had 
completed, and thus preserve the information that is in the transaction. To take this 
approach you need to edit the transaction and make changes along the following 
lines:

• Set the value of the transaction to 0.

• To keep details of the transaction on file it is suggested you edit the memo 
field to include what the value of the transaction would have been.

• To indicate that the transaction has been voided it is recommended to also 
add the text VOID to the memo or description field, perhaps as the first word 
in the Description.

Stop Payment

Moneydance does not have a facility to automatically record a stop payment.

In double entry accounting you never remove a transaction, rather it you post a 
transaction and for some reason it never completes you post a reversal entry to the 
account. This technique can be used in Moneydance, if you want to mimic what 
happens in the accounting world.

If your bank posts the transaction then reverses it, the method descibed above would
be how you approach it.

If the transaction is never posted by the bank but you wish to keep a record and  
maintain the details of what the transaction would have been if it had completed 
there methods you can use. An approach you can take to achieve this is you need to
edit the transaction to make changes along the following lines:

· Set the value of the transaction to 0.

· To keep details of the transaction on file it is suggested you edit the memo 
field to include what the value of the transaction would have been.

To indicate that the transaction has been stopped it is recommended to also add the 
text STOPPED  to the memo or description field, perhaps as the first word in the 
Description.

Parent/Child Accounts

Child accounts are often use when you want to allocate money for a particular 
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purpose.

A trap that can be fallen into is to name the child account after the specific purpose, 
like vacation, the trap occurs when you have a category with the same name. So first
up ensure the account names you choose do not duplicate a category name.

Child Accounts are not available with Investment Accounts. Investment Accounts 
use Child Accounts (called sub accounts in this context) for the securities you assign
to the account – a separate child account for each security.

We will demonstrate the use of child accounts through an example.

A question that often arises is if it is possible to allocate money toward, and keep 
track of, say things like a Vacation Fund or Christmas Fund in Moneydance but 
without having separate physical accounts, so the money is all in the one actual 
bank account. 

We are going to show a worked example of using Parent and Child accounts to 
achieve the objective, we are going to pack as much as we can into the example, 
you may not want to go to this level of set up but we hope it gives you some general 
ideas which you can adapt to suit your own needs.

The setup we are going to have includes having a Vacation Fund, a Christmas Fund 
and your Savings Account, we are going to have an overarching Parent account and 
call it Saving Funds

So your accounts in Moneydance would look like:

Savings Funds
|___>Savings Account
|___>Christmas Fund
|___>Vacation Fund

You may think that we should use the real Savings Account as the parent, and you 
could do this but our aim in using this structure is that on the Summary page and in 
the side bar we can see:

• The amount we have allocated to our Christmas Fund

• The amount we have allocated to our Holiday Fund

• The amount we have available in General Savings

• The total amount in the actual Savings account.

The way we are working this example is that there will be no transactions at all in the
“Savings Funds” account. You could have the Savings Account at the parent level 
and transfer general savings to a child account but the way we have done we believe
will result in less transactions and the software will calculate the general savings 
balance through the transactions entered.

Let us look at what this setup looks like on the summary page

The account called Savings Funds will show the bank balance of your Savings 
Account. The account in Moneydance called Savings Account will have the bank 
transactions in it but will show the available savings balance based on your 
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allocation, we have shown the setup with some transactions already entered. You 
will most likely use better names than we have chosen here.

Lets us examine how we got to this state. We are going to transfer 1000 from the 
current account and allocate some funds to the holiday and vacation funds:

We have used the Check number field to assign some unique references to the 
transfers to/from child accounts that we will make used of in during the reconciliation 
process.

Just to show the Holiday and the Christmas funds we have:
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In this method of managing child accounts we will only have transfers in the child 
accounts, any banking transactions will be entered in the Savings Account and if 
money is needed from one of the child funds then they are to be transferred back to 
the Savings account.

While you can use split transactions to do things like deposit money to the saving 
account and split some of the deposit to the child accounts we are going to suggest 
you do not do so using this method. 

The reason for this recommendation is that when it comes time to reconcile the 
account you of course only see the actual banking transactions to and from the 
account. The transactions you have entered to move money to/from the child 
accounts do not exist in the banking system, hence entering the transfers as 
standalone transaction helps with identifying them during reconciliation.

Reconciliation

When you are reconciling the account you select the parent account but you also 
select to include sub account in the reconciliation Window. 
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You can see we have selected the parent plus checked on the include sub accounts 
option as well as entering the end statement balance as usual.

The result of this is that you will see all the actual transactions plus the transfers 
to/from the child accounts as the following image shows:

The reference details we entered into the check number column can be used to 
match the transfers between the child accounts and allow us to easily identify and 
mark them as reconciled.

There are a couple of alternative approaches we could have taken here, we will 
discuss them briefly.

1. When entering the transactions you could have right clicked on them and 
marked them as reconciling. The result of this would be when you have the 
reconciliation window displayed these transactions would have already been 
selected (marked with an orange diamond).
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2. When entering the transaction right click and mark the transaction as 
reconciled (marked with green circle). By doing this the transaction will never 
appear in the reconciliation window so that it will only show physical 
transactions.

We hope that this section has provided some ideas on managing parent and child 
accounts.

Managing Home Inventory

The ability to have a home inventory within Moneydance, for such purpose as 
maintaining records for insurance purposes, has been requested on occasions. As 
Moneydance is based on accounting principles it has been necessary to develop a 
method that can exist within an accounting based system.

The method given here shows the basics that can be used to record and maintain an
Inventory in Moneydance.

You start by creating one or more asset accounts to contain your inventory, with one 
category to offset the assets. 

At the simplest level you use the description and memo fields to record details of the 
Asset, so things like description, model, serial number etc and the increase field to 
record the value.

It is suggested that you use tags for the categorization of each item in the inventory if
you are looking for more granularity, because by taking this approach you can have 
one asset account for home inventory. Another alternative is to create different asset
sub-accounts, some users have defined sub accounts based on the rooms in the 
house for example. However if the asset changed “categorization” you may have to 
move item between sub accounts.

You should record any purchase of an item separately from the asset record. If the 
purchase is regarded as an expense (including taxes, etc) categorize it in the most 
appropriate expense category, and create a separate entry in the Inventory Asset 
account this allows the asset itself to be valued something different than what you 
paid for it and can be changed over time if needed.
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Chapter 6: Investment Accounts
Investment Accounts hold any type of securities (stocks, bonds, mutual funds, etc.) 
as well as cash.

Investment accounts can also support the entry of standard bank transactions 
through the Bank register thus enabling Investment accounts that also provide 
standard banking functionality.

You can setup an investment account by navigating to Account → New Account.

The set up screen looks the same as for a Bank account, but the underlying account 
works in a very different way. With this screen what we are really doing is setting up 
an account like a Brokerage account. Within the brokerage account you can set up 
and add your securities and work with them through the brokerage account.

The set up does make provision for the Check Number field and like other accounts 
the default settings for the Check Number field are to use either the system default 
or account specific settings. Where the operation of this field differs in Investment 
account is that it applies to the Bank Register and in the Investment Register to the 
field used for the other side of the transaction i.e. the field below the Action field.

The set up of the Investment account does not mean that you can only use 
Investment accounts for share type securities, the setup can be used for any sort of 
Investment. The main thing to note is that the Investment account is where the 
individual investments are held in, no matter the type of investment. Some examples 
of using the Investment account for various types of investments are given later in 
this chapter.

We have made mention that Moneydance follows the principles of Double Entry 
Accounting. In most instances this works well This has some limitations when we talk
about Investments. In the accounting system the “ledgers” have entries for total 
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amounts, they are not concerned with how much a specific share costs or what an 
individual share is worth over time for example. The journal entries will often have 
the detail of things like these.

When an accountant or bookkeeper needs to work with this detail they will often 
make use of worksheets. These worksheets are the basis of Spreadsheet programs.

Moneydance has some of this worksheet detail built into it, so in this sense it is a 
superset of what your accounts would normally be in an accounting system, but it 
does not include all the details. Hence within this chapter you will encounter times 
when it is suggested that a spreadsheet (worksheet) be used to maintain the level of 
detail needed just as you would in Accounting.

Managing Investments

Investment accounts in Moneydance are primarily used to aggregate and track the 
value of a set of securities, as well as calculate the cash balance that is created by 
all transactions in that account.

You can display and modify your investment holdings using three different options:

• Portfolio View

• Investment Register 

• Securities Detail

and easily enter standard bank-type transactions in the Bank Register View.

Securities

Securities are items of value that can be aggregated and tracked in investment 
accounts. Examples of securities include stocks, mutual funds and bonds. The value 
of most securities change over time. In Moneydance, all securities are recorded 
relative to your base currency but can be displayed relative to any other currency.

All of the securities in your data file are accessible via the Tools → Securities menu 
or by clicking on the Stock Prices link on the Summary. You may add, remove or 
modify individual securities using this window.  Double-click on the name of a 
security to view and modify the Currency/Security History, including price and split 
history, current price, and currency in which the price is displayed. Click the “Edit” 
button to make changes to the ticker symbol, suffix, prefix and security name, as well
as to display the security’s price on the Summary Page.
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The Portfolio View

The Portfolio view provides an overview of a single investment account. All securities
in the selected investment account that have non-zero values are listed along with 
their current price, number of shares and the current value. The total value of the 
securities as well as the cash balance of the investment account are also displayed. 
If the investment account contains multiple types of securities (stocks, bonds, CDs, 
etc) then a graph is created showing the distribution of value across the different 
types of securities.
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The Investment Register

The Register view shows all transactions in your investment account, including bank-
type transactions. Clicking on a column header in the Investment Transaction 
Register will sort the transactions by that field, if possible. Additional functions are 
available by right-clicking (or control-clicking on a Mac) on the register or by clicking 
the pop-up icon in the top right corner of the register.
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Entering Transactions in the Investment Register

When editing transactions in the investment register, different fields may be enabled 
or disabled based on the type of transaction (the Action). The different fields are 
described below:

Date:  The date that the transaction was posted to the account.

Tax Date:  The date of the transaction for tax purposes.

Action:  The type of transaction. The possible Action types are listed in a separate 
table.

Check#:  If this account allows checks to be written from it, this field can be used to 
record the check number or other Check # field options.

Description:  General description of this transaction, or payee if this is a check or 
transfer.

Memo: General notes on this transaction.

C:  Cleared status: blank means the transaction is uncleared, a diamond indicates 
the transaction is in the process of being reconciled, a green circle indicates that the 
transaction has been reconciled (cleared).

Security:  The security that is associated with this transaction, if applicable.

Category:  The expenses or income category that is assigned for this transaction, if 
applicable.

Transfer:  The account or category from/to the funds for this transaction are 
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transferred, if applicable.

Fee Category:  The category to which the fee for this transaction is assigned, if the 
fee is non-zero.

Shares:  The number of shares being purchased or sold, if applicable.

Price:  The price of the shares being purchased or sold, if applicable.

Amount:  The total amount of the transaction. If shares are being purchased or sold 
then this will be equal to the number of shares multiplied by the price, plus (or minus)
any fees.

Fee:  The fee charged by your financial institution for this transaction.

Cash Balance:  Non-editable field which displays the cash balance of the account 
after this transaction is applied, in the order specified by the register sorting.

Investment Action Types

The possible Action types are:

Buy:  Purchase shares of a security, or units in an investment from funds in the 
account.

BuyXfr:   Purchase shares of a security, or units in an investment using funds from 
another account.

Sell:  Sell shares of a security, or units in an investment and deposit funds into the 
account.

SellXfr:   Sell shares of a security, or units in an investment, placing the funds into 
another account.

Div:   Dividends or any income earned for a specific security, funds are deposited 
into the account. In general this is the action to use for any regular income from an 
investment, with an appropriate category used. The name of “Div” is used for 
compatibility.

DivReinvest:   Dividends or income earned for a specific security are used to 
purchase more shares of that security. In general the action for any regular income 
from an investment, that is used to buy further units in that investment with an 
appropriate category used.

DivXfr:   Dividends or income earned for a specific security that are transferred to 
another account. In general the action for any regular income from an investment, 
where the funds received are transferred to another account with an appropriate 
category used.

Short*:   Sell shares of a security that you do not own, but can borrow (often from 
your broker), in the anticipation that those shares will go down in value and can be 
purchased for less in the future in order to return them to the lender. In the register 
the Short sale works and looks the same as a Sell transaction. This type of 
transaction is often referred to as being shorted.

Cover*:   Purchase shares to cover those that were previously short sold. In the 
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register the Short sale works and looks the same as a Buy transaction. This is the 
transaction that is used in order to repay the shares to the lender.

MiscInc:   Miscellaneous income associated with a specific security.

MiscExp:   Miscellaneous expense associated with a specific security.

Xfr:   Transfer funds to or from this investment account. This action can also be used
to record income or expenses transactions that are associated with the investment 
as a whole rather than with a specific security.

* Short and Cover transactions work in tandem while they show value in the account
register they individually do not show any value outside of the register, only any 
difference in the value of the two transactions is shown outside of the register.

Actions

With some products you will see quite an extensive list of Action Types, this could be
because in those product the action type determines not only how a transaction is to 
be processed but also the category that is to be used. Moneydance does not follow 
this practice.

In Moneydance the Action Type determines how a transaction is to be processed, 
the category to be used is determined by you when you post the transaction. This 
method offers a number of advantages:

• Adaptable to any country

• Facilitates any category structure

This method is therefore more flexible. Some samples of how you may map some of 
these action types to Moneydance is given in the following table.

General Action Moneydance Action Moneydance Category

CGLong Div Capital Gains:Long

CGMid Div Capital Gains:Mid

CGShrt Div Capital Gains:Short

ReinvLg DivReinvest Capital Gains:Long

ReinvMd DivReinvest Capital Gains:Mid

ReinvSh DivReinvest Capital Gains:Short

IntInc Div Interest Income

IntIncX DivXfr Interest Income

ReinvInt DivReinvest Interest Income

MargInt MiscExp Margin Interest

In short any routine income event can be mapped to the Div action and its 
derivatives. Div can be thought of as a synonym for Income (Inc). For example 
distributions from a Mutual fund can use the Div action type with a category perhaps 
of Mutual Fund Distributions.
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Using the Xfr Transaction

The Xfr transaction is quite flexible but it is also very generic at the same time. The 
typical use is of course to transfer funds into and out of the investment account, but it
can also be used to record any sort of income or expense transaction. 

The notable thing however is that with an Xfr transaction you cannot record any 
income or expense against a specific security, hence it is just recorded against the 
account. This could be the determining factor of whether to use this action type to 
record a specific transaction or whether something like MiscInc, MiscExp or Div may 
be a better choice,
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Bank Register View

Moneydance offers integrated support for linked investment and checking accounts.  
The bank register view makes it easy to enter standard bank-type transactions, and 
include these transactions in the balance of your investment account. The bank 
register is also used to enter transactions that the Investment register does not 
allows for.

For information on using the Bank Register in Investment Accounts refer to the 
Chapter on Standard Accounts as it functionally the same.

Transfers from Investment Accounts using Different Currencies

For users that have account and/or investment in two or more currencies it can be 
necessary to transfer funds between these accounts.

Where you need to transfer funds from an Investment account to another account 
that is in a different currency use the "Bank Register" instead of the "Register" to 
enter these transfers, the Investment register does not have any provision for 
exchange rates. You can either enter the exchange rate or the foreign amount. This 
keeps both accounts correct.
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The Securities Detail View

The Securities Detail View shows specific information about individual securities 
within the account.

Information is displayed for the selected security in the pop-up list. You can 
customize the graph by CTRL+clicking or right-clicking anywhere in the image field 
to bring up a number of options, including the ability to copy, print, and save the 
graph.

Transaction List:  A list of all transactions associated with the selected security 
within the current investment account.

Security Information:  Details such as the number of shares owned, current price, 
current value, cost basis and the percentage change of value. 

Security Function Buttons: for recording a stock split, adding or editing a new 
security, editing the lot assignment, editing the price/volume history, and removing 
the security.

Performance/Volume Graph: This graph displays the price of the security over time
(adjusted for splits) as well as the trading volume. The colors of the elements in this 
graph can be changed, Title and borders by right clicking and selecting properties. 
Lines and other elements require using the theme element editor, however such 
changes are global and effect any graph. The relevant colors are:
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Graph data set 1 Color of volume bars in Securities detail graph 

Graph data set 2 Color of plot line in Securities detail graph

Graph data set 3 Color for the "Buy Shares” marker in securities detail graph

Graph data set 4 Color for the "Sell Shares" marker in securities detail graph. 

Refer to the chapter on Themes for more detail on color changes.

Lot vs Average Cost Purchases

In essence, the cost basis of a set of shares is the amount that was spent acquiring 
those shares. Moneydance currently supports Average Cost and Lot-based Cost 
calculations.

Average Cost: This is the simplest calculation method, in which shares are 
assumed to have a cost basis equal to the average price paid for that security times 
the number of shares. This is the default selection in Moneydance.

Lot-based Cost: This calculation method allows you to select which buy 
transactions (and individual shares within those transactions) were used to purchase
the shares for each sale.  This is the appropriate method to facilitate the FIFO (First 
In, First Out) method of tracking your shares, or where you have the option to specify
which lots are sold.

Adding Securities to an Investment Account

Setting up securities in your investment account happens in three stages: creating 
the security, associating it with an investment account(s), and entering your holdings.

The core information about Securities, like prices, are stored in their own data 
structure independent of Investments or the Investment Accounts.

With this design, the premise in Moneydance is that a security should only be 
defined once within the Data Set and it can then be associated with as many 
investment accounts as required.

If this approach is not taken then you would have individual security definitions 
defined for every account where the security is used and the same security details 
and prices would be stored in each definition this leading to significant duplication, at
least. We have noted in some instances that only one instance of the price will be 
updated thus giving rise to problems in things like the net worth report.

Thus you should not define multiple instances of a security.

Creating a New Security 

From the "Securities Detail" portion of your investment account, choose Add Security
→ New Security.  There are a number of fields you will need to enter:
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Security ID:   A unique identifier of a security within Moneydance, it is not something
that has any existence or relevance outside of Moneydance.

Security Name:  The name of the security.

Ticker Symbol:  Enter the symbol for the stock.  Moneydance can download stock 
information from Alphavantage, Yahoo! Finance, TD Ameritrade and IEX Trading.

Price:  This value can be changed either from the "History" window or by using a 
number of the extensions that are available.

Value Prefix and Suffix:  By default, holdings are measured in shares as in equity 
holding. If you have some other kind of denomination for your holdings (such as 
contract for options) you can enter them here either as a prefix or a suffix to the price
per unit of the security.

Decimals:  Be sure to enter the same number of decimal spaces that are used in 
your broker's share accounting. (In most cases this will be 2, although some use 4 or
6.)

Associating an Existing Security with an Investment Account

If you have already created your security, you can associate it with a particular 
investment account by opening the Securities Detail view and clicking on the “Add 
Security” button.  Select the appropriate security and fill out the rest of the security 
information identifying it as a stock, bond, CD, option contract, etc. and the particular
information unique to that type of security. Most of this information is just used for 
identification purposes and is not used in calculations of any kind within 
Moneydance.  Creating a security using this method will automatically associate it 
with the investment account you are currently working in.

Classifying Securities

If you consider the Portfolio view given earlier you can see that each security 
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included in the account is listed separately, you can also see the Asset Allocation 
graph. The table is simply built from the securities. The Asset Allocation graph is not 
however, you can see in this case it is showing the Cash balance in the Investment 
Account. The total of Stocks and the value of the Mutual fund.

This is managed using Security Types and Sub-types. You can also create new 
investment sub-types. The available Security Types are:

Stock

Mutual

CD 

Bond

Stock Option

Other

Creating a custom sub-type is one way to add additional tracking information, or to 
add sub classifications, for example under Mutual you might have sub classifications 
for different types of funds. This is also especially helpful when holding non-
traditional investments such as peer-to-peer notes, precious metals, or barter items, 
which can be grouped under “Other”.

To create a new investment sub-type, open your investment account register.
Select "Actions" at the top right of the register, then select "Add Security".
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If necessary click "New Security" and create the new security. Alternatively, select an
existing security from the drop down menu.

Then look for the Sub-type field and select 'Edit' to the right of this.

In the window that opens, you can add or delete security sub-types.

Once created, these sub-types will be available for selection in the "Sub-types" drop 
down menu, in the previous window.

Note that this is the only path you can use to access these particular Security 
Screens, they CANNOT be access via the Menu item Tools → Securities.
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As stated earlier we can use this capability with Mutual Fund type investments to 
give more granularity to our investment reporting. A Fund can be comprised of other 
funds, if each of these sub funds are given a sub-type using the method outlined 
here your Asset Allocation graph will show the splits, for example one fund might be 
comprised of domestic shares, another of International shares, another of 
Government bonds, yet another of Property etc.

Another area of Mutual Funds where we can make use of this feature is with the 
cash balances in a fund. Most funds pass all cash through some type of account, 
now for some type of funds you may decide that having cash being carried as a 
balance in the Brokerage account is sufficient, however this does not allow for things
like Interest being earned on the cash balance as payments received in Investment 
accounts must be against a security. Funds will often set the cash accounts up as if 
they were a security, they may even be in the form of a Money Market Fund. The 
way the data downloads can also determine the most appropriate approach to take. 
Setting up a security and doing buys and sells of this security at a fixed value of 1.00
may be the best approach to take for a Cash Account.

The classification of securities into types and sub-types is performed at the 
Investment account level. This allows for a security to be classified differently 
depending on which account it is in. This allows for the greatest flexibility, as for 
example in one account you may broadly classify Investments into classifications like
property, CDs, shares etc. Yet in another shares may be broken down based on 
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industry type classifications e.g. Health, Finance, Utility etc.

Entering Transactions

This section will discuss entering various types of transactions. We will concentrate 
on the less usual types of transactions.

Methods of Entering Your Holdings

It is important to remember that Moneydance, when working with transactions 
imported from your financial Institution, can only import the data that the institution 
provides.  Therefore, unless the initial purchase of the security is in the download, 
along with all subsequent buys and sells you will not have the complete information 
for your security.  You may need to manually enter transactions for the account to 
reflect your current holdings.

Manual Entry

The most straightforward way to enter your holdings is to manually input all of the 
account transactions from the date of purchase to the current date into the register.  
This will allow Moneydance to track capital gains.

Starting with a Current Balance

If you feel you have too many historical transactions to enter manually, or prefer to 
start from your current balances, you can do so.  It is important to remember that if 
you start from the current balance and do not enter all the historical transactions, 
Moneydance will not be able to track capital gains.

If this is the method you choose, you must enter some form of “buy” transaction for 
all the shares of each security you own in the account. To add your current holdings 
for a security you can enter a Buy transaction for the total number of shares you 
currently own using the current market value.  For example, if you own 50 shares of 
XYZ stock, enter a single Buy transaction for 50 shares (even if you purchased them 
over time), using the current market price.  You could also enter the original basis for
the stocks and the appropriate number of shares, which permits better tracking of 
your ROI.  Repeat for each of your securities.  Once you have entered each of your 
securities this way your account will show a large negative cash balance. To correct 
this, go to Account → Edit Account (make sure you are in the account you want to 
edit) and enter the cash balance number as the starting amount in the Initial Balance
field (without the negative sign, of course).

An alternative method is you can enter BuyXfr transactions with a category like 
"Initial Holdings" as a custom income category to reflect that you already possess 
these securities at the creation of this account within Moneydance.

Fees

Handling fees when you are buying and selling stock, is either added to your 
purchase cost or is deducted from your sale proceeds and you can handle this in the

78



Buy or Sell transaction.

With funds there are various ways fees can be handled. Some funds insist that you 
maintain a Cash Account within the fund. Fees are taken from this account. How to 
handle this in Moneydance is dependent on how you set up the cash account. You 
may have to use say a MiscExp action to reduce the cash balance or if you maintain 
the account like a Money Market security you may need to perform a sell.

In other instances a fund may remove units from your account to pay these fees i.e. 
the value of the units taken is equal to the amount of the fee.

It is this method that we are concentrating on here, you can also use this approach if 
you have a Money Market security that is sold down to pay the fee as it is the same 
approach.

As with many things there are multiple ways of recording the transaction(s)  that are 
needed in creating this section as least three came to mind, but here we will look at 
what we think is the neatest and simplest approach.

We need to:

• Remove the number of units from the account that we have been advised

• Reduce the amount of the investment by the total amount of the fee

• Record this against a suitable Fee category.

So to record our transaction we need three pieces of information:

1. The number of units that are being taken

2. The price per unit

3. The total amount of the fee

Funds have many ways of providing information. The information we need here may 
be easily identified or it may be more obscure, you could need to look at the account 
transactions, you may also need to do some calculations from the data provided.

The only action type we have that reduces our ownership, in a standard way, is the 
Sell action, so this will be the action used here. For Description and Memo you can 
enter something informative, in the example here I have just used “Management 
Fee”

As with any sell you enter the price and the number of units (shares) that are being 
removed, in the fee amount field you enter the total fee. As the fee is the number of 
units x the price we should expect the total amount to be 0 and the cash balance in 
the account to be unchanged. We also enter a suitable category in the Fee Category
field I have used Investment:Management Fees in the example The screen shot 
below shows such a transaction.
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We have included the whole Moneydance window in this shot. To keep the example 
simple we have used the same price for both the purchase and when the fee was 
charged, it would be unlikely to be the same in the real world. 

You can see the initial purchase had a value of 500.00 with a share price of 10.00 
and after the fee has been charged the current value of the investment is 492.77 with
a share price of 10.00 but you can also see that we have 0.723 less shares, which 
accounts for the reduction in total value, which is the management fee.

Return of Capital

Return of Capital is a transaction type that very few finance programs have provision
for. In function it impacts the costs of assets and capital gains. In purely financial 
accounting terms it is a receipt of money and it is easy enough to pass entries to 
reflect these funds as such. A miscellaneous Income or even a Dividend will process
the payment, you can categorize it as a Return of Capital and post the monies to a 
bank account or to where ever else it may have been deployed, so programs satisfy 
this basic requirement of recording the funds.

Where programs are not assisting is in fields like taxation accounting, a return of 
capital reduces the cost basis of an asset. In overall terms you may have shares that
cost $1000 and you receive a Return of capital of $100 the cost basis of the shares 
is now $900. If you were to sell them for $1200 your capital gain is $300. Based on 
the transactions that we have this would not be reflected in any reporting being 
provided by the software.

To further complicate it shares are often built up over time, perhaps an initial 
purchase then dividend reinvestment is used to build up the holdings. Each of the 
purchases is referred to as a lot. When you have a Return of Capital the cost basis 
of each individual lot is changed. In some jurisdictions it is necessary to measure 
capital gains on a lot by lot basis at other times it may be desirable to handle it this 
way as it can impact the taxation position.
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In Moneydance we have the situation where the software does support lot matching 
but does not support Return of Capital, it is able to perform the basics of Financial 
Accounting but not the additional detail needed to support functions like Taxation 
Accounting. This leaves us with the quandary of how much to record, what actually 
to record and indeed how much data do we maintain in Moneydance.

There is no one answer, the position to take may simply be determined by how much
recording it would take to keep everything in Moneydance, or what level of detail to 
keep in the software. What is hoped to present here is some ideas and options.

Keep all data in Moneydance

This is probably the ultimate approach, but not without a downside. The main 
downside is that you lose pretty much all performance information, for many this may
not present a problem.

The method is easy to understand, but it requires some work, this is the other 
downside, and there may be a considerable amount of work to maintain the data. 
The assumption is that you will keep all data down to the lot level. You need to have 
the information on each lot, specifically the number of shares purchased and the 
cost.

For each lot you will enter a sale for the number of shares and the cost price, so if 
you have 10 lots you will have 10 sales. At the end you will have a cash balance in 
the account equivalent to the total cost of the shares.

From your Return of Capital advice you should have the return for each share, or 
can easily calculate it, i.e. Total Return/Number of Shares.

You will now enter a buy transaction for each lot with the price being the original cost
price – the capital return, so you end up with 10 purchase transactions using our 
example.

The funds left in the Investment account should match with your received Return of 
Capital, and can be deployed as required.

For a once off return using this method may not be too onerous. For investments that
routinely do Returns of Capital it could prove unworkable – I investigated one 
investment and I have calculated it would require in excess of 1200 transactions to 
date to maintain the information, so it would require a lot of work and more ongoing 
work.

Keep only High Level Data in Moneydance

At times it may be the decision to keep only high level data in Moneydance, by this I 
mean to only keep what really amounts to the basic financial information but to do it 
in a way that preserves some elements of the taxation data so that you gain some 
insight into the total performance.

This approach means that you will be maintaining some data outside of Moneydance
but in a way that minimizes the work required. I would suggest using a spreadsheet 
for maintaining the needed data outside of Moneydance. We are dealing with 
numeric data and calculations, exactly what spreadsheet software is intended for.
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What is going to be maintained in Moneydance is the overall position of the 
investment. At the outset I will say that the cost basis and capital gains reports in 
Moneydance will show rubbish, there is no avoiding this.

We need to set the security in question to use Average Cost in Moneydance.

When you receive a Return of capital you will enter a sell transaction for zero shares 
and the amount of the return, you deploy the funds received as required.

On screens like the Security Details the correct total cost base should be correct, on 
the performance report the total should also be correct.

The spreadsheet is where you will keep the details needed for cost basis, capital 
gains and taxation use.

A simple structure could be to initially record each buy transaction. If you receive a 
Return of Capital that is done within a new column, at the type you could record the 
data, the total amount of the return, the amount per share, really the basic 
information. A Simple formula is then used to calculate your new cost price per 
share, you can have additional columns to give you total cost price of that lot etc.

If you do any sales that again is its own column(s).

I leave it to the reader for the most suitable setup.

This type of work is very easy in a spreadsheet and does not take long to do.

An important point to note is that your financial data now comprises not only your 
Moneydance data but these spreadsheets, so that it is just as important to back 
these up as your Moneydance data set.

It is not recommended to make them an attachment, these are living documents that 
can and do require updating not the static type of documents that things like receipts 
are. We can possibly take note of how attachments work however.

Attachments are stored in a folder within your Moneydance data set. You could 
create another folder within the data set for the spreadsheets which would mean that
any and all spreadsheets are backed up with your Moneydance data. Note that I am 
not suggesting they will be included in any synchronizing, they will not, just that this 
ensures they would be included in a Moneydance backup, any movement of these 
documents between machines would have to be done by hand.

This approach is certainly at odds with the concept of maintaining everything in one 
place, but it is not so much at odds with the way bookkeeping is often performed. In 
many systems you have a set of books, these comprise the ledgers, various journals
and even worksheets, together they form your bookkeeping system and put simply 
not everything can be easily done in the one place. Compare this with using 
Moneydance and then having a number of spreadsheets, as a whole they comprise 
your Personal Finance System, but what is being done is using the best tool for each
job.

Capital Call

A Capital Call is processed in the exact same way as a Return of Capital but with 
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one import distinction, the flow of funds is in the opposite direction. Capital Calls can 
occur with partially paid shares or with shares that have been bought on an 
installment basis. So part of the money is paid on initial purchase and the remaining 
monies are paid in one or more calls at a latter time. It is very common with projects 
like mining ventures where the project is staged.

The difference in the process to be employed in Moneydance is that ware doing 
many things in the reverse order, so whereas in a Return of Capital moving money 
out of the Investment account is the last thing done, in a Capital Call moving money 
into the account is the first thing done. From there the processes employed are the 
same as in a Return of Capital.

Option Handling in Moneydance

When setting up to handle an option you associate a security with the investment 
account then within that account you edit the security as outlined earlier and set the 
type to Stock Options. You should name the security to identify which option it is. 
Each option should have a unique ticker, as options can often be short term it is 
likely that prices will not be downloadable.

This then shows additional options as can be seen above, these options include:
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Option Purpose

Call/Put Select whether this is a call or a put option

Stock Price Set the Stock price

Exercise Price Set the Exercise price

Exercise Month Set the month the option can be exercised in

Comments Additional Comments

For information the following definitions are provided.

You can both buy and sell options, we concentrate here on buying options.

Call Options

An option contract giving the owner the right (but not the obligation) to buy a 
specified amount of an underlying security at a specified price within a specified 
time.

A call becomes more valuable as the price of the underlying asset (stock) 
appreciates.

Put Options

An option contract giving the owner the right, but not the obligation, to sell a specified
amount of an underlying asset at a set price within a specified time. The buyer of a 
put option estimates that the underlying asset will drop below the exercise price 
before the expiration date.

Moneydance does not have Buy to Open (BTO), Sell to Open (STO), Sell To Close 
(STC), Buy to Close (BTC) transactions that are often used with options but you can 
use Buy, Short, Sell, and Cover transactions to achieve the same results 
respectively. There may be an issue if you are downloading transactions from a 
broker as they may need to be converted to the appropriate Moneydance transaction
(i.e. cover, short or sold), an expiration may be simply a "Bought" action at $0 per 
share.

You need to enter the quantity as the obligation quantity and not the number of 
contracts. Each option contract is for 100 shares.

Example of a Call Option

As described earlier a call option is an option contract giving the owner the right (but 
not the obligation) to buy a specified amount of an underlying security at a specified 
price within a specified time.

There are various methods you can use to manage the data in Moneydance, this is 
one of them. The goal of this method is to have a zero real value until the option is 
executed or lapses. It is a right that has no financial impact until that time and until 
this time it is unknown if the right will yield a profit or a loss.
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Options are general sold as a bundle with each bundle containing 100 shares, for 
this example we are going to have a call for 10 Acme options i.e. 1000 shares, the 
exercise price will be $40 and there is a premium of $2 per share, in summary:

Options Shares Exercise Price Premium
Acme 10 1000 $40 $2

Note that in Moneydance we need to use the actual number of shares not the 
number of options.

As already outlined you need to create the investment account (if appropriate) and 
the security for the options, associating the security with the investment account as 
per usual. You can then begin to record the option.

The first transaction to record is the Option contract. We will use a Cover transaction 
to do this. This looks like a buy transaction but the cash amount is not reflected 
outside of the Investment account. We are using a buy type transaction as this is an 
option to buy shares.

Typically the entries could look something like:

Field Value

Date The date you enter into the contract

Tax Date The exercise date

Action Cover

Description As appropriate

Memo As appropriate

Security Select the Option

Shares 1000

Price 40

Amount 40000

This will show a negative cash balance of -40000 in the register but that will not be 
reflected outside of the register in the sidebar or summary page totals, however it will
be included in reports. This transactions shows the total value of the call option.

Now suppose the market price has risen to $45 and our contract states that the 
premium is $2 per share, for our purposes think of the premium as a fee, So we have
the following expanded information:

Options Shares Exercise Price Current Price Premium
Acme 10 1000 $40 $45 $2

We now enter a short transaction to marry the entries. Typically the entries could 
look something like:
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Field Value

Date The date you exercise the right

Tax Date The exercise date

Action Short

Description As appropriate

Memo As appropriate

Security Select the Option

Fee Category Option Premium

Shares 1000

Price 45

Amount 43000

Fee Amount 2000

The result is a net profit of $3000:

Option Value – Option cost, in this case: 45000 – 40000 – 2000 = 3000

This transaction leaves a balance of 3000 in the account this balance is now 
reflected outside of the Investment register.

Typically you would transfer these funds to the account where the profit has gone to.

Allowing a Call Option to Lapse

With a call option your maximum liability is the premium i.e. you decide it is not 
worthwhile to exercise the option so you allow it to lapse, the premium is however 
payable in any case as it is part of the options contract. To achieve this you use a 
short transaction with the same price as in the contract for the exercise price but you 
add in the fee details.

We now enter a short transaction to marry the entries. Typically the entry could look 
something like:
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Field Value

Date The exercise date

Tax Date The exercise date

Action Short

Description As appropriate

Memo As appropriate

Security Select the Option

Fee Category Option Premium

Shares 1000

Price 40

Amount 38000

Fee Amount 2000

This leaves a -2000 figure in the register which is also visible outside of it. This is set 
to 0 by a transfer from whatever account you used to pay the fee.

Example of a Put Option

As described earlier this is an option contract giving the owner the right, but not the 
obligation, to sell a specified amount of an underlying asset at a set price within a 
specified time. The buyer of a put option estimates that the underlying asset will drop
below the exercise price before the expiration date.

As outlined under Call Options there are various methods you can use to manage 
the data in Moneydance, we are going to use a similar approach what was used for 
the Call option. The goal of this method is to have a zero real value until the option is
executed or lapses. It is a right that has no financial impact until that time and until 
this time it is unknown if the right will yield a profit or a loss.

Options are general sold as a bundle with each bundle containing 100 shares, for 
this example we are going to have a call for 20 XYZ Co. options i.e. 2000 shares, the
exercise price will be $10 and there is a premium of $1 per share, in summary:

Options Shares Exercise Price Premium
XYZ Co. 20 1000 $10 $1

Note that in Moneydance we need to use the actual number of shares not the 
number of options.

As already outlined you need to create the investment account (if appropriate) and 
the security for the option, associating the security with the investment account as 
per usual. You can then begin to record the option.

The first transaction to record is the Option contract. We will use a Short transaction 
to do this. This looks like a sell transaction but the cash amount is not reflected 
outside of the Investment account. We are using a sell type transaction as this is an 
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option to sell shares.

Typically the entry could look something like:

Field Value

Date The date you enter into the contract

Tax Date The exercise date

Action Short

Description As appropriate

Memo As appropriate

Security Select the Option

Shares 2000

Price 10

Amount 20000

This will show a positive cash balance of 20000 in the register but that will not be 
reflected outside of the register in the sidebar or summary page totals, however it will
be included in reports. This transactions shows the total value of the call option.

Now suppose the market price has decreased to $8 and our contract states that the 
premium is $1 per share, for our purposes think of the premium as a fee, So we have
the following expanded information:

Options Shares Exercise Price Current Price Premium
Acme 20 2000 $10 $8 $1

We now enter a cover transaction to marry the entries. Typically the entries could 
look something like:
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Field Value

Date The date you exercise the right

Tax Date The exercise date

Action Cover

Description As appropriate

Memo As appropriate

Security Select the Option

Fee Category Option Premium

Shares 2000

Price 8

Amount 18000

Fee Amount 2000

The result is a net profit of $2000:

Option Value – Option cost, in this case: 20000 – 16000 – 2000 = 2000

This transaction leaves a balance of 2000 in the account this balance is now 
reflected outside of the Investment register.

Typically you would transfer these funds to the account where the profit has gone to.

Allowing a Put Option to Lapse

With a put option your maximum liability is the premium i.e. you decide it is not 
worthwhile to exercise the option so you allow it to lapse, the premium is however 
payable in any case as it is part of the options contract. To achieve this you use a 
cover transaction with the same price as in the contract for the exercise price but you
add in the fee details.

We thus enter a cover transaction to marry the entries. Typically the entries could 
look something like:
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Field Value

Date The exercise date

Tax Date The exercise date

Action Cover

Description As appropriate

Memo As appropriate

Security Select the Option

Fee Category Option Premium

Shares 2000

Price 10

Amount 22000

Fee Amount -2000

This leaves a -2000 figure in the register which is also visible outside of the account. 
This is set to 0 by a transfer from whatever account you used to pay the fee.

Employee Stock Options

In many ways an employee stop option is very much like a call option, so that 
presents one way of handling it. There are any number of approaches you can take 
to managing employee stock options. Moneydance does not have specific actions for
this so there is likely to be some trade offs with any solution.

What is presented here is one possible approach.

Suppose you have a scenario where as an employee you were granted options for 
100 shares in Acme Corp in Feb 2019 with a strike price of $10 and a vesting period 
of 2 years (i.e. 50 shares in in 2020, 50 shares in 2021).

These are the steps to take.

 1. Go to the "Account" menu

 a) Select "New Account…"

 b) Select "Investment" for account type

 c) Enter your brokerage account info.

 2. Open the newly created investment account

 a) Select "Securities Detail"

 b) Select "Add Security"

 c) Select "New Security"

 d) Complete the fields as follows:

• Security ID: As required
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• Security Name: Stock and grant name

• Ticker Symbol: Stock Ticker Symbol

• Price: The exercise price

• Value Prefix: As required

• Value Suffix: As required

• Max. Decimal Places: leave at default

• Show on Home Page? deselect

 3. and click "OK"

 4. Back on the New Security screen complete the rest of the fields as follows:

 a) Broker: Brokerage details}

 b) Phone Number: As Required

 c) Type: Stock Option

 d) Sub-type: Add & Select Employee Options

 e) Call or Put: Call

 f) Stock Price: The exercise price

 g) Exercise Price: The exercise price

 h) Exercise Month: Select Month

 i) Comments: Detail to identify the grant

 j) Click "OK"

 5. Open the "Register" for you your Investment account. Create the following 
New Transactions:

Typically the entries could look something like:

Transaction 1:

Field Value

Date Feb 1 2020

Action Short

Description Stock Option Grant

Memo Award #{your grant/award number} 1 of 2

Security Select the Option

Shares 50

Price 10

Amount 500
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Transaction 2:

Field Value

Date Feb 1 2021

Action Short

Description Stock Option Grant

Memo Award #{your grant/award number} 2 of 2

Security Select the Option

Shares 50

Price 10

Amount 500

Vesting

There are three possible outcomes with a stock grant when it vests:

1. You could buy and keep the stock.

2. You could sell.

3. You could allow the stock grant to lapse.

As a guide some of the ways you could handle each of these are given below.

1. Buy and Keep

The easiest approach is to change the short action to a BuyXfr action and select the 
financial institution the funds are to come from in the category field.

You could also enter a cover transaction at the exercise price to close the short out 
then use a buy or BuyXfr to effect a buy. The overall effect is the same it comes 
down to the detail you want to maintain. The second method more accurately 
represent when the funds moved between accounts

2. Sell

To handle this outcome you can build on the buy approaches.

Assuming you do a sell on the same day as you exercise the grant, firstly you can 
change the short action to a Buy action. You then use a Sell to sell the security. You 
can then use a Xfr to move the profit to a selected account.

This method should see the profit reported in the Capital Gains report.

Another alternative is to enter a cover transaction at the received price price to close 
the short out. This leaves the profit in the account that you can then use a Xfr to 
move it to a selected account.

As of writing Moneydance is not reporting the capital gain correctly so it would be 
necessary to enter a transaction to have the capital gain reported in an Income and 
Expense report. Refer to the section on Option Report for a way of handling this.
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3. Lapse

The simplest approach is to enter a cover transaction at the exercise price to close 
the short out.

Option Reporting

Unfortunately, although this method meets many objectives in recording option 
trading, it does not show the profit in any category as it is a transfer. Through the use
of an extra transaction we can however facilitate this.

To record the amount of the profit so that it shows in Income & Expense reports. You
will need to create two categories:

• Tax:Investment Reporting

• Investment:Options Profits

To do this record a transaction as follows in the register of the security sold:

Field Value

Action DivXfr

Description <security> “Option Profit”

Security The security name

Category Tax: Investment Reporting

Transfer Investment: Options Profits

Amount The amount of the profit

This creates a transaction that is reflected in any Income and Expense report but 
does not contribute to net worth.

Reports like the Net Worth, Investment Transaction report and Investment 
Performance report are capable of showing the transactions used here.

Using Reminders for Option Trading

Option trading is very much a hands on activity. Transaction reminders are probably 
not applicable as the transactions are not repeating and the exact nature of the 
transaction is not know until it is exercised or it lapses.

General Reminders however may prove to be useful, for example you can set up a 
general reminder for the exercise date.

Demergers and Company Spinoffs

Usually with spinoffs and demergers to get an idea on how to account for it in 
Moneydance it is usually necessary to understand how the transaction was 
structured, many methods could be used, for example these include the following:

1. A special dividend was paid that was used to purchase the new stock.
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This is the easiest method to account for in Moneydance it is just a Dividend 
payment that is used to purchase new shares.

2. A capital return was paid which was used to purchase the new stock.

As Moneydance does not a Return of Capital function you will need to 
examine various method that can be used to account for this.

3. A part sale of the existing stock you hold was used to fund the purchase.

How this is handled can involve such issues as whether you are using 
Average Cost or Lot Matching for the cost base.

4. It may be handled in a similar way to bonus shares

A spinoff handled this way could be considered a gift. Often such shares have
an initial value, which equates to the value of the gift.

In some jurisdictions the gift may be tax free, however for the longer term you 
need to have a cost base for the shares and it is unlikely to be 0 it is the value
of the gift which equates to the number of shares multiplied by the initial value
per share so this becomes the buy transaction, for the funds to "purchase" 
these shares you can either change the initial value of the account, or create 
a tax free category to draw the funds from.

There is no doubt that the transaction could be structured in other ways.

Each of the above methods has different effects on cost basis, taxation of income or 
taxation of capital gains/losses, hence different ways of being handled in 
Moneydance.

What method a company uses can be influenced by the detail around the splitting of 
the company, taxation considerations and legal requirements within the country. With
all of these influences there is not just one way that an event like a spinoff is 
structured.

Entry of Draw-downs from Retirement Accounts

Retirement Accounts are often investment accounts, normally funds are moved from 
Investment Accounts to Bank Accounts using a transfer action, however this does 
not provide any categorization as it is a transfer. In many cases it may be desirable 
to also categorize this as Retirement Income, for Budgeting purposes for example, 
there may be taxation considerations as well. The following example shows one of 
the ways of handling this.

I have used an amount of 200 being taken out of the investment with a tax payable 
amount of 30.

I am assuming that the money exists in the Investment account in the form of a cash 
balance, if a share sale is necessary this needs to be complete first. Also there 
needs to be a category for the Draw-down, I have it as a subcategory of pensions 
and called it Drawdown

94



In the Bank account I have completed the basics of the date, description & memo 
then I select the split option in the category.

The first line I entered was for the retirement income, categorized as such with a 
suitable description and the gross amount i.e. 200 as a deposit.

The second split it to pull the monies from the Investment account so again a deposit
of 200 and a category of the Investment account.

The third split is to account for the investment draw down so a Payment entry with a 
category of the draw down.

The fourth split line is for the 30 tax paid categorized accordingly as a payment. 
when the split is exited you end up with a deposit of 170 to the check account.

The entries look as follows:

It may look like there is double handling of the amounts here, but in order to draw 
money from the Investment account, categorize it as a Pension and allow for the 
monies to be assigned to Taxation and the Bank account, the number of entries is 
necessary in order to comply with double entry accounting rules.

Handling Income in an Investment Account

There are a number of ways of handling income received in an investment account. 
Firstly it needs to be realized that the action types in Moneydance are indicative of 
the way a transaction is to be processed, it is not an indication of the transaction 
type. Part of the reason for using familiar names is for compatibility with transactions 
downloaded/imported from other sources.

Hence a Div transaction, along with its siblings DivXfr and DivReinv can be used for 
any income received from an investment as cash, transferred to another account or 
reinvested. The actual type of income is determined by the category you choose.
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Likewise MiscInc can be used for any income received as cash, with again the 
category used to determine the income type.

In both of the above cases you must select a security.

With some investments you have a cash account that you receive interest income 
from. Some users will create a security for this, perform buys and sells for monies 
coming into or going out of cash and record things like income against this “security”.

Others may decide to just carry a balance in the base brokerage account. This 
creates a problem in that the above Action types cannot be used as there is no 
security involved. To handling Interest received it is necessary to use a different 
action. What can be done is use a Xfr action type to record the interest going into the
account with an interest category selected in the Transfer Field.

Xfr is the only action type that works at the basic account level to bring monies into 
or out of the account without needing a security.

Event Handling

With investments there are various events that can happen. These are not 
transactions because there is no money involved, but the event does impact your 
investment. A stock split is one type of event, no money was involved but the 
number of shares you hold changes. This section discusses some of these events. 

Corporate Name Change

A Company changing its name is not an unusual event, the following describes a 
general way to get to the “Edit Security” window In order to change the name, there 
are other paths that you take to get to the screen you need to.

The general way to perform the change is:

• Choose the Menu item Tools → Securities.

• Choose the security and click on edit.

• In the next window click on the edit button next to the security name.

• In the resultant display you can change the name to what you want.  The 
screen should like the following:
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Many may like to have a record in the register of the name change and this is 
possible.

Moneydance does not possess an action type that just allows for the entry of text, 
however we can make use of one of the value action types to achieve the goal. 
Given we going to be using a value action we need to use a Category, and for this 
purpose it may be considered desirable to create a specific category for these, 
Perhaps a category called “Notes”.

To enter the transaction enter the date, use an action like “MiscInc”, enter the notes 
you want to make in the Description and Memo fields, choose the category you have
created and use a value of zero.

Given we are recording a category, we can user the Income and Expense (Detailed) 
Report to list all notes, you could also set up a hierarchy  of note category in order to 
group notes into various topics.

Transferring Shares between Accounts

There is no action in Moneydance that will transfer shares between accounts. It is 
necessary to take the following approach.

1. Perform a sell at the cost basis for the shares in the existing account.

2. Transfer the funds to the account the shares needs to be in.

3. Perform a purchase at the cost price for the shares in the new account.

This method ensures that the “transfer” does not generate a capital gain in your 
reporting from this event. There are some downsides, it means any reporting in 
Moneydance on performance is incorrect and when/if you sell the security the 
purchase dates for investments will be incorrect which could impact capital gains.

Stock Splits

Stock splits are not a financial transaction, they are an event that causes the number
of shares you own to change but adjusts the cost price per share so that your overall
cost base is not changed.

The following sections discuss various aspects of working with stock splits and stock 
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consolidations.

Working with Stock Splits and Stock Consolidations

If you open your investment and look at the Securities Detail screen 

In the middle of the window in the right hand pane you will see the stock split button, 
click on it and you get the data entry window shown below.

The current date will be displayed, this you change to the effective date of the split. 
Also the window shows a Split ratio of 1 for 1. You will need to enter the correct Split 
Ratio. If for example the split was on the basis of receiving 2 shares for each existing
share then you would enter 2 for 1.

If the transaction is a stock consolidation and for example for each 2 shares you own
you received one share then you would enter 1 for 2.

If you enter the split/consolidation from the History Window:
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You select a “New” split then adjust the Date and enter the Ratio, so in the example 
of a 2 for 3 stock consolidation you enter the ratio as 0.6667 i.e. 2/3.

After entering the Stock Split/Consolidation check the number of calculated shares, it
may be wrong due to the calculations yielding a fractional number of shares.

Companies have a number of ways of dealing with a fractional number of shares, 
these include:

• Round the number of shares up.

• Round the number of shares down.

• Pay out the fraction number of shares.

Each method should result in a whole number of shares being held.

Ideally to handle rounding of shares we need to have Add/Remove share actions 
within Moneydance, as we do not we will need to use a method similar to what we do
when Paying out the fractional number of shares.

To deal with with most straightforward situation first, Paying out the fractional shares.
This is achieved with a sell transaction. With Average cost based securities this is 
easy enough. With Lot Matching you will want to ensure that each lot ends up as a 
whole number of shares and this should be the goal initially. If following this you end 
up with the wrong number of shares you will need to do a one off buy/sell of a small 
number of shares with the reminder of the cash (after deducting the amount of the 
return) to adjust.

To deal with rounding down you use a similar approach to paying out, except with 
any balance left over you use a MiscInc or MisExp to absorb the funds, possibly 
using a category set up for Share adjustments.

Dealing with rounding up is potentially more complex. With Average Cost it is simply 
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a matter of a buy transaction. You could use a change to the initial balance to fund 
the purchase or again draw on a Share Adjustment category.

With Lot Matching, it is likely to require more work. Again lots will often show 
fractional shares, there is no way to add fractional shares so it is necessary to use a 
Sell transaction to get back to whole numbers. You will then need to use a Buy 
transaction to get to the required number of shares.

With both stock splits and stock consolidations the total value of your investment is 
not changed by the action (apart from rounding adjustments), what is changed is the 
number of shares held and the cost base of the shares so that:

Pre Transaction cost basis                                  Post Transaction cost basis 

                   x                                           =                                 x 

Pre Transaction number of shares                      Post Transaction number of shares

To remove a stock Split select the split in the split window that is shown above and 
then click on remove.

Stock Splits and Cost Basis

It is easily understood how stock splits will affect your cost basis, the total cost does 
not change but the cost per share does change based on the split ratio. This is the 
case for both Average Cost and Lot Matching.

What has been observed in some instances is that the cost basis, when using 
Average Cost, can be thrown out if you have the combination of one or more stock 
splits, along with a number of sales occurring both before and after the stock splits, 
this has been observed even if there is only one purchase transaction. It appears 
that the stock split is not being accurately used in the cost basis calculation.

User experience indicates that switching to Lot Matching can correct this. It seems 
that Lot Matching is able to handle the changes that you have in the cost basis that 
stock splits cause i.e if you have sales before and after a stock split the cost base of 
the shares sold will be different for those shares sold before the split to those that 
are sold after the split occurs.

Investment Reporting

This sections deals with some aspects of investment reporting

Reporting Capital Gains in Income and Expense Reports

Moneydance will not include capital gains in the Income and Expense reports. These
reports are based on the classification of transactions i.e. the category assigned to 
each transaction, whereas Capital Gains (or losses) are a calculated value based on 
the different between Purchase and Sale prices of securities.
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However it is possible to include such figures in the Income and Expense reports.  A 
possible method is to create two categories, one called say “Capital Gains” being an 
Income category and an Expense category called say “Investment Reporting”. In the 
Investment account where the gain has occurred you create a transaction with the 
Transfer field being the “Investment Reporting” category and the Category being 
“Capital Gains” and the amount naturally being the amount of the capital gain.

This method can be readily extended if you need to classify the capital gains e.g. into
Short Term and Long Term for example. You could potentially set up a hierarchical 
structure like:

Capital Gains 
Long Term
Short Term

Which in the reports will provide a total for each type of gain plus an overall total for 
all gains.

Reporting Cash Balances in Investment Accounts

The Portfolio Report is often thought of as being the report to use with investment 
accounts however this report will only report cash balances in account if a security 
within the account is also selected as a parameter.

There are a couple of ways of generating a report containing just the cash balances 
in investment accounts.

The first is to use the Account Balances report, just selecting the Investment account
and ensuring each security is deselected.

The other method is to set up a dummy security that is not used, it contains no 
transactions and it is assigned to the account. Then when using the Portfolio Report 
select the Investment Account and this specific security only.

Importing Security, Stock, or Mutual Fund Prices

Moneydance can automatically download price information (at the time of writing) 
from Alphavantage. Yahoo! Finance, TD Ameritrade or IEX Trading. Exchange rates 
can be sourced from Alpha Vantage or the European Central Bank.

First, install the Quotes and Exchange Rates extension. Users who purchased 
Moneydance from the Mac App Store do not need to install this extension.  Now 
open the extension by going to Extensions → Quotes and Exchange Rates (if you 
have purchased from our website) or Tools → Quotes and Exchange Rates (if you 
have purchased Moneydance through the Mac App Store).

You can customize the Quotes and Exchange Rates settings as follows:

Currency Exchange Rates: The default setting, “Do Not Update”, tells Moneydance
note to update currency exchange rates. The alternatives are “Alphavantage” and 
the “European Central Bank” (ECB) and these will update rates based on your 
chosen Update Frequency, or when you click “Update Now” in the Extension 
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window. The “European Central Bank” appears to be the best source at the time of 
writing.

Security Prices: Choose “Alphavantage”, “IEX Trading”, “TD Ameritrade” or “Yahoo!
Finance - USA” as the source for security price updates within Moneydance. Many 
sources concentrate on particular markets and/or certain types of investments. 
Yahoo is likely to provide the most global coverage. You may need to investigate 
which source provides the best coverage for the securities you own. Moneydance 
will apply updates based on your chosen Update Frequency, or when you click 
“Update Now”.

Update Frequency: Choose the interval at which the extension will automatically 
update rates and prices. Note that this is only checked when Moneydance is opened.

Next Update: Shows the date of the next scheduled update. Edit this field to 
schedule an update on a different date.

Only Show Securities that I Own: Tells the Extension to only list securities that you
have associated with an account. (View all the securities you have created in 
Moneydance by clicking Tools → Securities.)

Clicking the “Advanced” button will allow you to test whether quote and price 
histories are available for the securities you select. To run a test, click “Test” in the 
Advanced window. If Moneydance is able to download the information, check marks 
will appear in the “Test Results” field, along with a current quote. If the information is 
not available — the ticker symbol is incorrect, or the data is not accessible from the 
source you have selected — “X” marks will be shown.

Current exchange rates, security histories, and current quotes will automatically be 
integrated into your records. To view this information, click on an investment account
on the Summary Page or Sidebar, select “Securities Detail”, and then choose the 
security you would like to view.

You can also view the price and volume history of each of your securities by 
selecting “History” from the “Securities Detail” page of an Investment account.

Integrating Manually Entered Security Prices

Moneydance offers the ability to enter stock prices directly from the within 
Investment accounts.  You can do so in the following ways.

• Manual entry Method 1: Open the Securities Detail view and click History. 
Click the "New" button to add a new price entry, and repeat to enter as many 
entries as you like.  If you have many entries you may need to scroll down to 
see the "New" line.

• Manual Entry Method 2: Install and use the Security Price Entry extension. 
This extension makes the manual entry of a series of prices for a single day 
quicker and easier.

• Importing transaction prices from your security's transaction history: Open the 
Securities Detail view and click History.  Click the Import button. Select 
“Import from Transactions” and click “Import”. The information from your 
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security transactions will be integrated into your security’s history.  You will 
need to repeat this process for each security you would like to import 
information for.

• Importing a delimited file: Open the Securities Detail view and click History. 
Click the Import button. Select “Import from File” and click “Import”, then 
navigate to and select the file containing the security price history.  You can 
import Comma or Tab delimited files.

• Importing a QIF file: Open the Investment account and use the File → Import 
menu option to select and import a QIF file containing security prices.

Further information on importing price data from delimited and QIF files is given 
below.

Importing prices from a delimited file

Imports from a delimited file uses the Yahoo! Historical quotes spreadsheet file 
format as its default, but it is flexible.

• Columns can be comma, tab or | delimited.

• If a header line exists, the importer looks for the following column names to 
determine the column order:

“Date”, “High”,”Low”,”Close” and “Volume”

• If no header line exists the importer assumes the columns are in the order:

Date, High, Low, Close, Volume, Adj Close

• Date and Close columns are required.

• If columns are comma delimited use of ‘.’ as the decimal point is required.

An example of a file is given below, you can see a different column order used to 
demonstrate some of the flexibility

Close,Date,High,Low,Volume
39.9600,07/02/2021,40.0000,37.7450,78945572
37.2700,07/01/2021,37.3300,35.7600,52485781
36.9600,06/30/2021,37.4100,35.8700,63261393
36.3300,06/29/2021,36.4900,34.3500,64556081
34.7800,06/28/2021,35.2450,33.3500,62111303

Note that the date format used is MM/DD/YYYY.

To import each Security you have prices for into Moneydance you can use the 
following method.

1. Follow the menu path Tools → Securities to open the Edit Securities Window.

2. Double Click on the Security you have prices to load for.

3. Select the IMPORT button in the Currency/Security History window. 
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4. Select the ‘Import from File’ option and click on Import.

5. In the Explorer Window select the CSV file to import.

6. Select OK and the data should import.

Importing prices from a QIF file

In the QIF specification published in 1999 Intuit documented the following in relation 
to price data:

Price Records

The records in a list of security prices do not use any letter identifiers, and 
take the following form:

"<symbol>",<price>,"<date>"

where <symbol> is the security's ticker symbol, <price> is the security price, 
expressed as a whole number and a fractional part, and <date> is the date 
the security had that price.

For example, for shares of Intuit updated 6/30/98, with a price of $50.00 per 
share, the price record would be:

"INTU",50,"6/30/98"

Each price is followed by a ^ (end of entry indicator).

An example of a QIF price file is:

Type:Prices
"AGK",14.84,"10/17/2012"
"AGK",14.86,"10/18/2012"
"AGK",15.02,"10/19/2012"
"AGK",14.96,"10/22/2012"
"AGK",14.7,"10/23/2012"
"AGK",14.51,"10/24/2012"
"AGK",14.49,"10/25/2012"
"AGK",14.32,"10/26/2012"
^

The file can have prices for multiple securities each block of security prices ending 
with a ^ symbol.

When importing Security price files you must have an Investment account open 
when you select the menu Item File → Import and import the QIF file.

The QIF file import only supports importing the closing price.

Managing Funds at a Summary Level

You may have funds that you want or need to manage within Moneydance at a 
summary level rather than individual transactions. For example some funds invest in 
other funds and there can be many transactions involved which you do not want to 
have in Moneydance, in some instances the data may be such that it is not available 
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or readily available in a format that makes it easy to import or enter.

This section discusses an approach that minimizes the work needed yet allows for 
performance monitoring with Moneydance in an Investment Account (the other 
alternative is to have simple transactions in an Asset Account).

The method is best explained through an example.

Suppose you have investments in three master funds. A master fund being the type 
of fund that in turn invests in other (usually wholesale) funds. Each master fund is 
thus invested in a variety of wholesale funds. For a broad based balanced portfolio 
there could be a substantial number of wholesale funds, 20 or more would not be 
uncommon in a reasonable size portfolio.

It may well be impractical to even to try to maintain the full data for all these 
investments – the data may not be readily available or it may require a considerable 
amount of manual handling, especially when you consider you may change the mix 
of funds, perform re-balancing, handle re-investments etc.

In such a situation you may decide to just maintain each master fund at the total 
level within Moneydance and use Moneydance to give a guide to the overall 
performance of the funds as a total and to use other tools outside of Moneydance to 
analyze the performance of individual funds.

The approach we are going to take is to manage the portfolio at the master fund 
level as if it was just one fund. This will require us to derive some data based on real 
information that should be readily obtained. Some of the techniques we will use are 
similar to how individual funds arrive at their quoted prices.

Your initial investment will be a buy. You may have a statement that shows the 
amount and units in each underlying fund or it might just show a percentage split. 
For the way we are going to manage the investment all we need to know is the total 
amount. We are going to assign a “price” at the total fund level of $1 per unit (share) 
so the number of shares equals the total purchase price.

After setting the investment up this way only three events have to be accounted for:

• Depositing more money into the fund.

• Withdrawing money from the fund.

• Changes in the total value of the funds.

Moving money around the various wholesale funds is not relevant, neither is re-
investments, changing which funds we have invested in etc.

In this example we are updating values monthly.

So if all that has happened in the month is a change in value of your total investment
then the current value, which you should be able to obtain from the fund, usually 
online, divided by your "number" of shares gives you a new value per share which 
you enter as a new price each month.

If you add or withdraw money you get the value of the fund just before the event to 
update the price then a division of the amount of the investment added or withdrawn 
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by this price gives you the number of shares (units) you need to use to perform the 
buy or sell of the fund within Moneydance.

You are thus deriving the number of units you hold and the price of each unit based 
on the value of your investment at each point in time. The goal is to update the total 
value of the investment and we are using derived unit prices and number of units to 
arrive at this.

To make it easier you can create a spreadsheet with the logic embedded so you just 
have to enter the relevant data you obtain into it and get the calculated data you 
need for Moneydance, the spreadsheet is not a complicated one.

Taking this approach there are likely to be some rounding errors, but the quoted total
valuation of the funds is an approximation in many instances as in many cases 
underlying fund prices could be as at a different date so for our purposes the 
estimation is close enough. It has been noted that some fund prices may even be set
only weekly and buys and sells only occur on that day after the price has been set. 
Extensive usage has shown the estimation is within $1.00 of the fund quoted value 
at any point.

Other Types of Investments

In this section we will examine managing other types if Investments in Moneydance

Managing Investments Like Real Estate

An obvious way of managing real estate investments is through an asset account. 
Enter changes in value as new transaction using an appropriate category, likewise 
with income and expenses like rent received, maintenance costs etc recording these 
using appropriate categories.

Handling it in an investment account may prove to be a better approach as well as 
provide better performance reporting and the ability to see things like capital gains 
more clearly, as this chapter relates to Investment accounts we concentrate of that 
approach here.

The key is in the setup and the recording of transactions. The typical transactions 
that you have with property can be fairly easily mapped to standard investment 
transactions.

To set this up as usual you need create a security for the property and have an 
Investment account for it to be associated with. If you have multiple properties you 
would have a separate security for each.

The buy transaction for the property is not really any different to your normal 
investment, the number of shares is 1 and the price per share is the value of the 
property. You reflect changes in the value of the property by entering a new price per
share, the same as you would do with other investments, but in the case of property 
the new price is simply the value of the property.

Other transactions generally map well to Investment transactions. Rent received, 
given it is regular income can use a Div action with an appropriate Rent Received 

106



category. Expenses can all use the MiscExp action type again with appropriate 
categories used.

The only problem transaction is when you have capital improvements. In many 
instance these do not have an immediate effect, rather they may change the cost 
base of the asset, that is, it increases the cost base by the amount of the 
improvement. The equivalent Investment action is a Capital Call,  sometimes 
implemented in software by a negative Return of Capital i.e. a Return of Capital with 
the fund flowing in the opposite direction.

Moneydance does not have a Return of Capital/Capital Call action it is therefore 
necessary to take some other approach.

When you make Capital improvements you transfer the funds into the investment 
account. A problem you could face is that the capital improvements could well be 
represented by expense transactions which you may have already recorded i.e. you 
have paid for work to be carried out and these are reflected in you accounts as 
expenses. You thus need to “Capitalize” these expenses. A simple way to do this is 
to edit the initial balance filed of the Investment account by the amount of the 
improvements.

An approach you could take is to use a buy transaction for 0 shares and the price 
and total amount is the value of the improvements (you need to have your costs 
basis set to Average Cost for this to work). This does change the cost basis in some 
places but not in all reports.

Another approach you can take is to do a sell transaction at the original purchase 
price then perform a buy transaction using an amount which is the addition of the 
original buy price plus the value of the improvements. The downside to this approach
is that you lose some of your long term performance data.

The approaches you can use with a Return of Capital/Capital Call are discussed in 
greater detail earlier in this chapter.

Tracking Precious Metals

Basic tracking of precious metals can be done in Moneydance. What is shown here 
is maintaining this in an investment account. Two examples are provided here firstly 
Silver then gold.

Tracking Silver Prices

This first example provides an example of a method setting up an investment to track
the price of silver. The fundamental steps are:

1. Create an Investment account by selecting Account → New Account.

2. Name the account "Precious Metal".

3. Set the initial balance on the account to the initial purchase price of the metal.

The example below is to create a security that represent 1oz of silver.

Selecting Tools → Securities. Select the + button at bottom left:
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• Set the security name to "Silver". 
• Set the ticker symbol to "SLV". 
• Set the value suffix to "oz". 

Click OK, then select the Precious Metal investment account.

You will be asked if you want to add a security to this account. Select Yes.

Select the security you just created.

• Set the type" to "Other"
• Set the sub-type" to "Silver"

New Sub-types can be created by selecting "Edit", to the right of the Sub-type field

Click OK, then select the 'Register' section of the investment account.

Select "New transaction".

Enter a Buy transaction for the number of ounces of silver you own, at the price you 
paid for them.

Tracking Gold Prices

The example below explains method to create another security that represents gold.

In this example, the gold price will be updated automatically using the Quotes and 
Exchange Rates extension.

The best ticker symbol for this is GLD. 1 share in GLD is equivalent to 1/10oz of 
gold.

As before, Selecting Tools → Securities. Select the + button at bottom left.

• Set the security name to "Gold".
• Set the ticker symbol to "GLD".
• Set the value suffix to "1/10 oz".

Click OK, then select the 'Security Detail' section of the investment account.

Select "Add Security" and select the Gold security you just created.

• Set the type" to "Other"
• Set the sub-type" to "Gold"

Click OK, then select the 'Register' section of the investment account.

Select "New transaction"

Enter a Buy transaction for the number of 1/10 ounces of gold you own, at the price 
you paid for them.

Install the Quotes and Exchange Rate extension if you haven't already. This is 
available via Extensions  →  Manage Extensions. You may wish to refer to the 
'Extensions' section for more information.

Once installed, select Extensions → Quotes and Exchange Rates.

Change the update frequency to "Yearly". This will download the last year of prices.
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Select "Update Now."

Once updated, change the update frequency to back to "Daily".

Peer-to-Peer Lending 

Peer-to-peer (p2p) lending accounts are growing more popular, and you can track 
this as a type of investment in Moneydance.

To aid in tracking these accounts, you should create a new "Sub-type" of security for 
p2p notes.

You may wish to refer to the 'Security Sub-types' section for more information.

Add a new security, and set the security Type as “Other”.

Create a new sub-type named “Peer to Peer".

It's best to use the “Average Cost” method of basis calculation for these types of 
investments.

Create a "New Security" for each individual loan.

• The Security ID and Security Name are the identification code as set by the 
P2P company.

• Enter a price and the number of decimal places. All other fields can be left 
blank.

Then record the transfer of funds from a bank account into the investment account. 
To do this you should enter a buy transaction for each security.

When you have purchased initial shares, you will need to track the payments 
received each month.

As with a traditional bank held loan, these payments are divided into principle and 
interest payments.

The principle is a return of the initial loan, and is essentially a “sale” of some shares 
of the note.

The interest is income, using Xfr as the transaction type.

The complexity of investment accounts means it is not possible to create split 
transactions for this particular transaction.

Each month, create two new transactions for each note you hold.

It is suggested that you create reminders for the payments received, a method is 
suggested below.

Select a transaction within the investment account, right click (ctrl+click) to view the 
context menu. Select 'Create Reminder from Transaction' to create a transaction 
reminder.

This brings up the reminder creation interface. You may wish to refer to the 
'Reminders' section for more information.

It is important that you do NOT set the reminder to auto-commit.
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This is because the amount of each transaction changes from month to month.

When the reminder is “due", access each reminder from the Summary Page.

Change the amount of the transaction, and then "Record" the transaction.

You may also wish to create a reminder for any monthly fees. This generally remains
the same amount and can be auto-committed.

Correcting Issues in Investments

Fixing mismatched securities from OFX downloads

Downloaded transactions come with a security ID and name attached.

If the security ID does not match the ID of the security that you have manually 
entered, then you will be prompted to match the downloaded security or select "None
of the Above".

If you select "None of the Above" then Moneydance creates a new security and all 
subsequent downloads match this security.

To fix this, we must remove the security that was created when "None of the Above" 
was selected, reset the sync of the online download, then re-download and properly 
match the security.

Step one is to go to the Securities Detail area of your investment account and locate 
the automatically created security. Select the history button and then click the edit 
button next to the name.

You should see an edit security screen. Change the name to "Remove". This is to 
make sure you are removing the correct security. Now click Ok and Done to return to
the Securities Detail window.

Because you have not refreshed the page the name has not changed.

Now click the remove security button, scroll down until you find the security renamed
"Remove". You will be prompted to confirm that you want to remove this security. 
Type in yes to confirm deletion. At this point the security and transactions should be 
gone.

Step two is to select Online Banking → Set Up Online banking, then click the Reset 
Sync button. Now download your data again from your broker. Only the transactions 
you deleted (or new ones) should download. When prompted, you can now correctly 
match the security to the one you entered and subsequent downloads will match 
these.

Correcting Duplicate Securities

Securities in Moneydance are designed around the premise that you should only 
create one instance of a security with a given ticker symbol. You would normally 
define the Security under the Tools → Securities. You then add this security to any 
number of investment accounts. This centrally maintained security definition contains
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the name, ticker symbol, historical prices etc, in other words the data for the security 
that you only need to hold once in one central location.

There are situations however where you may end up with duplicate securities which 
is not normally a desirable outcome.

The outcome we wish to work towards is having only one instance of the security 
being listed under Tools → Securities. With all your accounts where you have this 
security using this one definition.

There are two approaches you can take to addressing this problem. The first that will
be discussed is using inbuilt methods in Moneydance, we will then discuss using the 
Toolbox extension to resolve the problem. 

Manually Correcting Duplicate Securities

Unfortunately standard tools like Batch Change and the Find and Replace extension 
cannot be used to address this problem, we need to use a much more hands on 
process.

To correct this situation, proceed as outlined below.

Before you start use the menu command File (Moneydance on Mac) → Export 
Backup to create a backup that can be restored if you should make a mistake.

You will need to perform this process for each duplicated Security.

1. Firstly examine the Security list (Menu item: Tools → Securities) to identify 
duplicated securities.

2. Examine each investment account to identify where the securities are used 
and the approximate number of transactions for each specific duplicated 
security.

3. Based on the findings above it is suggested you look to remove the security 
with the least number of transactions, to minimize the amount of work 
required, however you may decide to say keep the security with the best 
historical price/volume data.

4. Once you have decided on which instance of the security is to be removed 
return to the security list, Edit this security and rename it, you could for 
instance rename it to something like “To be Delete”. This will also help you to 
identify each account the security is used in.

5. For each Investment account that contains the security to be deleted check on
the Securities Detail tab to see if the security that is being retained is also 
assigned to the account. If not, from the Securities Detail tab, click Add 
Security and add the security to be kept to the account. After this stage both 
the security to be deleted and the security that is being retained should both 
be assigned to the account.

6. Now click on the Register tab and select the transactions that contain “To Be 
Deleted” in the Security field using the drop down to select the subject 
security. You need to do this everywhere a transaction contains “To Be 
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Deleted”.

7. Back in the Security Detail tab click on Remove Security and select “To Be 
Deleted” in the drop down. Then click OK.

8. Repeat Steps 5 to 7 for each account that contains the “To be Deleted” 
security. If you receive a message that the security is still in use it is likely you 
missed changing some transactions to use the security that is being retained.

9. Once you have completed all accounts you should check under Tools → 
Securities and the security that is “To be Deleted” should be gone, if it is not it 
means that it still exists in one or more accounts.

Automated Merging of Securities

As discussed above there is not a core function in Moneydance that can do this, 
however there is a function in the user written, but Moneydance endorsed, Toolbox 
extension that can.

The Merging Securities functions performs a number of checks and enforces certain 
rules to ensure that only appropriate securities can be merged. The checks include:

• Securities must have the same ticker.

• Securities must have the same current price.

• Different cost Basis (Lot, Average) for the securities when they are in the 
same account are not allowed, different basis are allowed if the securities are 
in different accounts.

• The securities must have the same Prefix.

• The securities must have the same Suffix.

• The securities must have the same stock splits.

A number of options will be presented for the merging of price histories.

To proceed you need to use the Extension → Manage Extension menu interface to 
install the Toolbox. You should also ensure that you create a backup before you 
commence using the tool.

You run the toolbox extension by selecting it under the Extensions menu.

• On the Toolbox extension menu click on TOOLBOX Options and select to 
enable Advanced mode, acknowledge each of the warnings.

• Select the MENU:  Currency & Security Tools.

• On the Currency & Security Tools Menu select “Merge ‘duplicate’ securities” 
to merge multiple instances of a security into the one security record and click
on PROCEED.

• You are then presented with a list of securities that can be merged.

• Select the securities you wish to merge and Click on OK.

• You will then be presented with a window to select the Security that will be the
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final master i.e. the security that will be retained. Select the one to be retained
and click on OK.

• You are then present with a Window to select the account the transactions will
be copied to, again select the appropriate security and click on OK.

• You will then be asked to select the price history strategy you want, you can:

◦ Keep the price record from the master record only

◦ Merge the other historic records into the master.

◦ Only keep the records from the other historic security

◦ Remove all price history records

• You will then be presented with a summary of the actions to be taken and the 
validation rules, click on Proceed to continue.

• You will then be asked to confirm the merging of the securities in question.

• You are then asked if you wish to perform backup, answer as appropriate, if 
as recommended you have already performed a backup, you can just 
proceed.

• You then need to enter ‘IAGREE’ into the disclaimer and click on OK.

• The utility will then perform the merge, provide a completion message ans ask
you to check the log.

• The utility will then ask if you want to delete the source account afterwards, 
this is your choice

• Finally a log file will be displayed reporting what has been done.

It is recommended that you restart Moneydance before proceeding.

You should then check your to determine that everything has been done correctly. 
All references to the historical security should be removed from all transactions.

Yes there are a lot of warnings and you have to confirm the various steps. The tool 
also prompts for backups to be created. What you are doing here is not reversible, if 
you wish to go back you will have to restore from backup, hence taking any steps to 
ensure, as much as possible, that this is what you want to do.
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Changing Decimal Places on Securities

The default setting when creating securities is 4 decimal places for the number of 
shares/units.

With unit funds you are likely to have part units, however with shares they are 
normally only in whole numbers.

Once the number of decimal places has been set there is no way within Moneydance
to change the number of decimal places for a security.

The Toolbox extension provides a way to reset the decimal places setting. The 
extension can:

• Increasing the number of places

• Reducing the number of places

When reducing the number of decimal places you have the option to

• Round numbers

• Truncate 

• Round up all numbers

To proceed you need to use the Extension → Manage Extension menu interface to 
install the Toolbox. You should also ensure that you create a backup before you 
commence using the tool.

To proceed run the toolbox extension by selecting it under the Extensions menu.

• On the Toolbox extension menu click on TOOLBOX Options and select to 
enable Advanced mode, acknowledge each of the warnings

• Select the option MENU: Currency & Security Tools

• Select to Edit a Securities Decimal Places settings and click to Proceed

• You will be presented with a list of securities

• Select the security you wish to change the decimal places for then Click OK

• You will be prompted for the number of decimal places to use. Click OK

• You will be taken through a series of information screens and confirmation 
windows

• You will then be prompted for how to apply rounding if you are reducing the 
number of decimal place.

• You then will see a window where you can review the settings and choose to 
cancel or proceed with the change.

• Again you will be taken through some confirmation dialogues
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After all steps have been taken you need to restart Moneydance.

Merging Investment Accounts

There is not a core function within the Moneydance program to merge one 
Investment Account with another.

This is not a simple function to create however it has been possible to provide a 
function that can achieve this within the user written but Moneydance endorsed 
Toolbox extension.

To proceed you need to use the Extension → Manage Extension menu interface to 
install the Toolbox. You should also ensure that you create a backup before you 
commence using the tool.

Then run the toolbox extension by selecting it under the Extensions menu.

• On the Toolbox extension menu click on TOOLBOX Options and select to 
enable Advanced mode, acknowledge each of the warnings

• Select the MENU: Transactions Tools

• On the transactions Menu select “Move/Merge Investment Transactions” and 
click on PROCEED.

• You will then be presented with a window to select the source account i.e. the 
account to transactions are to be moved from. Select it and click on OK

• You are then present with a Window to select the account the transactions will
be copied to again select it and click on OK.

• At this stage the tool will perform various checks and if for any reason it 
cannot perform the move it will present a warning screen detailing the issue 
and allowing you to abort the process.

• If the tool can perform the move it will display a screen that outlines what will 
be done, you can select Cancel or Proceed at this stage. You may also 
receive a screen that asks about loop transactions, see the note below 
regarding this.

• The utility then asks for confirmation.

• If you continue it will again ask about backups.

• In the following screen you need to enter IAGREE to proceed.

• The utility will then ask if you want to delete the source account afterwards, 
this is your choice.

• The utility will present a window when the merge has been completed to 
check and review the log.

• Finally a log file will be displayed reporting what has been done.

You should then check your accounts to determine that everything has been done 
correctly. Your target account should have all transactions and securities that were 
originally in the two accounts, the source account, if you did not select to delete, 
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should be empty. If the source account has an Initial balances this will be added to 
the initial balance of the target account.

There are a lot of warnings and you have to confirm the various steps. The tool also 
prompts for backups to be created. What you are doing here is not reversible, if you 
wish to go back you will have to restore from backup, hence taking any steps to 
ensure, as much as possible, that this is what you want to do, also internally the 
utility is performing as many checks as it can to ensure the move can be safely and 
successfully performed.

Loop Message

You may receive the following message:

Move/merge: Would create a loop. Proceed or Cancel?

What this message means is that there is some sort of transfer transaction occurring 
between the accounts you are asking to be merged. If you proceed what will happen 
is that you will have two transactions for the same amount one a positive amount 
and one a negative amount, the will effectively cancel each other out.

This method was chosen because it keeps all transactions that have been entered, if
you wish you could manually delete both.

Usage Notes

The utility will take certain actions and will not allow for some merges. The following 
highlights these

• The utility will merge initial balances.

• Account must be in the same currency

• If there are inter account transfers both transfers will be kept the utility will not 
marry and cancel transactions.
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Chapter 7: Loan Accounts

Loan Accounts

Loan Accounts track a loan, that you will typically have received from a financial 
institution, with regularly scheduled payments, a known interest rate, and a fixed 
starting debt.

This type of account is not for an overdraft type arrangement, where you can use a 
standard bank account. or for a revolving credit type of account, where a Credit Card
account is more suitable, nor is this type of account suitable for managing interest 
only loans.

Loan Accounts cannot track a loan that you may make to others i.e. a peer to peer 
loan.

When you open a loan account in Moneydance you can choose to add the principal 
of your new loan to the balance of another account.

With a loan account you may enter payments manually, or choose to schedule a 
recurring transaction reminder which will allow Moneydance to track how many 
payments have been made on your loan, how many are left, and the interest to 
principal ratio. Most financial institutions use slightly different methods of calculating 
the interest on a per-payment basis, so you should verify these amounts against the 
principal and interest amounts in your payment schedule.

Loan Accounts can be created by selecting Account → New Account. You can then 
enter the account details.

When you open a loan account in Moneydance, you can choose to add the principal 
of your new loan to the balance of another account. The set up screen for a loan 
account looks as follows:
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Scheduling Loan Payment Reminders

Recording loan payments in Moneydance can be made easier using loan payment 
reminders. These are special reminders that automatically split the payment between
principal, interest and escrow amounts based on the settings of a loan account. To 
create a loan payment reminder, open the loan account and then click the Actions →
Payment Reminder button/menu. This will display a window where you can modify 
the accounts, categories, and schedule the payment reminders.

Entering an Existing Loan

The following instructions are for setting up a loan account with a fixed rate that has 
been in existence and you have been making payments prior to using Moneydance. 
You will need to know:

• The original loan amount.

• The correct interest rate.

• The current loan balance.

• The correct loan payment (principal plus interest).

• Any escrow amount.
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First you will need to setup the loan, including the reminder, an image of the setup 
screen is given earlier in this section. You will then need to edit the loan to get the 
correct balance and number of payments remaining.

1. Setup a new Loan account. From the Menu select Account → New Account 
→ Loan. Click Next.

2. When the Create Account: Loan guide appears, fill in the fields carefully.

3. Name the Loan. Call it Home Mortgage or something meaningful to you.

4. Enter the ORIGINAL amount of the loan. This will calculate a loan payment in 
the Calculate Payment field further down in the guide. (The original amount is 
available on your loan disclosure documents or from previous mortgage 
statements).

5. Enter the correct interest rate. This will recalculate the loan payment. (The 
loan rate should be available from your annual mortgage statement).

6. Payments per year defaults to 12. Change this only if your loan is structured 
differently.

7. Enter the number of payments. A 30 year mortgage is expected to have 360 
payments. This will recalculate the loan payment and it should be equal to 
your actual loan payment before any escrow payments, mortgage insurance, 
or other charges are added. If it is not even close, then some of the above 
figures you entered are incorrect.

8. Set the Interest Category to the appropriate category.

9. Enter the Escrow Payment amount. This recalculates the Payment Amount 
and it should equal exactly what your payment is each month.

10.Select the appropriate Escrow Account.

11.Enter the original first payment due date in the Start Date field.

12.Click OK.

13.A window pops up that asks if you would like to transfer this amount of this 
loan to an account.  Answer NO unless you would like to record a deposit of 
the loan principal into another account.

14.Another window will pop up and ask you if you want to create a Reminder. 
Answer YES.

15.The Reminder creation box pops up.

16.Enter something like Mortgage Payment in the description field.

17.Enter the current due date in the First Date field. This is different from the 
Start Date entered previously.

18.Select Monthly, Date to be reminded, from the appropriate account, leave 
check number blank, enter the name of the loan holder in the Payee field.

19.Note that the Total Payment, including the escrow amount, is equal to your 
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monthly payment.

20.Click OK.

21.The Loan should appear in the Sidebar and on the Summary with the original 
loan balance.

22.Select the Loan from the Sidebar and note that the loan information appears 
in the upper right hand corner. The number of payments remaining is 360.

23.From the Menu select Account → Edit Account.

24.When the Account Info: Loan interface appears, select Specify Payment and 
enter your regular monthly payment amount.

25.Go back up and change the Principal field to match the Current Balance of the
loan provided by your mortgage holder.

26.Click OK.

27.A window pops up that asks if you would like to transfer this amount of this 
loan to an account. Answer NO.

28.Select the Loan from the Sidebar – it should now display the correct Principal 
Remaining, number of payments remaining, and the Upcoming Payment 
should have the correct Principal and Interest amounts, as well as, Escrow 
amount reflected.

29. If you use the Reminder to enter the transaction for your mortgage payment in
Moneydance going forward, the correct amortization should be calculated 
automatically for this loan.

The Loan Calculator Tool

The Loan Calculator calculates the amount of loan payments, as well as the total 
interest and total paid for a loan. It is located under Tools → Loan Calculator.

To complete this screen, follow the steps below.

• Choose the appropriate currency.

• Input the principal amount you intend to borrow.

• Input the anticipated interest rate you will be charged.

• If appropriate input the loan points.

• Input the number of payments per year. Use the drop down arrow if necessary
to change the number of payments.

• Input the number of years over which you will be repaying the debt.

The Loan Calculator will calculate the principal and interest for each subsequent 
payment until the loan has been completely repaid. The loan calculator will also 
summarize the total payment that you will make (principal plus interest), the total 
interest that you will pay, and the total amount you will pay (both principal and 
interest added together).
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The Moneydance Loan Calculator also provides a "Points vs. Rates" scenario. Many 
lenders will offer a lower rate in exchange for "points" paid up front. The "points" 
refer to a percentage of the loan amount that is paid at the time the loan is given. 
Paying this initial fee in exchange for a lower rate often makes sense if you expect to
keep the loan for a certain period of time. Click on the Points vs. Rates tab to access
this feature. The Points vs. Rate tool will show you the break-even point for any two 
combinations of points and interest rates. To show a comparison between two 
scenarios, fill in the information in the top portion of the screen and Moneydance will 
assist you with making a recommendation as to which financing choice would be 
best.

Adding Extra Principal Payments to a Mortgage

A number of methods have been proposed to deal with this.

The first option is to record the transaction as normal and then add a split that goes 
to the loan with the extra principal amount.

The second option is to add the extra principal to the mortgage amount.

In either case, Moneydance should handle all the detail, such as:

• Calculating your next payment correctly.

• Adjusting the remaining number of payments.

You could also enter an additional transfer transaction in a bank account, entering 
the loan account in the category field as you would with any transfer. If this is 
something you do on a regular or semi regular basis you could create a Reminder 
transaction for it, that you edit and set the amount before you commit it and skipping 
it if you do not make an extra payment.

The amount will automatically come off the principal and the interest should adjust 
for the next months payment accordingly.

If you decide you are going to always pay a higher amount you could edit the Loan 
account and specify a fixed payment amount. You then use the Action button that is 
in the Loan register to edit the reminder transaction to reflect the new payment 
amount.

Loan Redraw

It is not unusual for Loan accounts to have a redraw facility, where you can withdraw 
extra payments that have been made. To facilitate such a transaction in 
Moneydance you can take the following steps:

1. In the account where the funds are to be transferred to e.g. a bank account, 
enter a transfer transaction drawing on the loan account for the funds.

2. If you need to change any details of the loan open the Loan account register 
then choose the menu item Account → Edit.

3. Change any details then close the Edit Account screen.
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4. If you need to change the transaction reminder use the Action button that is in
the Loan register to edit the reminder where you can change any details you 
need to.

Closing a Loan where the Asset has been Sold

The following instructions can be used to close a loan account where an asset has 
been sold prior to the end of the loan period,  as part of this it allows to loan to be 
paid out and that account closed.

1. Create an Asset Account for the Item.
2. Create an Income Category for the sale of the asset. Use this category to 

record the sale amount of the item in the Asset Account.
3. Create a transaction (a transfer) from the Asset Account to zero out the 

principal in the loan account. If there are fees associated with paying of the 
loan, create expense categories for these and expense the fees.

4. What is left in the Asset Account should be the gain/loss on the sale. You 
would transfer this into the appropriate bank account where the proceeds 
went. If there is a downloaded bank transaction with these proceeds you can 
merge the two transactions or reclassify the category of the bank transaction 
to zero out the Asset Account.

The Asset Account should now be zero and can be toggled to inactive.

Interest only Loans

Interest only loans are often used for investment properties.

Moneydance does not have automatic functionality to handle an interest only loan. It 
is suggested that you create an account of type Liability rather than of type Loan. 
You would then have the flexibility to create whatever transactions you need in the 
account.

You categorize the interest to a specific category, usually created for the purpose. 
Depending on the structure of the loan a Bank may either debit a different account 
(typically a checking account for the Interest payment) or may debit the loan account 
for you to then pay. An automatic deduction from another account is very typical of 
these types of loans. As the Interest is coming through as a standalone transaction 
there is no great need for Moneydance to be able to calculate the interest amounts.

If you pay down the principal, this is not a category item like interest. You typically 
enter a principal payment in the bank account the money is coming from and select 
the liability account in the transfer field – The category field doubles as a transfer 
field when an account is chosen for the entry. A Principal repayment is an event that 
reduces the amount of the liability (Loan) by reducing the balance of an asset 
account (Bank). This transaction does not change your total Net worth it just 
changes the value of the accounts that make up Net Worth.
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Changing Loan Details

To change details of your loan you can Open the loan account then use the menu 
item Account→ Edit Account, alternatively from any screen select the menu item 
Tools → Accounts select the Loan account then click on the Edit button.

On this screen you can change details like:

• Interest rate

• Payment amount

• Escrow Amount

• Loan length
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Chapter 8: Online Banking

Overview

Moneydance supports direct connections to many banks and financial institutions. 
Moneydance uses a direct OFX connection to communicate securely across the 
Internet with properly equipped institutions. You can download information through 
direct connections into bank, credit card, and investment accounts. To store 
passwords for your online banking, direct connect enabled accounts, you MUST set 
a password for your data file as described here. If you have encrypted your file but 
you do not wish to save this password in Moneydance, go to Online → Forget Online
Passwords. Online banking downloads are ONLY available for Bank, Investment, 
and Credit Card accounts. 

Moneydance+ support the automatic downloading of transactions by using an 
aggregation service provided by Plaid.

The Download button at the top of the registers will download transactions using 
Direct Connect if configured, if this is not configured Moneydance+ will be used, if 
Moneydance+ is not configured and there is a URL in the Bank info data the 
software asks if you want to start the system browser, or if you want to setup online 
banking.

Comparison of Connection Methods

Direct Connect

This method directly links your software with a server at your bank over a secure 
connection. This type of connection allows you to download Bank and Investment 
transactions directly into your accounts within the software. Your institution may also 
support activities like paying bills online and transferring funds between accounts.

This is an open protocol that any institution or software product is able to freely 
implement. This protocol is supported by Moneydance.

Moneydance+

Moneydance+ uses an Aggregation service called Plaid to collect your financial 
transaction information from one or more banks or other Financial Institutions and 
allows you to download this information via one central provider to your financial 
software. To facilitate this various methods are used depending on your Financial 
institution and country, security and privacy issues are discussed elsewhere.  Plaid is
a paid for service. Paid for services, in general, have better privacy policies.

Moneydance has researched and specifically used a service which has the best 
Security and privacy policies that we could identify.

Using this service opens up the automatic downloading of transactions to many 
institutions that do not support Direct Connect, as of writing the number of institutions
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in an order of magnitude higher and it is possible to provide the facility in countries 
that are unlikely to ever support Direct Connect.

There is currently no ability to perform Bill Pay or any other activities with this 
method, it is strictly for the download of transaction information. Banks in the North 
American market are supported and support within the European Union and United 
Kingdom has been announced along with support for Investments.

Web Connect

This method uses a secure connection to your Institution’s Internet Banking site. It is 
not completely automated. When in use the software will open a browser Window 
when you click on the Update button that displays your Bank’s website.  You will 
then have to manually find and click on the button to download your transactions, 
From here the transactions will be downloaded into the software.

There is no ability to perform Bill Pay or activities other than transaction downloads 
with this method.

This is a closed protocol owned by Quicken, it is not open to other vendors to use, 
hence not supported by Moneydance.

Express Web Connect

With this method you are connecting to a server at Quicken to download your 
transactions.

To set up this method you provide the details of your bank accounts along with your 
username/password combinations to Quicken. The Quicken system pretends to be 
you to log onto the Bank sites and downloads your transactions to the Quicken 
server that you collect them from at a later time. This method is often referred to as 
an aggregation service.

There is no ability to perform Bill Pay or activities other than transaction downloads 
with this method.

This is a closed protocol owned by Quicken, it is not open to other vendors to use, 
hence not supported by Moneydance.

General Aggregation Services

Moneydance does not support the use of user selected Aggregation services. As 
said earlier we tried to identify a service that offered the best in the way of Security 
and Privacy. To facilitate downloads you may have to give these organizations your 
Usernames and Passwords that you use you access your banking data, via Internet 
Banking or Direct Connect. This also may be a free or a paid for service, in some 
cases the organizations aggregate the financial data and sell information they glean 
from it, for example spending habits.

There is no ability to perform Bill Pay or any other activities with this method, it is 
strictly for the download of transaction information.
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Automatic Downloads and Manual Downloads

The current list of financial institutions that are known to support Direct Connect and 
that Moneydance has Direct Connect information for, and is able to automatically 
download transactions from, is available at https://infinitekind.com/FI.  If your bank is 
not on this list, please email us to see if we can create a connection.

There is currently no tool in Moneydance nor facility provided by The Infinite Kind to 
“look up” what Institutions are supported by Plaid so it is necessary to go through 
Plaid or sign up for the free trial to see if your Institutions are supported. Methods 
that can be used to provide such a facility are being considered for future 
implementation.

For institutions that are supported via both Direct Connect and Moneydance+ we 
would recommend using Direct Connect as the preferred method. To this end 
Moneydance will always use Direct Connect if you happen to define both methods 
for a connection, note that there is no fall back capability so there is no benefit in 
defining both connection methods.

Even if your financial institution does not support Direct OFX connections, nor is 
supported by Moneydance+, most financial institutions allow you to download your 
transactions from the financial institution's Internet Banking website and import them 
into Moneydance. For more information, see the section on Downloading from your 
bank’s website.

Automatic Downloads via Direct Connect

Direct Connect Automatic Downloads make use of the OFX (Open Financial 
Exchange) standard to automate the downloading and importing of transactions from
your Financial Institution ready for you to confirm the transactions.

Enabling Direct OFX Connections with your Bank

First, make sure your account at the bank is properly enabled for application-based 
online banking via Direct OFX connections. This type of online banking often 
requires a different login/PIN than the ones that are used for ATM or web-based 
banking.

Although Moneydance uses exactly the same OFX server connection protocol as 
Quicken your bank representative may not be aware of this, and may mistakenly 
believe they cannot support the program. Calling your bank and saying “Please 
enable direct connect on my account so that I can connect to your servers directly 
with Quicken, as well as give the user name and password I need to connect to this 
service,"  should get you started. Some institutions impose a monthly or per-use 
charge for this type of service.

Some financial institutions will give you a temporary PIN which you are required to 
change the first time you log into their direct connect system.  To change your pin in 
Moneydance, select the account and click Online → Setup Online Banking → 
Change PIN.
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Setting up Online Banking with Direct Connect

Open the register of the account you are trying to connect to your bank.  If you have 
not yet created the account go to the menu bar, then select Account → New 
Account.  Now open the register. In the menu bar open the Online menu, then select 
"Set Up Online Banking".

The first screen you will see asks you to select the connection methodology:

In this case you would be selecting “Connect to OFX Service” (Direct Connect), this 
screen also allows you select Moneydance+ which is discussed later in this section.

The next screen starts the Direct Connect setup by asking you to select the financial 
institution for this account.
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Click the "New Connection" button.

Select your bank from the list; typing your bank's name in the box at the top of the 
window to search for your bank.

After selecting OK you will get a dialogue box that Moneydance is retrieving 
the financial institution profile.
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Once the profile has been retrieved you should see a dialogue and your 
Moneydance account name should be listed in the Financial Institution field.

Click Next.

Enter your Direct Connect username and password, then click OK.

Wait and in due course you should be presented a list of accounts that you bank has
available.

Select the account at your bank that corresponds with the account in Moneydance.  
If you have several accounts at this bank this step is especially important and as the 
list that is displayed is created from information sent to Moneydance from the Bank’s 
OFX server may take a little time to display, do not get impatient at this step. If you 
happen to click through the window before the bank’s server has sent, and 
Moneydance has displayed, the account list for you to select from the result will be 
that the software will map the first account from your bank to this account. This is the
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most common cause we see of problems with transactions going to the wrong 
account in Moneydance.

The link should now be established.  It may take a few minutes for Moneydance to 
download the available transaction history from your bank’s server for the first time.

OFX Tunneling

Some banks have started insisting that OFX connections only come from registered 
IP addresses. To ensure that you can still download your transaction from 
Moneydance, The Infinite Kind are providing an opaque tunneling proxy capability for
these organizations. This is to ensure that connections only come from an IP 
address that has been registered with the institutions. The Infinite Kind have no 
interest in proxy connections and it is reiterated that the “proxy” is merely a tunnel 
and the connections are encrypted using TLS/https between Moneydance on your 
computer and the financial institutions servers – there is no way for The Infinite Kind 
to access any information transmitted over the connection.

Multiple Logons with Direct Connect Online Banking

Having multiple online user accounts, even at the same bank, should not present 
any problems in Moneydance. Naturally you need to ensure that Online Banking 
(Direct Connect) has been enabled by your bank for all accounts. Within 
Moneydance when you are setting up your connection you are required to provide 
your Username and Password, you need to do this for every account as 
Moneydance stores and uses these details on an account by account basis.

The software does not assume there is a single sign on for a bank to allow for the 
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possibility that there may be multiple logins. Setting a master password and allowing 
for the storing of online passwords in the Moneydance data set avoids the tedium of 
having to reenter these username/password combinations every time you download.

Online Banking – Advanced Setup

The Advanced Setup is intended as a fallback for when a bank does support Direct 
Connect but Moneydance does not have any OFX settings for an institution's server 
in the system.

If you enter settings into the advanced OFX setup fields and we have that 
information already in our system, then Moneydance should automatically use the 
connection parameters that we have recorded for that institution.

Downloading Transactions Using a Direct OFX Connection

Moneydance allows you to download transactions for an individual account by 
clicking Online → Download [Account Name] Transactions. You can download 
information for all accounts simultaneously by selecting Online → Download All 
Accounts.

Once you have downloaded transactions you will need to Confirm them in your 
register.

Important Information on Using Direct Connect for the First Time

The first time you connect to your bank through Moneydance, Moneydance will 
download all transactions available on your bank's server.  This may result in 
duplicate transactions, especially if you have transferred data from another personal 
finance program.  First, try to run through the Confirmation process to merge the 
duplicates, then delete any undesirable transactions.

Many banks only offer the most recent 30-90 days of transactions on their direct 
OFX connection server.  To get transactions prior to this point you will need to 
download and import files from your bank's website.  Moneydance is able to import 
OFX, QFX, OFC, and QIF files, which are sometimes referred to by banks as 
“Quicken” or “Microsoft Money” files.

Special information regarding Investment Accounts: Regardless of which method 
you choose for entering your holdings, it is important to remember that Moneydance 
will only download transactions from your account when you import or download 
from your financial institution. Therefore, unless the initial purchase of the security is 
in the download, you will not have the complete information for your security. You 
may need to manually enter transactions for the account to reflect your current 
holdings.  To so do, please see the instructions in Chapter 6, on Managing 
Investments.

Subsequent Downloads Using Direct Connect

Moneydance implements a couple of methods to avoid downloading transactions 
that have previously been downloaded. 
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The prime method is the use of Transactions IDs. These were designed specifically 
for this purpose and are assigned by the Financial Institutions OFX server. They are 
stored as part of the transaction. If Moneydance sees a transaction with the same ID 
it knows to not download it or to discard it, and thus avoiding duplicates.

A secondary method is that Moneydance takes note of the last download date and 
includes this in the request it sends to the Financial Institution to try and limit the 
amount of data transmitted,

Regarding the last download date, some banks don't observe the last download date
option. When banks don't use this they either send all transactions, or they maintain 
their own internal 'date'.

When this date is not set in an account, it means the account’s transaction register 
has not yet been opened. When it is zero, it means you have at least viewed the 
account in Moneydance and the software has primed the field with a zero, at this 
stage no downloads have occurred. This is also the state an account with only 
manually entered transactions is expected to be in. When you perform a successful 
download the field is set with the download date information. Moneydance itself has 
an option to reset this value to zero, see Reset Sync option in the Online Banking 
Service Options.

There are times when you may want to set a specific date in this field, for example 
there have been instances where Financial Institutions have reset the date and this 
would force a full download of many previous transactions, so setting this date may 
be desirable to try and prevent these downloads (assuming the institution’s servers 
honors this setting).

We can use the Moneydance Online menu to reset the date of the OFX Last 
Transaction update.

As stated this setting will only work if the Institutions OFX server honors the setting.

Direct Connect Online Banking Service Options

Once you have Online Banking set up you can change aspects of the service 
through the Online Banking Service screen. You access this screen in the same 
manner as when you set up the service:

1. Open Moneydance to the register of the account in question.

2. From the Moneydance menu, select Online → Set Up Online Banking.

You will see the following screen:
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The options you have are:

Change: This can be used to change the Financial Institution that this account 
transactions are downloaded from.

Disable: This button is used to disable online access for this account.

Reset Sync: This button tells Moneydance to download any and all available data 
from the OFX server of the financial institution in question. The Reset Sync button 
basically resets Moneydance's internal tracker of the last download date back to 
zero. This means that, the next time you connect, Moneydance will request all 
available data, instead of just the transactions since the last time you downloaded. 
This however should not produce duplicates, since the existing transactions should 
have the same transaction IDs as any past transactions now being downloaded 
again.

This option is typically used if you have found that transactions have been skipped 
for some reason as this option is intended to reset the date and force all transaction 
that the server has for the account to be downloaded.

Change Pin: This option can be used to change your PIN.

Refresh: This reloads the data associated with this bank.

Updated Connection Information

From time to time banks will change the connection information for their OFX server 
and Moneydance will need to make changes as a result. These changes are made 
on a central machine that provide the information to your copy of the software.

If you are using any recent version of Moneydance then the connection information 
should automatically refresh itself. You can also manually refresh the connection 
information using the Online->Setup Online Banking menu and then hitting the 
Refresh button in the window that appears if the account is already connected.

On occasions it may be necessary to recreate the connection if the automatic update
does not appear to be working and in this case you should following the instructions 
in the next section.
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Recreating your Connection

At times it could be necessary to recreate your connection with your financial 
institution, for example the connection information may be changed and it is 
therefore necessary to have this new information to allow Moneydance to connect 
and the standard refresh method is not working for some reason. To do this you 
need to disable your current connection to your bank and then recreate it using the 
New Connection button on the Online Banking Setup screen. To do so, you can 
follow these steps:

1. Select your bank account in Moneydance.

2. Select the Online → Setup Online Banking button/menu.

3. Click the "Disable" button. If you don not see a disable button, just close the 
setup window.

4. Repeat the previous steps for any additional accounts at the same institution.

5. Select the Online → Setup Online Banking button/menu (again).

6. Click the "New Connection" button and select your bank and hit OK.

7. Continue with the setup process, entering your username/password.

Make sure you pick new connection, even though your bank is still one of the 
connection choices after you disable it. Choosing your bank from the list of 
available banks will force Moneydance to download the updated information, which 
should then allow you to connect.

Manually Removing a Connection

There can be times where you still will not be able to reconnect, in such instances it 
may be because Moneydance has retained the connection information yet the user 
interface thinks there is none. In such an instance you will need to manually clear the
current connection information for your bank in Moneydance.

To address this we need to use a maintenance tool to remove references to this 
service from Moneydance. This is not a routine task so there is no built in menu 
option.

Maintenance tools for Moneydance are contained in an extension named Toolbox. 
To install the Toolbox use the menu option Extensions → Manage Extensions, select
Toolbox from the list, then click on Install. Once installed close the Manage 
Extensions.. window

Once installed use the Menu Option Extensions → Toolbox to start the tool, it can 
take a little while to load so be patient.

You will then see the main Toolbox Screen.

Use the following steps to reset the data set to be a primary:

1. Select TOOLBox Options from the menu bar and then select “Advanced 
Mode” from the drop down.
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On the next dialogue Select to accept the risk

2. The next Dialogue suggests creating a backup, if you have not already done 
so it is advisable to create a backup.

3. The main Toolbox screen will then show some entries in Red, this indicates 
you can change options with these selections.

4. Click the button “MENU Online Banking (OFX) Tools”. 

5. Select “Delete OFX Banking Service/Logon Profile (remove_one_service.py)”

6. Click on the PROCEED Button

7. You should be prompted to select the Bank, do so and continue.

8. The bank information should now be removed from Moneydance.

You should Close and reopen Moneydance. You should now be able to set up the 
connection to your bank.

Common Direct Connect Error Messages

In using Direct Connect with Moneydance there are a number of error messages you
could potentially encounter, this section seeks to highlight the most common ones 
and the likely solution(s) where we can identify them. The majority of errors that are 
expected to be seen are in the 2xxx range and generally relate to Username or 
Password.

OFX
Error

Definition Solution

2000 General error This error often means that you accounts 
have not been enabled by your bank for 
Direct Connect access.
The message received from your Bank’s 
server may give additional details
A 2000 error should only be used when 
another more specific error cannot however
some banks do group many types of errors 
under his code.

2002 Other account error 

2005 Account Not Authorized That error generally means that the account
in question is not activated for direct 
connections. What this means in practice 
varies from institution to institution. 

2006 Source account not found 

2007 Source account closed 

2008 Source account not 
authorized 
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OFX
Error

Definition Solution

2014 Date too soon 

2015 Date too far in future Use the Reset Sync button in the Online 
Banking Service options to reset the 
download dates in Moneydance.

10510 Invalid payee ID 

10519 Invalid payee list ID 

13504 <FI> Missing or Invalid in 
<SONRQ> 

Something is wrong in the sign on request. 
This is a block of data that includes the user
ID, password etc. Such an error is not very 
helpful given its lack of specifics.
This error has been seen when a special 
character is used in a password, the 
password in the reported case had a “ and 
a < in the password. It is not known if one 
or both characters caused a problem but 
changing the password to an Alphanumeric
resolved the issue.
The OFX specification supports non 
Alphanumeric characters however it seems 
that some implementations of OFX servers 
may not.

15500 Signon invalid An invalid signon was given. Often this will 
be a subsequent message for example 
from an Error 2000

15502 USERPASS lockout You are mostly likely to get this error 
message because you have tried to log in 
too many times with the wrong password. In
order to clear the error, you will need to 
contact your bank and have them reset 
your lockout flag. You may want to make 
sure you are using the right username and 
password to authenticate with their server. 
This will help you avoid the lockout error in 
the future.  Note that this is your Direct 
Connect password not your Internet 
Banking password.

15510 CLIENT UID invalid This error has been seen when the bank 
requires you to take further steps to 
authorize your account for Direct Connect. 
It may need a response to an email 
message, using a particular web link that 
you have been sent etc.
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The following table lists some of the HTTP error codes seen when using direct 
connect.

HTTP
Error

Definition Solution

403 Forbidden This error usually meas you can 
communicate with the server system but 
cannot communicate with the OFX server 
software. Possible causes include 
1. The URL being used needs to be 
updated.
2. The bank has suspended access to the 
service – perhaps for maintenance 

Automatic Downloads via Moneydance+

The use of the Moneydance+ features requires a subscription.

Using Moneydance+ is totally optional and because running the service incurs fees 
from the service provider (and since we do not sell ads or customer data) the 
subscription is necessary.

We offer a 14-day free trial and the subscription can be canceled at any time.

Subscription Options

There are currently two subscription options.

1. Purchase Moneydance and subscribe to Moneydance+ at a cost of $2.00 per 
month

2. Subscribe to both Moneydance and Moneydance+ for a cost of $5.00 per 
month.

Changing Subscription Option

We envisage that some may start on the $5.00 per month option and decide at some
point to switch to the $2.00 option.

The process to do this is as follows

1. Cancel your current subscription. To do this, click the Online → Setup 
Moneydance+ menu, then click the Manage Account button which will open 
your Moneydance+ account page in a browser where you can cancel the 
account. Once you've canceled the account it may be that the account page 
shows your subscription as still active for the remainder of the period. If so, 
you might not be able to subscribe until the current period runs out. 

If you cannot wait, this can be forced to change you would need to contact 
support with the email address you used to register the subscription.

2. Once your subscription is canceled then you can purchase Moneydance at 
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https://infinitekind.com/purchase and then enter the new license key into 
Moneydance. 

3. At this point you can subscribe using the Online → Setup Moneydance+ menu
again, and should see the $2/month subscription option automatically.

Privacy and Security

For information on the privacy and security of Moneydance+, we recommend taking 
a look at the relevant blog post, there is also a whitepaper that provides 
supplemental information.

How to Subscribe

To subscribe to Moneydance+, open Moneydance. Choose the menu item Online → 
Set Up Moneydance+

Enter your email address and choose 'Connect to Moneydance+'You will then see 

the message - 'Waiting for email confirmation. Please check your inbox'

You should see an email from moneydance-auth@infinitekind.com

If you do not see the email within 5 minutes, check your spam/junk folder.

The email contains a confirmation link, and also a code that you will need to enter.

139

https://infinitekind.tenderapp.com/discussions/online-banking/20007/r?go=aHR0cHM6Ly9pbmZpbml0ZWtpbmQuY29tL3B1cmNoYXNl


Click the link and you will be taken to a page where you can input the code.

On the next page, you can choose 'Subscribe Now!'

Then follow the prompts to purchase the subscription.

Once the subscription has been purchased, open Moneydance again.

Choose Online → Setup Moneydance+

You will see a message that says 'You're fully connected', with an option to 'Connect 
Accounts'

Connect with your Financial Institution

After subscribing to Moneydance+ you will need to connect your accounts.

Select Online → Setup Moneydance+.

Click the 'Setup' tab and choose 'Connect Accounts'

Alternatively, select your account and choose Select Online → Setup Online 
Banking.

Choose 'Connect using Moneydance+' and choose 'Connect Accounts'.

You will then be directed to the Plaid Link interface, where you can search for the 
financial institution you want to connect with.

Select your bank or credit card company, and you will be directed to their website. 
You should follow the prompts to login (using your regular online banking 
credentials) and allow access to your accounts.

Multi Factor Authentication

Multi Factor Authentication is supported.

Setting up Moneydance+ for account access supports multi factor authentication by 
prompting for the access code. However for ongoing use your financial institution 
must allow for trusted devices as the system does not allow for authentication that 
needs to be provided at every login, the transaction downloads is not an interactive 
process hence there is no ability to support prompting for a code.

Assign your Moneydance Account

Once completed, you can navigate back to Moneydance.

Choose Online → Setup Moneydance+ and select the 'Accounts' tab.

You will see a list of any accounts you've connected with.

The name of the financial institution will be displayed, and on the right you will see 
'connected'.

Below this you will see your account information and the currency your account 
uses.

On the right you should see which account the transactions will download into.
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If you see 'None', click on this, and you can specify which account in your data file 
you would like to use.

Once an account has been selected, you can click again to choose 'Don't download',
this removes the account you have assigned.

Download your Transactions

To begin downloading, select your Moneydance account.

Then choose Online → Download AccountName Transactions.

As this is the first download, you'll be asked how much transaction history you would 
like to download.

You can choose 'All Available' to download all available history.

Or select the 1st of the month, with the last 12 months to choose from.

Determining Transactions to Download

Moneydance+ keeps track of the most recently downloaded transactions by date, 
and will not re-download any transactions from an earlier date unless you reset the 
syncing date, as detailed below. 

Reset Syncing Date

You can change the transaction history date range at any time.

Choose Online → Setup Moneydance+ and select the 'Accounts' tab.

Select the relevant account and choose 'Reset Sync Date'.

The next time you download transactions for this account, you will be asked how 
much transaction history you would like to download as if it is the first time.
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Moneydance+ Update Frequency

The information we have is that the service provider, Plaid, will typically check for 
transactions once every 6 hours, but that it may check less frequently (such as once 
every 24 hours) depending on factors such as the institution and account type. 

Direct Connect/Moneydance+  Preference

If you have both Direct Connect and Moneydance+ configured for an account then 
Direct Connect will be used. The preference is not user configurable, nor is it 
possible to ‘suspend’ one or the other. 

Note that you cannot use Moneydance+ as a fall back, if Direct Connect is 
configured, even if it should fail for some reason e.g. a server is down, 
Moneydance+ will not be used.

To use Moneydance+ you must remove any Direct Connect configuration for an 
account.

Number of Data Sets Supported with Moneydance+

A single Moneydance+ subscription enables you to register up to 3 data sets for that 
subscription. Each data set will maintain its own separate Moneydance+ authorized 
links, you set up each data set separately. 

Moneydance+ configuration data is stored in the individual data sets.

Problems Registering Subsequent Data Sets

If you have a problem registering additional data sets you can use the Toolbox 
extension to help resolve this. Use the Menu item Extensions → Manager 
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Extensions to install Toolbox if you have not already done so.

Ensure that the data set that has Moneydance+ configured open. Then start the 
Toolbox Extension using the Extension Menu.

1. Under “TOOLBOX Options” select “Advanced Mode” then “Hacker Mode”  in 
each case following the on screen prompts. Both modes need to be active.

2. Then under the Menu: Online Banking (OFX) Tools select “Export your 
Moneydance+ (Plaid) settings to a file (for ‘transplant’)”. Click PROCEED and 
follow-on screen prompts.

Then open the Data set you wish to set up Moneydance+  in. Start the Toolbox 
extension.

1. Under TOOLBOX Option select “Advanced Mode” then “Hacker Mode”  in 
each case following the on screen prompts. Both modes need to be active.

2. Then under the Menu: Online Banking (OFX) Tools select “Import 
(‘transplant’) your Moneydance+ (Plaid) settings from a file (exported by 
Toolbox)”. Click PROCEED and follow-on screen prompts.

Now this data set should have the base Moneydance+ set up and you can proceed 
to map the accounts read for downloads.

Updating or Canceling your Moneydance+ Subscription

Choose Online → Setup Moneydance+, then select 'Manage Account' at the bottom 
left of the window. You will be redirected to a page where you can update your
payment details or cancel your subscription.

Complete Removal of Moneydance+ Setup

For anyone that wants to completely remove their Moneydance+ setup from your 
data set you can follow the instructions given below.

1. Choose Online → Setup Moneydance+. Make sure you disconnect all banks 
and accounts setup. Then refresh. When the screen is empty, proceed to the 
next step.

2. Choose Online → Setup Moneydance+, then select 'Manage Account' at the 
bottom left of the window. You'll be redirected to a page where you can 
cancel your subscription.

3. Once this is done and your Data Set is deactivated use the Toolbox 
extension. Enable Hacker mode. Then on the Online banking menu choose to
delete the Moneydance+ license.

Moneydance+ setup has now been completely removed from this Data Set.

The Plaid Account

Plaid is the aggregator that The Infinite Kind has chosen to use, a significant driver in
the selection being Plaid’s privacy policy. The Plaid account is owned by the Infinite 
Kind who get charged for your downloads hence the monthly fee you pay. As such 
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you do not have an account with Plaid, you do have a set of connections that are 
links between you and a login/username at each bank to which you connect. 
Depending on how data is retrieved this could be an username/password or it could 
be a token issued by the financial institution. Because you do not have an account 
with Plaid you cannot manage access via the Plaid site. When subscriptions (or data 
files) are deactivated The Moneydance+ server uses a token it holds to disable any 
data access tokens.

Common Moneydance+ Error Messages

In using Moneydance+ there are a number of error messages you could potentially 
encounter, this section seeks to highlight some of the most common and the likely 
solution(s). 

Errors While using Moneydance+

Error # Error Text Solution

880011 Moneydance+ Connection 
Needs Relinking 

This usually means one of your 
Moneydance+ connections has expired 
and needs to be re-linked.

880012 INVALID_ACCESS_TOKEN This means that MD+ is trying to refresh 
but Plaid is saying there is a problem with 
the token. 
See brlow for more information

Invalid Access Token Error

This is a common error message. You should go to the Online → Setup MD+ menu 
and look in the connections list. Hit refresh. You should have an account that is now 
not mapped or a connection that is disconnected, you may see “no name” indicating 
it is disconnected. You will need to correct this. 

Your account might require a re-link which should be resolvable by selecting the 
Online → Setup Moneydance+ menu then clicking on the row in the table for the 
institution (not one of the accounts, just the header row) and clicking the rounded 
button as in the attached screenshot and selecting the "Re-link Connection" entry. 

Errors when setting up Moneydance+

Error Definition Solution

N/A INVALID_CREDENTIALS You may be redirected to the bank login 
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Error Definition Solution

screen.
If the bank is being accessed via Web login 
then ensure username/password are 
correct.
If via OFX ensure that access is granted.

N/A ITEM_LOCKED It is likely you have been locked out of your 
account because of too many login 
attempts.

Manual Downloads

Many institutions worldwide provide the ability to download transactions through their
Internet Banking websites.

Downloading from your Bank's Internet Banking Website

If your financial institution does not support the direct connect online banking 
protocol used by Moneydance, you may still be able to download transaction files 
from their website in QIF, OFX, QFX or OFC. Formats, and in some cases CSV. You
can quickly access your bank's website by using the Open Account Website tool. 
Many institutions will provide filter tools in order to allow you to limit the transactions 
you download, the most useful tool generally allows you to filter by date which can 
be very useful if you need to download transactions in older formats like QIF so that 
you can minimize duplicate entries.

In the finance world you can see references to formats like MT940 and ISO20022. 
These formats, in general, are used between organizations or in international 
payments systems and files in these formats are rarely provided to personal 
customers.

Using the Open Account Website Tool

Clicking Online → Open Account Website will automatically open your browser to a 
page you have pre-set.  The Download button at the top of the transaction register 
by default opens the Institutions website in an internal browser implemented inside of
Moneydance. This does not work with all institutions so as a short cut holding down 
the Ctrl key (Command key on a Mac) when clicking on this button will open up your 
system browser.

Designate the page you would like this function to open (your bank's home-page, a 
link to the Internet Banking log on page, etc.) by typing in the URL once as 
prompted. To edit the account website, go to Account → Edit Account and enter the 
new URL in the Website field.   If you have not yet entered a web address for an 
account, clicking Online → Open Account Website will display the following where 
you can enter the appropriate web address.
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Performing the Import

Many web browsers will automatically ask which program you want to use to open 
the downloaded file.  If your web browser prompts you in this manner select 
“Moneydance”.  If your browser does not offer this option save the file on your 
computer, then import the file by opening Moneydance and dragging the downloaded
file into the Moneydance program window, or by opening the File menu and selecting
Import.  The “Import file” dialogue box will appear.  From here the process differs 
depending on what type of file you are importing – QIF or OFX, OFC, and QFX files.

QIF is one of the earliest formats, it was original developed for the use of support 
staff to correct data problems, but has proven to be useful for data imports as well as
data migration.

OFX, OFC and QFX files are related. OFC was developed first and OFX was 
developed from this, QFX is a variant of OFX. OFX provides the ability to add vendor
specific data, Vendor specific data is ignored by other systems. QFX is just 
Quicken’s variant of OFX.

Importing Open Financial Exchange (OFX), Open Financial Connectivity (OFC) 
and Quicken Financial Exchange (QFX) files 

Moneydance will attempt to match the imported account with your existing accounts 
and should identify the correct account in subsequent imports. If the correct account 
is not currently visible, select the account to which you wish to import and click “OK.

There is also a check box on that screen to “Remember This Choice”.

If you tick that box, from that time on the OFX file gets imported immediately into the 
account you selected.

Clearing the “Remember This Choice” Option

To reset the “Remember This Choice” option, you need to use the match online 
window.
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To access this use the menu path Online → Match Online Accounts.

Within this window ensure that “Imported OFX/QFX”  is selected then identify which 
account you want to clear the option for.

Select the account and in the drop down select “None”.

You may need to Close and reopen Moneydance. You should now be able to 
perform the import and be prompted for the account.

Importing Quicken Interchange Format (QIF)

Using Moneydance, when you attempt to import a QIF file you will see a list of your 
accounts.

You may also see 'Imported Bank Account' which will allow you to import the 
transactions into a new account.

At the bottom of the window, the program will try to determine which date format and 
decimal character have been used within the file, it will also try to determine the text 
encoding of the file. The date format may not always be the format you would 
expect. If you want to check which date format has been used, open the QIF file with
a text program like TextEdit or NotePad to view the file contents.

The text encoding options include:

• Windows-1252 – Windows character set for Western languages.

• UTF-8 – Unicode 8 bit character encoding.

• ISO-8859-1 – ISO Western Europe Character set.

• US-ASCII – Standard ASCII character set.

• UTF-16 – Unicode 16 bit character encoding.

• UTF-16LE – Unicode 16 bit Little Endian character encoding.

• UTF-16BE – Unicode 16 bit Big Endian character encoding.

• ISO-8829-8 – ISO Hebrew character set.
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When importing QIF Transaction files downloaded from a financial institution ensure 
that the “File was downloaded” checkbox is marked. This will tell the software that 
these are downloaded transactions rather than being an import from another 
financial program, and as a result mark them with the blue dot so that you can use 
the confirmation process to assign categories, merge with existing transactions and 
accept the new transactions into the register as confirmed transactions.

Importing Comma Separated Value Files (CSV).

The CSV (comma separated values) format is essentially a table of rows and 
columns, like a spreadsheet. It is very versatile but is not specifically designed to 
contain financial information.

As such there is no standard way for a bank to store data in such a file. There is no 
standard order for the columns in a CSV file or names for those columns.

As a result of this the import process for CSV files is much more involved than any of
the other formats used here.

For this reason, we recommend using either OFX, QFX, OFC or QIF files for 
importing your data whenever possible. OFX and QFX files are the best format, with 
QIF files being the second best and CSV files being a distant third.

Moneydance provides two tools for importing CSV type files. The first is the inbuilt 
importer. The other is the Text File Importer extension.
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Inbuilt CSV Importer

CSV files imported in “download” mode are supported as part of the Blue Dot 
confirmation process, older versions of the standard CSV import function do not 
support the Blue Dot process nor does the Text File Importer extension.

Importing CSV Files Using the Inbuilt Importer

Navigate to File → Import, then select the file CSV you would like to import.

You can then choose the import settings.

1. Specify the account you would like to import data into.

2. Field Delimiter is the character that is used in your CSV file to separate the 
fields. Comma is quite common and so is tab, but if you are using something 
different you can specify that as well. If you are unsure, select comma.

3. You may also need to change the date format to the format used within the 
file.

4. Then specify either a period '.' or comma ',' as the decimal used in the file and
click Next.

5. You may also choose to automatically merge duplicate transactions.The next 
window displays a list of fields. Each of these fields represents a column in 
the CSV file.

E.g. "Field 1" is the first, left most column in the file. "Field 2" is column 2, to the right
of the first column, and so on...

The inbuilt CSV importer now has the ability to import files that have amounts in a 
single field with the sign differentiating whether it is a debit or credit. The following 
screen shot shows the amount options you can select for a field
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Therefore there seems to be little reason to install and use the Text File Importer, as 
this was the primary reason for using the extension.

You need to select the Moneydance transaction field that corresponds with the 
column in the CSV file.

To do this we suggest opening your CSV file in a spreadsheet program to see which 
column is which, and use that as a reference to match the different field values to the
corresponding columns in the CSV file.

Use the "More Fields" and "Fewer Fields" buttons to adjust the number of fields to 
import, corresponding to the number of columns in your CSV file.

You should remove any unnecessary fields, rather than assigning as 'Ignore'.

Click "Finish" to import the file.
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CSV Importing Problems

If data has imported, but the information displayed is incorrect (e.g. dates are wrong)
then it is possible the wrong settings were selected during the import process.

You can create a new dummy account by selecting Account → New Account. Using 
this new account will allow you to test the import settings, until you find the correct 
settings to use. When you are done, you can delete the 'Test' account without 
affecting your other accounts or balances.

You can then proceed to import your data into the correct account, using the correct 
settings.

Text File Importer Extension

The functionality of the Text File Importer has largely been incorporated into the 
inbuilt CSV Importer. However as there may still be some usage cases we have 
included details of this extension.  As with the CSV import the 'Text File Importer' 
extension allows you to specify which columns in a CSV file should correspond to 
which fields in a Moneydance transaction.

To install the Text File Importer extension, navigate to Extensions → Manage 
Extensions and install the extension there. If you purchased Moneydance from the 
Mac App Store, then you download the extension, then drag and drop it onto the 
Moneydance window to install it.

Importing CSV Files Using the Text File Importer

Once you have installed the "Text File Importer" extension, select Extensions → Text
File Importer.

A window will open, allowing you to browse to the CSV file you want to import. 
Navigate to the CSV file and select it to begin the import process.

You will be given the option to select the file encoding from these options:

• UTF-8
• UTF-16BE
• UTF-16LE
• UTF-16
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• US-ASCII
• ISO-8859-1

In most cases, you can leave it to the default option. Click Next to continue.

In the next window:

1. Specify the account you want to import the data into.

2. Select the Fields Delimiter from these options:

[tab] [space] [,] [.] [/] [] [-] [_] [*] [~] [;]

This is the character that is used in your CSV file to separate the fields. 
Comma is quite common and so is tab, but if you are using something 
different you can specify that as well. If you are unsure, select comma.

3. You may also need to change the date format to that used in the file. To do 
so, select the Date Format from the following options -

MDY, DMY, YMD, YDM

4. After that, specify either a period '.' or comma ',' as the decimal used in the file
and click Next
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The next window displays a list of fields. Each of these fields represents a column in 
the CSV file.

For example:. "Field 1" is the first, left most column in the file. "Field 2" is column 2, 
to the right of the first column, and so on..."

You need to select the Moneydance transaction field that corresponds with the 
column in the CSV file.

To do this we suggest opening your CSV file in a spreadsheet program to see which 
column is which, and use that as a reference to match the different field values to the
corresponding columns in the CSV file.

Use the "More Fields" and "Fewer Fields" buttons to adjust the number of fields to 
import, corresponding to the number of columns in your CSV file.

You should remove any unnecessary fields, rather than assigning as 'Ignore'.

Then, for each field/column, select the transaction field in Moneydance that the 
column value corresponds to from these options:

• Date
• Check Number
• Description (Payee)
• Account (this is "Category" in the register)
• Amount (positive for deposit, negative for payment)
• Memo
• Status
• Ignore

Click "Finish" to import the file.
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Text file importing problems

The Text File Importer supports dates in the format of XX/YY/ZZ and XX/YY/ZZZZ. If
your dates are in a format that includes letters (Jan-1-2015, for example), the Text 
File Importer will not be able to recognize your dates. You will have to change the 
format in a spreadsheet program to a format that the Text File Importer can 
recognize.

If your file has your credits and debits in one column, and another column that 
specifies whether the row is a debit or credit – you will have to adjust the amount 
column in your file to make the credits negative (with a minus sign in front of them).

If your file has credits and debits in two columns, then you will have to merge the 
columns into one to be able to import it with the 'Text File Importer' extension, or use 
the inbuilt 'CSV Importer' to try importing the data.

Recognizing Downloaded and Imported Transactions

When you have transactions in an account which need to confirmed, you will see a 
blue dot next to that account's name in your sidebar. Note that this capability is only 
available with Importers that support this functionality. The Text File Importer does 
not support the blue dot process, the OFX/QFX, QIF and CSV importers do support 
this process.

154



Downloaded and imported transactions are placed according to the current sort 
order of your account's register and so may be dispersed throughout the register.  
You can easily identify these transactions by using the “Unconfirmed” filter at the top 
of the register, or by looking for the “blue dot” in the description field.

Confirming Downloaded and Imported Transactions

Once you have downloaded or imported new transactions you will review and accept
them (or “confirm” them) into your register.  To begin the confirmation process, click 
on the first transaction in your account register with a blue dot.  After you confirm a 
transaction Moneydance will “look” for and select the next unconfirmed transaction.

When you highlight an unconfirmed transaction a matching panel will pop up on the 
right side of the screen which will contain suggested options for you to choose how 
to handle the transaction.
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Current Transaction:  Accept the transaction in its current form as displayed in the 
register.

Transaction as Downloaded:  Accept the transaction in its original format as 
Moneydance has received it.  This option will reverse any changes you have made 
to the downloaded transaction.

Merge Choices:  Merges the downloaded transaction with the duplicate in the 
register. Note that Merge is not supported in Investment accounts.

Similar Payees:  Changes the Description and Category to match the similar 
transaction. A confirmation with a similar payee match will change the description to 
match the prior transaction and adjust the category on the incoming transaction. If 
the prior transaction being matched to had a split category the split will be applied to 
the incoming transaction adjusting the splits proportionally for the total. If the prior 
transaction being matched to had a split category the split will be applied to the 
incoming transaction adjusting the splits proportionally for the total.

Select and click the desired option to process your transaction and click “Confirm” or 
“Merge”.

Once you have accepted the transaction into the register the blue dot disappears, 
and the blue circle signifying the transaction has been imported remains.

Moneydance attempts to recognize and auto-categorize transactions with similar 
payees and amounts, so once you have manually assigned a category to a 
transaction or changed its description you can expect Moneydance to suggest the 
same category and/or description for similar transactions.

Moneydance uses a weighted fuzzy matching algorithm to automatically assign 
categories to newly downloaded transactions based on the transactions that were 
already in your register. This matching algorithm takes into consideration the 
description, memo, date, amount etc. giving each of these a different weight. The 
field with the most weight is the description that the bank originally gave the 
transaction. The problem with using the check field and checks in particular is that 
some banks give all check transactions exactly the same description, e.g. the word 
"check". This results in every check transaction getting a very high matching score 
and results in a false positive match. There is nothing that Moneydance can do about
this.

If you change a description it does not cause a problem because each transaction 
actually stores two descriptions. The description that the transaction had that was 
assigned by the bank and the description that you manually change that to. The 
description that the bank gave the transaction has more weight than the description 
that you manually change it to. This means that if you download a transaction that 
has description "PAYPAL *AVANGATE BV 35345634781" when you download it and
you change it to "AVANGATE" and if you then download a transaction that your bank
gives the description "PAYPAL *AVANGATE BV 35345634781" it would be a perfect
match on the other transactions bank assigned description and would almost 
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certainly get a high enough score to be used for category assignment.

The categories are not learned, they are calculated on the fly from the transactions in
that account.

Inter Account Transfers

When you have multiple accounts (say Savings and Current) with the same bank 
when downloading transaction files from the bank to Moneydance the inter account 
transfers (between the Current and Savings accounts) may just appear as 
transactions as opposed to transfers to the relevant account within MD. 

After downloading your transactions, you should go through the confirmation process
to handle the recently downloaded data. Your unconfirmed transactions display a 
solid blue dot. Once confirmed, the dot changes to a blue circle.

In this situation you should download your Current account and Savings account 
transactions so that the relevant transactions are unconfirmed. Then navigate to 
either account (in this example, we will go to the Current account).

Highlight the relevant unconfirmed transaction, and you will see the confirmation 
panel appear on the right of the window. You can amend the transaction category 
within this panel. Amend the category to your Savings Account, then choose 
'Confirm'.

This will create a transfer between the accounts.

If you then navigate to the Savings account, you will see a new transaction has been
created. This new transaction is the 'other side' of the transfer from the Current 
account.

You should then go through the confirmation process for the transactions in your 
Savings account. When you reach the relevant transfer transaction, you will see it is 
a duplicate. One copy of the transaction is downloaded from the bank, and the other 
is the transfer from your Checking account.

Highlight the downloaded transaction, and you'll see the confirmation panel on the 
right. Then look for 'Merge Choices' in the panel on the right. You should see the 
transfer transaction displayed as a merge choice.

By merging the transactions, one will be removed from the account register. The 
transaction identification information will be retained which means the transaction 
should not download again assuming you are using OFX Direct Connect, or 
download OFX/QFX files from your banks website.

Options for OFX Data

Open Financial Exchange (OFX) is comprehensive specification generally use with 
Online Application based banking, but the specification is also often used  to create 
manually downloaded transaction files. Some options exist to determine the 
operation of OFX and how some items are to be handled. These options exist on the
Network tab under the menu item File → Preferences.
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Automatically Download Transactions in Background

When selected this option initiates transaction download for all Direct Connect 
enabled accounts upon program start as a background task.

Automatically Merge Downloaded Transactions

You may choose to have Moneydance automatically merge and categorize 
transactions downloaded via Direct Connect and also by manual downloads and 
imports instead of going through the confirmation process.  To enable this option, 
click File → Preferences → Network, and select “Automatically Merge Downloaded 
Transactions”.

There is a feature of the auto merging function called the "Similar payee" feature. 
The intended purpose of this feature is to homogenize manually modified payees, for
example if you download a transaction from your bank and the bank assigned the 
payee as "STARBUCKS 123 fake st. #98765" and you changed the payee to be 
simply "Starbucks" when you confirmed the transaction, the next time you download 
a transaction that is a good match for "STARBUCKS 123 fake st. #98765" it will have
its payee modified to match the change you had made to the similar transaction. This
feature is tied to the auto merging feature. Turning of the auto merging feature also 
turns of the similar payee feature.

If you write a lot of checks it is suggested that you turn of auto merging. The similar 
payee feature is primarily focused on finding transactions that have similar bank 
assigned descriptions. If the bank gives all checks the same description the 
algorithm will not work well.

The current merge matching algorithm will only offer a merge if the totals are 
identical.

Automatically Mark Confirmed Transactions as Cleared

To have your confirmed transactions automatically marked as cleared, click File → 
Preferences → Network, and select “Mark Transactions as Cleared When 
Confirmed”.    Some Moneydance users choose to use this option in lieu of manually 
reconciling their accounts. This option only applies to downloaded and imported 
transactions, and does not apply to transactions in Investment Accounts.

Use Bank Dates for Merged Transactions 

This option allows you to select whether the date in a manually entered transaction is
to be used or if the bank supplied date is used. Typically this means the date when 
you say wrote the Check or the date when the Check was cleared by your bank. 
When this box is checked and the date on a manually entered transaction is different
from the date of the downloaded transaction it is being merged with, for example 
when a check is written on December 4 and cashed on December 8, the bank’s date
replaces the manually entered date.   When this box is not checked the manually 
entered date will remain.

This option is one of personal preference.
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Ignore Transaction Types in Favor of Amount Sign

It has been observed that some financial institutions have reinterpreted the OFX 
specification and as such have changed the structure of the data they are providing.

We have seen this reflected in data being  incorrectly categorized between deposits 
and withdrawals when they are stored in Moneydance.

To deal with this an option has been implemented under the menu path File → 
Preferences → Network to Ignore Transaction Types in Favor of Amount Sign.

Selecting this option will result in Moneydance interpreting OFX data in a different 
way to account for the change in structure that some financial institutions are 
providing.

Proxy Settings

This setting is for those that need to use a Proxy Server to connect to the internet.  If 
you think you need to use proxy settings, contact your network administrator for the 
required information.

Observe Online Payment Date Restrictions

If this option is checked, Moneydance will re-set the date given to initiate a new 
payment forward by the number of days your bank requires for processing. If you 
initiate a payment for a date earlier than your bank says it can be processed, 
Moneydance will send you an error message.

Matching Timeframe

You can select the number of days that transactions are apart that Moneydance will 
use to determine potential matching transactions, click File → Preferences → 
Network, and enter the number of maximum days apart that you want Moneydance 
to consider for matching transactions.
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Chapter 9: Paying Bills – Online Bill Payment and 
Check Printing
Moneydance bank accounts have 2 tools to help you pay bills – online bill payment 
and printing of paper checks.  Online bill payment is only available if your bank 
supports this type of connection from personal finance programs via Direct Connect, 
check printing merely depends on your ability to purchase and print printable checks.

There is a setting if you need to use a proxy to connect to the Internet. To enable this
option, click File → Preferences → Network, and select “Use Proxy”.  You will need 
to type in the name of your Proxy server and the port number used.

Online Bill Payment

Setting up Online Bill Payment uses the same procedure as setting up regular online
banking. Note that not every financial institution that supports online banking will 
allow application-based online bill payment, so you may receive an error message if 
you attempt to set up bill payment with an institution that does not allow it.

Using Online Bill Payment

Once you have set up Online Bill Payment, go to Online → Online Bill Payment to 
begin creating an electronic payment.

First you will need to create a Payee entry for the recipient of your funds. Select the 
Payee tab to begin.

Next, click the Create Payee button to begin creating a new payee.

Enter the desired information for the payee.  It is important to use the 2 letter 
abbreviation in the State field (if the payee is located in the United States).
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To create an online bill payment, click the New Payment button.

Select the payee you would like to process a payment to, then click Next.

Fill in the appropriate amount, due date, account number with the payee, Category, 
and memo field (if desired).

Finally, click Finish to send the payment request to your bank's server.  The payment
request will be sent to your financial institution, and a corresponding new transaction 
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will be created in the Moneydance account register.

You can date transactions for a certain amount of time in the future, as determined 
by your financial institution's policy.  Please note that it may take a number of days 
for the payment to be processed and sent to the Payee, and some banks require that
you set the “Due Date” of your online bill payment request a specific number of days 
in the future.  You can set your Moneydance Preferences to automatically detect and
Observe Online Payment Date Ranges.

Moneydance will communicates directly with your Bank’s Direct Connect server 
when it sends payments. Nothing is stored or backlogged in Moneydance. After you 
have sent the payment request you should see the payment in your outbox has a 
status of "Will Process" – this will occur once the payment instruction has been 
received and acknowledged by your banks server.

Note that some banks do not provide any feedback on their Internet Banking website
that the payment request was received, executed or dropped. Without feedback, the 
only immediate status you have is the "will process" and "processed" indications in 
Moneydance. The transactions is likely to only show up on the Bank’s Internet 
Banking site when the transaction has been processed.

As has been outlined, the payment will show up as "will process" or "processed" in 
Moneydance’s Online Bill Payment outbox once you have completed it. To access 
the "Outbox" select "Online/Online Bill Payment" you should see a pop-up window 
titled "Online Bill Payment" this window will have "Outbox".

Initiating an Online Bill Payment from a Reminder

Moneydance makes using Online Bill Payment even easier!  Just click “Send Online 
Payment” when confirming a transaction reminder and you’ll be sent to the bill 
payment interface.
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Options for Online Bill Payment

Observe Online Payment Date Restrictions If checked, Moneydance will re-set 
the date given to initiate a new payment forward by the number of days your bank 
needs for processing. Otherwise if you initiate a payment for a date earlier than your 
bank says it can be processed, Moneydance will send you an error message. To 
enable this option, click File → Preferences → Network, and select “Observe Online 
Payment Date Restrictions”.

Printing Checks

It is possible to print Moneydance transactions on virtually any style of pre-printed 
check stock, including standard checks, checks with stubs, and voucher checks. To 
print checks with Moneydance you will first need to obtain pre-printed check stock. 
Moneydance will print the date, amount, payee, memo, and optionally the address of
a payee on your checks.  Moneydance cannot print the account and routing number 
on a completely blank check, due to special ink requirements, some banks will also 
use special security paper stock.

You will need to set the appropriate check printing preferences in Moneydance by 
going to Moneydance → Preferences → Check Printing (or File → Preferences → 
Check Printing on Windows or Linux). You use the following screen to set up the 
check stock layout.
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The font and size to be used when printing checks is set on the Printing Tab in the 
Preferences area. The same setting is also used for printing reports.

In respect of the Check Printing preferences the following should be noted:

• Margins relate to the page.

• X and Y settings are from the top left hand corner of each voucher.

Check printing settings are across your entire data file, so are the same for all 
accounts. Hence if you have different check stock for different accounts you would 
either need to change your check printing settings each time you want to print from a
different account, or perhaps set up those accounts in different data files.

To use the check-printing feature, you will need to mark some of your transactions 
as ‘to-be-printed’. This can be done by setting the check number field for the 
transactions to be printed as "{Print}".

In order to print the address of a payee on the paper check you will first need to 
make sure that an address book entry has been associated with the transaction to 
print.  You will also need to select the "Show Address" option for the style of check 
you are printing in the check printing preferences.  If an address book entry has been
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associated with a transaction, the @ symbol will appear next to the payee name in 
the transaction editor, or in the description field in the account register.

When you select the File → Print Checks function, Moneydance will locate any 
transactions with "{Print}" in the check number field, print them onto paper checks, 
and put the number of the paper check into the check number field.  You will have 
the opportunity to select the first check number to use, which checks to print, and 
other options. 

After printing the checks Moneydance will ask you to verify if all checks have printed 
correctly, and give you the option to reprint any that were not.
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Chapter 10: Using Reminders

About Reminders

You can use the Moneydance “Reminder” function to schedule reminder notes or 
transactions in advance.  Click on Reminders in the Moneydance sidebar to open the
Reminder Calendar.

Existing reminders are listed in alphabetical order to the right of the calendar.  All 
reminders are also listed in the calendar on the date(s) they are scheduled to occur.  
Dates in the calendar which have reminders that have not yet been recorded or 
acknowledged are highlighted in yellow.

There are two different types of reminders:

1. General Reminders are text notes that appear in the Calendar and on the 
Summary according to a set schedule.

2. Transaction Reminders are transactions that appear on the calendar and 
Summary according to a set schedule and can be recorded into your register 
directly.  These transactions can be entered automatically or manually.

Note that you cannot create or edit a Reminder for a Loan Account from within 
Reminders you must use the interface that is provided within the Loan Account.  
Loan Account reminders have a very specific setup that is only catered for from 
within the Loan Account.
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Create, Edit, or Delete a Transaction Reminder

First, bring up the Reminder calendar by clicking on Reminders in the Moneydance 
Sidebar (or by going to the Tools → Reminders menu item). To create a new 
reminder click on the appropriate date in the calendar, or on the + (plus) button at 
the bottom right of the page.

The Reminder Description field is for your information, and is used in the reminder 
list to the right of the reminder calendar.

The First Date is the first date the reminder will occur on, the Last Date is the last 
date the reminder will occur and is an optional field.

Reminders can occur one time, or can be Repeated.  Reminder can be applied 
manually or auto-committed. Reminders that are auto-committed will not 
automatically result in an online payment being made, the decision has been made 
that any online payment need to be deliberately initiated using the Send Online 
Payment option within the reminder screen.

Select the appropriate Account by clicking the up/down arrows.  Enter a Description, 
Category (or multiple categories using a split transaction), and Payment/Deposit 
amount.  You may also choose to enter a Check #, Memo, or Tag(s).

To delete a reminder click once on the reminder in the right panel of the reminder 
calendar, then click the – (minus) sign at the bottom right of the page.  To edit a 
reminder double-click on the name of the reminder in the right panel.
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Create, Edit, or Delete a General Reminder

When you select to create a General reminder the following Window is displayed:

General Reminders are text notes, they are designed to remind you of an event, bill, 
or other financial event.  Reminders can occur one time, or can be Repeated.  The 
First Date is the first date the reminder will occur on, the Last Date is the last date 
the reminder will occur and is an optional field.

To delete a reminder click once on the reminder in the right panel of the reminder 
calendar, then click the – (minus) sign at the bottom right of the page.  To edit a 
reminder double-click on the name of the reminder in the right panel.

Repeating Reminders

A repeating reminder offers a number of different date “tabs”.   A reminder will occur 
on all dates you specify in ANY and ALL tabs.

Daily: Repeat the transaction every X number of days.  This can be any number 
from 1 to 100,000.  If you are paid bi-weekly you could set a reminder to repeat 
every 14 days.  If there is a payment which needs to be made every 2 years, you 
could set it to repeat every 730 days.

Weekly: Repeat the transaction on every First, Second, Third, Fourth, Fifth, or Last 
Monday, Tuesday, etc of the Month.  For example, a transaction could be repeated 
on the second and fourth Tuesday and Thursday of the Month.

Monthly: Repeat the transaction on specified days of Every, Every Other, Every 
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Third, Every Fourth, or Every Sixth month.  For example, a transaction could repeat 
on the 1st and 15th day of every third month.

Annually: Repeat the transaction on the same day, once each year.

When creating a Transaction Reminder selecting “Auto-Commit” will enter the 
transaction in the appropriate account register a set number of days before the 
transaction is scheduled.  Selecting “0” in the “Days Before Scheduled” field will 
apply the transaction to your account on the day it is scheduled. If the Auto-Commit 
box is not checked when you create your Transaction Reminder, the transaction will 
not be applied to your register until/unless you manually apply the reminder.

Auto-Committed Reminders When Syncing

When your data is synced automatically it is possible for the reminders to be auto-
committed on multiple computers nearly simultaneously (or at least while one or all 
are offline), this results in duplicate transactions.

An option has been introduced to resolve this. The option can be found under the 
menu item Preferences → Network and is “Auto-commit Reminders (applies to 
current file on this computer)" Tick this box on the primary or secondary computer as
appropriate.

Note that this option ONLY appears if you are syncing to another device. By default 
this option is enabled on the computer that created the data set, and disabled on the 
rest. We recommend enabling this option only on the computer which is the most 
used and most often connected to the Internet.

What this option does is delay auto-committing of reminders until after the first sync 
pass is complete. This is to ensure that a reminder that is auto-committed on this 
computer has not already been auto-committed and synced on another computer.

In some instances you may find that auto reminders are not working until his option 
are selected.

Manually Applying Reminders

Upcoming and overdue reminders appear on the Summary if you have selected this 
module in your Preferences.
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Click on a reminder to choose from the following options:

Skip:  Skips only this instance of a recurring reminder.

Send Online Payment:  Opens the Online Bill Payment interface.  This option is 
only available if you have already set up online bill payment with your bank through 
Moneydance.

Defer:  Performs no action. Leaves the reminder in the overdue or upcoming list.

Record:  Enters the transaction into your register.

Acknowledge:  Removes the current instance of the General Reminder from your 
Summary.

Creating a Transaction Reminder from a Transaction

From a posted transaction you can create a transaction reminder by right clicking on 
the transaction and select the option to Create a Reminder from the Transaction. In 
the reminder setting screen that appears you can change any detail you need to 
before you select OK to create it.

Duplicating a Transaction Reminder

Moneydance does not provide a function to duplicate a transaction reminder, There 
is a method you can use however to create a copy with a minimal amount of effort.

From one of the previous posted transactions generated from the existing reminder 
right click and select the option to Create a Reminder from the Transaction. In the 
reminder setting screen that appears you can review and change any details you 
need to before you select OK to create it.

Recovery from a Skipped Reminder

You may find that you have inadvertently skipped a reminder that you should not 
have. It is not possible to reset a reminder hence other methods need to be used to 
recover.

The simpliest method in most instances is to go back to the last transaction that was 
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committed from this reminder click on the transaction and Select Duplicate, in the 
new entry change the date and any other needed fields and then enter the 
transaction.

The same methodology can be used with loan reminders but you will need to change
the amounts in these.
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Chapter 11: Reconciling Your Accounts

Why Reconcile?

The purpose of reconciling an account is to ensure that neither you nor your bank 
have made a mistake in recording transactions, to identify transactions that are 
missing in your accounts and to identify transactions that may have gone missing, 
e.g. checks that have been written some time ago but never presented to your bank. 
Reconciling accounts in Moneydance is akin to balancing a paper checkbook.

You can choose to reconcile your account manually, or have all transactions which 
you have downloaded/imported from your bank automatically marked as cleared. To 
do this, click File → Preferences → Network, and select “Mark Transactions as 
Cleared When Confirmed”.

Reconciling

To begin, select Reconcile from the Account menu. You will be shown a non-editable
Beginning Statement Balance.  The Beginning Statement Balance on the reconcile 
window is a calculated value, which is:

 Initial Balance of the Account + Cleared Deposits – Cleared Payments.

You will be asked to enter an Ending Statement Balance, usually the balance listed 
on your most recent bank statement, or on your bank’s website.

The "As of" date is only enabled if you download transactions for that account online 
using OFX. If this box is selected, then all transactions that were 
downloaded/imported on or before the date chosen will be marked as reconciling.

You can use the Moneydance Online menu to reset the date of the OFX Last 
Transaction update.
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The Reconcile Accounts window lists all transactions in the account which are not 
Cleared. You can change the order of transactions in this window by clicking on any 
of the column headings (Date, Check#, Description, C, Amount).

Payments are listed in the left-hand column and deposits are listed in the right-hand 
column. Each column shows a Cleared and Uncleared balance, which will change as
you click on transactions to toggle them between Reconciling and Uncleared. The 
Current Balance displays the effects of your reconciling thus far on the Beginning 
Balance, and the difference between Current and Target Balance as Difference.

When performing a reconciliation you will sometimes find that you have missed 
entering a transaction. You may think that you have to click on “Finish Later”, so that 
you can go and create a transaction. If you do this however when you come back to 
resume the reconciliation you have to type in the balance from the statement again, 
as if you are starting the reconciliation from the beginning, this can be annoying.

What is often not realized is that you do not have to stop the reconciliation process to
deal with the missing transaction.

What you do is keep the reconciliation window open, perhaps moving it to a position 
on the screen where you can easily find it again, then click on the main transaction 
window of the account so it gains focus. You then enter the transaction.

Going back to the reconciliation window, the transaction you have just entered will 
appear in the appropriate transaction list in the reconciliation window and you can 
continue with the process.

Once you have marked all the matching transactions from your statement as 
Reconciling and the Current Balance and Target Balance are now the same, you 
have successfully reconciled your account. Any remaining transactions in the 
account should be those that the bank has not received as yet. Click Done to exit the
reconcile window. The transactions marked as “Reconciling” will now be displayed 
as “Cleared” in the account register.  If you select “Finish Later”, transactions which 
are marked as “Reconciling” will display this status in the account register.  Select 
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“Unmark All” to mark all transactions as “Uncleared” and return to the account 
register.

If a transaction in Moneydance does not seem to match with your bank’s records, the
error may be in your entry.  Click on the appropriate transaction and use the Edit 
button to change its value in your account’s register. If you suspect the error is on 
the bank's end, you will need to contact them to have this investigated and rectified.

Beginning Statement Balances do not Match

If you reconciled last month, and this month the beginning statement balance does 
not match the ending statement balance from last month, there are a limited number 
of possible causes.

The possibilities are that you have:

• Modified the amount of a transaction that was already marked as cleared. 
• Deleted a transaction that was already marked as cleared. 
• Manually cleared a transaction in the intervening time. 
• Deleted a category that contained cleared transactions. 
• Deleted an account that had transfers to or from the account you are 

reconciling. 
• Changed the "Initial balance" of the account under Account → Edit Account. 
• Manually marked a cleared transaction as uncleared. 

If you have done anything in this list, it can be quite difficult to track down the cause 
of the change in the cleared balance.

The only way to fix such a problem is to go over the register and your old bank 
statements, to see if you can find anything that has changed. It can be useful to find 
points in the account in the past where they balanced and work forward through 
them until you find a point where it does not balance.

It has been suggested, on occasions, that the Beginning Statement Balance should 
be user changeable, being able to change the balance would however only hide that 
there is an error somewhere in the account. The method that in use will disclose that 
there is a problem with the data in some way.

Some Moneydance customers find it helpful to enter a dummy transaction with a 
zero amount. Then enter a description stating what the cleared balance was on this 
date, as a marker they can refer back to later.

Reconciliation Report

You may be used to generating and keeping or printing a reconciliation report. 
Moneydance does not have a defined report for this however there are a couple of 
ways of creating such a report.

1. In the previous section you can see an image of the reconciliation window. An
approach you could take is to take a screen image of this window just before 
you hit the done button and save or print this.
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This provides a good snapshot of the position in an easy to see way, provided
that all data fits on the screen without any scrolling being required.

2. Another approach you can take is to generate a Transaction Report using 
specific parameters.

Within parameters set:

i. Set the date to range to match the period reconciled.

ii. Tick box for using the Cleared field and then select the boxes for "Cleared"
and "Uncleared" transactions.

iii. Then generate the report.

3. You may notice there is a reconciliation report in Moneydance. This will give 
you a report containing data similar to the reconciliation screen but only if you 
create it before you perform your reconciliation, it cannot do so afterwards.

A reconciliation report is a point in time report, it shows the position at that 
point in time and it is not possible to generate it at a later date as the status of 
transactions will be different to what they were before a reconciliation was 
performed. 

Moneydance reports are not able to determine the date when the status of 
transactions change as this is not information that is tracked within the 
transaction and this, at a minimum, would be required to be able to go back 
and re-generate a reconciliation report as of a specific date.

Reconciliation vs Confirmation

There appears that there may be some confusion at times around the purposes of 
reconciliation and confirmation including around the cleared status of transactions.

The confirmation process is all about downloaded/imported transactions. It is the 
process by which you accept these new transactions into the register, assign 
categories to them and merge them with existing manual entries if applicable. The 
confirmation status is reflected by filled and unfilled circles in the Description column.

Reconciliation is the process by which you check off the transactions in your register 
with your bank statements to identify missing transactions on both sides and to 
check that all entries are valid. This process can also enable you to see what 
transactions are outstanding i.e. have not as yet been presented to you bank. The 
reconciliation status is reflected by various symbols in the column headed with a “C”.

From these two descriptions you may see that there is an amount of crossover in 
that if a downloaded transaction is confirmed into the register then you could say it 
has also been reconciled and should therefore be marked as cleared. Hence 
Moneydance provides the option to “Mark Transactions as Cleared When 
Confirmed” that you can use if desired. Whether to use this option depends on your 
personal workflow.
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Outside of this crossover the two process serve quite different purposes.
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Chapter 12: Budgeting and Forecasting
Moneydance has a number of tools which make it easier to create, customize, and 
track your budget.

Creating a Budget

Open the Budget manager by going to Tools → Budget Manager. and select either a
fixed time interval (weekly, biweekly, monthly, or annually) or mixed intervals for the 
budget style.  Fixed and Mixed Interval budgets are discussed separately in this 
chapter as their operation is different. It is not possible to convert budgets between 
the budget formats.

Fixed Interval (New Format) Budgets

Once you have created your budget you must close the Budget Manager then click 
on the budget name in the sidebar to open the budget for editing.

Budget View

Three columns will be displayed – showing the previous interval, current interval, and
upcoming interval for example, Last month, this month and next month for a budget 
with a monthly time interval.

The center column is the active time period being budgeted for. Within this you will 
see two columns of numbers.

The left number is the amount (either income or expenses) currently in the category.

The right number is the amount you have budgeted for the category. To set the 
amount, click the number on the right and enter the amount that you want to budget 
for that item. The number will be 0 if you have not budgeted anything for that 
category.

The Buttons at the top have the following effect:

All: Displays all categories in your data file.  To add, edit, or delete categories go to 
Tools → Categories.

Budgeted: Displays only categories that you have set budgeted amounts for the 
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current calendar year.

Active: Displays all categories which have been used this calendar year.

Setting Budget Amounts in the New Budget Format

You can easily set your budget based on past spending by right-clicking on the 
heading of a one of the columns and selecting one of the following options:

Copy and rollover previous period: Sets this period’s budget as the sum of last 
period’s budget and the difference between the previous period’s spending and 
budget.  For example, if last period’s grocery budget was $200 and you spent $150, 
this period’s grocery budget would be $250.

Copy previous period: Sets this period’s budget as the last period’s budget.  For 
example, if last period’s grocery budget was $200 this period’s grocery budget would
be $200, regardless of what your spending was in the previous period.

Use actual spending from previous period: Sets this period’s budget as the 
amount spent during the last budgeting period.  For example, if last period’s grocery 
budget was $200 and you spent $150, this period’s grocery budget would be $150.
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To individually edit the amount budgeted for each category click on second zero of 
the “0 of 0” in the budget table.

In this style of budget you specify categories to be budgeted by place a budget 
amount against the category.

Mixed Interval (Old Format) Budgets

After creating your budget, close the Budget Manager window, and select the budget
in the left sidebar to view a Mixed Interval Budget. To edit the budget click on the 
“Edit” button in the upper right hand corner of the screen.

From the Edit Budget window, press the “+” button and enter the appropriate values 
for each column to create the budgeted items.

Amount:  Enter the amount of money you would like to budget for this category.

Category: Click on the drop-down menu to select the category you would like to 
budget for.

Interval: Use the drop-down menu to select the frequency at which your budget will 
repeat. When selecting the interval, you can also choose whether you want the time 
period to be prorated or not.

Start Date: Select the date you would like your budget for this item to begin.

End Date: Select the date you would like your budget for this item to end. If you do 
not enter an end date, the budget will continue indefinitely.

Total Income/Expenses:  Use the drop-down menu to the left of these values to 
specify the time period for which you would like this information to be displayed. 
When you are done editing the budget, close the 'Edit Budget' window. You will see 
your budgeted items displayed in the main window.
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Calculating a Budget

To have Moneydance automatically calculate a budget based on your past spending,
click the Calculate button in the Budget Editor window.
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The “Effective On” field is the date you would like your new budget to begin.  In the 
Date field, select the pre-defined date range for transactions you would like to have 
used in the calculations.  Or you can use the "Custom Date" option and specify the 
date range manually.  The final field allows you to select the range you would like to 
use when calculating this budget- Annually, Tri-Monthly, Bi-Monthly, Monthly, Semi-
Monthly, Tri-Weekly, Bi-Weekly, and Weekly.

Setting Budgeted Amounts Manually

To add a new budget item, press the “+” button and enter the appropriate values for 
each column.  You can print and copy the budget from this screen.

Budget Name: Name your budget.

Calculate: See Calculating a Budget.

Amount: Enter the amount of money you would like to budget for this category.

Category: Click on the drop-down menu to select the category you would like to 
budget for.

Interval:  Use the drop-down menu to select the frequency at which your budget will 
repeat. When selecting the interval, you can also choose whether you want the time 
period to be prorated or not.

Start Date: Select the date you would like your budget for this item to begin.

End Date:  Select the date you would like your budget for this item to end. If you do 
not enter an end date, the budget will continue indefinitely.

Total Income/Expenses: Use the drop-down menu to the left of these values to 
specify the time period for which you would like this information to be displayed.

Note that if you have an expense or income item that has an irregular interval or 
changes amounts throughout the year, you will need to enter individual line items for 
each instance, using the Start Date and Interval fields to define them.  In this case 
you may find it easier to use the new budget format.
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In this style of budget you specifically set the categories that you wish to use in your 
budget.

Budget Status Graph

You can also monitor your budget using the Budget Status Graph. The Budget 
Status Graph provides you a quick overview of your financial status compared to 
your budget, and will adjust automatically each time you record a change in your 
budget or enter a new transaction.

The Budget Status Graph is located at the top of the register.

You can display this feature by selecting View → Show Budget Status.
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Clicking anywhere on the Budget Graph will bring up a chart of your budgeted 
categories.

Clicking on the budget name will let you select a different budget, choose the time 
period to be displayed, or open the budget manager window.

Any striped orange bar in the budget status is a "warning" indicating a problem within
the budget.

If it appears on the expense side, the striped orange line shows one is over their 
budget for the period selected.

If it appears on the income side, the striped orange section shows one has not 
received the income expected for the budgeted period. 

Summary Budget Bars

Budget Bars provide a detailed graphical view of how you are managing your 
budget.  By default, once you have created a budget using Budget Manager, the 
Budget Bars will be automatically displayed on your Summary Page.
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Select the time period you would like to monitor by clicking on the double arrows at 
the top of the Budget Bars.

Hovering over a budget bar will display the percentage of your budget for that 
category that is already spent. Hovering over the budgeted amount for that category 
will show the interval, time period, and budgeted total for that category.  Right click 
on any bar to move it up, down, or delete it from the graph.

Each bar corresponds to a budgeted Category.  The bar itself has several features:

Category Name:  Located directly above the bar on the left.

Budgeted Amount:  Located directly above the bar on the right. This number 
represents the total budgeted amount for the selected time period.

Actual Spending Amount:  Located on the budget bar at the left. This shows the 
current spending in this category for the selected time period.

Color:  The color of the budget bar shows where you stand in relation to your budget
based on a customizable color warning system.

Bar Length:  Current actual spending for the selected time period is represented as 
the horizontal length of the colored area.

Over Budget Limit:  In a budget you have overspent, a vertical line will appear in 
the budget bar to mark 100% of the budgeted amount.
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Customizing the Budget Bars

You can customize the Budget Bars by selecting the time frame, categories and 
order. Click the Settings button above the Budget Bars to set your preferences.

Budget: Select which of your budgets you would like to display.

Categories: Click the Select button to choose which categories you would like to 
display and drag them to the “Included Items” window.

Show full category names: Check this box if you would like to see full category 
names displayed, such as “Bills:Electric” rather than just “Electric.”

Show income bar limit as maximum: Checking this box will track income 
categories as if they were expenses, so that exceeding your income budget will 
display as being “over” the budgeted amount. Leaving the box unchecked will display
the income categories in green.

Under: Categories in which you have spent less than your budgeted amount will 
display in the color selected here. The default color is green.

Warning:  Select the percentage of your budget to be spent before being notified 
that you are nearing your budget limit. You can also modify the default color (yellow) 
for “Warning” categories.

Over: Select the percentage above your budget required for the Bar to turn red. You 
can also modify the default “Over” color.
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Cash Flow Budgeting

Cash Flow budgeting is where you budget for all cash items including loan 
repayments and other selected transfers between accounts. The budgeting in 
Moneydance is about budgeting for variable type expenses, it therefore concentrates
on Categories. You could also refer to it as discretionary budgeting.

A primary issue with cash flow budgeting within software concerns revolving lines of 
credit type accounts, that is accounts like Credit Cards. The problem is that you can 
have an amount that you are paying down, hence would like to budget for this cash 
flow as you would do with a standard loan, yet you could still be using the card for 
everyday expenses that are in other parts of your budget, the issue is how do you 
separate these, within the one account and potentially one transfer to the account 
that covers both but without double counting.

Users have developed various methodologies to extend the exiting budget model to 
provide for a cash flow budgets the following method to create a cash flow budget for
use with loans. It requires an extra entry for each transfer between accounts – like 
for example a mortgage payment which is usually a transfer between a bank account
and the loan account.

The method presented here can be used to budget a variety of transactions, plus it 
minimizes the number of transactions in your register.

Essentially you set up a budget category for each type of transfer that you want to 
include in your budget plus a single contra category to offset the amount. You post 
entries to these for each loan payment you make or transfer you which to budget for,
for example regular planned savings.

This method also keeps the transactions isolated in one set of entries, so it is 
relatively compact, the steps involved are:

1. Create an expense category with a unique name for the transfer or loan 
payment you want to include in your budget.

2. Create another expense category to act as the contra which you will use as 
an offset, you may even name it "Contra" but you can call it anything that 
makes sense to you.

3. Add your new budget category to your budget.

4. Now when you enter the transfer transaction, click on the split option in the 
category field, and add two additional splits. These will be in addition to the 
normal account transfer category which just shows the account receiving the 
funds which will be listed first. In the first extra transaction split just repeat the 
amount of the transfer with the new unique transfer category then in the 
second extra transaction split use the "Contra" category to offset the extra 
amount you added.

Now the transaction will show the transfer that you need and the budget will capture 
the activity from the expense category you added. You can memorize the transaction
with the splits and just set it up as a reminder so you do not have to repeat the 
process. The reason for using two expense categories is that they will offset each 

188



other so that the overall expense are not overstated since the budget categories will 
cancel each other and give a net zero amount is zero within the greater account set.

The transactions will look like:

Foresight

The primary purpose of Foresight is to predict your future spending, as part of this it 
also compares your actual past spending with what was planned. Foresight has two 
modules, these are introduced below.

Forecast

See how much money you'll have in the future.

Review

Keep your spending under control and on track.

Transaction Reminders

Foresight uses transaction reminders to project your future spending and to review 
your past spending.

Transaction Reminders are a feature provided by Moneydance. You set up a 
reminder for each income, expense or transfer transaction that you want to be 
reminded about. They could be for a one-off transaction or for something regular like 
a paycheck or a utility bill. They are very closely related to items that you would 
configure in a Moneydance budget. Every budget item should probably have a 
corresponding transaction reminder.

Budget Items vs Transaction Reminders

Budget items and transaction reminders are very closely related but budget items 
are from a different side of the family. Any item you can add to a budget you can 
represent as a transaction reminder. A reminder contains all the same information 
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but it has extra capabilities that can make them more useful. In fact, the Foresight 
Review functionality, which is based on transaction reminders, can take the place of 
budget items.

Transaction Reminders can Offer Advantages

The advantages that transactions reminders can have include:
• Transaction reminders allow you to specify which account the transaction is 

associated with. This makes it possible to forecast account balances.
• They have a more flexible scheduling feature. For example, maybe you buy 

groceries every 4 days.
• They can be displayed on a calendar or list on the summary page to see the 

exact day the transaction will take place.
• They can be entered automatically into the account register at the right time.

Create Transaction Reminders For Everything

To really get the most out of Foresight, create transaction reminders for everything 
you expect to be coming in, going out or moving between accounts. Everything. 
Even if its a one-off transaction. Even if it varies a little in frequency or amount. The 
closer your transaction reminders represent the reality of your transactions the more 
accurate Foresight’s predictions will be.

To read more about transaction reminders, including how to create them, see the 
section in this manual on Transaction Reminders. 

Forecast

The Forecast shows you when you’ll be able to buy that thing you want to buy.

When you create transaction reminders for all your expected income and expenses, 
the Foresight Forecaster can generate a cash flow forecast showing your account 
balances into the future. For some, this is the most valuable feature that personal 
financial software can provide. The recording of transactions and the managing of 
budgets are necessary functions but the ability to see how your spending affects 
your future is where some of the real value lies.

Getting Started

Create Transaction Reminders

The generated forecast is based on Transaction Reminders and transactions in 
account registers with a future date. Begin by creating Transaction Reminders for 
everything you expect to earn and everything you expect to spend. The more 
accurate they are the better but it doesn’t matter if you have to take a rough guess to
start with and refine the numbers over time.

Configure a Forecast

Open the Forecaster from the Moneydance main menu: Tools -> Foresight Forecast.
Select from the available accounts the ones you want to see a forecast for, choose 
the Future Period and click Calculate.
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Features

Chart View

The chart view gives a visual representation of your account balances over time. 
This is the standard view access via the Foresight Forecast menu item.

Transactions View

This view contains a table of all the transactions that will occur during the selected 
future period.
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Categories View

This view contains a breakdown of your projected income and spending in each 
category, displayed in a tree table that matches the hierarchical structure of your 
categories.

Summary Page Widget

The summary page has provision for two Foresight graphs, these are Foresight and 
Foresight – Reminder Review. To set the display options for these from the 
Moneydance main menu choose File → Preferences…, → Summary Page.

Save Forecast Configurations

You can save any number of configurations to be displayed again later. For example,
you might want to view a forecast for your ‘working’ accounts to make sure you leave
enough in them to pay the bills and then you might want a separate view for your 
savings or investment accounts or maybe a view that shows your net worth.

Account Markers

Some accounts have an amount that is significant in some way. A credit card has a 
maximum credit limit. A savings account may require a minimum balance in order to 
earn interest. The Forecaster allows you to create markers that will be displayed as 
horizontal lines on the chart so that you can easily see if you are going to go over 
your credit limit.

Credit Card Reminders

Transaction Reminders allow you to specify that a transaction of a fixed amount 
occurs on some configured frequency. But if you pay off your whole credit card 
balance each month the payments are seldom the same amount. There’s no way to 
create a Transaction Reminder that can figure out what that amount will be each 
month. But when you tell the Forecaster what your statement date is, what your 
payment date is and which account it gets paid from it can then figure out what your 
payment will be and add a ‘transaction’ into your forecast.

Note: This is only reliable if you pay off the whole statement amount each month. It is
unable to work out the correct amount if you make a partial payment.

Export to CSV

A forecast can be exported and saved as a CSV file on your computer which you can
then load into a spreadsheet program for different types of analysis.

Reminder Summary

This is a table view that lists all the reminders you have configured.

192



Reminder Review

The Reminder Review feature shows you if you are overspending. You can access 
this by Opening the Forecaster Review from the Moneydance main menu: Tools -> 
Foresight Review.

When your budget is setup as transaction reminders, the Reminder Review can 
show you if you’re on budget by comparing your actual spending over a given period 
in the past against your transaction reminders for that period.

You can see the result on a chart like this…

and/or in a table like this...
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Getting Started

Create Transaction Reminders

Create a transaction reminder for everything you spend money on. Everything. You 
can even create a reminder for an expense that only occurs once. For anything that 
doesn’t deserve a reminder of its own, you can create a single ‘miscellaneous’ 
reminder to cover them all.

Configure the Review

Select Categories

Open the settings dialog to select the categories you want to include in the review. 
Select everything to begin with. You can refine later once you become familiar with 
how the review works.

Select a Past Period

You have a lot of options to choose from but I recommend going for one of the 
options that shows you a sliding window, e.g. 12 months ago, 3 months ago. At any 
point in the year it will show you the preceding number of months. This gives a good 
picture of how well you are managing to stay on track. If you select something like 
‘Year to date’, things might look good at the end of January but that could be 
masking a December blowout.

Another Budgeting Option

Moneydance Budgeting provides two ways to do budgeting. Foresight offers a third 
option that offers you a different approach.
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Why Another Option?

Foresight started out with just forecasting functionality. The Reminder Review 
feature was added as a way to verify the accuracy of the forecast. If your reminders 
aren’t in line with your actual spending then you cannot trust the forecast. So the 
review functionality was intended to show where reminders needed to be adjusted. 
But it does an equally good job of showing where your spending needs to be 
adjusted. And that is essentially the purpose of a budget. It shows you where your 
spending needs to be adjusted to keep you on track. So as it turned out, the review 
functionality can perform a similar function to a budget and some may find it 
preferable.

Why it may suit you better

Foresight uses your configured Transaction Reminders to generate a forecast or 
review. Transaction Reminders are similar to budget items that you would set up in a
Moneydance budget. They both indicate an amount, a category and a frequency. But
that is about as far as a budget item can take you. Transaction Reminders can take 
you further.

Given the displays Foresight generates it may give you a more suitable way to 
manage your finances, reasons for this are discussed below.

Categories are Hierarchical

Expense and income categories can be arranged in a tree structure. The Reminder 
Review displays them in this same structure and aggregates totals at each level. 
This is useful if you don’t care too much about where money is being spent in a 
given sub-tree as long as you don’t exceed a total.

For example, you may have a Food category with subcategories of Dining Out and 
Groceries. If you go out to eat more often, you’ll spend less on groceries. You may 
be over budget on one and under budget on the other but as long as they balance 
out it makes no difference.

No Need for Prorated Budget Items

With the mixed interval budget, if you have a budget item that occurs less frequently 
than the budget period you are viewing, you can choose to treat it as a prorated 
amount. Let us say you have an annual expense but you want to view ‘this month’s’ 
budget. If this month happens to be the month that the annual expense occurs then 
it’s going to look like you are way overspending this month. Unless you specify the 
budget item as prorated. But then for 11 months of the year it will look like you are 
under spending a little.

A Transaction Reminder knows exactly which day of the year the expense occurs so 
it doesn’t suffer from that problem.
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Chapter 13: Graphing and Reporting

Graphing and Reporting Overview

The graphing and reporting functions in Moneydance enable you to view your 
financial data in many different ways. Reports are text-based, while graphs are visual
representations of your data.

To create a report or graph, go to Tools → Graphs and Reports. This will display a 
window where you can select the type of report or graph as well as any settings 
(such as start date, end date, accounts, categories, etc). Once you have selected the
graph and entered the settings, click the "Generate" button to display the report or 
graph.  You can also access graphs and reports from the sidebar.

Moneydance cannot print any attachments that you have, the only way of printing 
these is to double click on the preview icon and print using the program that you view
the attachment in.

Graph Types and Uses

The following graphs are available in Moneydance.

Account Balance:  Displays the balance of one account over a certain time period. 
You can choose whether or not to include the balance of sub-accounts in the graph. 
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This graph can display the balance by day, week, month or year.

Asset Allocation:  Displays the division of your assets, including securities, cash, 
and other assets.

Currency History:  Displays the value of a currency or security (including stocks, 
mutual funds, etc.) over time relative to any other currency or security. This graph 
can display the currency or security value grouped by Day, Week, Month or Year.

Expenses: Displays a selection of expense categories over a period of time. You 
can choose to display expenses incurred from all accounts or a subset of accounts.  
This graph can display expenses grouped by different time periods including Day, 
Week, Month or Year, can be filtered by tag, and displayed as either a stacked or 
cumulative graph.  You can also limit the graph to display the Top “x” number of 
expense categories, by spending.

Income: Displays a selection of income categories over a period of time. You can 
choose to display income which passes through all accounts or a subset of 
accounts.  This graph can display income grouped by different time periods including
Day, Week, Month or Year, can be filtered by tag, and displayed as either a stacked 
or cumulative graph.  You can also limit the graph to display the Top “x” number of 
income categories, as sorted by amount of income.

Income and Expenses:  Displays a graph comparing your income and expenses 
over a period of your choosing. You can choose to display income and expenses 
over all accounts or a subset of accounts. This graph can display income and 
expenses grouped by different time periods including Day, Week, Month or Year, 
and can be filtered by tag.

Net Worth:  Displays your net worth over a certain time period in terms of a currency
of your choice.  This graph can be customized to include all accounts or a subset of 
accounts.  This graph can display your net worth grouped by Day, Week, Month or 
Year.

Security Performance: Provides a graph pr prices or value of select securities. The 
graph can be grouped by various time periods.

Memorized Graphs: (Only available using the Tools → Graphs and Reports menu) 
Displays a list of graphs that you have memorized. Selecting a memorized graph 
from the list will let you regenerate that graph, using your current data. Date ranges 
such as "this year" apply to the current year, not to the year in which the graph was 
memorized.

Working with Graphs

Right click (CTRL-click for Mac) anywhere on a Graph will bring up a sub menu 
containing the follow options:

• Properties ...

• Copy

• Save As ...
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• Print ...

• Zoom In

• Zoom Out

• Auto Range 

Most items are self evident.

The Properties options is the one that allows you to change the look of the Graph. 
There is no standard set of options here as what is available will depend on the 
nature of the graph, i.e whether it is a pie chart, a line chart, an area chart etc.

This is the place to investigate when you wish to change the look of a graph.

For example to change the range of the “Y” axis to always start from 0 on a line chart
the process would look like:

1. Click the 'Plot' tab.

2. Click the 'Range Axis' tab.

3. In the 'Other' section, click the 'Range' tab.

4. Untick, the 'Auto-adjust range' checkbox.

5. Set the 'Minimum range value' to 0.

6. Click OK.

The Y-axis should now begin at 0.

Report Types and Uses

The following reports are available in Moneydance.

Account Balances:  Displays your account balances on a specific date in a 
currency of your choosing for a specified set of accounts. Settings include the option 
to display balances for all account types, and the option to also display accounts that
have a zero balance.

Asset Allocation: Displays the division of your assets, including securities, cash, 
and other assets, and can be grouped by time period.

Budget: Displays your budget performance for any given time period. You can also 
choose to include categories not defined in your budget, and/or to include items with 
zero actual and budgeted amounts.

Capital Gains:  Displays a summary of the transactions used to buy and sell 
securities and the gains made on those securities.

Cash Flow:  Displays income earned and expenses incurred for a given time period 
for all or a sub-set of accounts.  This report can be grouped by time period and 
filtered by tag, and displays the total for each account but not transaction details.

Cash Flow, Detailed:  Displays the same information as the Cash Flow report, but 
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includes the transaction details.

Cost Basis:  Displays the cost basis of securities that you currently own. This can 
be compared to the current value of those securities to determine the success of 
those investments. Settings include the option to display the cost basis for all 
securities, for securities under a certain account, or for a specific individual security.

Income and Expenses: Displays a summary of your income and expenses. You 
can specify which income and expense categories to include in the report, as well as
the source accounts.  This report can be filtered by tag, grouped by a time period, 
and can be set to include liability/loan accounts.

Income and Expenses, Detailed:   Similar to the Income and Expense report 
except that it also lists the individual transactions that make up the totals.

Investment Performance:  A snapshot of how your portfolio is performing based on 
returns and annual ROI, over any given period of time, for any accounts and/or 
securities you choose.   Ability to display zero balance accounts.

Investment Transactions: Displays investment transactions, with numerous 
subtotaling options.

Missing Checks:  Displays a list of transactions with numeric check numbers while 
highlighting any gaps between check numbers.

Net Worth:  Displays your net worth using the current balance, including 
transactions with dates in the future, or your cleared balance. You can select which 
types of accounts contribute to the net worth in this report.

Portfolio:  Displays a detailed look of your holdings by account and/or security for 
any given period of time.  Ability to display zero balance accounts.

Reconciliation: Generates a reconciliation report of transactions at a specified date.
Showing uncleared and optionally reconciling transactions.

Security Price History: Report displays prices for one or more securities from 
Moneydance’s price history.

Tag Summary: Displays a summary of all transactions marked with a particular tag. 
A sub-set of accounts can be selected, and the report can be grouped by time 
period.

Transactions:  Displays transactions for one or all accounts for a specified time 
period. Settings include the option to include transactions for sub-accounts, filter 
transactions by tag, display memos, or sub-total the transactions by day, week, 
month, year, account, payee or check number.

Transaction Filter: A highly customizable report.  If the “And (Intersection)” box is 
checked the report will display transactions which meet ALL of the report criteria, if 
the “Or (Union)” box is checked the report will display transactions which meet ANY 
of the report criteria.

Transfers:  Displays the movement of funds between selected accounts, offering 
filtering by tag and grouping by week, month, quarter, or year.
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Transfers, Detailed: Similar to Transfers report, but breakdown displays individual 
transactions instead of just account/category totals.

VAT/GST:  If you use the VAT/GST features in Moneydance, this will display a 
summary of the VAT/GST- applicable expenses and the total VAT/GST paid for a 
given time period. The VAT/GST report can be generated for specific categories or 
for all applicable categories.

Memorized Reports: (Only available using the Tools → Graphs and Reports menu) 
Displays a list of reports that you have memorized (see below for how to memorize a
report). Selecting a memorized report from the list will let you regenerate that report, 
using your current data. Date ranges such as "this year" apply to the current year, 
not to the year in which the report was memorized.

Working with Reports

The reports, as provided, are a template. The majority of the customization that you 
can perform with reports are set through the Parameters screen, accessed via the 
Edit Button at the top of the report window. The parameters that can be changed are 
determined by the report in question, there is not a standard set of parameters 
across all reports.

For example it would not be logical to have “Group By” options for those that report 
on individual transactions. The “Group By” option is restricted to those reports that 
provide totals only.

Other options that can be changed are:

• Font to be used when printed – set via the Preferences menu.

• Width of columns – set by clicking and dragging on the header divider.

• Order of columns – set by dragging the column header to the desired position.

It should be noted that any changes in the order of columns will not be memorized.

At times you may get unusual results with the reports, often this can be attributed to 
previous settings that have been used. It can be a good idea to use the Reset button
before you start developing a report, in order to reset all parameters to their default 
values.

Memorized Graphs and Reports

After generating a graph or report, there will be a "Memorize" button on the window 
displaying the results.  Clicking this button will save the settings that were used to 
generate this graph or report to the list of memorized graphs or reports.

To reproduce a memorized graph or report select the "Memorized Graphs" or 
"Memorized Reports" entry in the Graphs and Reports window and then choose the 
name of the memorized graph or report. Links to memorized graphs and reports are 
also available in the shortcuts section of the Summary, and individual memorized 
reports can be added to the sidebar by clicking the + button at the bottom of the 
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sidebar.

The memorized name will be used as the title of your report.

If you memorize a graph or report with the time period set to something other than 
"Custom Dates," then the time period applies to the date that the report is generated 
as opposed to the date on which it was memorized.

There have been reports of not being able to update memorized reports at times, if 
you should encounter this try the following approach:

1. Open the Memorized report from the left side bar. Click 'Edit'.

2. Set the report's parameters the way you want them. Click OK (to close the 
parameters window).

3. Click Edit → OK (To open and close the parameters window without making 
any changes).

4. Click Memorize → Update.

Exporting Graphs and Reports

After generating a graph or report, there will be a "Save" button on the window 
displaying the results.

Clicking this button on a graph window will allow you to save the graph as an image 
file on your computer.

Clicking this button on a report window will allow you to save the data in the report to
either an HTML (for use in a web browser), tab-delimited or comma-delimited (CSV, 
for use in a spreadsheet) file.

Reports also contain a “Copy to Clipboard” button to more easily transfer data to a 
spreadsheet.

Tax Related Reporting

Both the Income and Expense and the Income and Expense (Detailed) reports can 
be used for tax reporting.  If you have created income and expense categories 
designated as Tax Related and/or created Transaction Tags referencing taxes, you 
can use these as criteria for generating reports.

Once you have marked income and expense categories as Tax Related, you can 
use the “Only Tax Related” filter in the Income and Expense and Detailed Income 
and Expense reports.  This will allow you to produce reports showing all your tax 
related items for any time period you choose.

These two reports also allow you to specify to use the Tax Date as the basis for the 
Date range when generating the report.

Entering Transactions for Reporting Purposes

There are various reasons that the data you may want to include in reports is not in 
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Moneydance, these can include:

1. You are only recording data at a higher level rather than the detail that would 
give the reporting data needed.

2. You own investments like Mutual Funds which pay distributions which are 
recorded but the reporting data comprises multiple discrete items.

With Moneydance offering a great deal of flexibility we have the capability to enter 
transactions that can be used for reporting purposes but being based on accounting 
rules we need to use transactions that meet these rules.

Other sections of this document have details on entering specific types of 
transactions for reporting purposes.

The following sections suggest some more general approaches for recording 
transactions so that they can be reported on, yet not impact the value of the 
accounts.

Entering Transactions in Standard Accounts

You may have an instance where you receive a net payment on a periodic basis but 
you need to report some yearly figures that you only receive in a yearly statement, 
yet the source of these founds is not represented by an account in Moneydance that 
the funds can be drawn on.

The monthly payments you have the details of as you would be recording and 
categorizing these as they come into Moneydance, the ideal is to incorporate all the 
data into Moneydance so that you can produce a comprehensive report from the 
software, rather than taking the data from the Moneydance report and then 
incorporating some more data afterwards, but in many instances you do not have the
monthly data needed to be able to derive a gross total so that you could handle it 
similarly to how you do with salary and wages.

It is possible to achieve the objective we want, we use an element that you use with 
Salary and Wages type transactions plus a very deliberate category set up.

For the purpose of an example assume that we receive an annuity payment on a 
monthly basis, the payment is taxable, we obviously receive the net amount but the 
amount of tax that has been paid is only reported to us in a yearly taxation report.

A suitable category structure would be:

Income

   Annuity

       Received

       Tax Credit

Expense

   Annuity Tax Paid

The indentation shows the Category/sub-category structure. The structure is 
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significant and that will be used in the reporting to generate totals for us. It is best to 
ensured that you use unique category names in all instances, while Moneydance, 
will, for example allow you to use the same name in difference places, it has been 
noted that this can be problematic.

You record the Monthly payments that you receive against the category 
Annuity:Received

You then set up a split transaction to record the tax paid.

For the first transaction in the split you record the Tax paid with the Expense 
category Annuity Tax Paid as a payment. The second transaction in the split you 
again record the tax paid but this time you record it as a deposit against the Income 
category Annuity:Tax Credit. What has been done here is to record the tax payment 
and at the same time show it as a tax credit. Recording the transaction like this does 
not affect the account balance as the over all transaction has a zero value

It it not necessary for this transaction to be in a specific account so it could be placed
in any convenient account as desired, it is suggested that the best place for such a 
transaction would be in the account the annuity is held in.

Entering Transactions in Investment Accounts

Investment accounts function differently to other account types in Moneydance, we 
are able to use a DivXfr action to record transactions for reporting only purposes.

The method used here requires an Income category for the recording of such 
transactions. I’ve created one called Taxation:Investment Reporting.

For the actual recording of the reporting amount you either use existing categories or
create ones as needed.

For example with Mutual Fund distributions the actual income received could be split
across such categories as Interest, Dividends, Rent Received, Foreign Income etc.

The method for reporting of these amounts for reporting purposes is straightforward. 
The significant fields and their values are:

• Action: DivXfr.

• Transfer: Taxation: Investment Reporting.

• Category: the income category for the transaction.

Other fields are completed as necessary.

It may be noted that all the categories used in this example are on the Income side. 
This is a deliberate choice. To return to our example of a mutual fund, you could 
have assigned distributions it to a category like Mutual Fund Distributions and be 
reporting on these, to then include data on specific categories is double counting, by 
having the Taxation:Investment Reporting category as an Income category will offset
the individual items as this amount will be negative and thus preserve the totals.

The examples given are not intended to be exhaustive, but rather as a basis to 
develop the transactions that may be needed, for example, the above examples 
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concentrate on Income items but can be adapted to cover Expense items.

Transaction Printing

There are a number of ways you can print transactions, the method to use is often 
determined by what you need printed:

1. If you want the complete register you can use the menu command File → 
Print Transactions.

2. If you want transactions for a range of dates you can generate and print a 
Transaction Report.

3. If you want transactions based on a more complex criteria you can use the 
Transaction Filter report.
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Chapter 14: Multi-Currency Support 

Cross-Currency Transactions

Moneydance was designed to provide a way to deal with multiple currencies in an 
easy and flexible manner.  By default a new Moneydance data file contains several 
dozen currencies making it easy for you to get started with Moneydance, or simply to
track spending on a trip out of your home country.  In the instance where a 
transaction occurs between an account in one currency and an account or category 
in a different currency, Moneydance will default to the current exchange rate.

Every entry field that accepts an amount can automatically convert amounts based 
on exchange rates. For example, when entering the amount of a transaction in a 
EUR (Euro) account, entering 123 USD in the amount field will automatically convert 
and replace one hundred and twenty three US Dollars with the equivalent amount in 
Euros using the indicator rate held in Moneydance.  If you would like to use a 
different exchange rate, enter the needed information in the “Payment” or “Deposit” 
field. For example suppose your exchange rate is 1 USD buys 0.88 Euro you enter 
this as 123*0.88 and the software will perform the calculation and place the amount 
in the field.

Adding, Editing, or Deleting Currencies

You can even make up your own currencies, as long as the "Currency ID" (the 
standard, three letter identifier for currencies such as USD, GBP or EUR) is unique. 
You might want to make up your own currency if, for example, you would like to track
something other than money (cryptocurrencies, gold bars, or jellybeans) using an 
account in Moneydance.  To automatically update your currency history, install and 
run the Quotes and Exchange Rates Updater extension.

To view and edit the list of currencies in your data file in the menu bar go to Tools → 
Currencies.
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To add a new currency, click the + button.

To delete a currency highlight the currency and click the “–“ button.  You cannot 
delete a currency which is involved in any transactions in your data file.

Double click on a the currency’s name to view the current and historical exchange 
rates.

To change the Base Currency of your account set, highlight the desired currency and
click the “Set Base Currency” button.  While this will change the base currency of 
your file, and the default currency of new accounts or categories your create, it will 
not affect the currencies of existing accounts and/or categories.

From here you can add or remove historical exchange rates, import a set of historical
exchange rates, or clear all exchange rates.  Click the Edit button to change the 
Currency ID, Currency Name, Value Prefix (such as £, €, AU$, etc) of the currency.
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Currencies and Decimal Places

Once a currency has been created the number of decimal places cannot be 
changed.

Clearly the best option is to create the currency with the desired number of decimal 
places before it is used, or if it has already been defined to delete and recreate the 
definition.

When you click on the “+” button in the Edit Currency dialogue, you will be presented
with the following:

The default decimal places is 2 but you can set the desired number.

The Currency ID is the 3 character ISO currency code for the currency 

Using the Search Box as a Currency Calculator

The Search box also functions as a currency calculator.  Simply enter a number 
followed by a currency ID (such as GBP, EUR, USD etc) and the calculator will 
translate it into all other currencies in your data file.  To edit the currencies currently 
in your file go to Tools → Currencies.  Currency exchange rates are only available if 
you have one of the download Extensions installed, or have manually 
entered/imported exchange rates.

209



Importing Exchange Rates into Moneydance

Moneydance can import CSV files containing Exchange Rates if they are in the 
following format:

Date,Close
5/05/2019,1.87624301099478
8/04/2019,1.83604149453778
6/04/2019,1.83452577508714
2/04/2019,1.84362382699434

Note we have a header line but do not have quote marks around any text. We have 
used the comma as the field deliminator as is traditional with CSV files. The decimal 
point has been used in the exchange rates and the slash in dates. The header line is
required. The date format used is MM/DD/YYYY. Each currency must be in a 
separate file.

The structure is simple, however there is one factor that must be remembered and 
that is how Moneydance holds exchange rate data.

In simple terms you generally see exchange rates quoted in the form of:

1 unit of local currency = X units of the foreign currency

So to quote an AUD to GBP exchange rate from an AUD perspective you would 
expect to see:

1 AUD = 0.53298 GBP

However Moneydance holds exchange rate data in the form of

X unit of local currency = 1 units of the foreign currency

So to quote an AUD to GBP exchange rate from an AUD perspective in this format 
you would see:
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1.87624301099478 AUD = 1 GBP

Hence the value you see in the extract given above.

The calculation required to calculate the required rate from what you normally see is 
a simple one, it is:

Close = 1/Rate

Once you have a suitable CSV file to import each currency you have into 
Moneydance you can use the following method.

1. Follow the menu path Tools → Currency to open the Edit 
Currencies/Exchange Rate Window.

2. Double Click on one of the currencies you have rates to load for.

3. Select the IMPORT button in the Currency/Security History window. 

4. Select the ‘Import from File’ option and click on Import.

5. In the Explorer Window select the CSV file to import.

6. Select OK and the data should import.

You need to exit the edit window and renter the screen to see the rates that were 
added.

Repeat steps 1-6 for each currency you need to import.

211



212



Chapter 15: Setting up VAT/GST
A Value Added Tax or a Goods and Service Tax may be used in some countries as 
an indirect form of taxation i.e. not a tax on income. They are often used in place of 
taxes like wholesales taxes and other inefficient forms of taxation. Broad based 
consumption taxes are used also as a way of ensuring that taxation cannot be 
avoided. Different rates are often used on different classes of goods e.g. luxury 
items.

To use VAT/GST in Moneydance you firstly need to  enable VAT/GST support in 
Moneydance’s preferences and then restart Moneydance.

Setting VAT/GST Tax Rates

After restarting Moneydance you will need set the VAT/GST rate for each category.  
You can do this when creating categories, or view and edit all VAT/GST rates 
through the Tools → VAT/GST Settings menu. This will display a table where you 
can enter the tax rates for each category, as well as the category to which the taxes 
will be assigned.

Once a category has been assigned a tax rate and tax category, any new 
transactions that are assigned that category will be split into two parts; the tax part, 
and the normal income/expense part. The tax part of the transaction will be assigned
to the appropriate tax category. This splitting of transactions is subject to the "Apply 
VAT/GST" check box in the transaction editor remaining checked.

If you have a large number of transactions that have not been split you can use the 
Tools → VAT/GST Transactions menu to display all of the transactions to which 
VAT/GST may apply (according to your settings) so that you can quickly set the rate 
or tax amount for each one.  This window will only display VAT/GST transactions for 
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one account at a time, so you will need to repeat the process for each bank account, 
credit card, etc which has VAT spending.

Recording GST Incurred on Capital Items

As it has been seen GST in Moneydance concentrates on categories, in other words 
on expense items. However as the term implies it can apply to all goods and in some
cases these could be capital items, in Moneydance you may be maintaining the 
value of these in an Asset Account hence the purchase may be funded via a transfer
from another account and you would not have an option to record it to a category 
subject to GST.

Based on some elementary testing the following method may give the sort of 
reporting that is required.

Two categories were created, one called GST Paid, the other Asset Purchases. The 
Assets Purchases was set up to be a GST category with tax amounts going to GST 
Paid.

Then a payment from a bank account to the Asset Purchases category was 
recorded.

In an asset account created a deposit was entered drawing on the Assets Purchases
category but ensuring that "Apply GST" was deselected.

From what has been observed it appears the reporting is correct.
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Chapter 16: Customizing and Preferences

Moneydance Summary

When you first open Moneydance you will see the Moneydance Summary in the 
main panel of the Moneydance window.  You can add, delete, and arrange the 
Summary modules by going to Preferences → Summary. You may have the Sidebar
plus zero, one or two other columns. Depending on where you place the modules.

It is only possible to change the width of the sidebar, the other one or two columns 
will adjust to fit the remaining space.

Sidebar

The Moneydance sidebar is located on the left side of the Moneydance program 
window, and can make it easier to see and access information you use frequently.  
Turn off the Side Bar by selecting the “Hide Side Bar” option on the View menu.

By default, all your accounts will appear in the Side Bar.

Click on the Summary button to return to your Summary, or Reminders to see your 
Reminders calendar.

Removing an item (account, category, graph, budget, report, etc) from the sidebar 
DOES NOT delete or affect the functioning of that item.

To add or remove items from the sidebar, click the + button at the bottom, then the 
“Advanced” button.

You can also remove an item from the sidebar by right clicking (or ctrl+clicking on a 
Mac) on the item in the sidebar and selecting “Remove from Sidebar”.

Accounts are grouped by type.

To expand or collapse a group of accounts, click the small arrow to the left of the 
heading.

Open in a new window by double-clicking or ctrl+clicking (or right-click on a 2 button 
mouse).

Re-size by dragging the right edge of the sidebar, or using the “grab-bars” at the 
bottom right of the sidebar.

Within a group accounts are listed in Alphanumeric order, the order is not user 
settable.

Setting What File to Open

The default option in Moneydance is to open the last used data set (file). If you prefer
you can set Moneydance top open to the Welcome Screen where you can then 
select what data set (file) to open.
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To select this take the menu path Window → Welcome to Moneydance and change 
the When Starting option to Open This Window.

Setting Your Preferences

Selecting the Moneydance → Preferences menu (or File → Preferences on Windows
and Linux) brings up the preferences window.  Preferences fall into 6 tabs: General, 
Network, Check Printing, Printing, Backup and Summary.

General

Show Full Account Paths:  Left unchecked the account path “Bills:Electricity” would
appear as "Electricity".

Register Follows Recorded Transactions:  Register will scroll to new transactions 
as they are entered.

Use VAT/GST: Tells Moneydance to automatically split any transactions that have 
associated VAT/GST rates into two categories, one to reflect the purchase cost and 
one for the VAT/GST.  Edit the VAT/GST rates by clicking Tools → VAT/GST 
Settings.

Case Sensitive Auto-Completion: Only match previous transactions that begin with
the exact text that has been typed in the Description field.

Auto-Insert Decimal Point:  When checked, values such as "1234" will be 
interpreted as "12.34", always putting two digits after the decimal point.

Auto-create New Transactions: After entering a transaction a new transaction 
entry window will open.

Separate Tax Date for Transactions:  Allows two dates to be entered for each 
transaction, one for your records and one that can be used for taxes.

Show All Accounts in Pop-up:   If left unchecked, accounts with the “Hide on 
Summary Page (if balance is zero)” option checked and income/expense categories 
will not be in the pop-up list available at upper left the Moneydance window.  Inactive
accounts are never visible in the pop-up.

Beep When Transactions Change:  Makes a cash-register sound when a 
transaction is entered.

Show Selection Details: You can choose between “In main window” or “In separate
popup”. This setting can be useful with selection that resize columns. One noteable 
example of setting this to in a popup is that the Confirmation side bar will hover over 
the register rather than resizing the columns of the register. 

Side Bar Balance Type:  Choose between “Current Balance”, “Balance”,  and 
“Cleared Balance”. See the section on Standard Registers & Transactions in Chapter
5 Standard Accounts for more information on balance options.

Date Format:  Choose between several date formats.

Decimal Character:  Choose decimal or comma.
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Locale:  Select your locale to alter language and spelling.

Fiscal Year Start: Set a fiscal year with a start other than January 1.

Check for Updates: Sets you preference for update checking, options are: Don’t 
check for updates, Stable Updates Only, Preview/Beta Updates.

Appearance

Theme:  Allows you to use one of the built in Themes or to create your own custom 
theme. Refer to the Chapter 17 Appearance.

Font: Sets the font to be used for text in heading, transactions registers etc.

Numeric Font: Set the font to be used for transaction amounts, account balances 
etc.

Printing Font: Sets the font to be used in printed reports.

Font Size:  Select a font size for the Moneydance display.

Network 

The details provided hare are for completeness of this section. More details can be 
found in Chapter 8 Online Banking.

Automatically Download Transactions in Background:  Initiates transaction 
download for all Direct Connect enabled accounts upon program start.

Automatically Merge Downloaded Transactions:  Automatically merges and 
categorizes transactions downloaded through direct connections, or imported from 
your bank's website.

Mark Transactions as Cleared When Confirmed:  Marks transactions as cleared 
when they are confirmed.  Only applies to downloaded and imported transactions, 
and does not apply to transactions in Investment Accounts.

Use Bank Dates for Merged Transactions: When this box is checked and the date 
on a manually entered transaction is different from the date of downloaded 
transaction it is being merged with, the date on the downloaded transaction will be 
used.

Ignore Transaction Types in Favor of Amount Sign: This option determines how 
OFX transaction amounts are to be interpreted.

Proxy Settings: This setting is for those who use a Proxy to connect to the internet. 

Observe Online Payment Date Restrictions:  If checked, Moneydance will re-set 
the date given to initiate a new payment forward by the number of days your bank 
requires for processing.

Only match downloaded transactions when they are at most X days apart: If 
checked, the program will only offer matches which have dates in the stated range.

Auto-commit Reminders (applies to the current file on this computer): This 
option only applies if you are syncing between systems.
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This option delays auto-committing of reminders until after the first syncing pass has 
completed. This is to ensure that a reminder that is auto-committed on this computer 
has not already been auto-committed and synced on another computer.

By default this option is enabled on the computer that created the data set, and 
disabled on the rest. We recommend enabling this option only on the computer 
which is the most used and most often connected to the Internet.

Check Printing

Customize check type and format.  This setting is data file specific, so if you have 
two different types of checks you will need to re-set these options each time you 
change check type.  If you want to print addresses or memo fields on checks, you 
must check theses boxes. For more details on setting your preferences see the 
section of this guide on “Check Printing”.

Backups

This screen provides the settings for the automatic backups, see the section on 
Backups for more details.

Summary Page

The Moneydance Summary is divided into a left and right column. The "Available 
Items" box shows which additional information can be added to your Summary. 
Below this are two boxes showing the information displayed on the right and left 
sides of your Summary.  It’s also possible to place items in only one column to have 
a Summary with a single (wider) column or where two columns would be too wide for
your display.
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Encrypting Your Data

All Moneydance data is encrypted by default. With the default encryption the data 
can be read by Moneydance without further involvement, but not by other 
applications or by looking at the contents of the files. For further protection 
Moneydance can encrypt the data using as password of your choosing. To encrypt 
your data file using such a password, click File → Passwords.  If you would like 
Moneydance to remember your online banking passwords, select the “Store Online 
Passwords in File” option.
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After enabling this, you will need to enter your login credentials once more before 
they are stored.

If you lose or forget your password we cannot retrieve your data.  Choose your 
password and hint carefully.

It is necessary to have a user defined password if you want Moneydance to 
remember online banking passwords.
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Chapter 17: Appearance
Many diverse factors comes into appearance, things like the layout of the summary 
page what widgets to include, one versus two rows in registers and many other items
are involved.

This chapter is going to principally concentrate on two factors; Fonts and Themes. 
These two affect the overall appearance of the whole program rather that specific 
areas of the program, hence are core to the overall look and feel.

Screen Fonts

Moneydance uses a variety of fonts and font sizes.  The software allows you to 
change the core fonts used in the program.

There are two font parameters that are used in the screen display of fonts:

• main_font

• mono_font

The main_font is used for all general text, so for example register text, headings etc. 
The mono_font is used for general numbers like amounts and balances.

On each platform Moneydance has a default font that will be used if none is 
specified.

While conceivably any font could be chosen for each parameter, practical selections 
need to be made e.g, you should not chose something like Wingdings.

For the main font the following should be taken into consideration:

• You can choose either proportional or fix pitched spaced fonts.

• Readability should be a major consideration, and could be influenced by 
display size, screen resolution etc.

• How much data you want displayed, for example a proportional font is likely to
accommodate having more text displayed.

• Display issues may lead to the selection of a specific font for example it has 
been noted there may be some clipping with certain system configurations 
and certain fonts.

For the mono font many of the considerations given above also apply, but in 
addition:

• No matter what font is used it is beneficial that this uses fix pitch for the 
numerics at least. This ensures that when you have a column of numbers they
all align.

For total consistency it can be desirable to choose a font that uses proportional 
spacing for letters but fix pitch for numbers, so the same font is used for both.

Some Sans Serif examples of these include:
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• Tahoma

• Verdana

• Calibri

• Segoe UI

• Deja Vu Sans

In testing it has been noted that at the same size setting the size of the characters 
are different and this can affect readability Tahoma appears to be one of the 
“smaller” more condensed fonts while Verdana and Deja Vu Sans appear “larger”.

In terms of serif fonts, examples of those that have been shown to have proportional 
characters but fix pitched numbers include:

• Cambria

This testing has been undertaken using Windows hence the basic selection of the 
samples although Deja Vu Sans is included with LibreOffice hence is freely available
on all platforms.

Carlito is a LibreOffice font metrically compatible with Calibri while Caladea is a 
LibreOffice font metrically compatible with Cambria.

On a test system Sans Serif fonts seemed to be more readable than Serif.

It is not possible to change the size of the fonts used individually, you can change 
the base font size in the program by changing the default font size preference. As 
Moneydance uses a variety of font sizes in the program, the size selected 
determines the base as indicated with all fonts being sized relative to the base. This 
is why in preferences you do not specifically specify a point size, rather it is a size 
relative to the default base that is to be used for the base.

The following table shows the resultant size of fonts used when “Default” is selected 
as the font side preference.

Font Usage Size

default 12.0

Default text 12.0

Default title 14.0

mono 12.0

coding 12.0

header 14.0

register 11.0

Report Title 32.0
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calendarTitle 11.0

Report Header 10.0

Detail Title 14.0

Changing the Screen Fonts in Moneydance

Changing screen fonts is done via the preferences options accessed through the 
menu item File → Preferences on the Appearance tab. The appearance table looks 
like:

The specific fields we are interested in are Font and Numeric Font

The Font item sets the font to be used for text in heading, transactions registers etc 
while Numeric Font sets the font to be used for transaction amounts, account 
balances etc.

Due to differences in fonts you may need to use the combination of font and size to 
achieve the desired result, as outlined fonts do have visual differences at the same 
apparent size. The font and size to be selected is also likely to be affected by the 
screen size and resolution and naturally personal preference will play a key role.
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Screen Resolution

As stated in the last section the screen size and resolution can lead you to use a 
specific font that works with your configuration.

With resolutions like 4K that is now being seen, even in notebook computers, on 
relatively small screens this can cause Moneydance to remain difficult to read even 
when the font size has been dramatically increased.

We can use a technique available in Java to scale Moneydance’s display.

This can be done by editing the Moneydance.vmoptions file which is installed in 
the same folder as the Moneydance executable, which on Linux is in the folder 
/opt/Moneydance by default, On Windows it is located, again by default, in c:\
Program Files\Moneydance\. At this time it is not known if this can be used on 
MacOS.

To change the scaling, open Moneydance.vmoptions with a text editor and add 
the following two lines to the bottom of the file:

-Dsun.java2d.uiScale=2
-Dsun.java2d.uiScale.enabled=true

After adding those lines, save the file and restart Moneydance. Please note that at 
this time, non-integer scales (for example, 1.2) are not supported.

Themes

Moneydance allows you to choose from multiple color schemes or to create your 
own to customize the look of Moneydance, in Moneydance these are referred to as 
Themes.

Included Themes

Navigate within Moneydance to File → Preferences (or Moneydance menu on a 
Mac).

The preferences window will open on the Appearance tab. You should select 
"Theme" to view the drop down list.
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You can select from the following theme options:

• Default (Light Mode)

• Flat Dark

• High Contrast

• Classic

• Solarized Light

• Solarized Dark

Selecting 'OK' to close the preferences window will apply any theme changes.

For people who find that the text in the default theme too pale or lacking in contrast it
is suggested that you initially try the High Contrast and/or Classic Themes to see if 
these work any better for you. In some cases a slight increase in the font size has 
been found to enhance readability on some systems.

As well as choosing from one of the provided themes Moneydance also allows you 
to customize the chosen theme or to create your own custom theme. This is with the 
exception of Flat Dark which is a fixed theme, if you wish to customize a dark theme 
it is suggested you start with Solarized Dark.

Customizing Themes

Selecting the 'Customize...' button, to the right of the theme options will allow you to 
set custom colors for your backgrounds, text, icons etc.
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The first screen allows you to select the element:

The second screen allows you to select how the element should look.
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When you customize a theme the details are stored in the file located in 
your .moneydance directory called custom_theme.properties

A custom theme does not need to record all color elements, if a color element is 
missing in a custom theme then Moneydance will use the color specified in the 
Default (Light Mode) Theme for that element.

Theme Elements

The following is a chart of the custom colors, with the known elements given:

Element Short Name Additional Information

Default Background defaultBackground Default Background Color

Default Foreground defaultTextForeground Default text color

Secondary Text Color: 
subtitles, descriptive 
text, summary section 
titles

secondaryTextFG Secondary text color e.g. 
- Subtitles
- descriptive text 
- Headings for sections on 
Summary Page

Tertiary Text Color, 
subtitles dimmed text

tertiaryTextFG Tertiary text Color e.g. 
- Subtitles
- Dimmed Text
- “No Overdue reminder” text 
- Past calendar Events

Background of register 
transactions

registerBG1 Background color of the first 
line of the register 

Background of alternat-
ing register rows 

registerBG2 Background color of the sec-
ond line of the register 

Register selected row 
background 

registerSelectedBG Selected field/record back-
ground color
Text Field Cursor color

Register selected unfo-
cused row

registerUnfocusedSelectedBG Selected field/record back-
ground color when it does not 
have focus

Register selected row 
foreground 

registerSelectedFG Selected field/record text color

Downloaded transaction
indicator

registerUnconfirmedIconFG Color of circle that indicates 
an unconfirmed downloaded 
transactions

Register foreground 
text

registerTextFG Color of text of transactions in
the registers

Lists and tables back-
ground

listBackground

Color of list Selection 
background

listSelectionBG

Register grid lines registerGrid Color of Separator lines in reg-
isters e.g. column border line 
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color

Future transaction 
background

futureTxnBG Background color of 1st line of
upcoming transaction

Future transaction al-
ternating background 

futureTxn2BG Background color of 2nd line 
of upcoming transaction

Future transaction flag 
Indicator 

futureTxnIndicator Color of: 
- Bar in date field that indi-
cates a future transaction
- Highlighted border around 
today's date in the reminder 
calendar.

Main header/toolbar 
background

headerBG Background color of: 
- main header 
- register header

Internal line separator 
in reminders view

reminderHomeInnerLine

Heads up/X-ray view 
background

hudBG Color of background of a 
transaction in heads up mode

Heads up/X-ray view 
border 

hudBorderColor Color of the border that ap-
pears around a transaction in 
an account register when in 
heads up mode. If the register
is in single line mode the hid-
den second line appears

Heads up/X-ray text hudFG Color of text of a transaction 
when in heads up mode

Filter bar background filterBarBtnBG Background color of the filter 
bar in the register

Filter button back-
ground

filterBarBtnBG Background color of unse-
lected filter buttons

Filter button selected 
background

filterBarSelBG Background color of selected 
filter buttons

Filter button text filterBarFG Text color of unselected filter 
buttons

Filter button selected 
text

filterBarSelFG Text color of selected filter 
button

Filter button shadow filterBarShadow

Header background 
gradient 1

headerBG1 Background color of 1st header
line in reports

Header background 
gradient 2

headerBG2 Background color of 2nd header
line in reports

graph background gra-
dient 1

graphBG1 Line graph upper background 
color

graph background gra-
dient 2

graphBG2 Line graph lower background 
color

Scroll bar color scrollThumb
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Text Color for header 
items incl graph in 
header

headerFG

Color of main divider eg
on summary page

mainDivider Color of main divider eg 
- Main divider color on sum-
mary page

Text color of positive 
balances in summary 
and registers

positiveBalFG Text color of positive balances 
in summary and registers

Text color of negative 
balances in summary 
and registers

negativeBalFG Text color of negative bal-
ances in summary and regis-
ters

Sidebar negative bal-
ance

sidebarNegativeBalanceFG Text color of positive balances 
in sidebar

Sidebar positive bal-
ance

sidebarPositiveBalanceFG Text color of negative bal-
ances in sidebar

Icon color for income 
categories

incomeIconTint Budget income item icon color

Icon color for expense 
categories

expenseIconTint Budget expense item icon 
color

Summary view back-
ground

homePageBG

Summary view fore-
ground

homePageFG Home Page foreground color

Dashboard foreground dashboardFG Dashboard foreground color

Summary view alterna-
tive rows background

homePageAltBG - Color of background of alter-
nate lines on homepage for 
windows that support them in-
cluding reminder window, 
stock price Window.
- Color of Sat/Sun background
in Calendar

Calendar future event 
background

calEventBG Background color of future 
calendar events

Calendar overdue event
background

calPastEventBG Background color of overdue 
calendar events

Hud background 1 hudBG1

Hud background 2 hudBG2

Selected Row Gradient 
color 1

selectedRowGradient1 Color 1 for selected row Gradi-
ent

Selected Row Gradient 
color 2

selectedRowGradient2 Color 2 for selected row Gradi-
ent

Color selected Row un-
focused Gradient 1

selectedRowUFGradient1 Color 1 for selected row unfo-
cused Gradient

Color of selected Row 
unfocused Gradient 2

selectedRowUFGradient2 Color 2 for selected row unfo-
cused Gradient
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Table header back-
ground

tableHeaderBG

Popup window back-
ground

popoverBG

Popup window 
triangle/pointer

popoverTriangleBG

Popup window border popoverBorder

Main Panel Border Color mainPanelBorderColor Color for main Panel Border

Budget Healthy Color budgetHealthyColor Budget test/bar color for 
healthy amount

Budget Acceptable 
Color

budgetAcceptableColor Budget test/bar color for ac-
ceptable amount

Budget Alert Color budgetAlertColor Budget test/bar color for alert 
amount

Budget Graph Warning budgetGraphWarning

Error Message Fore-
ground

errorMessageForeground

Color of error Panel 
Background color

errorPanelBG Background color of warning 
panel on summary page

Color of error Panel 
Foreground color

errorPanelFG Foreground color of warning 
panel on summary page

Color to be used for 
text when report calls 
for “Blue”

reportBlueFG

Color to be used for 
text when report calls 
for “Red”

reportRedFG

Sidebar background sidebarBackground Sidebar background color

Sidebar selected item 
text

sidebarSelectedFG Sidebar selected item text 
color

Sidebar secondary text sidebarSecondaryTextFG Sidebar secondary text color

Sidebar selected item 
background

sidebarSelectedBG Sidebar selected item back-
ground color

Sidebar selected unfo-
cused item background

sidebarUFSelectedBG Sidebar selected item text 
color when focus is off sidebar

Text color for sidebar 
headers

sidebarHeader Color of headings in sidebar

Color of the summary 
icon

homeIconTint Color of home/summary icons 
in sidebar

Color of the graph icons graphIconTint Color of graphs icons in side-
bar

Color of the account 
icons

accountIconTint Color of account icons in side-
bar

Color of reminder Icon remindersIconTint Color of reminder icon in side-
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bar

Color of the report 
icons

reportIconTint Color of report icons in sidebar

Color of the budget 
icons

budgetIconTint Color of budget icons in side-
bar

Graph data set 1 graphData1 General graphs line 1/slice 1 
color Color of volume data in 
Securities detail graph.

Graph data set 2 graphData2 General graphs line 2/slice 2 
color
Color of plot line in Securities 
detail graph.

Graph data set 3 graphData3 General graphs line 3/slice 3 
color
Color for the "Buy Shares” 
marker in securities detail 
graph.

Graph data set 4 graphData4 General graphs line 4/slice 4 
color
Color for the "Sell Shares" 
marker in securities detail 
graph. 

Graph data set 5 graphData5 General graphs line 5/slice 5 
color

Graph data set 6 graphData6 General graphs line 6/slice 6 
color

Graph data set 7 graphData7 General graphs line 7/slice 7 
color

Graph data set 8 graphData8 General graphs line 8/slice 8 
color

Graph data set 9 graphData9 General graphs line 9/slice 9 
color

Graph data set 10 graphData10 General graphs line 10/slice 
10 color

Graph data set 11 graphData11 General graphs line 11/slice 
11 color

Graph data set 12 graphData12 General graphs line 12/slice 
12 color

Graph data set 13 graphData13 General graphs line 13/slice 
13 color

Graph data set 14 graphData14 General graphs line 14/slice 
14 color

Graph data set 15 graphData15 General graphs line 15/slice 
15 color

Graph data set 16 graphData16 General graphs line 16/slice 
16 color
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Graph data set 17 graphData17 General graphs line 17/slice 
17 color

Graph data set 18 graphData18 General graphs line 18/slice 
18 color

Graph data set 19 graphData19 General graphs line 19/slice 
19 color

Graph data set 20 graphData20 General graphs line 20/slice 
20 color

Graph data set 21 graphData21 General graphs line 21/slice 
21 color

Graph data set 22 graphData22 General graphs line 22/slice 
22 color

Graph data set 23 graphData23 General graphs line 23/slice 
23 color

The short name is what is used in the custom_theme.properties file. Each short 
name is preceded by the indicator “color.” in the file.

Custom Colors File

There is nothing notable about the customer color file it is just a simple text file that 
contains named elements and the assigned color for that element. There are no set 
entries that must be in the file, if an entry is not present it simply means that the 
default color is used.
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Chapter 18: Extensions and Python Scripts
Please note – If you purchased Moneydance through the Mac App Store you will 
need to manually download extensions from the Moneydance website and import 
them into Moneydance.

Individual extensions are generally not discussed in this manual unless they have a 
direct relevant to the task that is being performed.

Extension Location

Moneydance will store all installed extensions in a specific location. The location for 
your extensions varies depending on your operating system, and are listed below.

System Location

Mac:
 macOS:
  Big Sur and 
  Monterey 

/Users/<username>/Library/Containers/Moneydance/Data/
Library/Application Support/Moneydance/fmodules 

Mac: 
 OS X & macOS: 
  Lion through 
  Catalina

/Users/<username>
/Library/Containers/com.infinitekind.MoneydanceOSX
/Data/Library/Application Support/Moneydance/fmodules 

Mac:
 OS X: 
  Snow Leopard
  and earlier

/Users/<username>/Library/Application Support/Moneydance/ 
fmodules

Windows:
  Vista and later

C:\Users\<username>\.moneydance\fmodules

Windows:
  Pre Vista

C:\Documents and Settings\<username>\.moneydance\
fmodules

Linux /home/<username>/.moneydance/fmodules
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Adding, Deleting, and Updating Extensions

To add, delete, or update an extension, go to the menu bar and select Extensions →
Manage Extensions.  For Moneydance hosted extensions find the desired extension 
in the list and click either Install, Delete, or Update as desired.

To add an extension from a file, click the “Add from File” button in the bottom left-
hand corner of the dialogue box.  See the “Externally Available Extensions” section 
below for more on installing extensions manually.
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Moneydance Approved Extensions

An up-to-date list of Moneydance approved extensions is available online at 
http://infinitekind.com/extensions. A small number of Extensions are referred to in 
this document, they are listed here along with their purpose:

• Find and Replace

This extension is the primary way to work en mass with Tags. It can also be 
used when restructuring data.

• Quotes and Exchange Rates Updater

This extension provides a basic tool to automatically update Share Prices and
Exchange Rates.

• Toolbox

Toolbox contains a range of informational, diagnostics and repair tools.

This list does not mean that the other available extensions are not good, just that 
they are not referred to in these pages.

Externally Available Extensions

There are a number of Third-Party extensions developed for Moneydance which are 
available online.  Many of these extensions are wonderful tools, but they have not 
been examined by the Moneydance developers for safety or security.  Use caution 
and your own judgment when using these tools.  If you are a developer who would 
like your extension approved and “signed”, or considered for inclusion in 
Moneydance's extension menu, please contact us.

If you install an extension that have not been signed by The Infinite Kind, a warning 
message will be displayed to alert you to the fact that an unsigned extension is being
installed and it is not known if it is safe or not, the software is not performing any 
analysis on the contents of the extension. The banner will look something like what is
shown below.

If you proceed and install the extension you will see a warning banner at the top of 
the Moneydance display, the banner looks like:
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Note that the red banner warning on the summary page only displays one unsigned 
extension, you could have installed many, but only one is displayed. Again, the 
warning only tells you that the extension is unsigned not if it is really unsafe.

You have the option to acknowledge your use of the extension and to ignore that it is
unsigned, to do this click on the Ignore button.

This warning will occur with any extension that has not been submitted to The Infinite
Kind for signing. If you develop your own extensions and just wish to use them 
yourself you are unlikely to have them signed so this process will remove the 
warning banner for you.

Some extensions have limited distribution and are also unlikely to be signed.

In all cases when using unsigned extensions it is up to you, the user, to determine if 
they are safe to use.

Running Python Scripts

You may want or need to run Python scripts, to do so start the Moneybot Console via
the menu command: Window → Show MoneyBot Console. The console should look 
similar to:

Choose the Open Script option then navigate to the script and select it. Once loaded 
choose the Run option to execute the script.
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Chapter 19: Syncing With Other Computers
Moneydance allows you to sync your files seamlessly and efficiently across 
computers and mobile devices using our fully encrypted incremental syncing engine. 
Moneydance uses a shared folder (such as Dropbox) to quickly sync your financial 
data conflict-free, using end-to-end encryption to maintain your privacy.

The core system for syncing must be running Windows, macOS or Linux operating 
system and will be the system you use the initiate the Syncing setup.

Overview

With earlier versions of Moneydance the only way to share information was to place 
the Data Set in a shared location and for each user to use this location. This method 
did have a significant limitations, users could not simultaneously make use of the 
data, to do so places the data at the risk of corruption. Personal computing systems 
do not provide a ready way of preventing such use and certainly no way of allowing 
files to be simultaneously used.

Moneydance has implemented an architecture that does allow for the simultaneous 
use of the data.

To prevent the problem that having shared files creates each user has their own 
personal copy of the data that is stored locally, as you add, delete or change data 
Moneydance creates small incremental files within your own personal store, these 
files may contain one or more updates. Small incremental files make it quicker, 
easier and more efficient to pass the data updates between systems.

Moneydance makes use of a shared location where data can be exchanged, like a 
central post office, periodically Moneydance on each machine will check this location
(approximately every 30 seconds), if you have made updates that are not there they 
are copied to it. If there are updates there that you do not have they are copied to 
your own personal store. The update files contain the data and the information 
necessary so that the transactions can be applied in the correct order.

Once you have new updates in your local store Moneydance reads these and 
applies them to the local data thus bringing your machine up to date. This will occur 
periodically during your Moneydance session for the Data Set that you have open.

When you start Moneydance any of the transaction files that have not been 
incorporated into the core trunk file will be incorporated.

Systems participating in syncing fall into one of three categories:

• Master

• Secondary

• Mobile

Master and secondary systems are devices running Windows, macOS or Linux, the 
next section details the functionality differences between Master and Secondary 
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systems. Mobile devices are those running IOS or Android, these systems only allow
for on the go data entry of transactions into standard banking type accounts.

Master vs Secondary Systems

Moneydance has the concept of master and secondary machines, The system that 
initiates the syncing always remains the master (The master cannot be a mobile 
device), there is only one master system. This is the machine that determines the 
type of syncing used, it is the only one that syncing can be disabled on and syncing 
method changed.

All other systems are secondary systems. In most respects there is little difference 
between the master and a secondary system.

It is possible to convert a secondary to a master but it is necessary to reset that data 
set on that machine to be a standalone system and that requires extra work and a 
maintenance tool to be used, it is not a routine event.

Core Syncing Setup

You should make sure you are running the same version and build of Moneydance 
on all computer systems participating in the solution before you start. You can check 
the version and build number by navigating to Help → About Moneydance (or 
Moneydance menu → About Moneydance on a Mac).

It is very important that you ensure the data files you would like to sync are 
not already located in any shared folder (like Dropbox, a Network Share, etc) 
before syncing is setup. We strongly recommend that your main data files (the 
folders underneath the .moneydance/documents folder) are stored locally in any 
case. With newer versions of Moneydance, you will be prompted to move the file to 
your local system, if Moneydance detects the file is in a shared location.

NOTE: We recommend that you do not rely on the syncing data for your back ups. 
That is not the intention for this data and there are significant limitations if it is used 
like this.

We always recommend backing up your main desktop data set regularly using 
whatever backup method you use to protect your important information. Automatic 
Moneydance data backups can be enabled within Preferences → Backups, and 
manual backups can be created using File → Export Backup.

Open Moneydance to view the file you would like to sync, then navigate to File → 
Syncing. There are four possible syncing options:

Dropbox Folder – Sync using the Dropbox folder on this computer. This will allow 
Moneydance to process synced data even if you are not connected to the Internet at 
the time, as a copy is maintained under the Dropbox folder. With this method the 
Dropbox client is responsible for syncing of the data between the Dropbox server 
and the local computer, hence syncing can occur whether or not Moneydance is 
running. The user of Dropbox folder method does consume a Dropbox Client 
Connection license. 
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This method will only appear if the Dropbox Client has been installed and the 
Dropbox folder is in the standard location, If a custom location has been selected for 
the Dropbox Folder, then you can use the Shared folder method to make use of 
Dropbox.

Dropbox Connection – Sync by using the Dropbox API to manage the 
synchronizing of data between the local computer and your account on the Dropbox 
server. Moneydance will communicate with the Dropbox service directly if you 
authorize it to access your files. With this method Moneydance is responsible for the 
syncing of data between your machine and the Dropbox server. If you use 
Moneydance while you are offline the syncing of data will occur when you are next 
online and with the specific Moneydance data set open. The use of the Dropbox 
Connection method does not consume a Dropbox Client Connection license.

Shared Folder – Sync using a folder that you specify that is shared across 
computers. This option requires you to have read/write access to the shared folder. 
Moneydance assumes responsibility for keeping the local data in sync with the 
shared folder, hence syncing will only occur when Moneydance is running and the 
specific data set open.

iCloud – Sync using an iCloud folder. This method uses an iCloud folder for the 
shared location, only macOS systems are supported with this method, and this 
method will only be shown on a suitable system, there is also currently no mobile 
support with this method.

NOTE: If you also wish to share your data with the mobile app, you will need to 
ensure you select either Dropbox Folder or Dropbox Connection as the sync 
method.

You must choose Dropbox Connection if you purchased Moneydance from the 
Apple App Store.

You will then be prompted to create a Syncing Password if you have not already.

The Syncing password should be a unique password and something you should 
choose. It is not your Dropbox account password, nor should it be the same as your 
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local Moneydance password or the same as any other passwords for your own 
security. The Syncing Password is used to encrypt the data that is being passed 
between the systems sharing the data.

Moneydance will make a copy of the data in the service that you have specified.        
To ensure that Moneydance data is isolated a folder named .moneydancesync is 
created on the service, within this folder a sub folder will be created for each data set
that you are syncing, each of these folders will have a unique name called a UUID. 
This name is the unique name that links the data for all systems in the relationship. 
The V3 sub folder contains the Transaction files that are being passed between 
systems.

Within the .moneydancesync folder structure the tiksync_info.txt file contains the 
information which is used to distinguish files from each other when using File → New
→ Open Synced File to choose which synced file to open.

Non-Default Dropbox Client Setup

The Standard Dropbox Folder options works when the Dropbox folder in the default 
location, in other words Moneydance checks for a Dropbox folder in this location and
if it exists displays Dropbox Folder as one of the options.

Some users will want to place this folder in a different location, perhaps on a second 
disk drive. In this case you may find that you do not get a Dropbox Folder option 
when trying to set up syncing.

To facilitate this configuration, when setting up syncing choose the Shared Folder 
option and navigate to your Dropbox Folder.

Set up on Subsequent Computer Systems

On other computer systems you should open Moneydance and navigate to File → 
New (or 'Create New Account Set' from the Welcome to Moneydance window).
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Then select "Open Synced File" and proceed to select the same sync method as 
selected on the core system. You will then be given a screen where you select the 
location of data sets that can be synced, if you see a list of folders with alphanumeric
names you have gone one level too far down the folder tree, what you are seeing are
the actual data sets, you need to select the folder of the level above, i.e. the folder 
that the data set(s) are in, the reason you need to select this level is because there 
are files in this folder that provide Moneydance with the details of the data sets that 
exist in the folder, these files act like a Table of Contents fr Moneydance, once you 
have done this you will be presented with a list of available data sets for you to select
from, select the data set you would like to sync. Enter the same encryption 
passphrase that you used on the primary to set up syncing on this computer when 
prompted in order to start syncing.

It may take some time for the file to initially sync after completing the last step of the 
sync setup process. The time taken is dependent on factors such as network 
performance, size of the data, number of transaction files to be copied, number and 
size of attachments. Please wait for the syncing to complete and do not close or 
force quit the program.

You should note the following in respect of syncing:

1. When you share the data between systems – any Master Password on the 
original system will not be transferred. The password that you set to open 
data, is a local password just for the specific computer or mobile device. 
These passwords cannot be transferred as it is a matter of local security on 
each system. You will need to setup passwords for each system you are 
syncing with.

2. The preference settings also will not be transferred to your new system – this 
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is by design, preferences are considered to be a local setting. Each user will 
need to configure the preferences on the systems they are using to suit 
themselves. You may wish to refer to the 'Preferences' section for more 
information.

A simple reason that demonstrates the approach is a husband and wife share
a data file. Each wants their own preferences related to theme, font size etc. If
the original preferences were synced, the second system would have its 
preferences overwritten by the first, so the second user could not have their 
own personalized settings. Items like the best font size to use can also for 
example be dependent on the screen resolution of each system.

3. The Syncing Pass Phrase (password) must be the same across all systems.

4. Application Based Banking (Direct Connect) Usernames and Passwords are 
not transferred between systems. This is consistent with the Master Password
not being transferred as the use of master passwords is a requirement for the 
storage of Direct Connect passwords.

Set up of the Moneydance Mobile App

The Moneydance mobile app is available for IOS (iPhone, iPad, iPod Touch) and 
Android systems. The use of the Moneydance Mobile app does not consume a 
Dropbox Client Connection license.

The Moneydance mobile app is a free companion to the desktop version of 
Moneydance, and is meant to allow entry and modification of transactions while on 
the go. Accounts, categories and recent transactions are synced to your mobile 
device and transactions entered or modified on your mobile device are synced to 
your data file. The app protects your information using industrial-strength encryption 
(128-bit AES).  You can also secure the app on your mobile device with a 4 digit PIN,
by enabling 'Use Passcode' within the mobile app settings.

The mobile app offers remote syncing via Dropbox.  Syncing via Dropbox allows you 
to sync all of your devices remotely anywhere you have access to the internet. 
Transactions entered when you do not have internet access will be synchronized the
next time you connect to the internet.

Install the free app on your mobile device from the iTunes Store if you are using and 
iPhone, iPad, or iPod touch, or the Google Play Store if you are using Android.

Once installed, open the app to see the “Dropbox" title and logo displayed. Click on 
the Dropbox Logo, then tap "Connect to Dropbox". Do not tap on the WiFi icon that is
at the lower right hand corner of the screen, this uses an older method of syncing 
(Network Synchronizer Extension) which is only supported for older versions of 
Moneydance.

You will be taken to Dropbox's website to give the Moneydance app permis-
sion to access your Dropbox.
If you are already connected to Dropbox on your device, this may be done 
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automatically.

Click “Connect to Dropbox”.

If you cannot see the Dropbox Icon try changing your device into landscape mode. 
This should hopefully allow you to select the Dropbox logo and continue with the 
setup. It seems that Moneydance, on some devices, may render this screen 
incorrectly.

From here you will be taken to Dropbox's website to give the Moneydance app 
permission to access your Dropbox.

If you have more than one file enabled to sync via Dropbox, choose the file you 
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would like to sync.

Enter the Syncing Password that you created earlier.

Your data should populate into the app, showing the last 365 days of transactions 
within each account. It may take a few moments for the initial sync to complete and 
for your account information to display.

Using the Mobile App

As already outlined the Moneydance mobile app is a free companion to the desktop 
version of Moneydance, and is meant to allow entry and modification of transactions 
while on the go.

Accounts, categories and recent transactions are synced to your mobile device and 
transactions entered or modified on your mobile device are synced to your data file.

The app protects your information using 128 bit AES encryption. You can also 
secure the app on your mobile device with a 4 digit PIN, by enabling 'Use Passcode' 
within the mobile app settings.

The mobile app offers remote syncing via Dropbox. This allows you to sync all of 
your devices remotely anywhere you have access to the internet. Transactions 
entered when you do not have internet access will be synced the next time you 
connect.
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The mobile app includes 365 days of transactions for each account shown. The app 
will display Bank accounts, Credit Card accounts, Asset accounts and Liability 
accounts. Note that if an account is marked "inactive" on the desktop 
version it will not be displayed on the mobile device.

Select an account to view your transactions.

Note that if you are using an iPad you need to rotate the iPad to landscape mode. 
This should allow you to see a list of your accounts and balances on the left of the 
screen, if this is not done it you will not see the account list nor any arrows/buttons to
go to other accounts, you will only see the first Bank Account on the iPad, you 
should however be able to reveal the options you are looking for by placing your 
finger on screen and dragging left to right. The view is different on the iPad to on an 
iOS or Android mobile device.

247



A search box is available within each account, at the very top of the transaction list. 
Scroll to the very top of the transaction list to view the search field.

You can select an existing transaction to edit it, or select + at the top right of the 
screen to add a new transaction.

How to Sync One Account Set Using Multiple Dropbox Ac-
counts

These instructions are for syncing one Moneydance Account Set using multiple 
Dropbox accounts. The standard setup when using the syncing engine is to use a 
single Dropbox account for multiple users.

Some users may want to set up syncing the same Moneydance data but with 
different Dropbox accounts. The standard setup as stated above uses a single 
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Dropbox account for all users but in many households each person may have their 
own individual Dropbox account and wish to make use of it. Since Moneydance 
requires a single shared location that is accessible by all systems for the syncing 
data, you will have to set up your Dropbox accounts to share this single location 
between them.

The solution outlined here makes use of the Dropbox folder hence it is 
required to have the Dropbox client software installed and operational.

When you set up Moneydance syncing the first machine is the Primary system all 
other machines are secondary systems, the Dropbox account that the first machine 
uses will be the Primary Dropbox account, other Dropbox accounts are secondary 
Dropbox accounts.

It is very important that you ensure the account set you would like to share is 
not already located in any shared folder (like Dropbox, Network Share, etc) 
before syncing is setup. We strongly recommend that your account set (the
.moneydance folder) is stored locally. In newer versions of Moneydance, you will be 
prompted to move the folder to your local system, if Moneydance detects the folder 
is housed in a network location.

Note that you will often see the Account Set being referred to as a Data Set, the 
terms are interchangeable. Also on a Mac they can often be referred to as a bundle, 
to see the contents of a bundle on MacOS right click on it and then choose show 
contents.

The steps given below outline how to set the solution up:

1. The most significant parts of the setup involve the Primary system or the 
primary Dropbox account.

Starting with the primary system open Moneydance to view the file you would 
like to share, then navigate to File → Syncing.

From the three options presented we will only be interested in two of them for 
this solution:

Dropbox Folder – Sync using the Dropbox folder on this computer. This will 
allow Moneydance to process synced data even if you are not connected to 
the Internet at the time. 

Shared Folder – Sync using a folder that you specify that is shared across 
computers or devices.

Dropbox Folder is being used on the Primary System. This solution is based 
on having the Dropbox client installed. Dropbox folder is really just a specific 
instance of Shared folder so you could use either. Dropbox folder just takes 
you directly to the Dropbox directory whereas with Shared Folder you would 
need to navigate to the location.

Choose the Dropbox Folder option. 
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You will then be prompted to create an Encryption Password if you have not 
already.

The encryption password should be a unique password and something you 
should choose. It is not your Dropbox account password, and should not be 
the same as any other passwords for your own security. 

2. Next, log into the Primary Dropbox account at http://dropbox.com.

3. Right click on the folder called ".moneydancesync" and click "Invite to Folder".

4. In the next window, enter the Dropbox accounts of those you want to share 
the data folder with i.e. the Secondary Dropbox accounts.
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When you’re invited to a shared Dropbox file or folder, you’ll receive a 
notification on dropbox.com, in the Dropbox apps, and via email, it is best to 
ignore the “Go to Folder” link in the email it will not help with what we are 
doing here.

If you’re invited to a shared folder, you can add this folder to your Dropbox 
account. When you add a shared folder to your account, you have access to 
that folder and its contents. The shared folder also syncs with other members’
Dropbox accounts.

When you’re invited to a shared folder, you can access it by adding the folder 
to your account.

To add a shared folder to your Dropbox account through the Sharing tab:

a) Sign in to dropbox.com.

b) Click Files. 

c) Click Sharing.

d) Find the shared folder you want to access. Click the … (ellipsis) icon 
next to the folder name and select Add.

To add a shared folder to your Dropbox account from your notifications on 
dropbox.com:

a) Sign in to dropbox.com.

b) Click the notification (bell) icon.

c) Click Add to Dropbox under the shared folder you want to access. 

You need a Dropbox account and a verified email address to accept a 
shared folder invite. Shared folders are added directly to your Dropbox 
account and sync with all folder members.

5. On your second system after installing Moneydance you should open 
Moneydance and navigate to File → New (or 'Create New Account Set' from 
the Welcome to Moneydance window).

Then select "Open Synced File" and proceed to select the Dropbox Folder 
method if your Dropbox folder is in the default location, otherwise use the 
Shared Folder option.

The Dropbox Folder option should show you the available Data Set(s). If you 
select the Shared Folder option you will be prompted to select the data set 
you would like to sync. You need to navigate to .moneydancesync folder 
within the Dropbox folder and select folder and click on ‘Open’. 

The screen should now show you are connected to your designated 
dropbox/shared folder “Connected: Select Shared Folder”, click “NEXT”. 

You may see a search screen headed “Finding synced files” which will be 
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followed by “Select a synced document to open”.

Highlight the data set name you want to sync with and click NEXT. 

Enter the same encryption passphrase on the second computer in order to 
start syncing with the file. 

It may take a moment for the file to initially sync after completing the last step 
of the sync setup process. Please wait for the syncing to complete and do not
close or force quit the program.

Note the following when using the Moneydance syncing capability:

• The Master Password on the original system will not be transferred. The 
password that you set to open data, is a password just for the specific 
computer or mobile device. These passwords cannot be transferred as it is a 
matter of local security on each system. You’ll need to setup passwords on 
each system you’re syncing with.

• The preference settings will not be transferred to your new system – this is by 
design. You will need to configure your preferences on the systems you are 
syncing with. You may wish to refer to the 'Preferences' section for more 
information.

Multiple Dropbox Accounts and Syncing with Mobile App

We use the terminology of Primary and Secondary user here only for convenience. 
The Primary user just means the user of the first computer system that was setup 
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and his/her mobile. All other systems are secondary. So Primary really relates to 
where to syncing process is originally initiated from.

For the primary user the instructions in the section Setup the Moneydance Mobile 
App can be used. For secondary user the following instructions are provided.

You will be using the Dropbox account details of the owner of the secondary 
machine.

1. Install Moneydance on your Mobile Device, if already installed, uninstall and 
reinstall.

2. Open Moneydance on your Mobile Device.

3. Click “Link Dropbox Account” button.

4. You need to sign into the secondary Dropbox account.

5. On the screen “Moneydance would like access to the files and folders in your 
Dropbox” click ALLOW.

6. Select the data set you want to sync too.

7. Enter your sync password (passphrase) and click Begin Syncing.

This should complete the setup.
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Syncing Performance

There are no hard and fast rules about how long it should take to sync your data as 
you are using Moneydance in day to day operations, as with many computer related 
things it "depends".

One of the most significant "depend" factors with syncing is the method used.

Dropbox Folder should be the fastest method. This is simply because Moneydance 
is just reading data from your local disk. The transfer of data is largely being 
managed by the Dropbox client in the background so you do not see it. You just see 
the final step when it is being transferred locally between the Dropbox folder and 
your Moneydance Data Set.

Shared Folder should be next in performance terms, it will be slower that Dropbox 
Folder, in most instances, because it is reading data from a network device, yes the 
device is generally on you LAN but it is sill being read/written over a network and this
has performance implications.

Dropbox connection will be the slowest. The software is using an API to read and 
write data across the internet. The infrastructure that is involved alone guarantees it 
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will be the slowest method, without any of the other overheads that may be involved 
or even network or server congestion.

Slow is a relative term here it may add a few seconds or tens of seconds to the 
process and that can vary from time to time.

Initial Syncing

The factors given above impact initial syncing in the same way as far as time is 
concerned. The difference is in day to day operations is that you already have the 
base data on each system, with initial syncing you are starting with nothing, hence 
when you initially sync you should wait for each machine to finish this initial syncing 
before you use Moneydance on it.

Consolidating Shared Data

The shared data does not have a designated owner hence there is no consolidation 
of data in the shared location. This means that the data in the location continues to 
grow. While, in itself, this is not necessarily a problem, it has been noted that with a 
syncing configuration that has been in operation for a while that adding a new 
system to the setup may cause the new system to choke when it is attempting the 
initial sync, it is suspected that this may be due to the large number of files.

If the amount of data or the number of files is proving or suspected to be problematic
this can be manually addressed using the following method:

1. Ensure data is up to date on all devices

2. Close Moneydance on all desktops and devices

3. Open your .moneydancesync folder in the shared location

For Dropbox use the dropbox web app, as in the following link:

        https://www.dropbox.com/home/.moneydancesync

Use appropriate tools for other shared services to navigate to 
the .moneydancesync folder

4. In the .moneydancesync folder you will see one or more subfolders, each with
a long alphanumeric name. Each of those subfolders contains the sync data 
for one of your synced files. You will want to open the folder(s) corresponding 
to whichever file you are trying to consolidate. You can see the name of the 
file associated with each sync folder by viewing the data in the tiksync_info.txt
file within that folder.

5. For each folder you would like to consolidate, rename the "v3" subfolder to 
something like v3-backup

6. Open Moneydance on your desktop and load the data set that you would like 
to consiolidate. Moneydance will re-populate the v3 folder with a consolidated 
set of data.
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Resetting Syncing

At times it can be necessary to completely reset syncing.

This process involves disabling the current sync settings, deleting all trace of the 
sync from Dropbox, then setting up again from scratch.

NOTE: This process will delete any transactions that are not stored in the main data 
set, hence if you have any transactions on your mobile devices that have not been 
synced they will be lost. You will want to manually enter or record any transactions 
like this before following the following steps. 

Before commencing the process given here you should take a backup of your data 
and store it in a safe place.

1. On your phone use the setting menu to disconnect. 

2. First disable Dropbox syncing in Moneydance via File → Syncing, by setting 
Moneydance’s “Sync Method” to “Don’t Sync” then close Moneydance.

3. Using the Dropbox app or website interface, delete the .moneydancesync 
folder in your Dropbox folder.

4. Then re-open Moneydance and re-enable Dropbox syncing via File → 
Syncing by setting your “Encryption Passphrase”, then setting “Sync Method” 
to “Dropbox Folder” or, “Dropbox Connection” click OK.

5. Set up syncing to your mobile devices following the instructions given earlier 
in this chapter.

The instructions given above are geared towards a computer and a mobile device, 
where you have multiple computers the second and subsequent ones are added into
the syncing setup via the command File → Open Synced File, just as was done 
when the syncing setup was first created, however it might be a good idea to rename
the existing local data set that you have on the machine.

Disabling Syncing

To disable syncing you need to do it on the main computer (the computer that was 
used to set up syncing) the procedure only works with on the master system. So on 
the primary system perform the following steps:

1. Use the Menu Command; File → Syncing and select do not sync.

2. Then, close Moneydance and using the Dropbox app or website interface, 
delete the .moneydancesync folder in your Dropbox folder.

Note that when you disable syncing you are breaking the syncing relationship, after 
doing this to re-establish syncing you must set it up as if it is the first time.

Syncing Password

You can view the password used to setup syncing on the primary system i.e. the 
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system you used to initially create the syncing setup. You do this by the menu 
command File → Syncing and then use the button to "show passphrase".

This is only the syncing password not the main file password.

If you change this passphrase then you need to recreate the syncing setup on the 
other systems.

Changing Syncing Method

When you create a syncing setup, data is consolidated and copied to the shared 
location, with the syncing password used to encrypt the data, also names and 
linkages are created for the ongoing use of syncing.

If you wish to change the overall syncing method, there is no ready means within the
existing setup to change the location of the shared data or to reset the various 
linkages within the shared data or on each individual system.

Therefore if you wish to change the syncing method it is necessary to take the 
existing setup back to a single standalone instance, then to build a new syncing 
setup using the desired syncing method in the standard way.

Unable to Change Syncing Method

Under some circumstances you may find that you cannot change the syncing 
method. In effect you will have a display like the one below, that does not allow any 
change to the method.

The most common situation where you would see this is on a secondary computer 
were the syncing was setup using File (Moneydance on Mac) → New → Open 
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Synced File. This is perfectly normal the syncing method can only ever be set on the 
primary machine.

Even though a Moneydance backup/restore does strip out a lot of the syncing 
information – to ensure that data is not overwritten, you will see this message if you 
restore a backup created on a secondary computer and then try to set up syncing. 
This part of the syncing configuration is not being reset by the backup/restore 
process.

If you are trying to create a new syncing configuration from a secondary system 
backup there is a way to convert a secondary data set to a primary data set so that 
the syncing method can be changed.

Refer to the section on Backups, Exporting Data and Data Sets for information on 
this.
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Chapter 20: Passwords & Encryption
All Moneydance data is encrypted, even without setting a password. This means that
only Moneydance can read the data. If no user-provided passphrase is specified, 
Moneydance provides one to use which also goes through the PBKDF2* algorithm to
generate the main encryption key.

Master Password

Moneydance allows you to set a Master Password (sometimes also referred to as a 
Local Password as it is specific to the local computer). This password is used as the 
encryption key and thus in addition to the data not being able to be read by any other
application it can not be opened and read by Moneydance until you provide the 
password when prompted.

A Master Password must be used if you wish to store Direct Connect passwords in 
your Moneydance data file.

To set up a master password for your data file, select File → Passwords and enter a 
Password.

If you lose or forget your password your data cannot be retrieved. There are no
backdoor built into the system nor is there a way of setting a replacement 
password. Choose your password and hint carefully.

If you would like Moneydance to remember your passwords for automatic 
downloads, you can select the “Store Online Passwords in File” option.
After enabling this, you will need to enter your login credentials once more before 
they're stored.

The data set is always encrypted with AES128 using AES/CBC/PKCS5 Padding. If 
no user defined password is provided Moneydance provides a key that goes through
the PBKDF2* algorithm to generate the main encryption key. 

If a user defined data set password is provided a password derivation algorithm is 
used to encrypt/decrypt the key, specifically PBKDF2WithHmacSHA512. The local 
encryption of the data set is not secure unless the user provides a password.

Online Banking

Security and encryption used in online banking is determined outside of 
Moneydance. Moneydance is required to comply with the security standards that 
have been set. Moneydance has control about how passwords are stored within 
Moneydance and details of this as well as some overview information on Online 
banking security are given below.

Online Banking Security

Online Banking is using Direct Connect, the OFX specification defines the security 
and encryption here.
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From the specification the security standard used can be summarized as:

• Certificates (X.509 v3) are used to identify and authenticate servers, and to 
convey their public keys.

• PKCS #1 block type 2 is the encryption format specified.

• RSA is the encryption algorithm.

For complete details of the security employed with Direct Connect you can download
the OFX specification from www.ofx.net.

Online Banking Passwords

Direct Connect passwords are sometimes referred to as Online Banking passwords 
however a distinction needs to be made. Many people associate Online Banking 
Usernames and Passwords with Internet Banking via a Financial Institution’s 
Website or Telephone Banking. The Usernames and Passwords we are referring to 
here are for the Direct Connect system, sometimes known as Application Based 
Online Banking which is the system that Moneydance is using for transaction 
information and also for Bill Pay (if supported). It is generally a separate system to 
the Standard Web Based System that Financial institution’s provide and will often 
require a difference Username/Password combination. When store in your Data Set 
they are stored using the same 128 bit encryption as the other data. The bank 
passwords are not salted and hashed. While we realize this may sound alarming as 
security practices recommend to salt and hash passwords, there is no alternative in 
this case. It would simply be impossible to log into the bank to download transactions
if the password were hashed as a hash is a one way function.

When connecting to financial institutions the connection is over HTTPS. The specific 
encryption used over HTTPS is negotiated in the handshake of the HTTPS 
connection. Moneydance limits the connections to require no less than 128-bit 
ciphers. Moneydance comes with a bundle of trusted root CA certificates for verifying
the identity of the bank servers it connects to, just as your browser does. We 
carefully limit the CA certificates that Moneydance will use for trusted connections.

When setting passwords for online banking (Direct Connect) it should be noted that 
the OFX specification states that clear text passwords are limited to 32 Printable 
ASCII characters.

When transmitting the data to your bank’s server in OFX messages Moneydance 
escapes all data, including passwords. This is the ensure that as far as possible 
Moneydance transmits all data including special characters to the OFX server 
without data being deemed invalid in the path or being interpreted in some way. It is 
still possible for the OFX server to handle it incorrectly or for there to be some 
restrictions there above what the OFX specification states, for example restrictions 
on what special characters can be used.

Syncing Password

Finally we have the Syncing Password or Pass Phrase. This is the password used to
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encrypt the data that is passed between systems when syncing. It is set on the first 
system during the syncing setup and must be used on each subsequent system 
when linking to the sync data, it is a common passwords between all computers 
participating in the syncing process including mobile devices.

For the syncing data 128 bit AES encryption is used, with PBKDF2 used to generate 
the encryption key from the passphrase.
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Chapter 21: Backups, Exporting Data, and Data Sets

Backups

Moneydance provides two methods of performing backups. The first is the automatic
backup, which facilitates the automatic backup of data when you exit Moneydance. 
The second is a manually instigated backup.

Default Backup Locations

Moneydance will store any new backup files you create either in the default location 
or in the location you have specified under preferences.  The default location for your
backup file(s) varies depending on your operating system, and are listed below.

System Location

Mac:
 macOS:
  Big Sur and 
  Monterey 

/Users/<username>/Library/Containers/Moneydance/Data/
archive/backups

Mac: 
 OS X & macOS: 
  Lion through 
  Catalina

/Users/<username>
/Library/Containers/com.infinitekind.MoneydanceOSX
/Data/archive/backups

Mac:
 OS X: 
  Snow Leopard
  and earlier

/Users/<username>/Library/Application 
Support/Moneydance/archive/backups

Windows:
  Vista and later

C:\Users\<username>\.moneydance\archive\backups

Windows:
  Pre Vista

C:\Documents and Settings\<username>\.moneydance\archive\
backups

Linux /home/<username>/.moneydance/archive/backups
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Automatic Backups

Options for automatic backups are set via the Backup tab in the preferences menus: 
File → Preferences.

You have the option to create or not create backups and to select the number of 
backups you wish to keep. You can also select the location that the backups are 
created in. The name of the backup file will be of the form:

    YourDataSetName.DateOfBackup.moneydancearchive

The name is derived as follows:

YourDataSetName: This is simply the name of your Moneydance data set this is 
used as the base for the name of the backup file.

DateOfBackup: This is the date the backup was created on.

The automatic backup only allows for one backup per day. If you have multiple 
sessions during the one day the last backup created is the only one kept and 
becomes the backup for that day. It should be thought of as an end of day backup.

Manually Exporting a Backup

Moneydance offers the ability to manually export a backup to a location of your 
choosing (external hard drive, thumb drive, etc).  The default name for the exported 
backup will be a name in the following format:

   YourDataSetName.DateOfBackup-TimeStamp.moneydancearchive
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The name is derived as follows:

YourDataSetName: This is simply the name of your Moneydance data set this is 
used as the base for the name of the backup file.

DateOfBackup: This is the date the backup was created on.

TimeStamp: This is the time that the backup was created at. This allows you to 
create multiple manual backups during the one day.

As you can see the file extension is “.moneydancearchive” to indicate it is a 
compressed backup file.

To export a backup go to File → Export Backup, select the appropriate name and 
location for your backup file, and wait while Moneydance exports your data.  When 
the export is complete Moneydance will notify you that your data was exported 
successfully.

Restoring from Backup

To restore from a backup file:

1. Navigate within Moneydance to File → Restore from Backup.

2. In the window that opens, navigate to and select the .moneydancearchive file.

When data is restored in this way, a new data file is created for use going forward – 
a .moneydance file. This file can be found at the default file location, accessible 
within Moneydance by navigating to Help → Show Documents Folder. The name of 
the file is the same as the name of the backup file hence if you are using the default 
naming convention then the restored file will be a combination of your original data 
set name with the date/time stamp appended to the name.

If you would like to move the location where your data file is stored do so now by 
moving the entire "MyFileName.moneydance" folder to the desired location after 
closing down Moneydance. You will need to perform the following procedure to open
the moved file.

1. Open Moneydance.  If you do not see the "Welcome to Moneydance" window 
go to the Moneydance menu bar, open the "Window" menu, then select 
"Welcome to Moneydance".

2. Click the "Open Other" button in the lower left hand corner of the "Welcome to
Moneydance" Window.
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3. Navigate to the "MyFileName.moneydance" folder's location, click the folder to
select it, then click "Open" to open the file in Moneydance.

Once you have been satisfied that all is in order with the restored data, it is 
recommended to rename the data set to something more appropriate than the 
backup name, you may well want to rename it back to the original name it had.

For data fidelity reasons backup files do not contain data related to syncing, Nor do 
they contain information relating to online banking setup.

If you backup and restore a system that has been a system in a syncing relationship 
the data set that the creates is effectively a standard standalone system, irrespective
of if you restore a backup from a Primary or a Secondary system. The restore will 
reset the flag that differentiates the systems.

Recovering a Data Set From the Syncing Data

This procedure is intended to restore the computer that has been in a Moneydance 
synced solution that comprised a computer plus one or more mobile devices, where 
the computer has failed or some other catastrophic event has occurred with it so no 
data is recoverable from it.

The preferred method is to recover from backups so this approach should be 
considered one of last resort, where no backup exists. There is no guarantee that 
this process will work, or even if it does that the resultant data set will be usable, the 
syncing data should not be considered as a substitute for back ups.

This procedure attempts to recover your data from the “.moneydancesync” folder 
that is in the shared location, whether this be Dropbox or a Shared Folder.

Start the procedure by performing the following steps:

1. Install the same version of Moneydance as you were previously using.

2. In the shared location make a copy of the folder “.moneydancesync” with a 
different name and store it in a safe place.

3. In Moneydance click File → New → Open Synced File. Use the drop down to 
set the same sync method as was selected in the original setup. Enter the 
same passphrase as before and start syncing.

What this part of the procedure does, if it is successful,  is to create a secondary 
synced computer. The system now needs to be converted to be the primary system 
in the syncing relationships.

Before going any further create a backup using the File → Export Backup.

You are going to use a tool to convert the secondary data set created by this process
to a primary data set. Maintenance tools for Moneydance are contained in an 
extension named Toolbox. To install the Toolbox use the menu option Extensions → 
Manage Extensions, select Toolbox from the list, then click on Install. Once installed 
close the Manage Extensions.. window

Once installed use the Menu Option Extensions → Toolbox to start the tool, it can 
take a little while to load so be patient.
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You will then see the main Toolbox Screen.

Use the following steps to reset the data set to be a primary:

1. Select TOOLBox Options from the menu bar and then select Advanced Mode 
from the drop down.

2. On the next dialogue Select to accept the risk

3. If you have already create a backup you can skip through the next dialogue.

4. The main Toolbox screen will then show some entries in Red, this indicates 
you can change options with these selections.

5. Click the button to promote secondary to primary data set. 

6. Your data set has now been promoted to be a primary standalone data set. 

After the tool has finished you should have created a standalone copy of you data, 
there is no syncing in place.

You may need to tidy things up. Particularly what is listed in the side bar. Use the “+” 
at the bottom to add in any missing accounts into the side bar. The procedure you 
have performed just recovers data so things like preferences may be lost, also 
reminders, there is no way of recovering this data from the sync files as this 
information is considered local to a machine and it not copied as part of the syncing 
process.

At this stage you should check everything to make sure you are satisfied with your 
data and that all is in order.

Following this you should have a functional Moneydance system with data, but it is a 
standalone system and no data is being synced to any other device.

You now need to follow the standard Moneydance procedure for syncing between 
computers, in other words you are creating the syncing setup from the beginning, 
there is no way to reuse or attach to the syncing data that is already present, you 
can easily add in secondary computers but you cannot add or substitute a new 
master.

To explain why the master cannot be changed, when you create a syncing 
configuration a unique ID is created. Even restoring the data as we have done above
and even if it is the same computer there is no way to associate the unique ID  that 
was created originally with what is effectively seen as a new data set on the 
computer.

So with the approach we have had to employ here we are really going back to the 
beginning as far as syncing is concerned.

Exporting Data from Moneydance

You can export information from Moneydance by using the File → Export menu 
option.

• Select your desired file format. You can export data from Moneydance in QIF, 
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Tab-Delimited or Raw JSON format.

• Select the Account you wish to export or All accounts

• Choose a range of dates to be exported, or select "All dates" from the Date 
drop-down box.

• Select or type the path of a destination file name (this file need not exist 
before you start the export).

• Select the Currency to use for all financial values in the exported information.

In the next window, you can choose the file name and the file location for the export. 
When your done, select 'Save' to create the export file.

If you are looking to extract data to say perform further analysis in a program like a 
spreadsheet, you may be better served by creating a report of the data and saving 
the report in a Tab or Comma delimited format, or using the Copy to Clipboard 
function.

Data Sets

Default Data Set Locations

Moneydance will store any new data files you create in the default location.  If you 
have not manually moved your data file to a different location, all your Moneydance 
files will be stored in a default location.  The default location for your data file(s) 
varies depending on your operating system, and are listed below.
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System Location

Mac:
 macOS:
  Big Sur and 
  Monterey                  

/Users/<username>/Library/Containers/Moneydance/Data/
Documents

Mac:
 Mac OS X & macOS:
  Lion through 
  Catalina

/Users/<username>
/Library/Containers/com.infinitekind.MoneydanceOSX
/Data/Documents

Mac:
 Mac OS X: 
  Snow Leopard
  and earlier

/Users/<username>/Library/Application 
Support/Moneydance/Documents

Windows:
  Vista and later

C:\Users\<username>\.moneydance\Documents

Windows:
  Pre Vista

C:\Documents and Settings\<username>\.moneydance\
Documents

Linux /home/<username>/.moneydance/Documents

Moving Your Data Set to a Different Location

If you already have your data in Moneydance but would like to store your data 
outside the Moneydance library, follow these instructions  If you obtained 
Moneydance from the Mac Apple Store you cannot move your data file due to 
limitations imposed by Apple regarding the 'sandboxing' of Apps.

While Moneydance is open, in the menu bar go to Help → Show Documents Folder.

This will open a file browsing window. Close Moneydance, but keep this file browsing
window open.  You will see a folder in your file browser that looks like 
YourFileName.moneydance.  Move this folder to its new location. You only want one 
copy of this folder on your system, so it is important to move the file to the new 
location and delete it from the Documents folder.

Note that your Moneydance data set should always be located on a local disk, it 
is not supported, and may well cause issues if a data set is placed onto any form of 
shared storage, this can include corruption of the data.
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The local files (i.e, the visible Moneydance files that you open on your computer) 
have operations performed on them such as atomic writes and the expectation is 
that Moneydance is the only thing interacting with those files while they are open, file
sharing services have the problem that they could be could be changing files, or 
parts of files, out from under the software, it has been noted that this has caused 
serious issues in the past.

Moneydance is generally incompatible with storing its data on network based 
systems, like NAS and File Servers, as the software performs a lot of rapid 
read/write operations and these are not handled well across networks due to the 
inherent latency involved in networking.

Open Moneydance, and in the "Welcome to Moneydance" window which appears 
click the "Open Other" button in the lower left hand corner.

Navigate to the new location of your data file and click to open. Moneydance will 
remember the new location of your file and open it automatically next time you 
launch Moneydance.

Renaming Data Sets

From Moneydance, navigate to Help → Show Documents Folder. This will open a 
new file browsing window displaying the default location of your files.

If your files are stored outside the Moneydance library, navigate to the file location on
your system.

• Once you have located the file, it is important that you close Moneydance – 
but keep the file browsing window open.

• You will see a file/folder in your file browser named yourfilename.moneydance
On a Mac system, the file will appear with the Moneydance icon displayed.

On a Windows system, the file will appear as a regular 'folder' so you will not 
see the Moneydance icon.
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• You can right click (Crtl+click) on the file/folder and select 'Rename'.

• Change the name to whatever you wish – just be sure to retain the
.moneydance file extension at the end of the name.

• When you then reopen Moneydance you will likely be presented with the 
'Welcome to Moneydance' window.

• Your newly renamed data set should be displayed on the right of this window.

• If not, click the 'Open Other' option. A file browser will open, allowing you to 
navigate to and select your newly renamed data.

Deleting Data Sets

To remove an unwanted, duplicate, or unused data set – first open the data in 
Moneydance to ensure this is the correct file you would like to remove.

If your data is stored in the default location, you can access it by navigating within 
Moneydance to Help → Show Documents Folder.

• Once you have located the file, it is important that you close Moneydance – 
but keep the file browsing window open.

• You will see a file/folder in your file browser named yourfilename.moneydance

• Once the Moneydance program has fully closed, right click on the
.moneydance file, then select to Delete/Move to Trash.

Do not empty the trash/recycle bin just yet!
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• After that, open Moneydance and you will be brought to the Welcome screen. 
From here you can access your other data set(s).

• Select your current data file and open it in Moneydance and make sure that 
your data is correct. This is to ensure that you removed the correct file.

• Once you have done that, you can safely empty your Trash folder.

Repeat this process for any additional files you would like to remove.
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Chapter 22: Restructuring Data
Despite our best efforts we may need to restructure our data. Something may 
eventuate that we did not anticipate initially, circumstances may change, legislation 
may force some changes.

While some of the restructuring in this chapter is fairly minor there are some 
restructuring which is significant. Before making any changes a backup should be 
made. In addition for major changes it is suggested that you disable syncing and 
perform the changes in standalone mode.

While many of the methods make use of the standard capabilities of Moneydance, 
like Batch Change, this chapter also makes use of tools like the Find and Replace 
extension.

Note that it is not the intention here to be exhaustive of all the possible ways to 
achieve an objective.

Accounts

Changing Account Types

At times an account will be created as the wrong type and it is required to change 
the type. Once an account has been created and populated with transactions it is not
possible to change the type. You need to take an indirect approach to facilitate this. 
We need to create a new account of the correct type and move the transactions to 
this new account.

Firstly create a new account of the correct type. After doing this open the account 
you wish to change the type of.

Select all transaction in this register, generally you can do this by selecting a 
transaction then using the keyboard shortcut CTRL-A (CMD-A on Mac).

Now right click on the transactions and Select Batch Change. Select to Change the 
Account. The software will then display a window where you can select the account 
to move the transactions to.

After pressing the OK button the transactions will be moved.

The original account should now be empty you should be able to delete this account.

Moving One or a Group of Transactions

The methodology is the same as that used in changing Account types. The different 
is that not all transactions are selected. You can:

• Select one transaction.

• Selecting a range of transactions:

◦ On Windows/Linux: Select first transaction Hold down <Shift> and click on 
last transaction.
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◦ On Mac: Select first transaction Hold down <Shift> and click on last 
transaction.

• Selecting multiple discontinuous transactions:

◦ On Windows/Linux: Select first transaction, use <Ctrl> Click for 
subsequent transactions.

◦ On Mac: Select first transaction, use <CMD> Click for subsequent 
transactions.

Note that it is not possible to move transactions between investment accounts.

Categories

Categories have a hierarchical structure. There are two fixed starting points; Income 
and Expense, a category is one or the other it cannot be both. You should not 
duplicate category names nor should a category name and account name be the 
same.

Categories sit underneath either Income or Expense, underneath a Category you 
can have one or more sub-categories and further sub-sub-categories can cascade 
underneath sub-categories. You can view your Category/sub-category structure 
through the menu command:

Tools → Categories

A word of caution on Category Registers. It is extremely easy to get confused when 
working with Category Registers, At times you need to think of them in the same 
terms as an Account register and think of the Category as being an Account. The 
confusion that surrounds categories is a reason for the recommendation to not work 
directly in the Category Register and to work with categories when you are working 
with transactions in accounts.

You should only work in Category Registers when you really have no other option, 
and even then make a backup before you start. We have included a couple of 
situations where it is necessary to work in Category Registers, but have hopefully 
provided the specific details needed to do so successfully.

Changing Category Types

At times a category will be created as the wrong type and it is necessary to change 
the type. We will discuss two ways of changing category types in this section.

Once a category has been created it is not possible to change the type using 
standard Moneydance tools Using standard features you need to take an indirect 
approach to facilitate this. We need to create a new category of the correct type and 
move the transactions to this new category.

As with any restructure you should take a backup before you start, but it is especially
important here because any mistake can really damage your data.

Firstly create a new category of the correct type. After doing this open the category 
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you wish to change the type of, you do this by going to the category window through 
the menu command Tools → Categories, select the category then right click and in 
the drop down select “Open in New Window”.

This displays a register window – but note this is a category register window not the 
account type registers you are used to working with. Select all transaction in this 
register, generally you can do this by selecting a transaction then using the keyboard
shortcut CTRL-A (CMD-A on Mac).

Now right click on the transactions and Select Batch Change. Select to Change the 
Account. The software will then display a window where you can scroll down and 
select the Category to move the transactions to.

After pressing the OK button the transactions will be moved.

The original category should now be empty, if there are any subcategories you 
should change the parent of these and after doing this you should be able to delete 
the category.

After following this process you can change the name of category if you wish.

An alternative method is to use the Toolbox Extension.

In Toolbox under the MENU: Accounts and Category Tools there is an option to 
change the Account/Category type. This is an effective tool, the only restriction in its 
use is that it cannot change the type of a sub category, you will need to redefine a 
subcategory into a top level category before you start. This is because the tool 
cannot build the category tree. After changing the type you can build a category tree 
if you wish, is not recommended to have the same tree on both Income and Expense
sides, the aim should be to have unique names at each level, experience has shown 
that using the exact same number in multiple places can cause problems.

Restructuring Categories

One of the main reasons for restructuring categories is that the reporting is not 
meeting your needs, the category structure reflects how reports are structured. You 
may find a situation when you do not have totals where you need them, or the report 
structure is not suitable.

From the Categories window select the category you want to change and right click 
on it selecting Edit from the drop down.

The field “Parent Category” is the main one of interest here. This field allows you to 
select the category that you want this one to be the child of, it may be an already 
existing category or it may be necessary to create the appropriate category.

It is also on this screen where you can rename categories.

Amalgamating Categories

Before you start, take a backup of your data, this is a significant restructure and a 
mistake almost always results in the need to restore from Backup, mistakes are 
something you can rarely recover from when doing this.
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Decide which of the three categories you are going to keep, even if you plan on 
renaming it, that is easy to do, in due course. I would generally keep the category 
that has the most transactions it in.

You now need to open a transaction register for one of the categories you want to 
amalgamate with the one you are keeping. To do this use the menu item Tools → 
Categories.

Select the category you want to move the transactions from, Right click and select 
"Open in New Window" The result is a transaction register, now be careful here this 
is a category transaction register not the Account transaction register you are used 
to dealing with, yes they look the same but there are implications in changing things 
in this sort of register (Note about making sure you have a backup).

Select all transaction in this register, generally you can do this by selecting a 
transaction then using the keyboard shortcut CTRL-A  (CMD-A on Mac).

Now right click on the transactions and Select Batch Change. Select to Change the 
ACCOUNT (yes that is Account – this is one of the differences when using category 
registers) In the window that comes up scroll and select the category that you want 
these transactions to be part of i.e. the Category you are going to be keeping.

Repeat the above process for any other categories.

If you wish to rename the category, from the category window select the category 
and choose the Edit button, in the dialog that comes up you can change the category
name, and also change where it sits in the category structure (parent) if desired.

You should now have some empty categories these can be deleted.

Tags

Tags are unstructured text strings that can be assigned to transactions in addition to 
categories, they are generally used to further classify transactions, unlike categories 
you can assign multiple tags to a transaction.

Restructuring Tags

To bulk change any tags, you can go to Edit --> Advanced Search and search for a 
tag. Then highlight multiple transactions and right click, select Batch Change --> 
Tags. This will set the tags for all the highlighted transactions to the ones you enter 
in the Batch Change window.

For more extensive changes with tags it is necessary to use the Find & Replace 
extension, the extension provides you with the ability to:

• Add tags to the select transactions.

• Remove tags from the select transactions.

• Replace tags in the select transactions.
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Deleting a Tag

Removing a tag from all transactions deletes the tag. A tag only exist while it is being
used.
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Chapter 23: Troubleshooting Moneydance
Despite the best of efforts computers do not always work and neither does computer 
software, add to that human beings are fallible and you have the potential to have 
problems of one sort or another. Every computer user will face a problem sooner or 
later. Many problems are regular occurrences and easily fixed, for example my 
notebook’s battery is flat, others can be more involved. This chapter outlines some 
general approaches you can take in dealing with issues you may encounter.

The first step is something you should do before you ever have a problem, you 
should make regular routine backups of your Moneydance data and these should be 
stored on different media to where you keep the Moneydance data on the system.

The why is simple, one of the problems that could be encountered is a failed disk, 
disks do not fail all that often on their own accord, but it does happen, however 
physically being damaged is more likely. If you daily data and your backups are on 
the same device, a disk failure means you have lost your data.

The Moneydance software has provision for automatic daily backups and also for on 
demand backups, use the capability. One thing that must be remembered is a 
backup at this level does not backup your preferences, extensions, color 
customization etc. If you want to back these up they must be done separately.

Specific Problems

This section will document some specific problems that have been encountered and 
the likely solution.

Data Set Will Not Open

One of the most elementary problems is the inability to open your data, from above 
one of the reasons could be a failed drive, but of course you may not even be able to
start the computer if it only has one disk drive.

A Moneydance specific reason is shown in the nest screen shot:

What this message means is that there is something wrong with the Data Set, this is 
not something that Moneydance can recover from and is an indications that you will 
need to restore from backup.

Can such problems be prevented? Only to a degree. We can limit the damage by 
having regular backups, but the steps we can take to help prevent such problems 
are really limited to thoughtful management of the computer, things like shutting the 
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system down by using the software capabilities, in other words closing Moneydance 
by using its Quit option, shutting down a computer by using its shutdown function, 
not stopping the software and the system by just using the power switch.

Other events can happen which we have no control over, e.g. a power failure. While 
this problem is rare there are many things it could result from and we can only take 
the steps needed to recover from such problems, rather than prevent them.

Restored Accounts

Seeing a "Restored account ..." is really just a surfacing of an inconsistency in the 
data that may have been there for quite some time and just not visible.

These accounts are generally caused by Moneydance encountering something that 
refers to a category or account that is no longer present.  These references can be 
from a transaction, reminder, or sub-account.  Because MD does not know the name
of the category/account, it only has the ID number, it uses that to create the 
"Restored" accounts and uses this ID as part of the account name.

Check to see if there are any zero value transactions in the account, and if so, delete
them. To be safe you should make sure that no scheduled transaction reminders 
contain a reference to the restored account. Once that is done, you should be able to
deleted the restored account and it should not re-appear.

If there are non-zero transactions you should be able to categorize them by right-
clicking (or ctrl-clicking) on the transaction in the Recovered Account register and 
selecting "Show Other Side" which will take you to the other account and begin 
editing the transaction from that side, changing the category for the account from the
"recovered" account to a normal category.

Once the account is empty you should be able to delete it.

Moneydance is Not Registered

The reasons that Moneydance may be in demo mode include:

1. Something has happened to your configuration file, called config.dict. This file 
is where the license key is kept.

If your problem is that something has happened to the config.dict file then re-
entering your license key should resolve this.

2. A purchase of Moneydance directly from the company rather than from a third
party entitles you to use the version it was purchased for plus a free upgrade 
to the next major version, beyond that a key will not work and you need to 
purchase an upgrade at a 50% discount.

If you have upgraded to a version that your license is not valid for, you can 
upgrade directly purchased versions at a 50% discount as stated or you may 
be able to downgrade to a version that you are licensed to use.

3. The license key has not been entered into the software. 
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Moneydance does not automatically register itself you must enter the key into 
the software.

4. You have mixed versions. For example you bought Moneydance from the 
Apps Store but later on download a copy directly from The Infinite Kind and 
installed it. 

The licensing schemes and therefore licenses vary between the download 
sources and are not compatible.

5. The license key is not being accepted. 

The key must be entered exactly as received, using cut and paste usually 
resolves this sort of problem. 

The other reason for the key not being accepted is that it is not for the version 
of Moneydance you have installed. Keys are version specific and generally 
work with the version purchased and the next major release for license 
purchased directly from the company.

Unable to Remove Extension

At times is may not be possible for Moneydance to remove an extension itself.

The reasons for an extension not appearing in the Remove Extension list include:

1. The extension was for an earlier version of Moneydance and has not been 
upgraded for the later API.

2. An extension has been withdrawn.

3. An extension was manually installed and it unknown to Manage Extensions.

The first reason is likely to show as errors in the Error Log.

It is certain possible to just remove an extension from the .moneydance/fmodules 
folder which will prevent Moneydance from attempting to load it, however this will 
certainly result in errors appearing in the Error Log, this is not considered desirable.

To completely clean out all references to a module when no tools are available to do 
so it is necessary to manually remove the entry from the config.dict file.

You will need to note the file name of the extension, you can find this out by looking 
in the fmodules folder.

To demonstrate we will assume you need to manually remove the Quotes and 
Exchange Rates Extension.

From research we determine that the name of the extension file is yahooqt.mxt. After
taking a backup of the config.dict file we edit this file.

By searching in the file we can identify a block that related to the extension, it looks 
like:

"yahooqt" = {
    "verify" = "Y"
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    "id" = "yahooqt"
 }

It will be in a section that commences with: "gen.fmodules" = {

The complete block that relates to the extension needs to be remove, you can 
identify the block as it commences with the name of the extension then an equal size
followed by a curly bracket, the block ends with a closing curly bracket. The text, as 
shown above, would need to be deleted.

In Program Problems

Most problems occur however in day to day use, they may impact a specific feature 
or operation. The cause could be something in the software, it could be caused by 
external factors, it could be caused by a misunderstanding of how the feature or the 
software works, software by its nature has rules and Moneydance being based on 
Double Entry Accounting principles also has these rules to follow as well. or indeed, 
it could be a result of what you are doing just not being the way the software works.

When you are working to resolve a problem of this nature the path to follow depends 
on different factors, What expertise level are you for example. If you have a lot of 
experience with software you are likely to work you way through the problem, often 
without any outside assistance, an inexperienced user is likely to immediately reach 
out.

Start with the Basics

There are changes you make in Moneydance that can require a restart of the 
software. Many settings in Moneydance are not dynamic for example they are only 
read and processed at defined points, so a restart of Moneydance it the most 
assured way of making sure changes are reflected in the software. This is not just in 
settings but in things like Extension installation.

The software can seem to go haywire when there is something wrong in your 
preferences. This is a file that is not easy to fix by hand unless it is something very 
simple, but it is easy to see if it is the cause of the problems.

We can do this by, at least temporarily, renaming the preference file which is called 
config.dict.

Preferences file

The Moneydance preferences file (config.dict) can be found at one of the follow 
locations.

(i) macOS

If you're using a Mac, it should be located at one of these locations within your Home
folder:

macOS Big Sur and Monterey:
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~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Ap-
plication Support/Moneydance/config.dict

macOS X Lion until macOS X Catalina:

~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Ap-
plication Support/Moneydance/config.dict

macOS X Snow Leopard and earlier:

~/Library/Application Support/Moneydance/config.dict

If you have any trouble finding your Home Library folder you can open Finder and 
hold down the option key while selecting the Go menu and the Library folder option 
should occur or you can open Finder and select Go → Go to Folder and copy and 
paste in the following:

~/Library

This should pull up your local Library folder.

(ii) Windows

If you're using Windows, it should be located under your login directory at:

C:\Users\(yourusername)\.moneydance\config.dict

or

C:\Documents and Settings\(yourusername)\.moneydance\config.dict

Depending on your version of Windows

(iii) Linux

If you're using Linux it should be located in your home folder at:

~/.moneydance/config.dict

Once you've found your config.dict file, close Moneydance and rename it (to 
something like config-org.dict, for example), then open Moneydance again and it will 
appear as though you've just installed Moneydance for the first time and may have to
locate and open your data set again.

Now try the operation you were having trouble with and see if it works as expected.

If it does you can continue using the new configuration file by while viewing your data
file, choose Help → Register Moneydance and input your license key.

If you run into any problems, you can simply close Moneydance and rename config-
org.dict file back to config.dict and open Moneydance again to restore your original 
settings.

So we have some steps to employ to try and resolve the problem. If it is still an issue
it is time to go further.
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A Path to Follow to a Resolution

What we hope to outline here is a path to follow to reach a resolution. Start by 
documenting the problem, what steps or process did I take to get to here, what is the
result and what was I expecting. Even if you need to reach out, the people you will 
be talking to cannot read your mind or see what you see, you need to provide the 
detail, to draw a picture for them.

Before you go any further, search the Knowledge Base and any documentation for a 
solution, perhaps you have taken the wrong approach, perhaps you missed doing 
something, read up on how to use the feature.

https://infinitekind.tenderapp.com/kb

Search the forums for others that have experienced the same thing. If it has come up
before you may well find a solution has already been provided.

https://infinitekind.tenderapp.com/discussions

Now if the sources have not provided you with any insight, you will likely want to 
reach out for assistance. You have documented your problem, but this may not be 
enough information to kick off a support request.

Logging a Support Request

You have a problem and you have documented the steps that can reproduce it. As 
indicated this may not be enough data for others to help. With this information alone 
we have no idea about the environment you operate in for example, this forms part 
of the picture. The simplest way of getting a lot of information in the one step is to 
include a copy of your error log. Take the steps in Moneydance to recreate the 
problem, exit Moneydance then obtain a copy of the error log. An alternative to doing
this is to capture the console log which is also explained below, in some instances 
the console log may be requested as it can contain additional information.

Error Log

(i) macOS

If you're using a Mac, it should be located at one of these locations within your Home
folder:-

macOS Big Sur and Monterey:

~/Library/Containers/Moneydance/Data/Library/Application Support/Mon-
eydance/errlog.txt

macOS X Lion until macOS X Catalina:

~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Ap-
plication Support/Moneydance/errlog.txt

macOS X Snow Leopard and earlier:

~/Library/Application Support/Moneydance/errlog.txt
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If you have any trouble finding your Home Library folder you can open Finder and 
hold down the option key while selecting the Go menu and the Library folder option 
should occur or you can open Finder and select Go → Go to Folder and copy and 
paste in the following:

~/Library

This should pull up your local Library folder.

(ii) Windows

If you're using Windows, it should be located under your login directory at:

C:\Users\(YourUserName)\.moneydance\errlog.txt

or

C:\Documents and Settings\(YourUserName)\.moneydance\errlog.txt

Depending on your version of Windows.

(iii) Linux

If you're using Linux it should be located in your home folder at:

~/.moneydance/errlog.txt

You need to take a copy of the log after recreating the problems because the error 
log gets overwritten each time you start Moneydance.

As well as providing environment information the error log can also show problems 
as it name indicates.

You can see you are building up the information you have and can provide to others,
you now need to look at also what other type of information may be useful. This can 
be varied and almost impossible to outline. A degree of common sense is required. 
In may cases if you recently upgrade Moneydance it could well be significant and 
you would state what version you upgraded from. If you have an issue and recently 
migrated from another software program that would also be relevant. Many programs
can be quite creative in how they process transactions.

Likewise if you have a problem with Online Banking, which bank is a significant piece
of information as are any error messages you may be receiving, depending on the 
type of error these may not be reflected in the error log.

On the other hand if you problem relates to importing downloaded transactions then 
the file format you are using can be a critical piece of information.

With syncing what syncing method are you using, what systems are taking part in 
the syncing relationship.

So additional information that may be needed is driven by what you are doing.

You should post your request into the most suitable forum and provide a suitable 
title.
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It is important to note that the Forums are not Instant Chat sessions, there is not 
someone sitting there just waiting for your post. In post and reply forum systems 
responses are more email like in terms of response time.

Moneydance does not provide Telephone Support. With a software product from a 
small company that is sold world wide Telephone Support is just not viable.

Console Log

The console log is a little different to the error log. In some instances this log 
provides more detail, typically this will be in activities like online banking downloads, 
importing transactions.

To capture a Console log start Moneydance then open the Console Window, Menu 
Item: Help → Console Window, leaving this window open perform the activity in 
Moneydance then copy the console to the clipboard or save it using the buttons at 
the bottom of the window and include this with your support request.
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