Daily transaction order

misc's Avatar


03 Jul, 2010 06:26 AM


I see this has been raised before. I have asked about it and I also found another query about it, where a trac ticket had been raised but the issue dismissed as unnecessary. I think in that case it was actually suggesting dragging transactions to change the order.
My issue is with transactions being ordered as they are applied to an account, so that Moneydance might show a debit before any credit. This may be chronologically correct but it's apparently not how banks work, in that for each day they apply credits before debits, i.e. a day is treated as a time-slot, not an actual sequence of events.

Even if MD chooses not to sort transactions in this CR/DB way, it would be very helpful and convenient, if it allowed the user to sequence the transactions in the order they require rather than deciding for you.

Andy C

  1. 1 Posted by Ben Spencer on 03 Jul, 2010 02:59 PM

    Ben Spencer's Avatar

    HI Andy

    If you right click on the register and select Sort By->Date/Amount. Moneydance will put the credits before the debits on a particular day.

    Ben Spencer
    Moneydance Support

  2. 2 Posted by incoming on 03 Jul, 2010 03:58 PM

    incoming's Avatar

    On Sat, 3 Jul 2010 08:03:53 -0700, you wrote:
    Hi Ben

    Well that's a good start, thanks a lot. Now, how do I make it a permanent
    setting, because that's how I'd like it to behave all the time.

    Cheers Andy

  3. 3 Posted by Ben Spencer on 03 Jul, 2010 04:00 PM

    Ben Spencer's Avatar

    If you save your data file the setting should also save.

    Ben Spencer

  4. 4 Posted by misc on 03 Jul, 2010 04:09 PM

    misc's Avatar

    I tried that and the setting's not saved.
    I have it on both an old Windows PC and on a LInux box and it doesn't save it on either, but the Linux one may be a file ownership issue.

    Am I alone ?

  5. 5 Posted by Ben Spencer on 03 Jul, 2010 05:37 PM

    Ben Spencer's Avatar

    It definitely saves on both my windows and linux test machines.

    Make sure that you are running build 751. To see the build number select Help->About Moneydance.

    It might be that your permissions are set up incorrectly on your windows user account folder. You must have read and write access to the folder C:\documents and settings\your-account-name\

    Ben Spencer

  6. 6 Posted by misc on 03 Jul, 2010 06:39 PM

    misc's Avatar

    Thanks a lot for hte confirmation.

    I don't know what I did with the Centos PC because as you say it's saving the setting OK and works fine for me now.

    As for the very old Windows one, I only ran it as a backup. That didn't save it, but I have been gradually decommisioning it anyway, so this is one more step towards the scrap heap.

    Thanks for your help. Much appreciated.

  7. Ben Spencer closed this discussion on 03 Jul, 2010 06:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac