Software installation errors

Doug's Avatar


13 Mar, 2019 05:08 AM

I downloaded the free trial version of Moneydance and during the install process, I get the following pop-ups. See attached word document - - thanks - -

  1. 1 Posted by derekkent23 on 13 Mar, 2019 07:33 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    I could help support staff or others to help you if you posted your computers operating system. It looks like a windows computer, windows 10? 64bit or 32bit?.

  2. 2 Posted by Doug Neeld on 14 Mar, 2019 01:53 AM

    Doug Neeld's Avatar

    Windows 7 home premium

        On Wednesday, March 13, 2019, 12:33:53 AM PDT, derekkent23 <[email blocked]> wrote:


  3. 3 Posted by derekkent23 on 14 Mar, 2019 07:45 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    I run Moneydance 2019 on a Windows 7 64bit computer with no issues, not sure why you are having problems.

    One of the messages you get during installation indicates there is a log being created. Can you post that log, it may help support understand your issue?

    But before that try deleting Moneydance_windows_amd64.exe, clear your browser catch and down load again, this time from

    Hope this helps

  4. 4 Posted by Doug Neeld on 15 Mar, 2019 04:58 AM

    Doug Neeld's Avatar

    Went through the steps below and tried to install the version I downloaded from the link below but it didn't work so here attached is the .log file.  The log file may be pointing to issues with Java?  I'm running Java 6

        On Thursday, March 14, 2019, 12:45:30 AM PDT, derekkent23 <[email blocked]> wrote:

  5. 5 Posted by derekkent23 on 15 Mar, 2019 09:24 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Hi Doug

    I don’t see the i4j_nlog_3.log attached indicated in one of the messages in your first post at C:\users\Doug\AppData\Local\Temp\i4j_nlog_3.log

    The attachment in you last post, as you say, indicates you have java 6 installed.
    Moneydance 2019.2(1860) uses an embedded version of Java, Java: 11.0.2 (Oracle Corporation). This is installed as part of the installation when you run Moneydance_windows_amd64.exe
    Moneydance, including the embedded java would be installed at C:\Program Files\Moneydance\ Java is in the folder \lib
    Its only used by Moneydance. A separate version of java is not required to run Moneydance.
    On my window 7 computer and two windows 10 computers I have Java 8 installed to support another application without any issues. I can’t say that uninstalling your Java 6 would help but may be worth a try. I am not an expert on Java but thought Java 6 is old, not supported and thus could be a security risk?

    Let’s see if i4j_nlog_3.log shows anything.

    Hope this helps.

  6. 6 Posted by Doug Neeld on 18 Mar, 2019 04:15 AM

    Doug Neeld's Avatar

    Here attached is the "log" file, please let me know if this helps.  This log file was generated from the downloaded .exe version you recommended below.  I deleted all other previous "log" files so when I tried launching this latest .exe download, I would get a clean _1 file.  I'll await your response - - thanks - -

        On Friday, March 15, 2019, 2:24:18 AM PDT, derekkent23 <[email blocked]> wrote:

  7. Support Staff 7 Posted by Sean Reilly on 18 Mar, 2019 09:49 AM

    Sean Reilly's Avatar

    Hi Doug,

    Thank you for sending the log files and such complete information. As Derek mentioned the currently installed version of java shouldn't make any difference since moneydance bundles and uses its own version of java.

    Can you confirm if your computer is 32 or 64 bit? Moneydance 2019 is limited to 64 bit computers, so if your computer is only 32 bit or if your Windows version is only 32 bit then it won't work. In most cases I've seen where people have 32 bit versions of windows installed their computer is actually 64 bit. If your computer is 32 bit or you wouldn't like to upgrade windows then the most recent version of Moneydance you'll be able to run on this computer will be 2017.10 which can be downloaded from here:


    Sean Reilly
    Developer, The Infinite Kind

  8. Support Staff 8 Posted by Sean Reilly on 18 Mar, 2019 11:19 AM

    Sean Reilly's Avatar

    I missed the part where you say your computer and windows is 64 bit, but after some more research the messages in your log are indicative of a 32 bit platform being unable to load a 64 bit binary (the dll files mentioned). It would be great to completely confirm that. If that's definitely not the problem then maybe we could try a screen sharing session so that I could try to figure out the problem in real-time?


    Sean Reilly
    Developer, The Infinite Kind

  9. 9 Posted by Doug Neeld on 19 Mar, 2019 03:47 AM

    Doug Neeld's Avatar

    I hope these pics are helpful - - -

        On Monday, March 18, 2019, 4:19:30 AM PDT, Sean Reilly <[email blocked]> wrote:


  10. 10 Posted by dwg on 19 Mar, 2019 04:49 AM

    dwg's Avatar

    I'm a fellow user.

    You screen shot does not indicate that you have Windows 7 Service Pack 1 installed. It is my understanding that SP1 is a requirement for Java 11. This may or may not have an impact on the installation.

  11. 11 Posted by derekkent23 on 19 Mar, 2019 08:29 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Could be dwg has hit upon it.

    For java 11 windows 7 SP1 is required See

    Attached is my equivalent of one of your screen shots in which it states Version 6.1.7601 Service Pack 1 Build 7601
    Also see second attachment, lists Service Pack 1

    I found the following link to Microsoft on how to install service pack 1 on windows 7

    At your own risk.

    Hope this helps

  12. 12 Posted by Doug Neeld on 21 Mar, 2019 05:05 AM

    Doug Neeld's Avatar

    I updated Windows 7 to "SPI" (see below) and tried to load Moneydance and received the same ERROR (see below), so for your review, I've attached the latest "* _2.log" file which does read differently than the recent " *_1.log" file

        On Tuesday, March 19, 2019, 1:29:38 AM PDT, derekkent23 <[email blocked]> wrote:


  13. 13 Posted by derekkent23 on 21 Mar, 2019 08:16 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Can you confirm that under Control Panel > System and Security >Windows Update > Change Settings the dropdown Important updates is selected for “Install updates automatically (recommended)”. Also, to ensure your computer operating system is up to date clicked “Check for updates” under Control Panel > System and Security >Windows Update

    Assuming you are up to date and dwg has no more thoughts, time to take up Sean’s, the Moneydance’s software developers offer of a screen share session to see if he can work out what the issue is. Perhaps suggest a set of days and times when you would be available, remembering he is in the UK.

    Hope this helps.

  14. 14 Posted by dwg on 21 Mar, 2019 10:24 AM

    dwg's Avatar

    I looked at the log again and the system information and there is nothing standing out to me, it looks pretty standard. Yet I think the problem is specific to this system for some reason that we are not seeing, perhaps it is as simple at Java 6 getting in the way perhaps it is something else.

    I feel that Sean will need to do a screen sharing session, perhaps even doing something like an install in debug mode.

    I'm certainly curious as to the cause as I haven't seen a problem like this before with Moneydance.


  15. 15 Posted by hleofxquotes on 21 Mar, 2019 05:44 PM

    hleofxquotes's Avatar

    My input. From log file i4j_nlog_1.txt. The first error occurs here

    [26:68] Trying c:\users\doug\appdata\local\temp\e4j5169.tmp_dir1552625080\jre\bin\server\jvm.dll (exists 1)
    [38:323] Failed with error code 127
    What interesting is that a bit earlier than that when the installer try to check the Java version using the exe file "java.exe" it appears to be able to do succesfully
    [22:448] LoadDLL (0, C:\Users\Doug\AppData\Local\Temp\e4j5169.tmp_dir1552625080\jre, 0)
    [22:448] Got JRE location C:\Users\Doug\AppData\Local\Temp\e4j5169.tmp_dir1552625080\jre (java exe: 0)
    [22:448] MinVersion: 11, MaxVersion:
    [22:448] checkJavaExe (c:\users\doug\appdata\local\temp\e4j5169.tmp_dir1552625080\jre\bin\java.exe, [out], 1, 0, 1)
    [22:448] file exists
    [22:448] tempPath is C:\Users\Doug\AppData\Local\Temp\
    [22:448] tempFile is C:\Users\Doug\AppData\Local\Temp\e4jA534.tmp
    [26:52] Exit Code 0
    [26:52] Java version: 11.0.2
    [26:52] got version from execution 11.0.2
    [26:52] checkJavaExe returning 1
    My suggestion (which will cause change to your system. So take precaution such as do backup, system snapshot ... so that you can get back to where you are currently as needed):
    • Manually install JDK 11 (independent of MD embedded JDK).
    • If you can install and run a simple Java program using JDK 11, then the problem can be isolated to MD's installer (or embedded JDK)
    • If you cannot install or can install but cannot run JDK 11, the problem is likely to be system related.

    You can get JDK 11 from here:

    Good luck

  16. 16 Posted by hleofxquotes on 21 Mar, 2019 05:57 PM

    hleofxquotes's Avatar

    [38:323] Failed with error code 127

    I think 127 error code is

    127 (0x7F)
    The specified procedure could not be found.

    Shot in the dark - something to try: shorten your PATH value which currently is

    C:\Users\Doug\AppData\Local\Temp\e4j9EDF.tmp_dir1553142805\user;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files\Broadcom\Broadcom 802.11\Driver;C:\Program Files (x86)\Common Files\Roxio Shared\DLLShared\;C:\Program Files (x86)\Common Files\Roxio Shared\DLLShared\;C:\Program Files (x86)\Common Files\Roxio Shared\12.0\DLLShared\;C:\Program Files (x86)\QuickTime\QTSystem\

    In particular, look like there are duplicated entries (... Roxio ...) that you can remove.

    See if a shorter PATH will help.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Install_Errors.docx 60.4 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 May, 2019 10:00 PM
19 May, 2019 09:09 PM
19 May, 2019 08:36 PM
19 May, 2019 08:30 PM
19 May, 2019 08:17 PM