Importing from gnucash

me's Avatar


18 Mar, 2016 10:20 PM

Hi I'm looking at switching from gnucash. My starting point has been to use: to produce an xml file. I've tried calling it .md and .moneydance But I can't find a way to open these.

I did wonder if I needed to try and open it in an old version, so I downloaded the 2012 version, but when I opened I get an error:
"Error loading extension: java.util.MissingResourceException: Can't find bundle for base name com.moneydance.modules.features.txtimport.Resources, locale en_US"

Wondering if there is any way of opening the XML and getting it into the current version>

  1. 1 Posted by Ben Spencer on 18 Mar, 2016 11:11 PM

    Ben Spencer's Avatar

    Hi Chris

    I had not heard of this GnuCash to Moneydance XML converter before and have no knowledge of how well it works. The current version of Moneydance does not support importing the old Moneydance XML files. The most recent version that did was I believe MD2011. You can download MD2011 from the link below:

    Ben Spencer
    Infinite Kind Support

  2. 2 Posted by me on 18 Mar, 2016 11:42 PM

    me's Avatar

    Brilliant, that worked very well. (I just needed to modify the convertor
    to set the currency to pounds).

    Is there any way of requesting a licence for the 2011 version so that I can
    import all my transactions. (I bought a 2016 licence earlier today)


  3. 3 Posted by Ben Spencer on 19 Mar, 2016 12:22 AM

    Ben Spencer's Avatar

    You shouldn't need a license to import the data from your xml file into MD2011. Once you have everything in MD2011 you can install and run MD2015 (the latest version) and it will automatically convert your data into the new format.

    Ben Spencer
    Infinite Kind Support

  4. System closed this discussion on 18 Jun, 2016 12:30 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac