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Chapter 1: Introduction
Moving from one Personal Financial Management platform to another is not simply a
matter of installing the new application opening your exist data files and carrying on, 
there is no standard file format. Vendors also do not make it easy to move, tools just 
do not exist specifically to facilitate migrating. Moneydance has a range of tools that 
allow importing from the various file types that are used, but a lot of the limitations 
come back to what you can extract from a program and in what format. Think just 
how hard and time consuming it can be to move your accounts from one bank to 
another and on the surface this should be something that is not that hard to do,  
migrating your data between software products is much more involved.

The bottom line is that moving between platforms is a Migration, it is not that hard 
but it can be time consuming, it needs to be done in a methodical fashion to 
maximize the amount of data you can bring over and its accuracy. With the tools we 
have today we cannot transfer absolutely everything, I’m not confident we will ever 
be able to do this. So cleanup work will be required, you may need to setup some 
things (e.g. reminders) and to make some corrections (e.g. initial balances). The 
degree of this is difficult to predict. If you just have banking type of accounts it is 
generally minimal for most people. If you have investment accounts the degree of 
work increases as the complexity increases, but it can also depend on what software
you are migrating away from.

If you are upgrading from one version of Moneydance to a newer version of 
Moneydance do not use this guide instead refer to the Installation & Upgrade Guide.

This manual will explore various approaches to migrating from other programs.

The formats that are available to us usually fall into one of three groups:

• OFX/QFX/OFC

• QIF

• CSV

Open Financial Exchange (OFX), Open Financial 
Connectivity (OFC) and Quicken Financial Exchange 
(QFX) files

These formats are routinely used, and are the preferred formats, for data that is 
downloaded from Financial Institutions for importing into financial software. For this 
purpose it has one significant advantage, each transaction has a unique Transaction 
ID this can be used to prevent duplicate transactions.

The format has one significant flaw, if it is used to migrate from one financial program
to another, it lacks support for categories. You do not have an expectation of there 
being category information when you download data from a bank because the bank 
will not necessarily have any idea about how transactions are to be categorized, but 
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when migrating from another program you expect there will be category information 
already defined for each transaction and this is data you want to migrate.

This lack of support for categories means that these formats are not particularly 
suitable as a means of transferring data between program.

Quicken Interchange Format (QIF)

In the financial world QIF is a very old format, it was originally developed as a format 
that support could use to unload and load data into a program. It was pressed into 
use for the download of data as there was really nothing else available at the time 
that was suitable. It really is quite a simple, yet flexible format. For the purpose of 
downloading data it lacks Transaction IDs which is a drawback, this deficiency is not 
surprising given the reason the format was developed.

This format does support Categories and is an easy format to write, hence its 
suitability for use as a migration format.

The format is not perfect however, it only has provision for the actual raw 
transactions, it does not support things like Reminders for instance.

Comma Separated Value Files (CSV)

The CSV format is the simplest of all the formats here, if you do basic formatting of a
CSV file what you have is a table of data.

There are a number of factors as to how useful a CSV file can be for migrating data. 
The first is that there must be absolute consistency in the format. It is a table with 
columns, a specific column must always contain the same type of data, for example 
there is expected to be a date for each transaction, the date must always be in a 
specific column and that column must always contain date values and nothing else. 
While this may seem obvious it has been noted that the CSV files produced by some
programs has data that moves around, for example it was noted that with one 
program if a record did not have an entry in a particular field then the following fields 
are moved one column to the left and thus destroyed the consistency of the table.

If you have a properly laid out CSV file Moneydance can import the data into non-
investment accounts. 

During the import you will assign what column in the CSV file matches what field in 
the Account in Moneydance.

A simple table structure is not compatible with investment accounts.

Summary

For data that is routinely downloaded from a financial institution the preferred format 
is OFX/QFX/OFC, followed by QIF then CSV.
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On the other hand when performing a migration we have a different order of 
preferred formats. QIF is preferred. Good CSV files would be the next in preference 
for non-investment accounts and with OFX/QFX/OFC rounding out the list.

The conclusions given are about what format is best suited to the job that needs to 
be done.
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Chapter 2: Migrating Your Data From Other 
Programs
Migrating from Quicken and Microsoft Money are the programs that we will 
concentrate on here, these are the two most seen products in the Moneydance 
forums, and they both support the QIF format. We have however included 
information on other programs that have been encountered, and where possible, 
state what formats they support.

If you intend to import a large body of data (such as several years' worth of financial 
history) and/or if your QIF file includes a large number of split transactions or 
investment-related transactions, we strongly advise the following:

1. Make certain you are using the most recent version of Moneydance.

2. Try to create an account structure which is identical in terms of account 
names to what you had in your old software. The approaches taken here 
should assist with this. This should cut down on the number of new accounts 
generated by the import process. 

3. When importing you may need to adjust the date format you are using, as the 
exported date format may not be the same as the one you have chosen to 
use in your Moneydance data file.  Those using software in America should try
the MMDDYY date format first, those using  outside of the US should use the 
most common date format for their location.

Please note that Moneydance cannot directly open data files from most vendors 
products including Quicken and Microsoft Money.  Most programs use proprietary 
closed data file formats.  Moneydance itself has used an XML format, however since 
Moneydance 2015 the data is always encrypted hence only Moneydance can read 
its own files.  Moneydance can import the QIF files which other programs are 
generally able to export.  These files will make it possible to transfer most of your 
account information and transactions into Moneydance.  It is not possible to 
export/import your payee lists, reminders, recurring online bill payments, or recurring 
transactions.  If your file contains stock splits in investment accounts, this information
may not transfer properly in the QIF file and will need to be re-entered. 

As outlined earlier the QIF format was developed for use in support, it was intended 
to be used to be able to export data from a file and then be able to import it back in, 
so it could be used, for example, to correct data issues, but you would be working 
with an existing structure.  Being intended for such an environment QIF files do not 
directly define the structure, they can infer what the structure should be or is likely to 
be, however there are ambiguities, these are not a problem when working with a 
defined Account/Category structure but can be when using this information to create 
a structure.  Given their heritage QIF files were never meant for transferring data 
from one program to another, but it is arguable the best format that is available and 
does work with all account types.  You will likely need to spend some time cleaning 
up when the import is complete.

9



Note:  Due to limitations in the QIF file format, it is possible that some transactions 
(especially transfers between accounts) could be duplicated during the import 
process.  This is more likely if you exported to multiple QIF files or if you have 
accounts in multiple currencies. Moneydance has for many years tried to de-
duplicate transfers, as long as the date, amount and destination/source accounts 
exactly match. If duplicates occur these are the first things to check. If they continue 
to be a significant problem there are some techniques that can help to minimize 
these. If the balances in Moneydance and your other application do not match up 
exactly then it may be necessary to find and remove some transactions.  The Find 
and Replace extension can be very helpful in doing this. Data with multiple 
currencies are likely to be one of the biggest causes of problems. QIF files do not 
contain any currency or exchange rate data, amounts are just a number, hence why 
transfers between accounts in different currencies can cause duplicates to occur, 
effectively a transaction in each currency. If you are in this situation these 
transactions will have to be fixed by hand.
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Chapter 3: Exporting Data From Other Programs
This chapter details specific information on exporting data from the indicated 
programs. We do not have specific experience of all the programs included here, the
inclusion of some programs has been based on questions raised on the forums and 
research that has subsequently been carried out, it has not always been possible to 
obtain exported data from the programs to test their import into Moneydance.

We generally look to use QIF data wherever possible, for the reasons outlined 
earlier, while this format largely only contains raw transaction information it is still 
overall the best format that is available and can be imported into all Account types in 
Moneydance.

If all you can export are CSV files it is possible to import this data into non-
investment accounts as has already been stated.

Quicken 

Quicken stores its data in a proprietary closed data format using files with a QDF 
extension. Using a proprietary closed format means that the application itself must 
be used to export the data, it is not possible for Moneydance or other software to 
read the files directly.

It is recommended that you read this entire section before starting the import 
process.

Therefore transferring financial data from Quicken into Moneydance requires that the
data first be exported from Quicken using Quicken. Given the possible export 
formats the best one to use is QIF, this format is far from perfect but overall it is the 
best that is available.  A good approach to take when exporting your data from 
Quicken is to create a folder specifically for the data you are transferring from 
Quicken to Moneydance. 

Quicken also support a format called QXF (Quicken Transfer Format). This format is 
used to transfer data between different versions of Quicken and is a proprietary 
format that Moneydance cannot read. The export of financial data from Quicken 
using the QXF file format is limited to the accounts, transactions, scheduled 
transactions, categories, and tags of non-investment and non-business accounts, 
hence it is also a limited format in terms of the data it contains.

While some versions of Quicken for Mac do not export QIF files, they often support 
exporting QMTF files (Quicken Mac Transfer Format) which can be imported into 
Moneydance, QMTF files are very similar to QIF files, they appear to use a subset of
the QIF specification. See the section on Quicken for Mac for more details.

It is highly recommended that you export all your Quicken data into a single QIF file 
whenever possible, this helps Moneydance in that by having all the data in one file it 
can help to avoid the creation of duplicate entries. Historically the one exception to 
this is if you have accounts in more than one currency (US dollars, Canadian dollars,
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Euros, etc) in Quicken, testing has shown that there is a way to address this when all
data is in a single file.

If you do have accounts in multiple QIF files (perhaps your version of Quicken does 
not permit exporting into a single QIF file) you should follow the instructions for 
Exporting Data from Quicken Into Multiple QIF Files.

After exporting your data into the QIF file is it a good idea to inspect the contents of 
the file. Open the QIF file in a text editor or a word processor. The first thing to look 
for is to see if the data looks right, do the transactions look familiar to you, just ignore
the first character on each line these are QIF instructions.  Next you are looking for 
the date format used in the file, some of the generally seen ones are: 

• D25/03'2019 (Day/Month’Year)

• D15/04/2019 (Day/Month/Year)

• D5/17'19 (Month/Day’Year)

• D05/31/2017 (Month/Day/Year)

Other formats may be seen. Take a note of the format, also take a note of the 
character that is used to denote decimals, you will need this information during the 
import, close the file without saving it.

Moneydance can migrate your data from other applications without a multi-step 
process or dealing with complicated settings. Moneydance analyzes the file to figure 
out the best way to import the data, while in this guide we do make use of the new 
capabilities in order to reduce the complexity of the import, we have taken an 
approach that allows us to take extra steps if needed.

Specifically it is in the area of foreign currency accounts where we have introduced 
some more steps. Given that QIF files do not have any currency information in them 
we need to set the currency on any account that does not use the base currency, as 
the currency cannot be changed after the account has data in it we have to do it 
before any data importation. We also have to ensure that exchange rates are 
available in Moneydance before importing the transactions. While it is extra work to 
do during the import it is felt this far outweighs the clean up effort that may be 
required otherwise.

Exporting Quicken Data into a Single QIF File

The approach adopted here is to create a new empty data set and work with that, we
have chosen that approach as it gives us the flexibility to deal with different 
situations.
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1. First you will need to export your data from Quicken in QIF format. Open your 
data file in Quicken, then in the menu bar select File → Export and follow to 
instructions to export all of your data in a single QIF file. You may need to 
reactivate and include closed accounts if they could have an impact on a 
currently active account, this would normally be through transfer transactions.

Export options can vary between versions of Quicken, some versions will give
an Export options window similar to what is shown below.

Transactions Moneydance definitely uses these 

Account Lists Testing has shown that the Moneydance 
importer can use data from an Account list.

Category Lists Testing has shown that the Moneydance 
importer can use data from a Category list.

Memorized Payees Moneydance does not use these. Moneydance 
does not keep such a list.

Security List Testing has shown that the Moneydance 
importer can use data from a Security list.

Business List Items are of no use to Moneydance

Moneydance can build the accounts/categories from the transaction lists, 
historically this list was often all that was provided.
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Investigations has shown that the memorized payees list does not correspond
with the data needed for reminders.

It has been reported that Moneydance will import security price data from the 
Security List.

Based on what has been able to be found out about the Quicken lists, 
selecting all except the Memorized Payees and Business Lists for export 
would appear to be a good approach. If you should encounter any difficulties 
during the import then retrying using an export of just the Transactions would 
be the next step to take.

2. If you have accounts with currencies that are not the Primary Currency (i.e. 
they are in a foreign currency) then you can export you currency tables from 
Quicken by using the instructions given below under Obtaining Exchange 
Rates from Quicken.

Exporting Quicken Data into Multiple QIF Files

These instructions involve exporting your data into multiple QIF files, one file per 
account.  You should ONLY use these instructions if you really have to, for example if
your version of Quicken does not permit exporting into a single QIF file. 

1. First you will need to export your data from Quicken in QIF format. Open your 
data file in Quicken, then in the menu bar select File → Export → Selected 
Items to QIF.  Most versions of Quicken will permit you to export transactions 
in "Selected Accounts" - export one account at a time.  Export all accounts 
from Quicken before moving on to step 2. Note that you may also have to 
export closed inactive accounts if they have a bearing on any current account,
this would normally be through transfers between accounts, without all data 
you are likely to end up having accounts that would only contain transfer 
transactions.

2. If you have accounts with currencies that are not the Primary Currency (i.e. 
they are in a foreign currency) then you can export you currency tables from 
Quicken by using the instructions given below under Obtaining Exchange 
Rates from Quicken.

Exporting Multi Currency Data from Quicken

This section only applies if you have accounts that use a currency that is not your 
base currency.

As said before QIF file do not contain exchange rates and values in QIF files are just 
numbers, there is no indication of what currency a transaction is in, nor what 
currency an account is in, this presents a problem with multi currency data.

To overcome this limitation we need to take steps before we start importing the data. 
The first is to ensure that within Moneydance we create the account(s) in question 
with the right currency, this must be done before any transaction is imported into the 
software that will use one of these accounts. The second is to ensure that we have 
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appropriate exchange rates in Moneydance so the necessary conversion can be 
done at import time. The intention is to use Exchange Rates sourced from Quicken, 
as Quicken should have the correct rates in its history, that is the assumption being 
made here – that the Quicken rate history has the correct rate for the transactions.

This section will concentrate on extracting the rates we need from Quicken and 
importing them into Moneydance.

Obtaining Exchange Rates from Quicken

With Quicken you can only export a single currency at a time, however most users 
are likely to only be using only a few currencies so the amount of effort required 
should not be too onerous.

In Quicken perform the following steps for each currency you require:

1. Open the Tools menu. 

2. Select Currency List.

3. Click on the currency you wish to export.

4. Select the Historical Prices button from the bottom right side of the window.

5. In the window that opens, select "Print" from the menu.

6. In the Print Options window toggle the option "Export to".

You should end up with a series of Windows that look something like:
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In the ‘Export to’ field you have a number of options. The Tab-delimited disk file  
and .PRN disk file are the options of interest to us. The Tab-delimited file is Excel 
compatible as indicated. A PRN file is really a traditional CSV file which should also 
work for us. As you will need to do a little data manipulation it comes down to if one 
format works better than the other in the spreadsheet you use. The spreadsheet 
program will be used to save the data in the format that Moneydance requires.

The data you export will look in a spreadsheet something like what is shown below.

It is a very simple date and exchange rate table, this happens to be a AUD to GBP 
rate table so on 5/5/19 AUD 1.00 = GBP 0.53298 for example. This is from an 
account set where AUD is the base currency. 

Moneydance however stores Exchange rates in a different way to Quicken, so we 
will need to do a little manipulation in a spreadsheet. In simple terms Quicken holds 
this type of data in the form of:

1 unit of local currency = X units of the foreign currency
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Date Rate

5/05/2019 0.53298

8/04/2019 0.54465

6/04/2019 0.5451

2/04/2019 0.54241



Where as Moneydance holds it in the form of

X unit of local currency = 1 units of the foreign currency

Therefore the above table needs to look like:

We have also changed the header to read Close rather than Rate. This seems to be 
necessary for the importer to work. The calculation to calculate the required rate is a 
simple one, it is:

Close = 1/Rate

The CSV file we want created from this data looks like:

Date,Close

5/05/2019,1.87624301099478

8/04/2019,1.83604149453778

6/04/2019,1.83452577508714

2/04/2019,1.84362382699434

Note we have a header line but do not have quote marks around any text. We have 
used the comma as the field deliminator as is traditional with CSV files. The decimal 
point has been used in the exchange rates and the slash in dates.

How you achieve this transformation of the data is dependent on the spreadsheet 
you use, so what has been given above is what the input looks like and what output 
we need to have rather than a specific method.

Microsoft Money

Before beginning, note that Microsoft Money will not export an account that has been
closed in Microsoft Money to a QIF file. You will need to Re-open any closed 
accounts that you want to export before attempting to exporting them from Microsoft 
Money.

You need to use Microsoft Money to export your data into QIF files, one QIF file for 
each account, including any closed account that have transfers to any open 
accounts, re-open these accounts if necessary.

In Microsoft Money open the file that you want to export.

1. Select File → Export.

2. Click Loose QIF, then click OK.
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Date Close

5/05/2019 1.87624301

8/04/2019 1.83604149

6/04/2019 1.83452578

2/04/2019 1.84362383



3. In the File Name box, type a name for the account that you want to export. 
Give the files descriptive names so that you don't get confused later. 
Investment accounts will require two files, one for the investment transactions 
and one for the cash transactions. That's because Microsoft Money treats 
them as two separate accounts internally. Loan accounts cannot be exported.

4. When prompted to select the account type you want to export, click Regular 
or Investment for the account being exported, then click OK.

5. In the Account List box, click the account that you want to export, then click 
Continue.

6. When Money is finished exporting the account, click OK.  

Repeat the process steps 1 to 6 for each account.

AceMoney

AceMoney provides the capability to export data on an account by account basis 
only, there is no ability to export everything into one file. We successful exported 
AceMoney non-investment data using the following procedure and imported the 
resultant QIF files into Moneydance.

During our testing Moneydance was able to successfully de-duplicate transfers, and 
initial balance entries were set up correctly in Moneydance. 

Testing of this functionality was performed using the sample file provided along with 
a some additional manually entered transactions.

The following procedure was used to export each account. We created a new folder 
called AceMoney_migration to hold all of the data.

1. Open the register of the account
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2. Select menu item File → Export

3. Navigate to the directory where you wish to save the exported QIF file to.

By having the account register open AceMoney will set the export file name to
match the account name

4. Change the file type to QIF
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5. Ensure the correct account to export is selected and enter appropriate start and 
end dates

Repeat the above procedure for each account.

Refer to the section on Importing Multiple QIF files for the process to get the data 
into Moneydance.

There is no ability to export exchange rates from AceMoney.
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Investment Accounts

We looked at various exports from Investment accounts. QIF exports were 
disappointing, the only type of transaction that we could detect as being close to 
useful were transfers, however even for these there was no Action, other 
transactions were nothing more than a date and an amount. 

In looking at a CSV file from an Investment account, it read as you would expect a 
statement to read, not something that you could expect to be imported into 
Investment Accounts in financial software, much, but not all, of the data was there 
but it was not in a usable structure.

We also looked at a CSV file of Investment Transactions and while initially this did 
look promising (we were thinking of using a QIF converter) on closer examination the
data is incomplete. Specifically it uses the Ticker rather than the Security Name, 
there are no transfer transactions and there are no categories. The Action given also 
does not match to what is normally accepted and the data lacks descriptions.

To somehow get something that is useful you would have to somehow bring both 
CSV files together as well as reformat and derive some data. Not a simple 
undertaking.

To see for yourself what data there is open the Investment Account register and use 
the instructions given above except select the CSV format. To generate an 
Investment transaction CSV Select the Portfolio Icon,  then select the Investment 
Transaction tab, ensure the specific account in question is selected in the side bar, 
and then use the File → Export menu item as you did before, you will only have 
selections like CSV, TXT and HTML, choose CSV. It is best to view these files in a 
spreadsheet.

At this time we do not see a usable migrating path from Investments in AceMoney to 
Moneydance using any of the data that AceMoney can provide.

Alzex Personal Finance

Alzex Personal Finance software allows you to export data to QIF (Quicken 
Interchange format), CSV (Comma separated values) and text with delimiters (tabs, 
commas, etc.).

On the main menu, click Tools > Export. This opens the window for selecting a file. 
Select the file type that you want to use for data export (QIF, CSV or TXT) from the 
drop-down list at the bottom of the window. Enter the file name and click Save. This 
opens the export settings window. Select all necessary settings and click OK.
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1. Export - Click the button to export data.

Export to QIF 

QIF files are a universally recognized standard for information exchange between 
personal finance software. However this file format is limited and not all data can be 
exported to this format, QIF files contain raw transaction information, it is however 
the best format to use for the migration of data.

1. Interval - Time interval for export. Transactions that do not fall into this time period
will not be exported.

2. Account - The program exports transactions related to this account. You can only 
extract from one account at a time.

3. Date format - Default system format is usually fine. Some program recognizes 
only one date format. In this case select from the list or enter the necessary format, 
for Moneydance any format should work.
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4. Check number - This term is not used in Alzex software. You can specify one of 
the extra fields as a check number.

5. Encoding - Encoding - ANSI or a variant of Unicode. QIF format traditionally uses 
ANSI. Some letters in ANSI files may be unreadable in a system where English is the
default language, in general you should select ANSI.

6. Export categories - QIF file may contain information not only about transactions, 
but also about categories. Tick the checkbox if you want to include categories into 
the file.

7. Export transactions - You can export only the list of categories without 
transactions.

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance.

Banktivity

Banktivity allows you to export your data to a QIF file. You can use the following 
procedure:

1. Choose File  → Export To →  Quicken Format (QIF). 

2. Enter the starting and ending date for the data you want to export. All 
transactions that fall within the range you specify will be included in the QIF 
file. By default, the starting and ending dates are set to include all transactions
in the document. 

3. Click “Continue” to proceed. 

4. On the next screen, check off the accounts you want to include in the QIF file. 

5. Once you have chosen which accounts to include, click “Continue” to 
proceed. 

6. Banktivity will prompt you to enter a name for the QIF file and to choose the 
location where it should be saved. As you cannot import payees and notes, 
you should check the box next to “Protect sensitive information“ so that these 
items are excluded.

7. Click “Export” to complete the export process. 

Note that if you choose accounts that use different currencies, Banktivity cannot 
export them into the same file. Instead, Banktivity will create multiple QIF files, one 
for each currency.

CountAbout

From information supplied by the software vendor, CountAbout can export your data 
to a CSV file and this file can be opened in a spreadsheet program. There is no 
indication that any other formats are available.
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No files produced by CountAbout are available for us to test the suitability of the files 
for importing into Moneydance. If the CSV files are well defined, clearly and 
consistently structured then there is every expectation that they could be imported 
into non-investment accounts in Moneydance.

Eqonomize

Eqonomize can export data in QIF, CSV  and HTML formats.

QIF Exports can be on an account by account basis, or all accounts.

To export the data choose the option Activate File → Export QIF File and select the 
account to export, format for dates and numbers, and filename. 

As indicted it is possible to export transactions from all accounts, multi-account QIF 
files are preferred for Moneydance so these should be created by preference. As 
always with QIF not all transaction properties are exported. 

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance.

Home Accountz

Home Accountz maintains that everything can be exported as CSV. It is not known if 
any other format are supported, however no other formats are disclosed.

From your standard reports to your custom built reports, Balances, Payees or the 
additional components can be exported.

In any table in Home Accountz, there is a floppy disc icon where you can instantly 
export the view that is set on Home Accountz, saving it to the location of your choice.
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In summary:

1. From any table, and click on the floppy disc icon with is on the far right side 
above the table.

2. Chose an appropriate folder and filename, using for the type of file: 
'Spreadsheet files (CSV)'.

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance.

Jumsoft Money

The information provided by the vendor is that account data can be exported as CSV
files on an account by account basis. There is no indication of support for an other 
formats.

To exporting data from an account to a CSV file perform the following steps:

1. Select File →  Export; 
2. Name the file and choose the location for saving, then click Save. 

This will create a CSV file with the transactions of the selected account. 

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance or if anything can be done to CSV files from 
Investment accounts to allow those to be processed in any way.

KMyMoney

With KMyMoney you can only export one account at a time to a QIF file. It is not 
possible to extract all accounts to a single QIF file.

To export one of your accounts to a QIF file, choose the Export → QIF from the File 
menu. You will be prompted for which single account to export, what file to export it 
to, and what QIF Profile to use. This is shown in the following screen image. 
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At this time the KMyMoney QIF Exporter does not support exporting of investment 
data. 

Moneyspire

Moneyspire allows you to export your data to a QIF file. 

To do this, select the File → Export QIF menu option in Moneyspire: 
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On the next screen specify the file to export your data to:

The next screen allows you to navigate to a location, once selected choose to Save.
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MoneyWell

MoneyWell allows you to export your transactions to a standard QIF format. This 
export format contains your accounts, buckets (categories), and transactions, in 
other words the core transaction information. It will not include favorites or any 
budgeting information, both of which are unsupported by the QIF format.

MoneyWell allows for the export of all accounts or a selection of accounts. For 
importing into Moneydance we recommend exporting of all accounts.

To export all accounts to a QIF file take the following steps

1. Select "All Transactions" in the Source list. 
2. Select the Cash Flow view. 
3. Click the File menu and select Export…. 
4. Choose a file name and location, then click Save. 
5. Click Export on the export progress panel. 

No files produced by this process are available to us so it is unknown how well 
structured they are and thus their suitability for importing into Moneydance.

MoneyWiz

From information supplied by the software vendor, MoneyWiz can export your data 
to CSV or PDF file. There is no indication that any other formats are available.

No files produced by MoneyWiz are available for us to test the suitability of the files 
for importing into Moneydance. If the CSV files are well defined, clearly and 
consistently structured then there is every expectation that they could be imported 
into non-investment accounts in Moneydance.

QuickBooks

Migrating from QuickBooks is a problem, Intuit does not really want you to move 
away so they do not provide the tools that readily allow it. QuickBooks is also 
primarily a business accounting program so it is not really comparable to 
Moneydance. 

QuickBooks does not allow exporting to QIF, which is the main format that is used to 
migrate between software programs. Only the Intuit Interchange Format (IIF) is 
supported.

An IIF to QIF converter will not solve the problem either, as journal entries cannot be 
exported in IIF format, only lists are exportable.

A somewhat viable way to overcome this problem is to set up a journal report, to 
show all journal entries. Print the report using the "print to file" option. Set the file 
type to Excel before printing. Rename the extension of the resulting file from PRN to 
CSV.
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The CVS importer in Moneydance may be able to handle this file but this is unknown
as we have no experience with QuickBooks and have not found any references 
about the files produced, or seen a sample from QuickBooks.

You may be able to use the XL2QIF Excel macro that is available to convert the CSV
files to QIF. The CSV file may need to be reorganized to generate the appropriate 
format for the macro to work, such as separating check accounts from term deposits,
etc. The above referenced Excel macro supports split transactions.

In summary it is likely that it would require some work to move data from QuickBooks
to any other program.

Quicken Essentials

Earlier versions of Moneydance had an option on the Welcome to Moneydance 
screen to “Migrate from Quicken Essentials”. With Quicken Essentials having been 
discontinued some time ago this option has been removed, however it is still 
possible to import this data into Moneydance. To import a Quicken Essentials data 
file from the Welcome to Moneydance screen choose the option “Import New 
Account Set” and navigate to your .quickendata file.  This should import your 
Quicken Essentials into a new Moneydance data file.

Quicken for Mac 2015/2016

Quicken 2015/2016 for Mac does not export QIF files, however it does export QMTF 
files.

QMTF files are very similar to QIF files with a different extension. To export from 
Quicken for Mac perform the following procedure:

1. From Quicken, select Export and choose the QMTF file format or 'Quicken 
2007 Format'.

2. When selecting the "Export Options", choose the export date range, and 
select 'Next'.

3. Enter a name for your exported data and select a location on your system to 
save the file.

4. Once exported you should locate the QMTF file at the saved location.

5. You can rename the file so that it ends with the .QIF file extension, rather than
.QMTF

Once the file has been renamed to the QIF format, you can follow the steps to import
the QIF file into Moneydance.

It should be noted that QMTF files do not support all account types fully, and 
Investment accounts do not transfer correctly.
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Reckon Personal Plus

Reckon Personal Plus can be thought of as an Australian version of Quicken. During 
its lifetime the software has gone by various names, initial it was called Quicken 
which reflected its heritage, it has also been known as Reckon Accounts Personal 
and as Reckon Personal Plus.

By default, there is no export to QIF feature. If you check the menu command File →
Export there are only two entries: Desktop Super and Addresses.

If you use the key sequence <CTRL> <SHIFT> Z. You will see that there is now a 
third entry in the list, QIF File.

This is however not a permanent change it must be done every time you restart 
Reckon. From user experience this is known to work in Reckon Accounts Personal 
2015 & 2016 and in Quicken Personal Plus 2012, it may also work in other versions. 
The screen shot given below shows the effect of adding the QIF option.

A restriction still exists that you can only export to QIF one account at a time. It is not
possible to select all accounts and then export all to a single QIF file.

Exporting Reckon Data into Multiple QIF Files

Given the export restrictions from Reckon, these instructions involve exporting your 
data into multiple QIF files, one file per account.  

1. First you will need to export your data from Reckon in QIF format. Open your 
data file in Reckon, then in the menu bar select File → Export → Selected 
Items to QIF (use the above instructions to add the QIF export option).  Export
all accounts from Quicken before moving on to step 2. Note that you may also
have to export closed inactive accounts if they have a bearing on any current 
account, this would normally be through transfers between accounts, without 
all data you are likely to end up having accounts that would only contain 
transfer transactions.

30



2. If you have accounts with currencies that are not the Primary Currency (i.e. 
they are in a foreign currency) then you can export you currency tables from 
Quicken by using the instructions given below under Obtaining Exchange 
Rates from Reckon.

Exporting Multi Currency Data from Reckon

What you see here are the same instructions as for Quicken. They have been 
reprinted here in order to have a self contained section on Reckon.

This section only applies if you have accounts that use a currency that is not your 
base currency. 

As said before QIF files do not contain exchange rates and values in QIF files are 
just numbers, there is no indication of what currency a transaction is in, nor what 
currency an account is in, this presents a problem with multi currency data.

To overcome this limitation we need to take steps before we start importing the data. 
The first is to ensure that within Moneydance we create the account(s) in question 
with the right currency, this must be done before any transaction is imported into the 
software that will use one of these accounts. The second is to ensure that we have 
appropriate exchange rates in Moneydance so the necessary conversion can be 
done at import time. The intention is to use Exchange Rates sourced from Reckon, 
as Reckon should have the correct rates in its history, that is the assumption being 
made here – that the Reckon rate history has the correct rate for the transactions.

This section will concentrate on extracting the rates we need from Reckon and 
importing them into Moneydance.

Obtaining Exchange Rates from Reckon

With Reckon you can only export a single currency at a time, however most users 
are likely to only be using only a few currencies so the amount of effort required 
should not be too onerous.

In Reckon perform the following steps for each currency you require:

1. Open the Tools menu. 

2. Select Currency List.

3. Click on the currency you wish to export.

4. Select the Historical Prices button from the bottom right side of the window.

5. In the window that opens, select "Print" from the menu.

6. In the Print Options window toggle the option "Export to".

You should end up with a series of Windows that look something like:
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In the ‘Export to’ field you have a number of options. The Tab-delimited disk file  
and .PRN disk file are the options of interest to us. The Tab-delimited file is Excel 
compatible as indicated. A PRN file is really a traditional CSV file which should also 
work for us. As you will need to do a little data manipulation it comes down to if one 
format works better than the other in the spreadsheet you use. The spreadsheet 
program will be used to save the data in the format that Moneydance requires.

The data you export will look in a spreadsheet something like what is shown below.

It is a very simple date and exchange rate table, this happens to be a AUD to GBP 
rate table so on 5/5/19 AUD 1.00 = GBP 0.53298 for example. This is from an 
account set where AUD is the base currency. 

Moneydance however stores Exchange rates in a different way to Reckon, so we will
need to do a little manipulation in a spreadsheet. In simple terms Reckon holds this 
type of data in the form of:

1 unit of local currency = X units of the foreign currency
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Date Rate

5/05/2019 0.53298

8/04/2019 0.54465

6/04/2019 0.5451

2/04/2019 0.54241



Where as Moneydance holds it in the form of

X unit of local currency = 1 units of the foreign currency

Therefore the above table needs to look like:

We have also changed the header to read Close rather than Rate. This seems to be 
necessary for the importer to work. The calculation to calculate the required rate is a 
simple one, it is:

Close = 1/Rate

The CSV file we want created from this data looks like:

Date,Close

5/05/2019,1.87624301099478

8/04/2019,1.83604149453778

6/04/2019,1.83452577508714

2/04/2019,1.84362382699434

Note we have a header line but do not have quote marks around any text. We have 
used the comma as the field deliminator as is traditional with CSV files. The decimal 
point has been used in the exchange rates and the slash in dates.

How you achieve this transformation of the data is dependent on the spreadsheet 
you use, so what has been given above is what the input looks like and what output 
we need to have rather than a specific method.

Once you have your QIF file you should be able to use the instructions in the section 
on Importing Data Using Multiple QIF files to import your data into Moneydance.

See Finance

You can export transactions from See Finance to QIF or CSV files. Moneydance 
supports importing using both QIF and CSV file types but it is recommended to use 
QIF files wherever possible. The instructions provided here are for QIF files.

The following information has been extracted from See Finance documentation.

1. Select "Export" → "To QIF..." from the program's File menu. 
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Date Close

5/05/2019 1.87624301

8/04/2019 1.83604149

6/04/2019 1.83452578

2/04/2019 1.84362383



2. Select the account(s) for the export. 

3. Select the date range for the export. 

4. Click "Export" to continue with the export. 

5. Use the save panel to set the name and location for the exported QIF file. 

6. Click "Export" to export and save the QIF file. 

QIF file exports will include the list of exported accounts, the category list, the tags 
list, and the transaction lists for the exported accounts. If an investment account is 
exported then the security list and the historical prices will also be included in the 
export. 

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance.

You Need a Budget 4 (YNAB 4) 

You Need a Budget 4 for Desktop can export accounts to both QIF and CSV formats 
on an account by account basis, it can not export all accounts to the one file. 
Moneydance supports importing using both QIF and CSV file types but it is 
recommended to use QIF files wherever possible.

Before starting to export your accounts, please take a note of their Opening Balance.
YNAB does not include a transaction for the opening balance so will need this 
information when you are setting up your accounts in Moneydance. For the accounts
to come up with the right balance after the import you will need this to set the amount
of the Initial Balance.

You will need to export all accounts form YNAB and import all accounts into 
Moneydance. This is because there may transfers between accounts and without 
both accounts, balances can be thrown out.

Exporting from YNAB

1. Go to All Accounts view then File -> Export.

34



2. Choose the QIF export method.
3. You’ll be notified that all accounts have been exported as separate QIF file. 

Click Open Output Folder button to open the folder containing your files. 
They’ll be named as “My Budget-ACCOUNTNAME as of DATE.qif”. 

No files produced by this process are available to us so it is unknown how suitable 
they are for importing into Moneydance.

Other Programs

Any software that can export data into either a single or into multiple QIF files should 
provide data that can be imported into Moneydance, as the QIF format is a defined 
standard. Information on exporting from the software programs provided here can 
provide some indication of what you need to do and hence some general guidelines 
that you can make use of.

As stated in the introduction QIF data is really just the raw transaction information, 
but it will usually represent the bulk of the information. It is generally a reasonably 
complete list of transactions in bank type accounts, but will usually be inadequate for
Investment accounts.

Some software can only export data in the CSV format, a section has been included 
in the Import chapter on importing data from CSV files into non-Investment accounts.

As has been discussed CSV files are really just a table of information, non 
Investment accounts in Moneydance are structured in such a way that allows the 
table of CSV data to be mapped to columns in the register and thus imported.

Investment accounts however, while they look like a simple table, are not. What you 
need to enter for an investment transaction is not dependent on what data appears 
where, it is driven by the Action field, which has a number of defined actions. Specific
actions determine what fields are active, what fields are mandatory and which are 
optional. The way these accounts work do not make them compatible with a simple 
mapping of data between the register and columns in a table.

We have not discussed the use of OFX/QFX/OFC files at all in these pages. The use
of these formats appears to have been limited to the financial institutions using these
formats for the transfer of information between their servers and personal financial 
software programs. We have seen no evidence that personal financial software 
programs are capable of exporting data in any of these formats.
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Chapter 4: Importing Data Into Moneydance
This chapter details importing data into Moneydance that you have exported from 
other programs. We have documented two main methods and various techniques 
that can be used during your migration.

Before you commence the import it can be useful to ascertain the date format that 
was used when writing the QIF files, if you did not do this while exporting your data 
you now do this by opening one of the QIF files and record what the date format is.

For the migration detailed here we are importing the data into a brand new Data Set. 
To get to this stage follow the instructions given below:

1. If this is the first time you have run Moneydance you will be presented with 3 
options within the 'Welcome to Moneydance' window. Click the button that 
says "Create a new account set".

2. If you have created a Data Set before, create a new, empty data set before 
importing by using the menu item File → New. Follow the prompts to create a 
new file (Data Set) and click NEXT. Type in an Account Set Name (Data Set) 
and click NEXT. Set the Primary Currency (base currency), as necessary. 
Leave the File Type as “Standard Account set”, click FINISH.

Importing Exchange Rates into Moneydance

Before we start to import transaction data if you have been using multiple currencies 
you should take steps to get the necessary rates into Moneydance. The reason is 
that there are no rates in the imported transaction data, if the rates are present 
during the import transfers between accounts in different currencies should be 
properly handled.  If they are not you are likely to get duplicate transactions with 
different amounts, a transaction with an amount in each currency.

Moneydance can import CSV files containing Exchange Rates if they have the 
following format:

Date,Close

5/05/2019,1.87624301099478

8/04/2019,1.83604149453778

6/04/2019,1.83452577508714

2/04/2019,1.84362382699434

The header line is required.

To import each currency you have into Moneydance you can use the following 
method.

1. Follow the menu path Tools → Currency to open the Edit 
Currencies/Exchange Rate Window.

2. Double Click on one of the currencies you have rates to load for.
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3. Select the IMPORT button in the Currency/Security History window. 

4. Select the ‘Import from File’ option and click on Import.

5. In the Explorer Window select the CSV file to import.

6. Select OK and the data should import.

You need to exit the edit window and renter the screen to see the rates that were 
added.

Repeat steps 1-6 for each currency needed.

Currencies Available During Import

During the import process Moneydance has the ability to create accounts, however 
there is a notable restriction in this when you have multiple currencies. By default the
initial currency offered is your base currency, and, by the default, the following 6 
currencies are shown in the list:

• British Pound
• Canadian Dollar
• Chinese ‘Yuan’ Renminbi
• Euro
• Japanese Yen
• US Dollar

To have other currencies available in the list you must take action before you start 
the import. Ensure the currency is set to “Display on the Summary page”.  To do this 
take the menu option: Tools → Currencies, Select a currency and double click on it, 
on the dialogue that appears select the Edit button next to the currency name and on
the pop up that appears check on Show on Summary Page.

Importing Data From a Single QIF File

1. If this is the first time you have run Moneydance you will be presented with 3 
options within the 'Welcome to Moneydance' window. Click the button that 
says "Create a new account set".

2. If you have created a Data Set before, create a new, empty data set before 
importing by using the menu item File → New. Follow the prompts to create a 
new file (Data Set) and click NEXT. Type in an Account Set Name (Data Set) 
and click NEXT. Set the Primary Currency (base currency), as necessary. 
Leave the File Type as “Standard Account set”, click FINISH.

3. To import your QIF file use the menu option File → Import.

4. A file browser will be displayed. Navigate to your QIF file, select the file, and 
click "OK".

5. The "Import QIF File" window will appear, it should look something like we 
have below.
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6. Moneydance should automatically detect the settings used within your file. 

This is where the date format and decimal character you noted from the QIF 
file come into play, compare them to what the above screen shows, they 
should be the same.

You will see that it has suggested various account that will be created, it has 
done this based on information within the file. In the above listing is also the 
name “Imported Bank Account”. This is a name you may or may not see in an 
Import, it should be most commonly seen when you are doing an import 
without a name field in the file.

You can see we have already changed the currency of accounts where 
necessary to what they need to be, it is important to do this at this stage. We 
have also set the account types correctly.

7. Then choose 'Import' and your wait for your data to populate into the program.

8. It may take a few minutes for the import to complete - this time will vary 
depending on the size and complexity of the file being imported.
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Now is the time to check how the import went. If after importing data your balances 
are incorrect, the most likely cause is the QIF file did not include an initial balance 
transfer as the first transaction for the account. You will need to set the initial balance
on your accounts in Moneydance manually.

Importing Data From Multiple QIF Files

1. In the menu bar go to File → Import.

2. A file browser will be displayed. Use it to locate one of your QIF files. It is best 
to import the QIF file for your most complex account(s) (such as your primary 
checking account) first, doing this is likely to cause the creation of most of the 
accounts because of transfers.  Select the file and Click "OK".

3. The "Import QIF File" window will appear.  

4. Moneydance should automatically detect the settings used within your file. 

This is where the date format and decimal character you noted from the QIF 
file come into play, compare them to what the above screen shows, they 
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should be the same.

You will see that it has suggested various account that will be created, it has 
done this based on the transfers in the account, given it is pulling the names 
from the QIF file they should be correct. You can see we have already 
changed the currency of the accounts as necessary to what they need to be, it
is important to do this at this stage. We have also set the account types as 
needed..

You may see a checkbox towards the bottom of the window (not shown) that 
says “File was downloaded”. You should ensure that this box is unchecked. 
This options is an indication that Moneydance is not sure if the data came 
from another financial program or if it was downloaded from a Financial 
Institution

5. In the above listing is also the name “Imported Bank Account” and it is 
highlighted that this is the currently selected account for the imported data. 
This is a name you may or may not see in an Import. It is not unusual for a 
QIF file containing data for a single account to not have a name flag in the file 
and in that case this default account name is used.

6. In his case the QIF file did not have a name flag so select the, “Imported Bank
Account”. Click OK.

7. After performing the import you need to rename the account to be the same 
as the account name in your old software before you import any more 
accounts.

8. You may find that importing multiple QIF file creates duplicate transactions, 
especially those transactions which record transfers between accounts.  If no 
action is taken you will need to manually delete these duplicate transactions.

An approach you could take is before you perform an import into an account 
is to select all transactions in the account and to delete them, as you are 
doing the initial populating of the data any transactions that are in account are
the result of transfers, which will be reinstated when you perform the import 
into the specific account.

9. You will basically be repeating the above steps for each account you want to 
import, but with some differences. After you have imported your first account it
is likely that many of your other accounts would have been created, if it has 
then you would select that account while performing the import, if it is a new 
account you will likely see the “Imported Bank Account” name again and have 
to check the account type and currency and correct as needed then rename 
this account after the import.

This is the reason we try to use a core account for the first import, as that is 
likely to have the most transfers with other accounts.
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When importing the cash portion of Investment accounts from Microsoft Money 
remember to select the "Bank" account when importing the cash portion of the 
investment accounts.

After completing the import it is time to check to data. Many issues are discussed in 
the section on Common Issues when Importing Data from other Personal 
Finance Programs.

Importing Data From CSV Files

In Moneydance, CSV files can be imported into all account types with the exception 
of Investment Accounts. The table like structure of CSV files does not mesh with the 
way Investment Accounts work in Moneydance.

The CSV (comma separated values) format is essentially a table of rows and 
columns, like a spreadsheet. It is very versatile but is not specifically designed to 
contain financial information.

While the versatility of the CSV format is a strength it is also a weakness as there is 
no standard way for a financial institution to provide data in such a file. There is no 
standard order for the columns in a CSV file, what data is to be included in any 
column or names for those columns.

As a result of this the import process for CSV files is much more involved than any of
the other formats used here.

Moneydance provides two tools for importing CSV type files. The first is the inbuilt 
importer. The other is the Text File Importer extension. We will only concern 
ourselves with the inbuilt importer in this document. Details on the Text File Importer 
are provided in the Moneydance User Guide.

Importing CSV Files Using the Inbuilt Importer

Given the data in the import will not have details of the account it will be necessary to
create the account before you import the data, also you will have a separate CSV file
for each account you are to import.

Navigate to File → Import, then select the CSV file you would like to import.

You can then choose the import settings.

1. Specify the account you would like to import data into, this will be one of the 
accounts you have created.

2. Field Delimiter is the character that is used in your CSV file to separate the 
fields. Comma is quite common and so is tab, but if you are using something 
different you can specify that as well. If you are unsure, select comma.

3. You may also need to change the date format to the format used within the 
file, this is not the format used in Moneydance it relates to the format within 
the CSV file.
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4. Then specify either a period '.' or comma ',' as the decimal used in the file and
click Next. If the decimal used is a comma then the field delimiter cannot also 
be the comma.

5. You may also choose to automatically merge duplicate transactions.

The next window displays a list of fields. Each of these fields represents a column in 
the CSV file.

E.g. "Field 1" is the first, left most column in the file. "Field 2" is column 2, to the right
of the first column, and so on...

The inbuilt CSV importer has the ability to import files that have amounts in a single 
field with the sign differentiating if it is a debit or credit, us the ‘Amount’ selection if 
this is the case.
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You need to select the Moneydance transaction field that corresponds with the 
column in the CSV file.

To do this we suggest opening your CSV file in a spreadsheet program to see which 
column is which, and use that as a reference to match the different field values to the
corresponding columns in the CSV file.

Use the "More Fields" and "Fewer Fields" buttons to adjust the number of fields to 
import, corresponding to the number of columns in your CSV file.

It is preferable to remove any unnecessary fields, rather than assigning as 'Ignore'.
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Click "Finish" to import the file.
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Chapter 5: Common Issues When Importing Data 
From Other Personal Finance Programs
What is given below are some of the more common issues encountered when 
migrating data from other finance programs.

Common Problems with QIF Data

This section deals with some specific problems encountered when import QIF files,

Cross-currency Transfers are all Using the Wrong Exchange Rates.

Unfortunately, QIF files do not contain any currency or exchange rate information. 
Hence if no action is taken Moneydance uses the current rate on all foreign currency 
transfers or a value of 1 for the exchange rate. The method outlined in this guide will 
give the correct transactions if the supplied exchange rates are correct. You are likely
to get duplicates for every foreign currency transfer if data is just imported because 
the amounts are different on each side and Moneydance can't match them up.  If you
have a lot of foreign currency transfers and cannot get correct rates and you want to 
move to any other personal finance program you may want to consider starting your 
data set from the beginning of the year rather than trying to import all of your data.

The Dates on Imported Transactions are Incorrect

The QIF file can have dates in one of 3 different formats. The QIF file doesn't tell 
Moneydance which format it is using. The date format used in the QIF file is not 
necessarily the same as the date format the user had specified for display purposes 
in the old software. The Moneydance QIF import window has a "Date Format" option 
and gives a suggest format based on what it has analyzed from the import file. You 
can open the QIF file in a text editor as suggested and see what the correct format 
is.

Some of the Account Balances are Incorrect

If after importing data your balances are incorrect, one of the most likely causes is 
that the QIF file did not include an initial balance transfer as the first transaction for 
the account. You will need to set the initial balance on your accounts in Moneydance 
manually. You may know the initial balance amount, or Moneydance can easily 
calculate the appropriate initial balance for each account.

1. First open the account register in question by clicking on the account in the 
Moneydance side bar or Moneydance Summary.

2. Next, select Account → Edit Account.  If you know the appropriate Initial 
Balance enter the amount and click "Ok". (If not, go to step 3).  Repeat for 
each account.

3. Moneydance can calculate your Initial Balance.  For example if your current 
checking account balance is $200, and the balance shown in Moneydance is 
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$27.65, then enter 200-27.65 (use the minus sign) in the Initial Balance field 
and hit enter.  Moneydance will automatically calculate the proper Initial 
Balance.  Repeat for each account.

There are Accounts/Categories in MD with x's at the end of the 
Name

Some instances of these occurring are the result of hidden categories that some 
programs use behind the scenes for various reasons, and it includes them in the 
export. Some might be used for the initial balance transfer. Some programs also 
have the ability to have entries in an account where the source of the funds is the 
very same account that the entry is in. Moneydance follows the rules of Double Entry
Accounting and what other software may be doing is invalid because of this, hence 
the creation of an Account or Category with an x at the end of the name.

In some instances these accounts/categories can safely be deleted, in others 
however you should look at the transactions inside the account/category to 
determine what needs to be done before deleting it, in some cases it may be 
appropriate to change the initial balance of an account, in others an appropriate 
home could need to be found for the transaction.

Investment Accounts are Messed Up

Investment accounts are where we see the most work being required. These are the 
most complex accounts and there are vast differences between software programs 
in terms of capability, but in also the way things are done.

Some of the issues you may need to address include:

• If you have stock splits in your accounts these may not have transferred to 
Moneydance and may need to be recreated.

• Return of Capital/Capital Calls are not supported in Moneydance. Their 
impact can only be partially reflected.

• Lot Matching data may not be in the QIF file. While Moneydance will be able 
to determine the purchased lots, it may not be able to link sales back to these 
lots based on the QIF data, so they need to be reassigned in Moneydance.

• Moneydance does not have add/remove share functions they need to be 
restructured as buy/sell transactions.

• There are actions that are all similar to each other in some programs and they
differ in simple things like forcing category assignments. Moneydance uses 
one action type with flexible assignment of the category. This particular issue 
can be often seen in Quicken data.

This is not an exhaustive listing.

In some cases an effective approach to reducing some of the problems is to do 
some pre-processing of the QIF files before importing. Some problems for example 
may be addressed by editing the QIF file and performing some global substitutions. 
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In other cases you may need to try and get specific help from members on the 
forum.

Reminders did not Transfer

Unfortunately reminders are not supported in QIF files and there is no way of 
exporting them from most programs.

Some of the Imported Accounts are not in the Side Bar

This is often seen, simply use the “+” at the bottom of the side bar to added them in.

The Value of the Investments is Wrong

With investment accounts, QIF files do not always carry security prices other than 
the buy or sell price associated with each transaction, so investment account values 
may be wrong until you update with current security prices.

Problems with CSV Data

If the data has imported, but the information displayed is incorrect (e.g. dates are 
wrong) then it is possible the wrong settings were selected during the import 
process.

Wrong settings are the most common cause of issues, as indicated wrong date 
formats are a common issue, but also things like assign the wrong field to the wrong 
column in the CSV data.

You can create a new dummy account by selecting Account → New Account. Using 
this new account will allow you to test the import settings, until you find the correct 
settings to use. When you are done, you can delete the 'Test' account without 
affecting your other accounts or balances, if you prefer you could create a test data 
set for your testing.

Once you have determined the correct settings you can proceed to import your data 
into the correct account/data set, using the settings you have identified.

The ability to import CSV data into Moneydance is directly tied to the structure of the 
CSV file. A badly formatted CSV file, and these are not hard to find, will make the 
task very difficult if not impossible.
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Chapter 6: Post Import Tasks
Once you have imported your data and everything is correct then you can consider 
some general tasks that you may need or want to do. The intention here is to 
highlight some things you may wish to do rather than how to do it, the User Guide 
provides specific information on performing the tasks mentioned here.

• Renaming accounts/categories to something more suitable or to make 
corrections.

• Changing the category structure. This can be the category/sub-category 
structure or where a category exists in the category tree.

• Changing Parent/Child structure in the case of accounts.

Tasks for Specific Applications

The following sections provide specific post import tasks that are relevant to data 
migrated from particular applications.

Microsoft Money 

1. Move all transactions from the temporary "Bank" accounts you created as 
place holders for the cash portion of the investment accounts from Microsoft 
Money into the corresponding investment account in Moneydance. To move 
transactions, select them in the "Bank" account by selecting the first 
transaction and then using shift-click to select the last transaction. Then right 
click on the select transactions and select "Batch Change" → Account and 
specify the investment account as the destination. Delete the temporary place
holder account in Moneydance. Moneydance will contain the cash 
transactions in the root of the investment account.

2. Edit the loan accounts in Moneydance. When you click Done, Moneydance 
will ask if you want to transfer the loan balance to another account. Select Yes
and choose the account that received the loan proceeds. This may be a 
checking account if it was an unsecured loan or it may be an asset account if 
there was an asset that was acquired. You may need to modify the transaction
later to account for closing costs, etc.

3. Any accounts that are closed should be made inactive by highlighting the 
account in the side bar and clicking the menu item Account → Edit Account 
and ticking the inactive box. To remove them from the side bar right, click and 
select ‘Remove From Side Bar’.

Now the real work starts to check balances and tidy thing up. This can be especially 
true of investment accounts as not all action types are supported.
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Chapter 7: Dealing with Problematic QIF files

QIF files were never designed for migrating between different software products, the 
file format was designed to allow for the unloading and loading of raw data into an 
existing structure, it is a tool for support to use to correct various types of problem.

Even with the intended use of QIF files and their limitations it is still the best format 
that is available to us.

The intended usage of QIF files along with how some vendors have implemented 
data extracts in this format gives rise to problems, some problems are common and 
are fairly easy to correct hence the earlier chapter on common issues, other 
problems are more difficult to overcome.

This chapter is going to discuss other ways of bringing QIF data into Moneydance 
and/or the use of other tools to use in a migration.

As well as the standard Moneydance tools we will consider the use of other 
extensions in this section, extension like:

• Find and Replace

• Batch Change

• Toolbox 

Since we are dealing with a more difficult migration it will take longer and require 
more work. We cannot hope to cover all potential problems however so we will 
concentrate on showing usage of the tools and some problems they can help with.

Working with Account/Category Definition Problems

With the standard import tool you have the option to define account types. QIF files 
will often have no indication of what type of account each is so the standard import 
capability includes the ability to set what type of account each is as well as the 
currency of the account, before it does the actual data import.

Categories will sometimes have the same sort of problems, an Income category may
be defined as an Expense category for example, or in some instances a category will
be set up as an account, the standard importer cannot resolve such problems as it is
working with incomplete information.

The solution we will consider is using the Toolbox extension to force the change of 
account and/or category classifications.

It would not normally be expected that you would need to change the Account type 
since during the standard Moneydance import you can set the account type for each 
account, but as already stated misclassification of categories does occur.

Before starting you need to install the Toolbox as follows.
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Use the Extension → Manage Extension menu interface to install the Toolbox. You 
should also ensure that you create a backup before you commence using the tool.

To proceed run the toolbox extension by selecting it under the Extensions menu.

• On the Toolbox extension menu click on TOOLBOX Options and select to 
enable Advanced mode, acknowledge each of the warnings

• Select the option MENU: Accounts & Categories Tools

• Select the option FIX: FORCE Change an Account’s Type

• You will be presented with a warning, this is a fundamental change and the 
warning reflects this, click on I agree, Proceed to continue.

• Select the Account/Category to change

• From the Drop down select the type of account /category that the item is to 
become.

• You will receive another warning, along with the details of what is to be 
changed. Cli on I Agree, Proceed to continue.

• Another message is displayed as to the nature of the change, select Yes to 
proceed.

• You will then be asked of you wish to create a backup, you should do so 
unless you have done this already, then select Proceed.

• Type in IAGREE in the disclaimer box.

• After clicking on OK you then will see a dialogue that the change has been 
done.

You should then check to ensure the change has been done correctly. 

Creating an Empty Structure

We will now consider how we can use the Toolbox to create an initial empty structure
which is then corrected before data is imported.

This method provides the capability that existed in previous generations of the 
importer and can be useful when you have QIF files that are particular troublesome, 
for an import that only has a few problem accounts/categories then you should 
consider using the Toolbox capability to force change account/categories as your first
option as detailed above.

To import a structure create a new account set, install and start Toolbox, you can 
then choose the Toolbox option MENU: General Tools which will display a screen like
the one given below.
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You select the item “‘Older’ Import QIF File and set parameters” and click on 
PROCEED

You will then be prompted to select a file, navigate and select a file and then click on 
proceed.

You will be asked to set and confirm parameters on the parameter screen, A typical 
screen is shown below, note that we have selected to import the Structure Only with 
no data.
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You can then respond to the Perform backup question.

You will receive a completion message and a notice to check the log for messages. 
You will then have a Data set that contains an account/classification structure but 
with no data.

It is now necessary to check and correct any problems with the structure before 
importing any data.

Correcting Structural Problems

The types of structural problems that we may need to correct can include:

• Categories defined as Accounts

• Accounts defined as Categories

• Categories defined as the wrong type i.e. Income defined as Expense or 
Expense defined as Income

• Accounts defined as the wrong type of account

• Accounts/categories defined in the wrong currency

To correct the first four items using standard Moneydance tools you need to delete 
and redefine the account/Category as the correct type, it is not possible to change 
the type once defined.

A point to note is that the name must be identical to the deleted name. Names are 
significant so if a name is not the same a later import of data will create a new 
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account/category with the original name. Names can be changed once the data has 
been correctly imported.

The other alternative with these items is the Toolbox’s ability to force change the 
definition.

With accounts/categories that are in the wrong currency you can change the 
currency provided there are no transactions in that account/category.

Once the structure has been corrected where necessary you can then proceed to 
import the data, you can use the Toolbox’s import data function or even 
Moneydance’s own importer. It is recommended that you take a backup of the empty
data set in case you discover more issues than need to be corrected.

55


