Failed import on upgrade to Moneydance 2015

norfolkjp's Avatar


11 Nov, 2015 04:47 PM

I have just upgraded to Moneydance 2015, but I can't import my account set from my previous pre-2011 version of Moneydance. In the process I have lost my previous version, so at the moment I have lost all my records! Help, please!

  1. 1 Posted by Scott Meehan on 11 Nov, 2015 05:32 PM

    Scott Meehan's Avatar


    Can you tell me the full name, including the extension, of the file that you're trying to import? Are you going to File -> Open -> Open Other in Moneydance, or File -> Import?

    Scott Meehan
    Infinite Kind Support

  2. 2 Posted by norfolkjp on 11 Nov, 2015 06:02 PM

    norfolkjp's Avatar

    Hi Scott

    Before upgrading I closed my version of Moneydance, but also before
    closing it, I did a 'Saved as' save with a different file name. However
    both these saved folders now seem not to have any data in them. All
    that seems to be in the saved folders (e.g. Moneydance
    11.11.15.moneydance) are six files as follows:

    Moneydance 11.11.15 1.mdinternal
    Moneydance 11.11.15 1.mdinternal-2015-11-04
    Moneydance 11.11.15 1.mdinternal-2015-11-05
    Moneydance 11.11.15 1.mdinternal-2015-11-08
    Moneydance 11.11.15 1.mdinternal-2015-11-09
    Moneydance 11.11.15 1.mdinternal-2015-11-11

    Jeremy Norfolk

  3. 3 Posted by Scott Meehan on 11 Nov, 2015 07:50 PM

    Scott Meehan's Avatar

    Hi Jeremy,

    I would suggest make a new folder named Moneydance 11.11.15 1.moneydance, then copying your Moneydance 11.11.15 1.mdinternal file into that folder and renaming it to root.mdinternal, then try opening the root.mdinternal file with Moneydance and see if it opens your data then.

    Scott Meehan
    Infinite Kind Support

  4. 4 Posted by norfolkjp on 12 Nov, 2015 09:28 AM

    norfolkjp's Avatar

    Hi Scott. I have tried this, i.e. copying the Moneydance 11.11.15
    1.mdinternal file to a new folder and renaming it 'root.mdinternal' and
    then trying to open it with Moneydance, but nothing happens. I also
    tried 'importing' this file, also with no effect. The file size is
    approx. 11,500 KB. Does this sound as if it might be my data file? - I
    have been using Moneydance for years and had a lot of accounts and a lot
    of transaction history.

    Might it be possible to restore the old version? I still have a number
    of files in my Moneydance program folder which are shown as last
    modified in October 2011 (and some last modified on 28.9.15, again
    before the update. There is an Application file and a number of
    Executable Jar Files. I tried opening one of these and the first thing
    that happened was that I got the message 'Your autosave file is newer
    than your data file. Would you like to use the autosave instead.'. I'm
    hoping this means that my data is stored somewhere!

    As I'm sure you can imagine, restoring this data is critically important
    to me. I look after investment portfolios for several members of my
    extended family, run a small property business and look after the
    accounts of two charities, all of which I manage on Moneydance!

    Anything you can suggest would be hugely appreciated.
    Kind regards

  5. 5 Posted by Scott Meehan on 13 Nov, 2015 09:04 PM

    Scott Meehan's Avatar

    Hi Jeremy,

    That does sound like your data file. Did you make sure that the folder you put the root.mdinternal file into had a .moneydance extension? It needs this to be able to open with Moneydance.

    As an alternative, you could rename the file to have a .md extension, then go to File -> Open -> Open Other, or File -> Import to open it (depending on your version of Moneydance).

    Scott Meehan
    Infinite Kind Support

  6. 6 Posted by norfolkjp on 14 Nov, 2015 10:03 AM

    norfolkjp's Avatar

    It worked! You are officially my saviour! I spent most of yesterday
    beginning to rebuild my history (I had my pre-2012 records on an old PC
    and was trying to rebuild from there). It was becoming increasingly
    clear that it would take me months (literally!) to do - and even then
    there would be critical gaps because I simply did not have the
    information anymore. So thank you so, so much! - you can have no idea
    how important this is to me.

    Kind regards

  7. System closed this discussion on 19 Mar, 2016 05:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac