TIAA CREF Mutual Fund Account downloads

sth's Avatar

sth

16 Dec, 2018 09:05 PM

There seems to be an issue with Mutual funds at TIAA-CREF. I had a mutual fund account at TIAA-CREF and it has worked for years. I recently setup a new account and tried to automate downloads to that account. It is failing badly. I get connection through the setup, and the account shows up in the pop up list, but when I select that account and then try to download it errors out and tells me no such account.

I have been unable to duplicate the error using curl with POST file but I have a guess as to what is the issue.

TIAA-CREF uses an account number NNNNNNN. Where N is a numeral. But according to the Console Log when it requests an account it is sending the string MFNNNNNNNN. In this case MF are the literal characters "MF" for the concept of "Mutual Fund" account?? When MD sends the account number preferences by MF, then TIAA-CREF objects as an unknown account.

Basically TIAA-CREF needs an account number that is different than the one in the list of accounts it sends to MD during setup. My previous one was setup a few years ago and this problem is more recent, so the old setup worked. As I said this is a *guess" and needs to be verified the it is the issue. The log shows
MF0NNNNNNN
And the response is "Account not found.

And to follow my own advice :-)

Starting Moneydance 2017.10 (1706) at Thu Dec 20 10:25:25 EST 2018
Settings Folder: /Users/sth/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance
OS: Mac OS X 10.11.6 x86_64
Java: 1.8.0_162 (Oracle Corporation)
Is in sandbox: true; restricted file access: false
Initializing Moneydance SSL

  1. 1 Posted by sth on 27 Dec, 2018 06:36 PM

    sth's Avatar

    I am going to bump this up a bit, it is getting annoying to hand enter transactions in this account! IK!!! Are you there?

  2. 2 Posted by sth on 20 Jan, 2019 02:22 AM

    sth's Avatar

    If the connection specialist could get around to looking at this or if there were a way to manually enter the account number it would be very helpful!

  3. 3 Posted by sth on 06 Feb, 2019 01:47 PM

    sth's Avatar

    And this issue persists with MD 2019....

  4. 4 Posted by sth on 18 Apr, 2019 02:27 AM

    sth's Avatar

    I know this is old, and there seems to be a lot of open issues with 2019 still. However this seems to still be an issue.

  5. System closed this discussion on 18 Jul, 2019 02:30 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac