Moneydance 2019.2 (1868) Online Banking does not connect to First Technology Federal Credit Union

Sam Doe's Avatar

Sam Doe

06 May, 2019 06:08 AM

I have 2019.2 (1868)

I am not able to download connections to First Tech anymore! Below is the symptoms of problems). Incidentally, I also have E*Trade which works just fine - downloads new transactions into register as before.

- When I select download connection, Moneydance appears to go to starting webpage of bank https:/www.firsttechfed.com which has login button.
- clicking on login button leads to either blank page sometimes or a page with "outdated browser" warning at other times.
- from there on, nothing happens. stuck
- sometimes (totally randomly) I am able to login successfully and get in and a very messed up interface with some parts saying (:could not process response for module) comes on and I see account values. but what's the value of this! I need to be able to download transactions in my register and from there nothing else happens from there?!!!

I tried resetting account to no avail.
- for this, I used, as expected, selecting online menu tab above->set up online banking->online banking sign up window-> selecting first tech in drop down menu and clicking next etc. (I don't get any option to delete account, reset sync or anything else -- just the next button or new connection button). Nowhere does it ask me for username/password as it used to in pre 2019.2 versions.

I am stuck. Please help! this 2019.2 seems nothing but pain! everything worked well before

  1. 1 Posted by dwg on 06 May, 2019 06:31 AM

    dwg's Avatar

    I'm a fellow user.

    Did you upgrade from Moneydance 2017 or earlier?

    If so the download button opened your normal Web Browser in the earlier release, in Moneydance 2019 it opens the embedded browser, this browser however is still in beta so is not working with all banks correctly.

    If this is your case then, holding down the CTRL key when clicking on the download button or selecting the menu item Online --> Open Account Website will use your system browser.

  2. 2 Posted by Sam Doe on 06 May, 2019 06:35 AM

    Sam Doe's Avatar

    Thank you dwg. I honestly do not care to use the embedded browser. I just want to DOWNLOAD my transactions!

    As for your suggestion, thank you, did not know this. Yes indeed, Holding control takes me to browser. HOWEVER, I can go to external browser directly anyway to login to my account, why do I need to have Moneydance for that.

  3. 3 Posted by dwg on 06 May, 2019 10:16 AM

    dwg's Avatar

    I'm a fellow user.

    The intent for the embedded browser is to have a facility that is closely tied into Moneydance, and with that for the facility to have the ability to automate the downloading and importing of transaction data into Moneydance.

    At the moment the systems that are in use are Direct Connect, which is largely limited to the U.S. market and the Quicken proprietary Web Connect system, which is limited to the North American market, many banks also appear to be dropping Direct Connect. There are aggregators around the world but they require you to hand over your Internet Banking username/passwords to them, a questionable thing to do in my view. Thus the intent is to give Moneydance the capability to interact with your internet banking account directly from your machine and potentially this could be used by people around the world and as it is on your machine there are not the security concerns of using a third party.

    The embedded browser is the first step in this. The idea of exposing it to users at this early stage was to gain feedback on its general operation with as many banks as possible, unfortunately I do not think the problems encountered with MD2019 were envisaged and thus we have not seen too much action on this front to date. Even at this early stage with any bank that the browser works with a download triggers Moneydance's import capability without any further action required

  4. 4 Posted by Sam Doe on 10 May, 2019 06:18 AM

    Sam Doe's Avatar

    Understood. But it broke my working Moneydance and First Tech where I do all my banking does not work.

    what do I do now? revert to older moneydance? which one? and where? I need this software to work and it keep loading forever in the "embedded page" with broken sections all over! so frustrating.

  5. 5 Posted by dwg on 10 May, 2019 06:34 AM

    dwg's Avatar

    I'm a fellow user.

    Holding down the CTRL key when clicking on the download button or using the Menu Command Online --> Open Account Website will open your normal system browser. It is only using the download button on its own that opens the embedded browser.

  6. 6 Posted by Sam Doe on 10 May, 2019 06:35 AM

    Sam Doe's Avatar

    will that cause transactions from one of the 4 accounts with First Tech to download into my register like it used to?

  7. 7 Posted by Sam Doe on 10 May, 2019 06:37 AM

    Sam Doe's Avatar

    All that seems to do is takes me out of Moneydance and onto Safari and I am looking at it like Moneydance might as well not exist. How does this enable me to actually DOWNLOAD transactions.

  8. 8 Posted by dwg on 10 May, 2019 08:18 AM

    dwg's Avatar

    It sounds like you may want to use Direct Connect. While I know DC is still in Moneydance 2019 I do not know how to override the use of the embedded browser to facilitate that.

  9. 9 Posted by TonyRI on 10 May, 2019 10:51 AM

    TonyRI's Avatar

    Hi Des,

    I do not know how to override the use of the embedded browser to facilitate that.

    Once you have Direct Connect set up for an account, it will no longer try to use the embedded browser when you click on the download button.

    @Sam,

    It sounds like you may have had Direct Connect set up before with First Tech. I don't understand why the connection information wouldn't have transferred over when you upgraded, but you may want to try to re-establish the connection by following this procedure:

    https://infinitekind.tenderapp.com/kb/online-banking-and-bill-pay/d...

    The way that the Moneydance Download button (within the register) works, is it will open the embedded browser when there is no DC connection set up. IF you don't want to use the embedded browser, AND you want to manually download data, you would just begin by opening you favorite browser and manually download files by using these instructions:

    https://infinitekind.tenderapp.com/kb/online-banking-and-bill-pay/m...

    If you have any further problems, don't hesitate to post back. There is certainly a possibility that the First Tech connection setup may have to be looked at by IK Staff.

    Regards,

    Tony (NOT from Moneydance Support)

  10. 10 Posted by TonyRI on 10 May, 2019 11:05 AM

    TonyRI's Avatar

    PS I realize that you already tried to set up the connection again, BUT one very important step that may have been missed was to select "NEW CONNECTION" even if your previous connection was already on the list.

    IF you directly connect to First Tech, then you should be able to download all of your accounts, not just the first one of 4. You may have to map the accounts from your bank to the accounts that you have set up in Moneydance correctly.

    The IK instructions for actually mapping accounts are currently very weak. If you go too quickly, you may skip a screen and then only the first account will be mapped as the default account.

    Just a note: After you enter your USER ID and PIN, click "Ok", then WAIT for an account selection screen to populate. Select the appropriate account from the dropdown menu to map it to the appropriate accounts that you have set up in Moneydance.

    IF I've just confused you more than before, I apologize.

  11. 11 Posted by dwg on 10 May, 2019 12:17 PM

    dwg's Avatar

    Hi Tony,

    Thanks, that make sense since there is no reason to use both the Embedded browser and Direct Connect, you would tend to use one or the other, and you still have access to the system browser with the Open Website option. I do not think I'm ever likely to see Direct Connect here.

    Des

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac